使用 Visio 甘特图共享日程和任务详细信息

使用 Visio 甘特图共享日程和任务详细信息

注意: 我们希望能够尽快以你的语言为你提供最新的帮助内容。 本页面是自动翻译的,可能包含语法错误或不准确之处。 我们的目的是使此内容能对你有所帮助。 可以在本页面底部告诉我们此信息是否对你有帮助吗? 请在此处查看本文的英文版本以便参考。

甘特图用于帮助安排项目任务和跟踪进度。 若要向经理或其他团队成员传达详细任务和日程信息, 可以在 Microsoft Visio 中创建甘特图。 您还可以使用甘特图管理任务级别的项目日程。

设置甘特图

  1. 在 "类别" 列表中, 单击 "日程" 类别。

  2. 单击“甘特图”,然后单击“创建”。

  3. 在“甘特图选项”对话框中,为时间刻度设置日期:

    • 单击“日期”选项卡,然后选择所需的选项。
      主要单位”是要在图表中使用的最长时间单位(如年或月),“次要单位”是最短时间单位(如日或小时)。

    • 在“格式”选项卡上,单击要在任务栏、里程碑和摘要栏上使用的形状和标签,然后单击“确定”。
      如果您不确定要选择何种格式,接受默认选项即可。 您可以稍后再更改格式。

给甘特图添加数据

任务

甘特图中的每个任务在图表框架中占用一行。 当您在“任务名称”列的单元格中键入任务名称时,任务工期将表示为时间刻度下方区域中的任务栏。

目标

要进行的操作

更改任务名称

  • 单击包含该任务的“任务名称”列中的单元格,然后键入新名称。

设置或更改任务工期

  • 在包含要更改日期或工期的甘特图框架中,单击单元格,然后键入新信息。

根据以下规则键入工期:

  • 1h 表示 1 小时

  • 1d 表示一天

  • 1w 表示一周

  • 1m 表示一个月

添加新的任务行

  • 请将“形状”窗口中的“”形状拖放到要在其中插入新行的图表中。

给任务添加完成百分比指示器

  1. 选择要显示完成百分比列的位置左侧的列。

  2. 请在“甘特图”选项卡上的“”组中单击“插入”。

  3. 在“列类型”下,单击“完成百分比”,然后单击“确定”。

随着任务的进展,在新列中键入任务的完成百分比。 完成百分比指示器便会出现在任务栏中。

删除任务

  • 选择表示您想删除的任务的行中的任意单元格,然后在“甘特图”选项卡上的“任务”组中单击“删除”。

里程碑

由于里程碑表示日程中的重要事件而不是任务,因此请将其工期设置为零。

目标

要进行的操作

添加新里程碑

  1. 请将“形状”窗口中的“里程碑”形状拖放到要在其中创建新里程碑行的图表中。

  2. 右键单击表示里程碑的行的“开始时间”列中的单元格,然后单击快捷菜单中的“编辑日期”。

  3. 设置日期,然后单击“确定”。 “完成时间”列中的日期将发生变化,以便与“开始时间”列中的日期相匹配,且“工期”设置为零 (0)。

将现有任务转换为里程碑

  • 在表示要转换为里程碑的任务的行的“工期”列中,键入零 (0) 工期。

更改里程碑标记的显示方式

  • 右键单击里程碑标记,然后单击快捷菜单中的“任务选项”。 选择要更改的选项,然后单击“确定”。

删除里程碑

  • 选择表示您想删除的里程碑的行中的任意单元格,然后在“甘特图”选项卡上的“任务”组中单击“删除”。

摘要任务

当您要在一个总括任务下合并若干附属任务时,可以使用摘要任务。

目标

要进行的操作

创建摘要任务下的附属任务

摘要任务是一种普通任务行。 它概述了其下缩进的附属任务。 要创建附属任务:

  1. 选择包含任务名称的单元格。 要选择多个任务,请在单击时按住 Shift。

  2. 请在“甘特图”选项卡上的“任务”组中单击“缩进”。

缩进的任务现在从属于它上面的摘要任务。

设置摘要任务的工期

  1. 在表示第一个附属任务的行中,单击“开始时间”列中的单元格,然后键入该任务的开始日期。

  2. 对于同一个附属任务,单击“完成时间”列中的单元格,然后键入该任务的结束日期。

  3. 对每个附属任务重复第 1 步和第 2 步。

在为所有附属任务添加任务工期信息后,摘要任务的工期会自动填入。

提升任务级别(升级)

  • 右键单击要提升的任务的名称,然后单击快捷菜单中的“升级”。

更改摘要任务栏的显示方式

  1. 右键单击要更改的摘要任务的时间栏,然后单击快捷菜单中的“任务选项”。

  2. 在“摘要栏”下,选择摘要栏开头和结尾要使用的符号,然后单击“确定”。

依赖关系(链接任务)

当您在甘特图中创建依赖另一个任务的任务时,一个箭头将把两个任务栏连接起来。 如果更改另一个任务所依赖的任务的日期或工期,则依赖任务的日期也会随之更改。

目标

要进行的操作

设置任务之间的依赖关系

  1. 选择您要链接的任务和里程碑的名称单元格。 要选择多个任务,请在选择时按住 Ctrl。

  2. 请在“甘特图”选项卡上的“任务”组中单击“链接”。

中断任务之间的依赖关系

  1. 通过单击包含任务名称的单元格,选择带有要断开依赖关系的任务。 要选择多个任务,请在选择时按住 Ctrl。

  2. 请在“甘特图”选项卡上的“任务”组中单击“取消链接”。

更改依赖关系箭头的样式

  • 打开甘特图,右键单击绘图页,然后单击“S 型连接线”。

添加列

目标

要进行的操作

重命名现有列

  • 单击要重命名列的标题,然后键入新名称。

添加预先设计的新数据列

  1. 选择要显示新列的位置左侧的列标题。

  2. 请在“甘特图”选项卡上的“”组中单击“插入”。

  3. 在“列类型”列表中,单击与要添加的数据类型相对应的列名称,然后单击“确定”。

添加您自己设计的新数据列

  1. 选择要显示新列的位置左侧的列标题。

  2. 请在“甘特图”选项卡上的“”组中单击“插入”。

  3. 在“列类型”列表中,单击与要使用的数据格式(例如,“用户定义的小数”、“用户定义的文本”或“用户定义的时间”)相对应的一个用户定义的列,然后单击“确定”。

  4. 为列键入新的名称。

注意:  如果添加多个文本列,请每次单击不同的用户定义文本选项。 例如,为第一列单击“用户定义的文本 1”,为第二列单击“用户定义的文本 2”,依此类推。

删除(隐藏)数据列

  • 选择要删除(隐藏)的列的标题。

  • 请在“甘特图”选项卡上的“”组中单击“隐藏”。

注意:  删除或隐藏图表中的列时,该列中的数据将保存到文件中。 如果以后要再次显示该列,请右键单击列标题,然后单击“插入列”。 在列表中选择要再次显示的列,然后单击“确定”。

移动数据列

  1. 单击要移动的列的标题。

  2. 将列拖到新的位置。

  3. 执行下列操作之一:

    • 要将一列移到另一列的左侧,请将要移动列的中点放置在另一列中点的左侧。

    • 要将一列移到另一列右侧,请将要移动列的中点放置在另一列中点的右侧。

    • 要将一列移到时间刻度区域的右侧,请将要移动列的中点放置在时间刻度区域中点的右侧。

时间刻度

时间刻度是主要时间单位和次要时间单位的刻度,它将从项目的开始日期延伸到结束日期。 您可以定义时间刻度的时间单位、开始日期和结束日期以及非工作日。

目标

要进行的操作

更改开始日期和/或结束日期

  1. 请在“甘特图”选项卡上的“管理”组中单击“图表选项”。

  2. 在“甘特图选项”对话框中的“时间刻度范围”下,设置日期范围。

更改时间单位

  1. 请在“甘特图”选项卡上的“管理”组中单击“图表选项”。

  2. 在“甘特图选项”对话框中的“时间单位”下,选择所需的“主要单位”和“次要单位”,然后单击“确定”。

设置非工作日

  1. 请在“甘特图”选项卡上的“管理”组中单击“配置工作时间”。

  2. 在“配置工作时间”对话框中,为“工作日”和“工作时间”选择所需选项,然后单击“确定”。

滚动至特定的任务或里程碑

  1. 通过单击包含任务名称的单元格,选择要滚动至的任务或里程碑。

  2. 请在“甘特图”选项卡上的“导航”组中单击“滚动到任务”。

滚动至特定日期

  • 要滚动至时间刻度的结束位置,请在“甘特图”选项卡上的“导航”组中单击“转至完成”。

  • 要向左滚动一个次要单位,请在“甘特图”选项卡上的“导航”组中单击“下一个”。

  • 要向右滚动一个次要单位,请在“甘特图”选项卡上的“导航”组中单击“上一个”。

  • 要滚动至时间刻度的开始位置,请在“甘特图”选项卡上的“导航”组中单击“转至开始”。

更改时间刻度区域的宽度

  1. 选择时间刻度列。

  2. 向任一个方向拖动列右侧的选择手柄,直到区域的宽度满足您的要求。

显示更多时间单位

  1. 单击甘特图框架周围的实线以选择该框架。

  2. 向右拖动位于框架中心偏右侧的选择句柄。

注意:  当您展开时间刻度以显示更多时间单位时,还可以更改与项目相关的结束日期。

您要做什么?

将甘特图用作通信工具

设置甘特图

给甘特图添加数据

打印大型甘特图

将甘特图用作通信工具

在甘特图中, 图形元素 (如条形图和箭头) 表示任务和它们之间的依赖关系, 以便你可以跟踪一项任务中的更改对其他任务的影响。

您也可以在一个摘要任务下对多个附属任务进行分组, 并为每个任务添加说明、所需资源和完成百分比。

任务在时间刻度上显示为条形。

甘特图数据列

通过应用配色方案并将文本标签添加到甘特图, 可以为演示文稿快速生成美观的批注日程。

如果开始将复杂项目的日程安排作为 Visio 甘特图, 则可以轻松地将计划数据导出到Microsoft Project 2010, 然后使用 project 详细规划和管理项目。

产品

时使用

Visio

  • 希望为演示文稿准备外观精美的带批注的日程安排。

  • 您希望在项目早期阶段的计划中定义基本任务。

  • 您的计划包含的任务少于30个。

Project

  • 您希望使用功能完备的项目管理工具来计划和安排项目。

  • 您的日程包括许多任务。

  • 你需要为任务分配多个资源或连接不同项目的计划。

返回页首

设置甘特图

  1. 在“文件”选项卡上,单击“新建”。

  2. 在 "选择模板" 下, 单击 "计划", 然后双击 "甘特图"。

  3. 在 "甘特图选项" 对话框中, 设置时间刻度的日期。 您还可以选择要如何设置任务栏、里程碑和其他图表元素的格式:

    • 单击“日期”选项卡,然后选择所需的选项。

      注意: “主要单位”是要在图表中使用的最长时间单位(如年或月),“次要单位”是最短时间单位(如日或小时)。

    • 在“格式”选项卡上,单击要在任务栏、里程碑和摘要栏上使用的形状和标签,然后单击“确定”。
      “甘特图选项”对话框

注意:  如果您不确定要选择何种格式,接受默认选项即可。 您可以稍后再更改格式。

关闭图表框架

设置甘特图后, 将显示一个通用图表框架。

该帧类似于一个空白画布, 您可以在其中绘制日程的详细信息:

  • 在 "任务名称" 列中, 单击一个单元格, 然后键入以使用特定的任务名称替换一般文本。 你可以在项目进度中添加更多任务。

  • 最初, "开始" 和 "完成" 列中的日期反映您为项目指定的开始日期。 若要更改日期, 请单击单元格, 然后键入。

  • 键入新的开始和完成日期时, "工期" 列将自动更新。 您还可以键入日期和工期之一来指示任务的长度。

  • 在 "时间刻度" (标记为2000的区域, 如下所示) 中, "主要单位" 位于顶部,次要单位在底部。 时间刻度从指定的开始日期和完成日期开始和结束。 当您添加任务的开始和结束日期或工期时, 任务条形图将显示在时间刻度下方的区域中, 并且区域将展开。

提示: 若要记录每个任务的其他数据, 可以添加更多列。 例如, 您可以添加一个 "资源" 列, 以便甘特图反映每个任务的负责人。

返回页首

给甘特图添加数据

您可以将反映项目日程详细信息的数据填充到框架中。 你可以添加和优化以下计划元素:

Tasks

里程碑

摘要任务

依赖关系(链接任务)

数据列

时间刻度

任务

甘特图数据列

甘特图中的每个任务在图表框架中占用一行。 当您在“任务名称”列的单元格中键入任务名称时,任务工期将表示为时间刻度下方区域中的任务栏。

目标

要进行的操作

更改任务名称

  • 单击包含该任务的“任务名称”列中的单元格,然后键入新名称。

设置或更改任务工期

  • 在包含要更改日期或工期的甘特图框架中,单击单元格,然后键入新信息。

注意:  根据以下规则键入工期:

  • 1h 表示 1 小时

  • 1d 表示一天

  • 1w 表示一周

  • 1m 表示一个月

在甘特图底部添加新任务

  • 通过单击环绕图表的实线选择甘特图框架。 若要创建新的任务行, 请在 "甘特图" 选项卡上的 "任务" 组中, 单击 "新建"。
    “任务”组

在两个现有任务之间添加新任务

  • 选择要在其上方显示新任务行的行中的任意单元格, 然后在 "甘特图" 选项卡上的 "任务" 组中, 单击 "新建"。
    “任务”组

给任务添加完成百分比指示器

  1. 在要显示 "完成百分比" 列的位置左侧的列顶部选择阴影部分, 然后在 "甘特图" 选项卡上的 "" 组中, 单击 "插入"。
    “列”组

  2. 在“列类型”下,单击“完成百分比”,然后单击“确定”。

  3. 随着任务的进展,在新列中键入任务的完成百分比。 完成百分比指示器便会出现在任务栏中。

删除任务

  • 选择表示您想删除的任务的行中的任意单元格,然后在“甘特图”选项卡上的“任务”组中单击“删除”。
    “任务”组

里程碑

甘特图上的里程碑

由于里程碑表示日程中的重要事件而不是任务,因此请将其工期设置为零。

目标

要进行的操作

添加新里程碑

  1. 里程碑形状从 "甘特图形状" 模具拖到甘特图框架上, 然后将其放在包含希望里程碑关注的任务的任务名称的单元格之间, 并将其放在前面。

  2. 右键单击表示里程碑的行的“开始时间”列中的单元格,然后单击快捷菜单中的“编辑日期”。

  3. 键入所需的日期, 然后单击"确定"。 “完成时间”列中的日期将发生变化,以便与“开始时间”列中的日期相匹配,且“工期”设置为零 (0)。

将现有任务转换为里程碑

  • 在表示要转换为里程碑的任务的行的“工期”列中,键入零 (0) 工期。

更改里程碑标记的显示方式

  • 右键单击里程碑标记,然后单击快捷菜单中的“任务选项”。 选择要更改的选项,然后单击“确定”。

删除里程碑

  • 选择表示您想删除的里程碑的行中的任意单元格,然后在“甘特图”选项卡上的“任务”组中单击“删除”。
    “任务”组

摘要任务

具有摘要任务和附属任务的甘特图

当您要在一个总括任务下合并若干附属任务时,可以使用摘要任务。

目标

要进行的操作

创建包含附属任务的摘要任务

  1. 向甘特图添加摘要任务和附属任务或里程碑。

  2. 若要选择附属任务, 请选择包含任务名称的单元格。 要选择多个任务,请在单击时按住 Shift。

  3. 请在“甘特图”选项卡上的“任务”组中单击“缩进”。
    “任务”组

设置摘要任务的工期

  1. 在表示第一个附属任务的行中,单击“开始时间”列中的单元格,然后键入该任务的开始日期。

  2. 对于同一个附属任务,单击“完成时间”列中的单元格,然后键入该任务的结束日期。

  3. 对每个附属任务重复第 1 步和第 2 步。

注意:  在为所有附属任务添加任务工期信息后,摘要任务的工期会自动填入。

降级 (降级) 任务

  • 选择要降级的任务的名称, 然后在 "甘特图" 选项卡上的 "任务" 组中, 单击 "降级"。
    “任务”组

提升任务级别(升级)

  • 右键单击要升级的任务的名称, 然后在 "甘特图" 选项卡上的 "任务" 组中, 单击 " Oudent"。
    “任务”组

更改摘要任务栏的显示方式

  1. 右键单击要更改的摘要任务的任务栏, 然后单击快捷菜单上的 "任务选项"。

  2. 在“摘要栏”下,选择摘要栏开头和结尾要使用的符号,然后单击“确定”。

依赖关系(链接任务)

甘特图上的里程碑

当您在甘特图中创建依赖另一个任务的任务时,一个箭头将把两个任务栏连接起来。 如果更改另一个任务所依赖的任务的日期或工期,则依赖任务的日期也会随之更改。

目标

要进行的操作

设置任务之间的依赖关系

  1. 通过单击包含任务名称的单元格, 选择要在其间设置相关性的任务和里程碑。 若要选择多个任务, 请在按住 SHIFT 的同时进行选择。

  2. 请在“甘特图”选项卡上的“任务”组中单击“链接”。
    “任务”组

中断任务之间的依赖关系

  1. 通过单击包含任务名称的单元格,选择带有要断开依赖关系的任务。 若要选择多个任务, 请在按住 SHIFT 的同时进行选择。

  2. 请在“甘特图”选项卡上的“任务”组中单击“取消链接”。
    “任务”组

更改依赖关系箭头的样式

  • 打开甘特图,右键单击绘图页,然后单击“S 型连接线”。

数据列

项目日程由特定于任务的数据生成。 任务开始日期和工期的累计确定项目的完成日期。 在 Visio 甘特图中, 将任务数据存储在数据列中。

如果要在甘特图中记录和显示其他任务数据, 则可以添加新列。 例如, 你可能希望添加任务笔记栏, 其中可以描述复杂任务或唯一任务, 一列用于列出负责完成每项任务的人员, 或用于跟踪每个任务的完成百分比的列。


甘特图数据列

默认情况下, 创建新的甘特图时, 图表包含 "任务名称"、"开始"、"完成" 和 "工期" 列。 你可以重新排列现有列、添加新列以及删除不再需要的列。

目标

要进行的操作

重命名现有列

  • 单击要重命名列的标题,然后键入新名称。

添加预先设计的新数据列

  1. 选择要显示新列的位置左侧的列标题。

  2. 请在“甘特图”选项卡上的“”组中单击“插入”。
    “列”组

  3. 在“列类型”列表中,单击与要添加的数据类型相对应的列名称,然后单击“确定”。

添加您自己设计的新数据列

  1. 选择要显示新列的位置左侧的列标题。

  2. 请在“甘特图”选项卡上的“”组中单击“插入”。
    “列”组

  3. 在“列类型”列表中,单击与要使用的数据格式(例如,“用户定义的小数”、“用户定义的文本”或“用户定义的时间”)相对应的一个用户定义的列,然后单击“确定”。

  4. 为列键入新的名称。

注意:  如果添加多个文本列,请每次单击不同的用户定义文本选项。 例如,为第一列单击“用户定义的文本 1”,为第二列单击“用户定义的文本 2”,依此类推。

删除(隐藏)数据列

  • 选择要删除(隐藏)的列的标题。

  • 请在“甘特图”选项卡上的“”组中单击“隐藏”。
    “列”组

注意:  删除或隐藏图表中的列时,该列中的数据将保存到文件中。 如果以后要再次显示该列,请右键单击列标题,然后单击“插入列”。 在列表中选择要再次显示的列,然后单击“确定”。

移动数据列

  1. 单击要移动的列的标题。

  2. 将列拖到新的位置。

  3. 执行下列操作之一:

    • 要将一列移到另一列的左侧,请将要移动列的中点放置在另一列中点的左侧。

    • 要将一列移到另一列右侧,请将要移动列的中点放置在另一列中点的右侧。

    • 要将一列移到时间刻度区域的右侧,请将要移动列的中点放置在时间刻度区域中点的右侧。

注意: 如果时间刻度区域很长, 则可能需要缩小以将列移出区域的中点。 若要缩小, 请在 "视图" 菜单上, 指向 "缩放", 然后单击所需的缩放级别。

时间刻度

时间刻度是主要时间单位和次要时间单位的刻度,它将从项目的开始日期延伸到结束日期。 您可以定义时间刻度的时间单位、开始日期和结束日期以及非工作日。

甘特图数据列

你可以滚动到时间刻度上的特定日期或任务, 并且可以更改时间刻度区域的宽度并显示更多日期。

目标

要进行的操作

更改开始日期和/或结束日期

  1. 请在“甘特图”选项卡上的“管理”组中单击“图表选项”。
    “管理”组

  2. 在 "甘特图选项" 对话框中的 "时间刻度范围" 下, 更改单击要更改的日期。

更改时间单位

  1. 请在“甘特图”选项卡上的“管理”组中单击“图表选项”。
    “管理”组

  2. 在“甘特图选项”对话框中的“时间单位”下,选择所需的“主要单位”和“次要单位”,然后单击“确定”。

设置非工作日

  1. 请在“甘特图”选项卡上的“管理”组中单击“配置工作时间”。
    “管理”组

  2. 在“配置工作时间”对话框中,为“工作日”和“工作时间”选择所需选项,然后单击“确定”。

滚动至特定的任务或里程碑

  1. 通过单击包含任务名称的单元格,选择要滚动至的任务或里程碑。

  2. 请在“甘特图”选项卡上的“导航”组中单击“滚动到任务”。
    “导航”组

滚动至特定日期

  • 要滚动至时间刻度的结束位置,请在“甘特图”选项卡上的“导航”组中单击“转至完成”。

  • 要向左滚动一个次要单位,请在“甘特图”选项卡上的“导航”组中单击“下一个”。

  • 要向右滚动一个次要单位,请在“甘特图”选项卡上的“导航”组中单击“上一个”。

  • 要滚动至时间刻度的开始位置,请在“甘特图”选项卡上的“导航”组中单击“转至开始”。
    “导航”组

更改时间刻度区域的宽度

  1. 在 "时间刻度" 区域顶部的灰色区域中单击一次, 然后再次单击以选择 "时间刻度" 列。

  2. 沿任意方向拖动列右侧的蓝色选择手柄, 直到区域达到所需宽度。

显示更多时间单位

  1. 单击甘特图框架周围的实线以选择该框架。

  2. 向右拖动框架右侧的蓝色选择手柄。

注意:  当您展开时间刻度以显示更多时间单位时,还可以更改与项目相关的结束日期。

返回页首

打印大型甘特图

除非你要为小项目创建计划, 否则你的甘特图可能超出了一个标准打印机页面的边界。 下表介绍了可能遇到的一些打印问题, 以及在打印之前可以采取的步骤, 这些问题将帮助你获得预期结果。

问题

解决方案

要进行的操作

只打印部分甘特图。

请确保整个图表适合绘图页。

  1. 在 "设计" 选项卡上的 "页面设置" 组中, 单击 "页面设置" 对话框启动器。

  2. 在 "页面设置" 对话框中, 单击 "页面大小" 选项卡, 在 "打印缩放" 下, 选择 "适应"。

  3. 在 "调整为" 旁边的 "在工作表中" 框中键入 "1", 在 "工作表" 框中键入 "1"。

  4. 单击 "应用", 然后单击"确定"

打印页和绘图页方向不同。

更改打印机页面方向。

  • 在 "设计" 选项卡上的 "页面设置" 组中, 单击 "方向", 然后单击所需的方向。

您不知道图表将跨多少页打印。

打印之前预览绘图的打印效果。

  • 在 "文件" 选项卡上, 单击 "打印", 然后单击 "打印预览"。

您不知道分页符将出现的位置。

启用分页符以查看图表将横向平铺的页数。

  • 在 "视图" 选项卡上的 "显示" 组中, 选择 "分页符"。 图表上的灰线指示分页符出现的位置。

打印页面之间的破断会出现在笨拙的位置。

更改页边距设置以控制页面之间的重叠。 边距越大, 页面间的重叠量越大。

  1. 在 "设计" 选项卡上的 "页面设置" 组中, 单击 "页面设置" 对话框启动器。

  2. 在 "打印设置" 选项卡上的 "打印机纸张" 下, 单击 "设置"。

  3. 键入所需的边距设置, 然后单击"确定"两次。

返回页首

您要做什么?

将甘特图用作通信工具

设置甘特图

给甘特图添加数据

打印大型甘特图

将甘特图用作通信工具

在甘特图中, 图形元素 (如条形图和箭头) 表示任务和它们之间的依赖关系, 以便你可以跟踪一项任务中的更改对其他任务的影响。

您也可以在一个摘要任务下对多个附属任务进行分组, 并为每个任务添加说明、所需资源和完成百分比。

任务在时间刻度上显示为条形。

甘特图示例

通过应用配色方案并将文本标签添加到甘特图, 可以为演示文稿快速生成美观的批注日程。

如果开始将复杂项目的日程安排作为 Visio 甘特图, 则可以轻松地将日程数据导出到 Microsoft Office project, 然后使用 Office project 详细规划和管理项目。 有关从 Office visio 导出甘特图的详细信息, 请参阅 Microsoft Office visio 中的帮助。

产品

时使用

Office Visio

  • 希望为演示文稿准备外观精美的带批注的日程安排。

  • 您希望在项目早期阶段的计划中定义基本任务。

  • 您的计划包含的任务少于30个。

Office Project

  • 您希望使用功能完备的项目管理工具来计划和安排项目。

  • 您的日程包括许多任务。

  • 你需要为任务分配多个资源或连接不同项目的计划。

返回页首

设置甘特图

首先设置基本图表框架和时间刻度的日期。 您还可以选择要如何设置任务栏、里程碑和其他图表元素的格式。

稍后, 您可以更改日期、添加或删除任务和里程碑, 以及创建任务之间的相关性。 您也可以应用配色方案和添加标题和图例。

  1. 在 Visio 中, 在 "文件" 菜单上, 指向 "新建", 指向 "日程", 然后单击 "甘特图"。

  2. 单击“日期”选项卡,然后选择所需的选项。

    主要单位”是要在图表中使用的最长时间单位(如年或月),“次要单位”是最短时间单位(如日或小时)。

  3. 在“格式”选项卡上,单击要在任务栏、里程碑和摘要栏上使用的形状和标签,然后单击“确定”。

如果您不确定要选择何种格式,接受默认选项即可。 您可以稍后再更改格式。

关闭图表框架

设置甘特图后, 将显示一个通用图表框架。

该帧类似于一个空白画布, 您可以在其中绘制日程的详细信息:

  • 在 "任务名称" 列中, 单击一个单元格, 然后键入以使用特定的任务名称替换一般文本。 你可以在项目进度中添加更多任务。

  • 最初, "开始" 和 "完成" 列中的日期反映您为项目指定的开始日期。 若要更改日期, 请单击单元格, 然后键入。

  • 键入新的开始和完成日期时, "工期" 列将自动更新。 您还可以键入日期和工期之一来指示任务的长度。

  • 在 "时间刻度" (标记为2000的区域, 如下所示) 中, "主要单位" 位于顶部,次要单位在底部。 时间刻度从指定的开始日期和完成日期开始和结束。 当您添加任务的开始和结束日期或工期时, 任务条形图将显示在时间刻度下方的区域中, 并且区域将展开。

若要记录每个任务的其他数据, 可以添加更多列。 例如, 您可以添加一个 "资源" 列, 以便甘特图反映每个任务的负责人。

返回页首

给甘特图添加数据

您可以将反映项目日程详细信息的数据填充到框架中。 你可以添加和优化以下计划元素:

任务

里程碑

摘要任务

依赖关系(链接任务)

数据列

时间刻度

任务

甘特图数据列

甘特图中的每个任务在图表框架中占用一行。 当您在“任务名称”列的单元格中键入任务名称时,任务工期将表示为时间刻度下方区域中的任务栏。

目标

要进行的操作

更改任务名称

  • 单击包含该任务的“任务名称”列中的单元格,然后键入新名称。

设置或更改任务工期

  • 在包含要更改日期或工期的甘特图框架中,单击单元格,然后键入新信息。

根据以下规则键入工期:

  • 1h 表示 1 小时

  • 1d 表示一天

  • 1w 表示一周

  • 1m 表示一个月

在甘特图底部添加新任务

  • 通过单击环绕图表的实线选择甘特图框架。 若要创建新的任务行, 请拖动框架底部中心的绿色选择手柄。

在两个现有任务之间添加新任务

  • 右键单击要在其上方显示新任务行的行中的任意单元格, 然后单击快捷菜单上的 "新建任务"。

给任务添加完成百分比指示器

  1. 右键单击要显示完成百分比列的位置左侧的列顶部的阴影部分, 然后单击快捷菜单上的 "插入列"。

  2. 在“列类型”下,单击“完成百分比”,然后单击“确定”。

  3. 随着任务的进展,在新列中键入任务的完成百分比。 完成百分比指示器便会出现在任务栏中。

删除任务

  • 右键单击表示要删除的任务的行中的任意单元格, 然后单击快捷菜单上的 "删除任务"。

更改任务栏的显示方式

  • 右键单击任务栏, 然后单击快捷菜单上的 "任务选项"。 从列表中, 单击所需的选项, 然后单击"确定"

里程碑

甘特图上的里程碑

由于里程碑表示日程中的重要事件而不是任务,因此请将其工期设置为零。

目标

要进行的操作

添加新里程碑

  1. 里程碑形状从 "甘特图形状" 模具拖到甘特图框架上, 然后将其放在包含希望里程碑关注的任务的任务名称的单元格之间, 并将其放在前面。

  2. 右键单击表示里程碑的行的“开始时间”列中的单元格,然后单击快捷菜单中的“编辑日期”。

  3. 键入所需的日期, 然后单击"确定"。 “完成时间”列中的日期将发生变化,以便与“开始时间”列中的日期相匹配,且“工期”设置为零 (0)。

将现有任务转换为里程碑

  • 在表示要转换为里程碑的任务的行的“工期”列中,键入零 (0) 工期。

更改里程碑标记的显示方式

  • 右键单击里程碑标记,然后单击快捷菜单中的“任务选项”。 选择要更改的选项,然后单击“确定”。

删除里程碑

  • 右键单击表示要删除的里程碑的行中的任意单元格, 然后单击快捷菜单上的 "删除任务"。

摘要任务

具有摘要任务和附属任务的甘特图

当您要在一个总括任务下合并若干附属任务时,可以使用摘要任务。

目标

要进行的操作

创建包含附属任务的摘要任务

  1. 向甘特图添加摘要任务和附属任务或里程碑。

  2. 若要选择附属任务, 请单击包含任务名称的单元格。 要选择多个任务,请在单击时按住 Shift。

  3. 右键单击所选任务之一, 然后单击快捷菜单上的 "缩进"。

设置摘要任务的工期

  1. 在表示第一个附属任务的行中,单击“开始时间”列中的单元格,然后键入该任务的开始日期。

  2. 对于同一个附属任务,单击“完成时间”列中的单元格,然后键入该任务的结束日期。

  3. 对每个附属任务重复第 1 步和第 2 步。

在为所有附属任务添加任务工期信息后,摘要任务的工期会自动填入。

降级 (降级) 任务

  • 右键单击要降级的任务的名称, 然后单击快捷菜单上的 "降级"。

提升任务级别(升级)

  • 右键单击要升级的任务的名称, 然后单击快捷菜单上的 "升级"。

更改摘要任务栏的显示方式

  1. 右键单击要更改的摘要任务的任务栏, 然后单击快捷菜单上的 "任务选项"。

  2. 在“摘要栏”下,选择摘要栏开头和结尾要使用的符号,然后单击“确定”。

依赖关系(链接任务)

甘特图上的里程碑

当您在甘特图中创建依赖另一个任务的任务时,一个箭头将把两个任务栏连接起来。 如果更改另一个任务所依赖的任务的日期或工期,则依赖任务的日期也会随之更改。

目标

要进行的操作

设置任务之间的依赖关系

  1. 通过单击包含任务名称的单元格, 选择要在其间设置相关性的任务和里程碑。 若要选择多个任务, 请在按住 SHIFT 的同时进行选择。

  2. 右键单击所选任务之一, 然后单击快捷菜单上的 "链接任务"。

中断任务之间的依赖关系

  1. 通过单击包含任务名称的单元格,选择带有要断开依赖关系的任务。 若要选择多个任务, 请在按住 SHIFT 的同时进行选择。

  2. 右键单击所选任务之一, 然后单击快捷菜单上的 "取消任务链接"。

更改依赖关系箭头的样式

  • 打开甘特图, 右键单击绘图页, 然后单击快捷菜单上的 " S 型连接线"。

数据列

项目日程由特定于任务的数据生成。 任务开始日期和工期的累计确定项目的完成日期。 在 Visio 甘特图中, 将任务数据存储在数据列中。

如果要在甘特图中记录和显示其他任务数据, 则可以添加新列。 例如, 你可能希望为任务笔记添加列, 在其中可以描述复杂任务或唯一任务, 一列用于列出负责完成每个任务的人员, 或用于跟踪已完成的每个任务的百分比的列。 comple李小明.


甘特图数据列

默认情况下, 创建新的甘特图时, 图表包含 "任务名称"、"开始"、"完成" 和 "工期" 列。 你可以重新排列现有列、添加新列以及删除不再需要的列。

目标

要进行的操作

重命名现有列

  • 单击要重命名列的标题,然后键入新名称。

添加预先设计的新数据列

  1. 右键单击要显示新列的位置左侧的列标题, 然后单击快捷菜单上的 "插入列"。

  2. 在“列类型”列表中,单击与要添加的数据类型相对应的列名称,然后单击“确定”。

添加您自己设计的新数据列

  1. 右键单击要显示新列的位置左侧的列标题, 然后单击快捷菜单上的 "插入列"。

  2. 在“列类型”列表中,单击与要使用的数据格式(例如,“用户定义的小数”、“用户定义的文本”或“用户定义的时间”)相对应的一个用户定义的列,然后单击“确定”。

  3. 为列键入新的名称。

注意:  如果添加多个文本列,请每次单击不同的用户定义文本选项。 例如,为第一列单击“用户定义的文本 1”,为第二列单击“用户定义的文本 2”,依此类推。

删除(隐藏)数据列

  • 右键单击要删除 (隐藏) 的列的标题, 然后单击快捷菜单上的 "隐藏列"。

注意:  删除或隐藏图表中的列时,该列中的数据将保存到文件中。 若要以后再次显示该列, 请右键单击列标题, 然后单击快捷菜单上的 "插入列"。 在列表中选择要再次显示的列,然后单击“确定”。

移动数据列

  1. 单击要移动的列的标题。

  2. 将列拖到新的位置。

  3. 执行下列操作之一:

    • 要将一列移到另一列的左侧,请将要移动列的中点放置在另一列中点的左侧。

    • 要将一列移到另一列右侧,请将要移动列的中点放置在另一列中点的右侧。

    • 要将一列移到时间刻度区域的右侧,请将要移动列的中点放置在时间刻度区域中点的右侧。

注意: 如果时间刻度区域很长, 则可能需要缩小以将列移出区域的中点。 若要缩小, 请在 "视图" 菜单上, 指向 "缩放", 然后单击所需的缩放级别。

时间刻度

时间刻度是主要时间单位和次要时间单位的刻度,它将从项目的开始日期延伸到结束日期。 您可以定义时间刻度的时间单位、开始日期和结束日期以及非工作日。

甘特图数据列

你可以滚动到时间刻度上的特定日期或任务, 并且可以更改时间刻度区域的宽度并显示更多日期。

目标

操作 要采取的

更改开始日期和/或结束日期

  1. 在甘特图中, 右键单击时间刻度中的任意位置, 然后单击快捷菜单上的 "日期选项"。

  2. 在 "时间刻度范围" 下, 选择新的开始或结束日期或时间, 然后单击"确定"

更改时间单位

  1. 在甘特图中, 右键单击时间刻度中的任意位置, 然后单击快捷菜单上的 "日期选项"。

  2. 在 "时间单位" 下, 选择所需的主要单位次要单位, 然后单击"确定"

设置非工作日

  1. 在甘特图中, 右键单击时间刻度中的任意位置, 然后单击快捷菜单上的 "配置工作时间"。

  2. 为 "工作日" 和 "工作时间" 选择所需的选项, 然后单击"确定"

滚动至特定的任务或里程碑

  1. 通过单击包含任务名称的单元格, 选择要滚动到的任务或里程碑。

  2. 在 "甘特图" 工具栏上, 单击 "滚动到任务" 按钮。

注意:  如果看不到 "甘特图" 工具栏, 请在 "视图" 菜单上, 指向 "工具栏", 然后单击 "甘特图"。

滚动至特定日期

在甘特图中, 右键单击时间刻度中的任意位置, 然后单击快捷菜单上的下列操作之一:

  • 滚动到 "完成日期", 滚动到时间刻度的末尾。

  • 左滚动一个单元, 向左滚动一个次要单位。

  • 右滚动一个单元, 向右滚动一个次要单位。

  • 滚动到 "开始日期", 滚动至时间刻度的开始位置。

更改时间刻度区域的宽度

  1. 在 "时间刻度" 区域顶部的灰色区域中单击一次, 然后再次单击以选择 "时间刻度" 列。

  2. 向任意方向拖动列右侧的绿色选择手柄, 直到区域达到所需宽度。

显示更多时间单位

  1. 单击甘特图框架周围的实线以选择该框架。

  2. 向右拖动框架右侧的绿色选择手柄。

注意:  当您展开时间刻度以显示更多时间单位时,还可以更改与项目相关的结束日期。

返回页首

打印大型甘特图

除非你要为小项目创建计划, 否则你的甘特图可能超出了一个标准打印机页面的边界。 下表介绍了你可能会遇到的一些打印问题以及在打印之前可以采取的步骤, 这些问题将帮助你获得预期的结果。

问题

Sol ution

要进行的操作

只打印部分甘特图。

请确保整个图表适合绘图页。

  1. 在“文件”菜单上,单击“页面设置”。

  2. 单击 "页面大小" 选项卡, 单击 "调整大小以适应绘图内容", 然后单击"确定"

打印页和绘图页方向不同。

更改打印机页面方向。

  1. 在“文件”菜单上,单击“页面设置”。

  2. 单击 "打印设置" 选项卡, 单击所需的方向, 然后单击"确定"

您不知道图表将跨多少页打印。

打印之前预览绘图的打印效果。

  • 在 "文件" 菜单上, 单击 "打印预览"。

您不知道分页符将出现的位置。

启用分页符以查看图表将横向平铺的页数。

  • 在 "视图" 菜单上, 单击 "分页符"。 图表上的灰线指示分页符出现的位置。

打印页面之间的中断会出现在笨拙的地方。

更改页边距设置以控制页面之间的重叠。 边距越大, 页面间的重叠量越大。

  1. 在“文件”菜单上,单击“页面设置”。

  2. 在 "打印设置" 选项卡上, 单击 "设置"。

  3. 键入所需的边距设置, 然后单击"确定"两次。

返回页首

扩展你的 Office 技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×