使用 SharePoint Designer 创建自定义列表表单

重要:  本文是由机器翻译的,请参阅免责声明。请在 此处 中查找本文的英文版本以便参考。

SharePoint 列表和库包含允许用户显示、 编辑和将项目添加到列表或库的列表表单。与Microsoft SharePoint Designer 2010,您可以创建和自定义这些窗体,以使其更容易用户可以添加和更新列表中的项目。如果列表窗体您设计的解决方案的一部分,您需要自定义窗体,以便它面向解决方案,并收集相关的数据,以支持您的解决方案。

在自定义列表表单中,可以显示或隐藏某些字段、 重新组织这些字段、 更改的窗体布局、 添加格式化的文本和图形和最终,更改 XSL、 HTML 或 ASP 使用窗体。您只能通过在SharePoint Designer 2010中创建自定义列表表单执行这些任务。

本文介绍了与列表关联的默认表单以及如何为列表或库创建自定义表单。

注意: 如果您使用的 SharePoint Online 和本文中的信息不符合您看到的内容,您可能在服务升级后使用 Office 365。在 SharePoint Designer 中的某些功能不支持在下一版本的 SharePoint Online 中。请参阅在 SharePoint Designer 2013 发生了什么变化

本文内容

查看默认列表表单

创建新的列表表单

后续步骤

检查默认列表表单

列表表单都位于同一个文件夹及其关联的 SharePoint 列表。使用SharePoint Designer 2010,您可以快速、 轻松地查看与列表相关联的默认列表窗体。

查看与列表关联的默认表单的最简单方法是打开该列表的摘要页。

  1. 使用您的网站在SharePoint Designer 2010中打开,单击导航窗格中的列表和库

  2. 在库中单击所需的列表,例如“通知”

  3. 在摘要页的“表单”下将显示与该列表关联的表单。

    SharePoint Designer 表单

查看与列表关联的默认表单的另一种方法是使用“导航”窗格中的“所有文件”选项卡打开网站层次结构。

  1. 您的网站在SharePoint Designer 2010中打开,单击导航窗格中的所有文件

    注意: 如果看不到所有文件,请联系您的网站管理员有关启用SharePoint Designer 2010在您的网站的结构。

  2. 若要打开 SharePoint 列表,请单击“列表”文件夹,然后单击所需列表,例如“通知”

    在此处,您可以查看与列表关联的表单及任意视图,如 AllItems.aspx。(在“请参阅”部分中可以找到指向视图详细信息的链接。)

    注意: 在此处除了查看和打开表单之外,还可以使用“导航”窗格下显示的网站层次结构来浏览列表。只需单击加号 (+) 即可展开“列表”文件夹,继续单击加号 (+) 可展开所需的列表。

    SharePoint Designer 表单

  3. 对于 SharePoint 库,请依次打开“共享文档”文件夹和“表单”文件夹以查找关联的表单。

返回页首

DispForm.aspx、EditForm.aspx 和 NewForm.aspx 列表表单

默认情况下,有三个表单与列表关联:DispForm.aspx、EditForm.aspx 和 NewForm.aspx。以下三幅插图显示的是“通知”列表的默认列表表单。

  • DispForm.aspx 页提供在查看列表中的单个项目时出现的“显示项目表单”。

    SharePoint Designer 表单

  • EditForm.aspx 页显示在编辑列表中的项目时出现的“编辑项目表单”。

    SharePoint Designer 表单

  • NewForm.aspx 页显示在向列表中添加新项目时出现的“新建项目表单”。

    SharePoint Designer 表单

注意: SharePoint 库使用另一个表单 Upload.aspx 而非 NewForm.aspx 在库中添加新项目。

返回页首

新建列表表单

在 Web 部件称为列表表单 Web 部件 (LFWP) 中存储的默认列表窗体 (显示项目窗体、 编辑项目窗体中和新建项目窗体)。LFWP 使用 CAML (协作应用程序标记语言) 呈现窗体,并且这不能在SharePoint Designer 2010中自定义。

若要自定义窗体,您可以插入数据表单 Web 部件 (DFWP)。它使用 XSLT,可以自定义SharePoint Designer 2010中。简而言之,您正在使用 DFWP,替换默认窗体,并有两种方法可以执行此操作。

新建一个列表表单,并将其与列表关联

创建自定义列表表单的最快速简便的方法是创建新表单并将其设置为列表的默认表单。

  1. 使用您的网站在SharePoint Designer 2010中打开,单击导航窗格中的列表和库

  2. 在库中单击所需的列表,例如“通知”

  3. 在摘要页的“表单”下,单击“新建”

    SharePoint Designer 表单

    注意: 或者,也可以单击“列表设置”选项卡上功能区中的“列表表单”

  4. 在“新建列表表单”对话框中,指定新表单的文件名。(请勿使用与默认表单 DispForm.aspx、EditForm.aspx 和 NewForm.aspx 冲突的文件名。)

    SharePoint Designer 表单

  5. 对于表单的类型,请指定“新建项目表单”“编辑项目表单”“显示项目表单”

  6. 若要将此表单设置为与列表关联的默认表单,请单击“设置为所选类型的默认表单”。执行此操作后,将为此列表使用自定义表单而非原始的默认表单。

  7. 对于高级选项,可选择对表单使用的内容类型,通常是与列表对应的类型。

    注意: 每个列表或库都可以配置为允许使用多种内容类型,这些内容类型随后将出现在此菜单中。每种可用于列表或库的内容类型都可以使用一组不同的自定义列表表单。例如,如果列表中既有“新闻发布”内容类型又有“行业新闻”内容类型,则可以创建和使用两组不同的自定义列表表单,每种内容类型各对应一组。对每种内容类型使用不同组的自定义列表表单具有以下好处:每个自定义列表表单都只用于显示适合该内容类型的字段。在“请参阅”部分中可以找到有关内容类型的详细信息。

  8. 若要在表单中添加自定义链接,请选择选项“在列表项菜单和功能区中创建链接”,并指定链接和命令名称。

    “请参阅”部分中可以找到指向与列表关联的自定义操作的相关详细信息的链接。

  9. 单击“确定”以创建新表单并返回您的列表的摘要页。

    此时将显示新表单以及与该列表关联的其他表单。

返回页首

编辑现有列表表单

创建自定义列表表单的另一种方法是直接编辑与列表关联的默认表单之一。执行此操作时,需要在页中插入替换页上默认表单的新表单(数据表单 Web 部件)。

注意: 实际上,可以在SharePoint Designer 2010任何 ASPX 页上来执行这些步骤。编辑现有窗体的优点是已与列表相关联。

  1. 使用您的网站在SharePoint Designer 2010中打开,单击导航窗格中的列表和库

  2. 在库中单击所需的列表,例如“通知”

  3. 在摘要页的“表单”下,单击所需表单(例如“NewForm.aspx”)以打开表单进行编辑。

    SharePoint Designer 表单

  4. 与 NewForm.aspx 页面编辑器中打开,将光标置于紧下方的默认窗体和几次按键以创建窗体下方多余的空格。

    SharePoint Designer 表单

    若要快速将光标放在该位置的另一种方法是单击默认列表窗体上同时按esc 键和向右箭头键。

  5. 在功能区上,单击“插入”选项卡,然后在“数据视图和表单”组中单击所需表单,例如“新建项目表单”

  6. 选择要将表单关联到的列表或库,例如“通知”

    此时页上的默认表单正下方将显示“新建项目表单”

    下一步是隐藏默认列表表单,从而在页上只显示新表单。这样还可以确保原样保留页与 SharePoint 列表的连接,且指向此页的链接可在网站上正常工作。

  7. 单击默认列表表单以选择它。

  8. 单击功能区中的“格式”选项卡,然后在“Web 部件”组中选择“属性”

    或者,也可以右键单击默认 Web 部件,然后选择“Web 部件属性”

  9. 在“Web 部件”对话框中,单击“布局”旁边的加号,选中选项“隐藏”,然后单击“确定”

    请勿删除页中的默认 Web 部件;只能隐藏该部件。删除默认 Web 部件将断开页与列表的连接。在“请参阅”部分中可以找到指向隐藏 Web 部件的相关详细信息的链接。

    在SharePoint Designer 2010的 ASPX 页上显示两个窗体。预览表单,但是,将看到只有您新的窗体。

使用 Office InfoPath 2010 替换默认表单

除了使用SharePoint Designer 2010中的列表窗体编辑器,可用于使用Microsoft InfoPath 2010创建、 编辑和设计的窗体。InfoPath 2010 是强大的工具,用于创建可用于 SharePoint 列表、 库和工作流的高度自定义窗体。

“请参阅”部分中可以找到指向 Office InfoPath 2010 表单的相关详细信息的链接。

返回页首

在“网站集管理”下,单击“SharePoint Designer 设置”。

创建列表或库的自定义窗体后下, 一步是开始自定义窗体以满足您的需求。您可以添加或删除列、 更改字段的布局、 应用不同的字体或样式、 添加自定义图像,等等。您可以使用功能区中SharePoint Designer 2010 ,若要执行此自定义。如果您不能使用功能区进行的更改,您可以编辑窗体 XSL 直接在代码视图中。查找有关自定义列表表单,在另请参阅部分中的详细信息的链接。

若要删除一个表单,请在摘要页上突出显示该表单,然后在功能区中选择“删除”。此操作将从服务器中删除该表单,而该表单不再可供用户访问。

注意: 机器翻译免责声明:本文是由无人工介入的计算机系统翻译的。Microsoft 提供机器翻译是为了帮助非英语国家/地区用户方便阅读有关 Microsoft 产品、服务和技术的内容。由于机器翻译的原因,本文可能包含词汇、语法或文法方面的错误。

扩展你的技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×