使用数据连接向导将数据导入 Office Publisher、Visio 或 Word

注意:  我们希望能够尽快以你的语言为你提供最新的帮助内容。 本页面是自动翻译的,可能包含语法错误或不准确之处。我们的目的是使此内容能对你有所帮助。可以在本页面底部告诉我们此信息是否对你有帮助吗? 请在此处查看本文的 英文版本 以便参考。

没有在 Microsoft Office Publisher、 Visio 或 Word 程序,您可以在每个应用程序内使用外部数据世界。但是,如何导入数据,并保护其安全?它是详述进行正确的连接。

你要做什么?

Office 数据连接概述

使数据访问更安全

创建或通过使用 Excel 中编辑 Office 数据连接文件

使用数据连接向导中的 office Publisher: 导入外部数据

Office Visio: 使用数据连接向导导入外部数据

Office Word: 使用数据连接向导导入外部数据

Office 数据连接概述

以下各部分讨论如何外部数据连接的工作以及如何与其他应用程序和用户共享的连接信息。

了解数据连接的基础知识

在您的程序中的数据可以来自外部数据源,如文本文件、 工作簿中,或数据库。此外部数据源连接到您的程序通过数据连接,这是一组的信息,其中介绍了如何查找、 登录,并访问外部数据源。

这是否连接到外部数据的主要优点是: 您可以定期分析该数据,而不重复将复制数据。重复复制数据是非常耗时且出错的操作。

连接信息存储在您的工作簿,并可以还存储中的连接文件,例如在 Office 数据连接 (ODC) 文件 (.odc) 或 (.dsn) 的数据源名称 (DSN) 文件。

要外部数据引入您的程序,您需要的数据访问权限。如果您想要访问外部数据源不是在本地计算机上,您可能需要与数据库管理员联系密码、 用户权限或其他连接信息。如果数据源是一个数据库,请确保未在独占模式下打开数据库。如果数据源文本文件或工作簿,请确保其他用户没有文本文件或以独占方式打开工作簿。

多个数据源也需要 ODBC 驱动程序或 OLE db 访问接口来协调信息流的程序、 连接文件,和数据源之间的数据。

下图汇总了有关数据连接的要点。

连接到外部数据

1.有多种可以连接到的数据源: Microsoft SQL Server、 Microsoft Office Access、 Microsoft Office Excel 中,和文本的文件。

2. 每个数据源都有关联的 ODBC 驱动程序或 OLE DB 提供程序。

3. 连接文件定义了访问和检索数据源中的数据所需的所有信息。

4. 连接信息是从连接文件复制到程序中的。

共享的连接

连接文件是共享上以一致的方式连接、 建立连接更易于查找、 有助于提高安全性,和方便数据源管理特别有用。若要共享的连接文件的最佳方式是将它们放在一个安全和受信任位置,如网络文件夹或Microsoft Office SharePoint Designer库,此时,用户可以读取文件,但仅指定用户可以修改该文件。

通过使用 Excel,或者通过使用数据连接向导连接到新的数据源,您可以创建 Office 数据连接 (ODC) 文件 (.odc)。.Odc 文件使用自定义 HTML 和 XML 标记来存储连接信息。可以轻松地查看或编辑在 Excel 中文件的内容。

您可以与其他用户可授予他们必须相同访问外部数据源中共享连接文件。其他用户没有要将数据源设置为打开连接文件,但它们可能需要安装的 ODBC 驱动程序或访问他们的计算机上的外部数据所需的 OLE db 访问接口。

了解 Microsoft 数据访问组件

Microsoft 数据访问组件 (MDAC) 2.8 是 Microsoft Windows Server 2003 和 Microsoft Windows XP SP2 随附和更高版本。Mdac,您可以连接到并使用各种关系和非关系型数据源中的数据。您可以通过使用开放式数据库连接 (ODBC) 驱动程序或OLE DB提供程序连接到许多不同数据源。可以将内置和由 Microsoft 发运或者开发的各种第三方。安装 Microsoft Office 时,其他 ODBC 驱动程序和 OLE DB 提供程序添加到您的计算机。

若要查看您的计算机安装的 OLE DB 提供程序的完整列表,显示数据链接属性对话框中的数据链接文件,从,然后单击提供商选项卡。

若要查看您的计算机上安装的 ODBC 提供程序的完整列表,显示ODBC 数据库管理器对话框,然后单击驱动程序选项卡。

您可以使用 ODBC 驱动程序和其他制造商提供的 OLE DB 提供程序以从 Microsoft 数据源,包括其他类型的 ODBC 和 OLE DB 数据库以外的源获取信息。有关安装这些 ODBC 驱动程序或 OLE DB 提供程序的信息,查看数据库中的文档或联系您的数据库供应商。

使用 ODBC 连接到数据源

下面部分将详细介绍开放式数据库连接 (ODBC)。

ODBC 体系结构

在 ODBC 体系结构中,在应用程序 (如您的程序) 连接到 ODBC 驱动程序管理器,这又使用特定的 ODBC 驱动程序 (如 Microsoft SQL ODBC 驱动程序) 连接到数据源 (如 Microsoft SQL Server 数据库)。

定义的连接信息

若要连接到 ODBC 数据源,请执行下列操作:

  1. 确保包含数据源的计算机上安装了适当的 ODBC 驱动程序。

  2. 通过使用任一ODBC 数据源管理器将连接信息存储在 Microsoft Windows 注册表或.dsn 文件,或通过使用 Microsoft Visual Basic 代码中的连接字符串传递连接定义数据源名称 (DSN)直接向 ODBC 驱动程序管理器的信息。

    若要定义数据源,请打开 Microsoft Windows 控制面板,双击管理工具图标,然后双击数据源 (ODBC)图标。

    有关的各种选项的详细信息,请单击每个对话框中的帮助按钮。

机器数据源

计算机数据源存储在 Windows 注册表中的用户定义的名称与特定计算机上连接信息。您可以在定义的计算机上使用计算机数据源。有两种类型的计算机数据源-用户和系统。用户数据源可以由只有当前用户,并为只允许该用户均可见。系统数据源可以由一台计算机上的所有用户,并为计算机上的所有用户都均可见。当您想要提供额外的安全,因为它有助于确保只有登录的用户可以查看计算机数据源,并且无法将计算机数据源远程用户通过复制到另一台计算机,计算机数据源是特别有用。

文件数据源

文件 (也称为 DSN 文件) 的数据源中文本文件,不能在 Windows 注册表中,保存连接信息和通常比计算机数据源使用更加灵活。例如,您可以将一个数据源复制到具有正确的 ODBC 驱动程序的任何计算机,以便您的应用程序可以依赖的所有使用计算机的一致且准确的连接信息。或者,可以将单个服务器上的文件的数据源,在网络上的多台计算机之间共享它,然后轻松地保持在一个位置的连接信息。

也可以共享文件的数据源。共享的文件的数据源驻留在一台计算机上,指向计算机数据源。您可以使用共享的文件数据源从文件数据源访问的计算机上的现有数据源。

使用 OLE DB 连接到数据源

以下各节详细描述对象链接和嵌入数据库 (OLE DB)。

OLE DB 体系结构

OLE DB 体系结构中,在访问数据的应用程序称为数据 (如 Publisher) 中,使用者,然后使本机访问数据的程序称为数据库提供程序 (如 Microsoft OLE db 访问接口的 SQL Server)。

定义的连接信息

通用数据链接文件 (.udl) 包含数据消费者用于通过该数据源的 OLE db 访问接口访问数据源的连接信息。您可以通过执行下列操作之一来创建的连接信息:

  • 在数据连接向导中,使用数据链接属性对话框中定义的 OLE db 访问接口的数据链接。

  • 使用.udl 文件类型,创建一个空白的文本文件,然后编辑该文件,其中显示了数据链接属性对话框。

返回页首

使数据访问更安全

当您连接到外部数据源或刷新数据时,务必要注意的潜在的安全问题,并了解有关这些安全问题可以执行哪些操作。使用以下准则和最佳做法可帮助保护您的数据。

在受信任位置中存储数据连接

数据连接文件通常包含一个或多个数据源的查询。通过替换该文件,具有恶意的用户可以设计查询访问机密信息并将其分发给其他用户或执行其他有害操作。因此,务必确保下列:

  • 由可靠人员编写的连接文件。

  • 连接文件的安全,它来自受信任位置。

若要帮助提高安全性,连接到外部数据可能在您的计算机上不可用。若要打开工作簿时,连接到数据,您必须激活数据连接通过使用信任中心栏或通过将工作簿放在受信任位置。

有关详细信息,请参阅创建、 删除或更改您的文件的受信任的位置添加、 删除或查看受信任的发布者查看我在信任中心的安全设置

安全地使用的凭据

通常访问外部数据源需要凭据 (如用户名和密码) 用于验证的用户。确保安全的方式,以向您提供这些凭据,不要无意中显示给其他人这些凭据。

使用由大写字母、小写字母、数字和符号组合的强密码。弱密码不混合使用这些元素。例如,Y6dh!et5 是强密码;House27 是弱密码。密码长度应大于等于 8 个字符。最好使用包括 14 个或更多个字符的密码。

记住密码是非常重要的。如果您忘记了密码,Microsoft 无法为您找回。请将记好的密码保存在安全位置,远离密码所要保护的信息。

避免在连接到数据源时保存登录信息。此信息可能存储为纯文本格式的工作簿,并连接文件,并且恶意用户可以访问破坏安全性的数据源的信息。

如果可能,请使用 Windows 身份验证 (也称为信任连接) 使用 Windows 用户帐户来连接到 SQL Server。当用户连接到 Windows 用户帐户时,SQL Server 使用信息在 Windows 操作系统中要验证的帐户名称和密码。您可以使用 Windows 身份验证之前,服务器管理员必须配置 SQL Server 使用此身份验证模式。如果 Windows 身份验证不可用,避免保存用户的登录信息。为用户输入登录信息登录每次更安全。

返回页首

创建或通过使用 Excel 中编辑 Office 数据连接文件

您可能想要与其他用户或其他程序之间共享 Office 数据连接 (ODC) 文件 (.odc)。若要创建或编辑.odc 文件,您可以使用 Excel。

通过使用 Excel 中创建一个新的 ODC 文件

  1. 找到您的计算机上的我的数据源文件夹。

  2. 执行下列操作之一:

    • 若要创建任何类型的连接文件,右键单击+ 连接到新数据源.odc文件,,然后单击快捷菜单上的在 Excel 中打开

      Excel 启动。如果将显示Microsoft Office Excel 安全声明消息,请单击启用

      显示的数据连接向导欢迎使用数据连接向导页面。按照向导中的说明进行操作。

    • 若要创建 SQL Server 连接文件,右键单击+ 新的 SQL Server Connection.odc文件,,然后单击快捷菜单上的在 Excel 中打开

      Excel 启动和的连接到数据库服务器页面的数据连接向导中显示。

通过使用 Excel 中编辑现有 ODC 文件

  1. 找到包含.odc 文件,例如您的计算机上的我的数据源文件夹或受信任的网络文件夹的文件夹。

  2. 右键单击.odc 文件中,,然后单击快捷菜单上的在 Excel 中打开

  3. Microsoft Office Excel 安全声明邮件可能会出现。如果您信任数据源,请单击启用

    按.odc 文件检索的数据将显示在新工作簿,以确认您已正确连接的第一个工作表。

  4. 在“数据”选项卡上的“连接”组中,单击“连接”。

  5. 工作簿连接对话框中,选择连接,,然后单击属性

  6. 进行所需连接属性对话框中的更改。

    有关修改连接文件信息的详细信息,请参阅 Excel 帮助系统。

  7. 后的所有修订,请单击定义选项卡,然后单击导出连接文件

  8. 保存文件对话框中,单击保存

  9. 关闭连接属性工作簿连接对话框,然后退出 Excel,而不保存新的工作簿。

返回页首

使用数据连接向导中的 office Publisher: 导入外部数据

在 Microsoft Office Publisher 中,您将导入外部数据使用邮件合并。使用邮件合并创建大量的大部分是相同的文档,但将包含一些唯一的信息,如要发送给您的顶级 100 客户产品发布。您还可以导入的文本文件,Excel 工作表和 Access 表或查询直接,而无需使用连接文件。有关详细信息,请参阅创建邮件合并

你要做什么?

使用 OLE db 访问接口导入文本文件

使用的 ODBC 驱动程序导入文本文件

使用导入数据从 Excel 97-2003年或 2007年工作簿的 OLE DB 提供程序

使用导入数据从 Excel 97-2003年或 2007年工作簿的 ODBC 驱动程序

使用导入数据从 Access 2000、 2003年或 2007年数据库 OLE db 访问接口

使用导入数据从 Access 2000、 2003年或 2007年数据库的 ODBC 驱动程序

使用导入数据从 SQL Server 2000 或 2005年数据库 OLE db 访问接口

从 SQL Server 2000 或 2005年数据库使用的 ODBC 驱动程序导入数据

使用 OLE db 访问接口导入文本文件

导入文本以逗号分隔值 (CSV) 文件 (.csv) 非常简单。如果您的文本文件不使用列表分隔符定义在您的计算机的.csv 文件或文本文件不是.csv 文件,您可以使用 Schema.ini 文件指定了正确的文件格式。

导入文件

  1. 工具菜单上指向邮寄和目录,,然后单击邮件合并电子邮件合并目录合并

  2. 执行下列操作之一:

    • 邮件合并任务窗格中,单击创建或连接到的收件人列表

    • 电子邮件合并任务窗格中,单击创建或连接到的收件人列表

    • 目录合并任务窗格中,单击创建或连接到产品列表

  3. 在“选择数据源”对话框中,执行下列操作之一:

    • 若要使用现有.odc 文件,请双击.odc 文件。导入数据后,并且您已完成。

    • 要创建新的.odc 文件,请单击新建源,然后执行过程中的每个步骤。

      数据连接向导中显示。

  4. 欢迎使用数据连接向导页面中,单击其他/高级

    数据链接属性对话框中显示。

    有关各种对话框中的其他选项的详细信息,请单击帮助

  5. 提供商选项卡上,选择Microsoft Jet 4.0 OLE DB 提供程序,,然后单击下一步

  6. 连接选项卡上的选择或输入数据库名称框中,输入完整路径包含文本的文件的文件夹。

    为了帮助您找到的文件夹,请单击框旁边的浏览按钮。

  7. 单击全部选项卡,选择扩展属性,然后单击编辑值

  8. 属性值框中,输入下列选项之一:

    • 如果文本文件具有列标题,请输入文本;页眉 = 是

    • 如果文本文件不具有列标题,请输入文本;页眉 = 无

  9. 单击“确定”。

  10. 若要确保您输入了正确的信息,请单击连接选项卡,然后单击测试连接

  11. 执行下列操作之一:

    • 如果您收到一条错误消息,重新检查您在前面的步骤中输入的值。

    • 如果您收到消息"测试连接成功",单击确定

  12. 单击“确定”。

    数据连接向导将重新出现。

  13. 选择数据库和表页面下的名称列中,选择要导入的文本文件,然后单击下一步

  14. 保存数据连接文件和完成页上,在文件名框中,输入.odc 文件的名称,然后单击完成

    若要更改文件夹的位置,这是默认情况下的我的数据源文件夹,请单击浏览

  15. (可选) 若要使连接文件更易于查找,您可以在说明友好名称搜索关键字框中输入的其他信息。

使用 Schema.ini 文件指定不同列表分隔符字符或文本的文件格式

Schema.ini 文件是一个文本文件,其中包含用于替代默认文本驱动程序设置 Windows 注册表中的条目。一般情况下,使用 Schema.ini 文件,必须执行以下操作:

  • 将 Schema.ini 文件存储在您要导入的文本文件所在的文件夹。

  • 命名文件Schema.ini

  • 在 Schema.ini 文件的第一行中,键入要链接到的文本文件的名称用方括号括起来。

  • 添加其他信息,以指定不同的文本的文件格式。

以下各部分显示使用 Schema.ini 文件的常见的示例。

示例: 指定分号 (;) 作为分隔符

[Categories.txt] Format=Delimited(;)

足够: 指定制表符作为分隔符

[Products.txt] Format=TabDelimited

示例: 指定固定宽度的文件

[Shippers.txt]Format=FixedLengthCol1=ShipperID Text Width 11Col2=CompanyName Text Width 40Col3=Phone Text Width 24

返回页首 返回节首

使用的 ODBC 驱动程序导入文本文件

导入文本文件使用 ODBC 驱动程序是,至少两个步骤。首先,如有必要,在您的计算机文本的 ODBC 驱动程序定义 DSN 的用户。第二步,使用导入的文本文件 DSN 的用户。如果您的文本文件的逗号分隔值 (CSV) 文件,不使用列表分隔符定义在您的计算机或您的文本文件不是.csv 文件,您可以使用 Schema.ini 文件指定了正确的文件格式。

定义 DSN 的用户

  1. 打开 Microsoft Windows 控制面板,双击管理工具图标,然后双击数据源 (ODBC)图标。

  2. ODBC 数据库管理员对话框中,在用户 DSN选项卡上,单击添加

  3. 创建新的数据源对话框中,选择Microsoft 文本驱动程序 (.txt; *.csv),,然后单击完成

    显示ODBC 文本设置对话框。

  4. 数据源名称中输入的名称。

  5. 清除使用当前目录复选框。

  6. 单击选择目录

  7. 选择目录对话框中,找到包含要导入,请确保在文件名框中,下面的列表中显示的文本文件的文本文件的文件夹,然后单击确定

  8. 单击两次“确定”

有关各种对话框中的其他选项的详细信息,请单击帮助

导入文件

  1. 工具菜单上指向邮寄和目录,,然后单击邮件合并电子邮件合并目录合并

  2. 执行下列操作之一:

    • 邮件合并任务窗格中,单击创建或连接到的收件人列表

    • 电子邮件合并任务窗格中,单击创建或连接到的收件人列表

    • 目录合并任务窗格中,单击创建或连接到产品列表

  3. 在“选择数据源”对话框中,执行下列操作之一:

    • 若要使用现有.odc 文件,请双击.odc 文件。在导入的数据,并且您完成。

    • 要创建新的.odc 文件,请单击新建源,然后执行过程中的每个步骤。

      数据连接向导中显示。

  4. 欢迎使用数据连接向导页面中,单击ODBC/DSN

  5. 连接到 ODBC 数据源页中,选择刚创建的用户 DSN,然后单击下一步

  6. 选择数据库和表页上,选择在名称列下的文本文件,然后单击下一步

  7. 保存数据连接文件和完成页上,在文件名框中,输入.odc 文件的名称,然后单击完成

    若要更改文件夹的位置,这是默认情况下的我的数据源文件夹,请单击浏览

  8. (可选) 若要使连接文件更易于查找,您可以在说明友好名称搜索关键字框中输入的其他信息。

使用 Schema.ini 文件指定不同列表分隔符字符或文本的文件格式

Schema.ini 文件是一个文本文件,其中包含用于替代默认文本驱动程序设置 Windows 注册表中的条目。一般情况下,使用 Schema.ini 文件,必须执行以下操作:

  • 将 Schema.ini 文件存储在您要导入的文本文件所在的文件夹。

  • 命名文件Schema.ini

  • 在 Schema.ini 文件的第一行中,键入要链接到的文本文件的名称用方括号括起来。

  • 添加其他信息,以指定不同的文本的文件格式。

以下各部分显示使用 Schema.ini 文件的常见的示例。

示例: 指定列标题

[Categories.txt] ColNameHeader=True

示例: 指定分号 (;) 作为分隔符

[Categories.txt] Format=Delimited(;)

示例: 指定制表符作为分隔符

[Products.txt] Format=TabDelimited

示例: 指定固定宽度的文件

[Shippers.txt]Format=FixedLengthCol1=ShipperID Text Width 11Col2=CompanyName Text Width 40Col3=Phone Text Width 24

返回页首 返回节首

使用导入数据从 Excel 97-2003年或 2007年工作簿的 OLE DB 提供程序

  1. 工具菜单上指向邮寄和目录,,然后单击邮件合并电子邮件合并目录合并

  2. 执行下列操作之一:

    • 邮件合并任务窗格中,单击创建或连接到的收件人列表

    • 电子邮件合并任务窗格中,单击创建或连接到的收件人列表

    • 目录合并任务窗格中,单击创建或连接到产品列表

  3. 在“选择数据源”对话框中,执行下列操作之一:

    • 若要使用现有.odc 文件,请双击.odc 文件。在导入的数据,并且您完成。

    • 要创建新的.odc 文件,请单击新建源,然后执行过程中的每个步骤。

      数据连接向导中显示。

  4. 数据连接向导欢迎页面上,单击其他/高级

    数据链接属性对话框中显示。

    有关各种对话框中的其他选项的详细信息,请单击帮助

  5. 提供商选项卡上,选择Microsoft Office 12.0 Access 数据库引擎 OLE DB 提供程序,,然后单击下一步

  6. 连接选项卡上的数据源框中,输入 Excel 工作簿的完整路径和文件名。

  7. 单击全部选项卡,选择扩展属性,然后单击编辑值

  8. 属性值框中,输入下列选项之一:

    • 如果工作簿中的数据有列标题,输入Excel 8.0;页眉 = 是

    • 如果工作簿中的数据不具有列标题,请输入Excel 8.0;页眉 = 无

  9. 单击“确定”。

  10. 若要确保您输入了正确的信息,请单击连接选项卡,然后单击测试连接

  11. 执行下列操作之一:

    • 如果您收到一条错误消息,重新检查您在前面的步骤中输入的值。

    • 如果您收到消息"测试连接成功",单击确定

  12. 选择数据库和表页上,选择下的名称列中,工作表,然后单击下一步

  13. 单击“确定”。

    数据连接向导将重新出现。

  14. 保存数据连接文件和完成页上,在文件名框中,输入.odc 文件的名称,然后单击完成

    若要更改文件夹的位置,这是默认情况下的我的数据源文件夹,请单击浏览

  15. (可选) 若要使连接文件更易于查找,您可以在说明友好名称搜索关键字框中输入的其他信息。

返回页首 返回节首

使用导入数据从 Excel 97-2003年或 2007年工作簿的 ODBC 驱动程序

  1. 工具菜单上指向邮寄和目录,,然后单击邮件合并电子邮件合并目录合并

  2. 执行下列操作之一:

    • 邮件合并任务窗格中,单击创建或连接到的收件人列表

    • 电子邮件合并任务窗格中,单击创建或连接到的收件人列表

    • 目录合并任务窗格中,单击创建或连接到产品列表

  3. 在“选择数据源”对话框中,执行下列操作之一:

    • 若要使用现有.odc 文件,请双击.odc 文件。在导入的数据,并且您完成。

    • 要创建新的.odc 文件,请单击新建源,然后执行过程中的每个步骤。

      数据连接向导中显示。

  4. 欢迎使用数据连接向导页面中,单击ODBC/DSN

  5. 连接到 ODBC 数据源页中,选择Excel 文件,,然后单击下一步

  6. 选择工作簿对话框中,在数据库名称框中,输入包含 Excel 工作簿的文件夹,在列表中,选择工作簿,然后单击确定

  7. 选择数据库和表页面下的名称列中,选择要导入的工作表,然后单击下一步

  8. 保存数据连接文件和完成页上,在文件名框中,输入.odc 文件的名称,然后单击完成

    若要更改文件夹的位置,这是默认情况下的我的数据源文件夹,请单击浏览

  9. (可选) 若要使连接文件更易于查找,您可以在说明友好名称搜索关键字框中输入的其他信息。

有关各种对话框中的其他选项的详细信息,请单击帮助

返回页首 返回节首

使用导入数据从 Access 2000、 2003年或 2007年数据库 OLE db 访问接口

  1. 工具菜单上指向邮寄和目录,,然后单击邮件合并电子邮件合并目录合并

  2. 执行下列操作之一:

    • 邮件合并任务窗格中,单击创建或连接到的收件人列表

    • 电子邮件合并任务窗格中,单击创建或连接到的收件人列表

    • 目录合并任务窗格中,单击创建或连接到产品列表

  3. 在“选择数据源”对话框中,执行下列操作之一:

    • 若要使用现有.odc 文件,请双击.odc 文件。在导入的数据,并且您完成。

    • 要创建新的.odc 文件,请单击新建源,然后执行过程中的每个步骤。

      数据连接向导中显示。

  4. 欢迎使用数据连接向导页面中,单击其他/高级

    数据链接属性对话框中显示。

    有关各种对话框中的其他选项的详细信息,请单击帮助

  5. 提供商选项卡上,执行下列操作之一:

    • 如果数据库是 Microsoft Access 2000 或 Microsoft Office Access 2003 数据库,选择Microsoft Jet 4.0 OLE DB 提供程序

    • 如果数据库是Microsoft Office Access 2007数据库,选择Microsoft Office 12.0 Access 数据库引擎 OLE DB 提供程序

  6. 单击“下一步”

  7. 连接选项卡上的选择或输入数据库名称框中,输入 Access 数据库的完整路径和文件名。

    如果您选中提供商选项卡上的Microsoft Jet 4.0 OLE DB 提供程序,可帮助您查找该数据库,可单击框旁边的浏览按钮。

  8. 若要确保您输入了正确的信息,请单击连接选项卡,然后单击测试连接

  9. 执行下列操作之一:

    • 如果您收到一条错误消息,重新检查您在前面的步骤中输入的值。

    • 如果您收到消息"测试连接成功",单击确定

  10. 选择数据库和表页上,选择表或查询,在名称列下的,然后单击下一步

    注意: 此列表中没有链接的表。如果您想要导入的链接的表,Access 数据库中创建链接表到查询执行导入操作之前。

  11. 保存数据连接文件和完成页上,在文件名框中,输入.odc 文件的名称,然后单击完成

    若要更改文件夹的位置,这是默认情况下的我的数据源文件夹,请单击浏览

  12. (可选) 若要使连接文件更易于查找,您可以在说明友好名称搜索关键字框中输入的其他信息。

返回页首 返回节首

使用导入数据从 Access 2000、 2003年或 2007年数据库的 ODBC 驱动程序

  1. 工具菜单上指向邮寄和目录,,然后单击邮件合并电子邮件合并目录合并

  2. 执行下列操作之一:

    • 邮件合并任务窗格中,单击创建或连接到的收件人列表

    • 电子邮件合并任务窗格中,单击创建或连接到的收件人列表

    • 目录合并任务窗格中,单击创建或连接到产品列表

  3. 在“选择数据源”对话框中,执行下列操作之一:

    • 若要使用现有.odc 文件,请双击.odc 文件。在导入的数据,并且您完成。

    • 要创建新的.odc 文件,请单击新建源,然后执行过程中的每个步骤。

      数据连接向导中显示。

  4. 欢迎使用数据连接向导页面中,单击ODBC/DSN

  5. 连接到 ODBC 数据源页中,选择MS Access 数据库,然后单击下一步

    出现选择数据库对话框。

  6. 选择目录对话框中,找到包含要导入,请确保在文件名框中,下面的列表中显示的 Access 数据库的 Access 数据库的文件夹,然后单击确定

    数据连接向导将重新出现。

  7. 选择数据库和表页上,选择表或查询,在名称列下的,然后单击下一步

  8. 保存数据连接文件和完成页上,在文件名框中,输入.odc 文件的名称,然后单击完成

    若要更改文件夹的位置,这是默认情况下的我的数据源文件夹,请单击浏览

  9. (可选) 若要使连接文件更易于查找,您可以在说明友好名称搜索关键字框中输入的其他信息。

有关各种对话框中的其他选项的详细信息,请单击帮助

返回页首 返回节首

使用导入数据从 SQL Server 2000 或 2005年数据库 OLE db 访问接口

  1. 工具菜单上指向邮寄和目录,,然后单击邮件合并电子邮件合并目录合并

  2. 执行下列操作之一:

    • 邮件合并任务窗格中,单击创建或连接到的收件人列表

    • 电子邮件合并任务窗格中,单击创建或连接到的收件人列表

    • 目录合并任务窗格中,单击创建或连接到产品列表

  3. 在“选择数据源”对话框中,执行下列操作之一:

    • 若要使用现有.odc 文件,请双击.odc 文件。在导入的数据,并且您完成。

    • 要创建新的.odc 文件,请单击新建源,然后执行过程中的每个步骤。

      数据连接向导中显示。

  4. 欢迎使用数据连接向导页面中,单击Microsoft SQL Server

  5. 连接到数据库服务器页面上,执行下列操作:

    • 服务器名称框中输入数据库服务器的名称。

      如果数据库是您的计算机上,输入(本地)

    • 登录凭据,请执行下列操作之一:

      • 若要使用您的 Windows 用户名和密码,请单击使用 Windows 身份验证

      • 要使用的数据库的用户名和密码,请使用下面的用户名和密码,请单击,然后在相应的框中输入的数据库的用户名和密码。

  6. 单击“下一步”

  7. 选择数据库和表页上,在数据库框中选择的数据库、 表、 视图或用户定义的函数,在名称列中,选择,然后单击下一步

  8. 保存数据连接文件和完成页上,在文件名框中,输入.odc 文件的名称,然后单击完成

    若要更改文件夹的位置,这是默认情况下的我的数据源文件夹,请单击浏览

  9. (可选) 若要使连接文件更易于查找,您可以在说明友好名称搜索关键字框中输入的其他信息。

返回页首 返回节首

从 SQL Server 2000 或 2005年数据库使用的 ODBC 驱动程序导入数据

从 SQL Server 数据库使用的 ODBC 驱动程序导入数据的两个步骤。首先,如有必要,在您的计算机的 ODBC 驱动程序定义 DSN 的用户。第二步,从 SQL Server 数据库导入数据。

定义 DSN 的用户

  1. 打开 Microsoft Windows 控制面板,双击管理工具图标,然后双击数据源 (ODBC)图标。

  2. ODBC 数据库管理器对话框中,选择用户 DSN选项卡,,然后单击添加

  3. 创建新的数据源对话框中,选择SQL Server,然后单击完成

    显示创建新的数据源与 SQL Server对话框。

  4. 名称框中输入数据源名称。

  5. (可选) 在说明框中输入的数据源的说明。

  6. 服务器框中输入数据库服务器名称。

    如果数据库是您的计算机上,输入(本地)

  7. 单击“下一步”

  8. 在下SQL Server 应如何验证登录 ID 的真实性?,请执行下列操作之一:

    • 使用您的 Windows 用户名和密码,请单击与 Windows NT 身份验证使用网络登录 ID

    • 若要使用的数据库的用户名和密码,通过使用 SQL Server 身份验证的登录 ID 和用户输入的密码,请单击,然后在相应的框中输入数据库登录 ID 和密码。

  9. 单击两次下, 一步,然后单击完成

  10. 若要确保您输入了正确的信息,请单击测试数据源

  11. 执行下列操作之一:

    • 如果您收到一条错误消息,重新检查您在前面的步骤中输入的值。

    • 如果您收到消息"测试成功完成 !",单击确定

  12. 单击两次“确定”

有关各种对话框中的其他选项的详细信息,请单击帮助

从 SQL Server 数据库导入数据

  1. 工具菜单上指向邮寄和目录,,然后单击邮件合并电子邮件合并目录合并

  2. 执行下列操作之一:

    • 邮件合并任务窗格中,单击创建或连接到的收件人列表

    • 电子邮件合并任务窗格中,单击创建或连接到的收件人列表

    • 目录合并任务窗格中,单击创建或连接到产品列表

  3. 在“选择数据源”对话框中,执行下列操作之一:

    • 若要使用现有.odc 文件,请双击.odc 文件。在导入的数据,并且您完成。

    • 要创建新的.odc 文件,请单击新建源,然后执行过程中的每个步骤。

      数据连接向导中显示。

  4. 欢迎使用数据连接向导页面中,单击ODBC/DSN

  5. 连接到 ODBC 数据源页中,选择您在上一节中定义数据源名称,然后单击下一步

  6. 选择数据库和表页上,在数据库框中选择的数据库、 表、 视图或函数下的名称列中,选择,然后单击下一步

  7. 保存数据连接文件和完成页上,在文件名框中,输入.odc 文件的名称,然后单击完成

    若要更改文件夹的位置,这是默认情况下的我的数据源文件夹,请单击浏览

  8. (可选) 若要使连接文件更易于查找,您可以在说明友好名称搜索关键字框中输入的其他信息。

返回页首 返回节首

返回页首

Office Visio: 使用数据连接向导导入外部数据

在 Microsoft Office Visio 中导入外部数据,以便它可以直接添加到绘图中的形状。使用绘图监控信息以直观的方式,如网络图显示停机时间统计信息或显示进度栏和米进行汇总项目任务的流程图。以下是有关说明文本文件和 SQL Server 数据源。您还可以导入 Excel 工作表、 Access 表或查询,然后直接在文件列表不使用的连接文件的 SharePoint。有关详细信息,请参阅从 Excel、 SQL Server、 SharePoint 网站和其他外部源导入数据

你要做什么?

使用 OLE db 访问接口导入文本文件

使用的 ODBC 驱动程序导入文本文件

使用导入数据从 SQL Server 2000 或 2005年数据库 OLE db 访问接口

从 SQL Server 2000 或 2005年数据库使用的 ODBC 驱动程序导入数据

使用 OLE db 访问接口导入文本文件

导入文本以逗号分隔值 (CSV) 文件 (.csv) 非常简单。如果您的文本文件不使用列表分隔符定义在您的计算机的.csv 文件或文本文件不是.csv 文件,您可以使用 Schema.ini 文件指定了正确的文件格式。

导入文件

  1. 数据菜单上,单击数据链接到形状

  2. 在数据选取器向导的第一页,单击其他 OLE DB 或 ODBC 数据源

    数据连接向导中显示。

  3. 单击其他/高级

    数据链接属性对话框中显示。

    有关各种对话框中的其他选项的详细信息,请单击帮助

  4. 提供商选项卡上,选择Microsoft Jet 4.0 OLE DB 提供程序,,然后单击下一步

  5. 连接选项卡上的选择或输入数据库名称框中,输入完整路径包含文本的文件的文件夹。

    为了帮助您找到的文件夹,请单击框旁边的浏览按钮。

  6. 单击全部选项卡,选择扩展属性,然后单击编辑值

  7. 属性值框中,输入下列选项之一:

    • 如果文本文件具有列标题,请输入文本;页眉 = 是

    • 如果文本文件不具有列标题,请输入文本;页眉 = 无

  8. 单击“确定”。

  9. 若要确保您输入了正确的信息,请单击连接选项卡,然后单击测试连接

  10. 执行下列操作之一:

    • 如果您收到一条错误消息,重新检查您在前面的步骤中输入的值。

    • 如果您收到消息"测试连接成功",单击确定

  11. 单击“确定”。

    数据连接向导将重新出现。

  12. 选择数据库和表页面下的名称列中,选择要导入的文本文件,然后单击下一步

  13. 保存数据连接文件和完成页上,在文件名框中,输入.odc 文件的名称,然后单击完成

    若要更改文件夹的位置,这是默认情况下的我的数据源文件夹,请单击浏览

  14. (可选) 若要使连接文件更易于查找,您可以在说明友好名称搜索关键字框中输入的其他信息。

  15. 单击“完成”。

    数据选取器向导将重新出现。

  16. 选择数据连接页面中,执行下列操作之一:

    • 若要使用您刚刚创建的.odc 文件并接受所有行和列的数据源中,单击完成

    • 可以继续使用数据选取器向导中,以便您可以选择特定列和行数,以便您可以创建一个唯一的标识符,单击下一步

      数据选取器向导在每一页的详细信息,请按 F1。

使用 Schema.ini 文件指定不同列表分隔符字符或文本的文件格式

Schema.ini 文件是一个文本文件,其中包含用于替代默认文本驱动程序设置 Windows 注册表中的条目。一般情况下,使用 Schema.ini 文件,必须执行以下操作:

  • 将 Schema.ini 文件存储在您要导入的文本文件所在的文件夹。

  • 命名文件Schema.ini

  • 在 Schema.ini 文件的第一行中,键入要链接到的文本文件的名称用方括号括起来。

  • 添加其他信息,以指定不同的文本的文件格式。

以下各部分显示使用 Schema.ini 文件的常见的示例。

示例: 指定分号 (;) 作为分隔符

[Categories.txt] Format=Delimited(;)

示例: 指定制表符作为分隔符

[Products.txt] Format=TabDelimited

示例: 指定固定宽度的文件

[Shippers.txt]Format=FixedLengthCol1=ShipperID Text Width 11Col2=CompanyName Text Width 40Col3=Phone Text Width 24

返回页首 返回节首

使用的 ODBC 驱动程序导入文本文件

导入文本文件使用 ODBC 驱动程序是,至少两个步骤。首先,如有必要,在您的计算机文本的 ODBC 驱动程序定义 DSN 的用户。第二步,使用导入的文本文件 DSN 的用户。如果您的文本文件的逗号分隔值 (CSV) 文件,不使用列表分隔符定义在您的计算机或您的文本文件不是.csv 文件,您可以使用 Schema.ini 文件指定了正确的文件格式。

定义 DSN 的用户

  1. 打开 Microsoft Windows 控制面板,双击管理工具图标,然后双击数据源 (ODBC)图标。

  2. ODBC 数据库管理员对话框中,在用户 DSN选项卡上,单击添加

  3. 创建新的数据源对话框中,选择Microsoft 文本驱动程序 (.txt; *.csv),,然后单击完成

    显示ODBC 文本设置对话框。

  4. 数据源名称中输入的名称。

  5. 清除使用当前目录复选框。

  6. 单击选择目录

  7. 选择目录对话框中,找到包含要导入,请确保在文件名框中,下面的列表中显示的文本文件的文本文件的文件夹,然后单击确定

  8. 单击两次“确定”

有关各种对话框中的其他选项的详细信息,请单击帮助

导入文件

  1. 数据菜单上,单击数据链接到形状

  2. 在数据选取器向导的第一页,单击其他 OLE DB 或 ODBC 数据源

    数据连接向导中显示。

  3. 欢迎使用数据连接向导页面中,单击ODBC/DSN

  4. 连接到 ODBC 数据源页中,选择刚创建的用户 DSN,然后单击下一步

  5. 选择数据库和表页上,选择在名称列下的文本文件,然后单击下一步

  6. 保存数据连接文件和完成页上,在文件名框中,输入.odc 文件的名称,然后单击完成

    若要更改文件夹的位置,这是默认情况下的我的数据源文件夹,请单击浏览

  7. (可选) 若要使连接文件更易于查找,您可以在说明友好名称搜索关键字框中输入的其他信息。

  8. 单击“完成”。

    数据选取器向导将重新出现。

  9. 选择数据连接页面中,执行下列操作之一:

    • 若要使用您刚刚创建的.odc 文件并接受所有行和列的数据源中,单击完成

    • 可以继续使用数据选取器向导中,以便您可以选择特定列和行数,以便您可以创建一个唯一的标识符,单击下一步

      数据选取器向导在每一页的详细信息,请按 F1。

使用 Schema.ini 文件指定不同列表分隔符字符或文本的文件格式

Schema.ini 文件是一个文本文件,其中包含用于替代默认文本驱动程序设置 Windows 注册表中的条目。一般情况下,使用 Schema.ini 文件,必须执行以下操作:

  • 将 Schema.ini 文件存储在您要导入的文本文件所在的文件夹。

  • 命名文件Schema.ini

  • 在 Schema.ini 文件的第一行中,键入要链接到的文本文件的名称用方括号括起来。

  • 添加其他信息,以指定不同的文本的文件格式。

以下各部分显示使用 Schema.ini 文件的常见的示例。

示例: 指定列标题

[Categories.txt] ColNameHeader=True

示例: 指定分号 (;) 作为分隔符

[Categories.txt] Format=Delimited(;)

示例: 指定制表符作为分隔符

[Products.txt] Format=TabDelimited

示例: 指定固定宽度的文件

[Shippers.txt]Format=FixedLengthCol1=ShipperID Text Width 11Col2=CompanyName Text Width 40Col3=Phone Text Width 24

返回页首 返回节首

使用导入数据从 SQL Server 2000 或 2005年数据库 OLE db 访问接口

  1. 数据菜单上,单击数据链接到形状

  2. 在数据选取器向导的第一页,单击Microsoft SQL Server 2000 或 2005年数据库

    数据连接向导中显示。

  3. 连接到数据库服务器页面上,执行下列操作:

    • 服务器名称框中输入数据库服务器的名称。

      如果数据库是您的计算机上,输入(本地)

    • 登录凭据,请执行下列操作之一:

      • 若要使用您的 Windows 用户名和密码,请单击使用 Windows 身份验证

      • 要使用的数据库的用户名和密码,请使用下面的用户名和密码,请单击,然后在相应的框中输入的数据库的用户名和密码。

  4. 单击“下一步”

  5. 选择数据库和表页上,在数据库框中选择的数据库、 表、 视图或用户定义的函数,在名称列中,选择,然后单击下一步

  6. 保存数据连接文件和完成页上,在文件名框中,输入.odc 文件的名称,然后单击完成

    若要更改文件夹的位置,这是默认情况下的我的数据源文件夹,请单击浏览

  7. (可选) 若要使连接文件更易于查找,您可以在说明友好名称搜索关键字框中输入的其他信息。

  8. 单击“完成”。

    数据选取器向导将重新出现。

  9. 选择数据连接页面中,执行下列操作之一:

    • 若要使用您刚刚创建的.odc 文件并接受所有行和列的数据源中,单击完成

    • 可以继续使用数据选取器向导中,以便您可以选择特定列和行数,以便您可以创建一个唯一的标识符,单击下一步

      数据选取器向导在每一页的详细信息,请按 F1。

返回页首 返回节首

从 SQL Server 2000 或 2005年数据库使用的 ODBC 驱动程序导入数据

从 SQL Server 数据库使用的 ODBC 驱动程序导入数据的两个步骤。首先,如有必要,在您的计算机的 ODBC 驱动程序定义 DSN 的用户。第二步,从 SQL Server 数据库导入数据。

定义 DSN 的用户

  1. 打开 Microsoft Windows 控制面板,双击管理工具图标,然后双击数据源 (ODBC)图标。

  2. ODBC 数据库管理器对话框中,选择用户 DSN选项卡,,然后单击添加

  3. 创建新的数据源对话框中,选择SQL Server,然后单击完成

    显示创建新的数据源与 SQL Server对话框。

  4. 名称框中输入数据源名称。

  5. (可选) 在说明框中输入的数据源的说明。

  6. 服务器框中输入数据库服务器名称。

    如果数据库是您的计算机上,输入(本地)

  7. 单击“下一步”

  8. 在下SQL Server 应如何验证登录 ID 的真实性?,请执行下列操作之一:

    • 使用您的 Windows 用户名和密码,请单击与 Windows NT 身份验证使用网络登录 ID

    • 若要使用的数据库的用户名和密码,通过使用 SQL Server 身份验证的登录 ID 和用户输入的密码,请单击,然后在相应的框中输入数据库登录 ID 和密码。

  9. 单击两次下, 一步,然后单击完成

  10. 若要确保您输入了正确的信息,请单击测试数据源

  11. 执行下列操作之一:

    • 如果您收到一条错误消息,重新检查您在前面的步骤中输入的值。

    • 如果您收到消息"测试成功完成 !",单击确定

  12. 单击两次“确定”

有关各种对话框中的其他选项的详细信息,请单击帮助

从 SQL Server 数据库导入数据

  1. 数据菜单上,单击数据链接到形状

  2. 在数据选取器向导的第一页,单击其他 OLE DB 或 ODBC 数据源

    数据连接向导中显示。

  3. 欢迎使用数据连接向导页面中,单击ODBC/DSN

  4. 连接到 ODBC 数据源页中,选择您在上一节中定义数据源名称,然后单击下一步

  5. 选择数据库和表页上,在数据库框中选择的数据库、 表、 视图或函数下的名称列中,选择,然后单击下一步

  6. 保存数据连接文件和完成页上,在文件名框中,输入.odc 文件的名称,然后单击完成

    若要更改文件夹的位置,这是默认情况下的我的数据源文件夹,请单击浏览

  7. (可选) 若要使连接文件更易于查找,您可以在说明友好名称搜索关键字框中输入的其他信息。

  8. 单击“完成”。

    数据选取器向导将重新出现。

  9. 选择数据连接页面中,执行下列操作之一:

    • 若要使用您刚刚创建的.odc 文件并接受所有行和列的数据源中,单击完成

    • 可以继续使用数据选取器向导中,以便您可以选择特定列和行数,以便您可以创建一个唯一的标识符,单击下一步

      数据选取器向导在每一页的详细信息,请按 F1。

返回页首 返回节首

返回页首

Office Word: 使用数据连接向导导入外部数据

在 Microsoft Office Word 中,您将导入外部数据使用邮件合并。使用邮件合并创建一组文档,例如发送到多个客户或为假日卡片邮寄地址标签工作表的套用信函。您还可以导入的文本文件,Excel 工作表和 Access 表或查询直接,而无需使用连接文件。有关详细信息,请参阅创建邮件合并

你要做什么?

使用 OLE db 访问接口导入文本文件

使用的 ODBC 驱动程序导入文本文件

使用导入数据从 Excel 97-2003年或 2007年工作簿的 OLE DB 提供程序

使用导入数据从 Excel 97-2003年或 2007年工作簿的 ODBC 驱动程序

使用导入数据从 Access 2000、 2003年或 2007年数据库 OLE db 访问接口

使用导入数据从 Access 2000、 2003年或 2007年数据库的 ODBC 驱动程序

使用导入数据从 SQL Server 2000 或 2005年数据库 OLE db 访问接口

从 SQL Server 2000 或 2005年数据库使用的 ODBC 驱动程序导入数据

使用 OLE db 访问接口导入文本文件

导入文本以逗号分隔值 (CSV) 文件 (.csv) 非常简单。如果您的文本文件不使用列表分隔符定义在您的计算机的.csv 文件或文本文件不是.csv 文件,您可以使用 Schema.ini 文件指定了正确的文件格式。

导入文件

  1. 邮件选项卡上的开始邮件合并组中,单击选择收件人,然后单击使用现有列表

    Word 功能区图像

  2. 在“选择数据源”对话框中,执行下列操作之一:

    • 若要使用现有.odc 文件,请双击.odc 文件。在导入的数据,并且您完成。

    • 要创建新的.odc 文件,请单击新建源,然后执行过程中的每个步骤。

      数据连接向导中显示。

  3. 欢迎使用数据连接向导页面中,单击其他/高级

    数据链接属性对话框中显示。

    有关各种对话框中的其他选项的详细信息,请单击帮助

  4. 提供商选项卡上,选择Microsoft Jet 4.0 OLE DB 提供程序,,然后单击下一步

  5. 连接选项卡上的选择或输入数据库名称框中,输入完整路径包含文本的文件的文件夹。

    为了帮助您找到的文件夹,请单击框旁边的浏览按钮。

  6. 单击全部选项卡,选择扩展属性,然后单击编辑值

  7. 属性值框中,输入下列选项之一:

    • 如果文本文件具有列标题,请输入文本;页眉 = 是

    • 如果文本文件不具有列标题,请输入文本;页眉 = 无

  8. 单击“确定”。

  9. 若要确保您输入了正确的信息,请单击连接选项卡,然后单击测试连接

  10. 执行下列操作之一:

    • 如果您收到一条错误消息,重新检查您在前面的步骤中输入的值。

    • 如果您收到消息"测试连接成功",单击确定

  11. 单击“确定”。

    数据连接向导将重新出现。

  12. 选择数据库和表页面下的名称列中,选择要导入的文本文件,然后单击下一步

  13. 保存数据连接文件和完成页上,在文件名框中,输入.odc 文件的名称,然后单击完成

    若要更改文件夹的位置,这是默认情况下的我的数据源文件夹,请单击浏览

  14. (可选) 若要使连接文件更易于查找,您可以在说明友好名称搜索关键字框中输入的其他信息。

使用 Schema.ini 文件指定不同列表分隔符字符或文本的文件格式

Schema.ini 文件是一个文本文件,其中包含用于替代默认文本驱动程序设置 Windows 注册表中的条目。一般情况下,使用 Schema.ini 文件,必须执行以下操作:

  • 将 Schema.ini 文件存储在您要导入的文本文件所在的文件夹。

  • 命名文件Schema.ini

  • 在 Schema.ini 文件的第一行中,键入要链接到的文本文件的名称用方括号括起来。

  • 添加其他信息,以指定不同的文本的文件格式。

以下各部分显示使用 Schema.ini 文件的常见的示例。

示例: 指定分号 (;) 作为分隔符

[Categories.txt] Format=Delimited(;)

示例: 指定制表符作为分隔符

[Products.txt] Format=TabDelimited

示例: 指定固定宽度的文件

[Shippers.txt]Format=FixedLengthCol1=ShipperID Text Width 11Col2=CompanyName Text Width 40Col3=Phone Text Width 24

返回页首 返回节首

使用的 ODBC 驱动程序导入文本文件

导入文本文件使用 ODBC 驱动程序是,至少两个步骤。首先,如有必要,在您的计算机文本的 ODBC 驱动程序定义 DSN 的用户。第二步,使用导入的文本文件 DSN 的用户。如果您的文本文件的逗号分隔值 (CSV) 文件,不使用列表分隔符定义在您的计算机或您的文本文件不是.csv 文件,您可以使用 Schema.ini 文件指定了正确的文件格式。

定义 DSN 的用户

  1. 打开 Microsoft Windows 控制面板,双击管理工具图标,然后双击数据源 (ODBC)图标。

  2. ODBC 数据库管理员对话框中,在用户 DSN选项卡上,单击添加

  3. 创建新的数据源对话框中,选择Microsoft 文本驱动程序 (.txt; *.csv),,然后单击完成

    显示ODBC 文本设置对话框。

  4. 数据源名称中输入的名称。

  5. 清除使用当前目录复选框。

  6. 单击选择目录

  7. 选择目录对话框中,找到包含要导入,请确保在文件名框中,下面的列表中显示的文本文件的文本文件的文件夹,然后单击确定

  8. 单击两次“确定”

有关各种对话框中的其他选项的详细信息,请单击帮助

导入文件

  1. 邮件选项卡上的开始邮件合并组中,单击选择收件人,然后单击使用现有列表

    Word 功能区图像

  2. 在“选择数据源”对话框中,执行下列操作之一:

    • 若要使用现有.odc 文件,请双击.odc 文件。在导入的数据,并且您完成。

    • 要创建新的.odc 文件,请单击新建源,然后执行过程中的每个步骤。

      数据连接向导中显示。

  3. 欢迎使用数据连接向导页面中,单击ODBC/DSN

  4. 连接到 ODBC 数据源页中,选择刚创建的用户 DSN,然后单击下一步

  5. 选择数据库和表页上,选择在名称列下的文本文件,然后单击下一步

  6. 保存数据连接文件和完成页上,在文件名框中,输入.odc 文件的名称,然后单击完成

    若要更改文件夹的位置,这是默认情况下的我的数据源文件夹,请单击浏览

  7. (可选) 若要使连接文件更易于查找,您可以在说明友好名称搜索关键字框中输入的其他信息。

有关各种对话框中的其他选项的详细信息,请单击帮助

使用 Schema.ini 文件指定不同列表分隔符字符或文本的文件格式

Schema.ini 文件是一个文本文件,其中包含用于替代默认文本驱动程序设置 Windows 注册表中的条目。一般情况下,使用 Schema.ini 文件,必须执行以下操作:

  • 将 Schema.ini 文件存储在您要导入的文本文件所在的文件夹。

  • 命名文件Schema.ini

  • 在 Schema.ini 文件的第一行中,键入要链接到的文本文件的名称用方括号括起来。

  • 添加其他信息,以指定不同的文本的文件格式。

以下各部分显示使用 Schema.ini 文件的常见的示例。

示例: 指定列标题

[Categories.txt] ColNameHeader=True

示例: 指定分号 字符 (;) 作为分隔符

[Categories.txt] Format=Delimited(;)

示例: 指定制表符作为分隔符

[Products.txt] Format=TabDelimited

示例: 指定固定宽度的文件

[Shippers.txt]Format=FixedLengthCol1=ShipperID Text Width 11Col2=CompanyName Text Width 40Col3=Phone Text Width 24

返回页首 返回节首

使用导入数据从 Excel 97-2003年或 2007年工作簿的 OLE DB 提供程序

  1. 邮件选项卡上的开始邮件合并组中,单击选择收件人,然后单击使用现有列表

    Word 功能区图像

  2. 在“选择数据源”对话框中,执行下列操作之一:

    • 若要使用现有.odc 文件,请双击.odc 文件。在导入的数据,并且您完成。

    • 要创建新的.odc 文件,请单击新建源,然后执行过程中的每个步骤。

      数据连接向导中显示。

  3. 数据连接向导欢迎页面上,单击其他/高级

    数据链接属性对话框中显示。

    有关各种对话框中的其他选项的详细信息,请单击帮助

  4. 提供商选项卡上,选择Microsoft Office 12.0 Access 数据库引擎 OLE DB 提供程序,,然后单击下一步

  5. 连接选项卡上的数据源框中,输入 Excel 工作簿的完整路径和文件名。

  6. 单击全部选项卡,选择扩展属性,然后单击编辑值

  7. 属性值框中,输入下列选项之一:

    • 如果工作簿中的数据有列标题,输入Excel 8.0;页眉 = 是

    • 如果工作簿中的数据不具有列标题,请输入Excel 8.0;页眉 = 无

  8. 单击“确定”。

  9. 若要确保您输入了正确的信息,请单击连接选项卡,然后单击测试连接

  10. 执行下列操作之一:

    • 如果您收到一条错误消息,重新检查您在前面的步骤中输入的值。

    • 如果您收到消息"测试连接成功",单击确定

  11. 选择数据库和表页上,选择下的名称列中,工作表,然后单击下一步

  12. 单击“确定”。

    数据连接向导将重新出现。

  13. 保存数据连接文件和完成页上,在文件名框中,输入.odc 文件的名称,然后单击完成

    若要更改文件夹的位置,这是默认情况下的我的数据源文件夹,请单击浏览

  14. (可选) 若要使连接文件更易于查找,您可以在说明友好名称搜索关键字框中输入的其他信息。

返回页首 返回节首

使用导入数据从 Excel 97-2003年或 2007年工作簿的 ODBC 驱动程序

  1. 邮件选项卡上的开始邮件合并组中,单击选择收件人,然后单击使用现有列表

    Word 功能区图像

  2. 在“选择数据源”对话框中,执行下列操作之一:

    • 若要使用现有.odc 文件,请双击.odc 文件。在导入的数据,并且您完成。

    • 要创建新的.odc 文件,请单击新建源,然后执行过程中的每个步骤。

      数据连接向导中显示。

  3. 欢迎使用数据连接向导页面中,单击ODBC/DSN

  4. 连接到 ODBC 数据源页中,选择Excel 文件,,然后单击下一步

  5. 选择工作簿对话框中,在数据库名称框中,输入包含 Excel 工作簿的文件夹,在列表中,选择工作簿,然后单击确定

  6. 选择数据库和表页面下的名称列中,选择要导入的工作表,然后单击下一步

  7. 保存数据连接文件和完成页上,在文件名框中,输入.odc 文件的名称,然后单击完成

    若要更改文件夹的位置,这是默认情况下的我的数据源文件夹,请单击浏览

  8. (可选) 若要使连接文件更易于查找,您可以在说明友好名称搜索关键字框中输入的其他信息。

有关各种对话框中的其他选项的详细信息,请单击帮助

返回页首 返回节首

使用导入数据从 Access 2000、 2003年或 2007年数据库 OLE db 访问接口

  1. 邮件选项卡上的开始邮件合并组中,单击选择收件人,然后单击使用现有列表

    Word 功能区图像

  2. 在“选择数据源”对话框中,执行下列操作之一:

    • 若要使用现有.odc 文件,请双击.odc 文件。在导入的数据,并且您完成。

    • 要创建新的.odc 文件,请单击新建源,然后执行过程中的每个步骤。

      数据连接向导中显示。

  3. 欢迎使用数据连接向导页面中,单击其他/高级

    数据链接属性对话框中显示。

    有关各种对话框中的其他选项的详细信息,请单击帮助

  4. 提供商选项卡上,执行下列操作之一:

    • 如果数据库是 Access 2000 或 Access 2003 数据库,选择Microsoft Jet 4.0 OLE DB 提供程序

    • 如果数据库是Office Access 2007数据库,选择Microsoft Office 12.0 Access 数据库引擎 OLE DB 提供程序

  5. 单击“下一步”

  6. 连接选项卡上的选择或输入数据库名称框中,输入 Access 数据库的完整路径和文件名。

    如果您选择Microsoft Jet 4.0 OLE db 访问接口(以帮助您查找数据库) 的提供商选项卡上单击框旁边的浏览按钮。

  7. 若要确保您输入了正确的信息,请单击连接选项卡,然后单击测试连接

  8. 执行下列操作之一:

    • 如果您收到一条错误消息,重新检查您在前面的步骤中输入的值。

    • 如果您收到消息"测试连接成功",单击确定

  9. 选择数据库和表页上,选择表或查询,在名称列下的,然后单击下一步

    注意: 此列表中没有链接的表。如果您想要导入的链接的表,Access 数据库中创建链接表到查询执行导入操作之前。

  10. 保存数据连接文件和完成页上,在文件名框中,输入.odc 文件的名称,然后单击完成

    若要更改文件夹的位置,这是默认情况下的我的数据源文件夹,请单击浏览

  11. (可选) 若要使连接文件更易于查找,您可以在说明友好名称搜索关键字框中输入的其他信息。

返回页首 返回节首

使用导入数据从 Access 2000、 2003年或 2007年数据库的 ODBC 驱动程序

  1. 邮件选项卡上的开始邮件合并组中,单击选择收件人,然后单击使用现有列表

    Word 功能区图像

  2. 在“选择数据源”对话框中,执行下列操作之一:

    • 若要使用现有.odc 文件,请双击.odc 文件。在导入的数据,并且您完成。

    • 要创建新的.odc 文件,请单击新建源,然后执行过程中的每个步骤。

      数据连接向导中显示。

  3. 欢迎使用数据连接向导页面中,单击ODBC/DSN

  4. 连接到 ODBC 数据源页中,选择MS Access 数据库,然后单击下一步

    出现选择数据库对话框。

  5. 选择目录对话框中,找到包含要导入,请确保在文件名框中,下面的列表中显示的 Access 数据库的 Access 数据库的文件夹,然后单击确定

    数据连接向导将重新出现。

  6. 选择数据库和表页上,选择表或查询,在名称列下的,然后单击下一步

  7. 保存数据连接文件和完成页上,在文件名框中,输入.odc 文件的名称,然后单击完成

    若要更改文件夹的位置,这是默认情况下的我的数据源文件夹,请单击浏览

  8. (可选) 若要使连接文件更易于查找,您可以在说明友好名称搜索关键字框中输入的其他信息。

有关各种对话框中的其他选项的详细信息,请单击帮助

返回页首 返回节首

使用导入数据从 SQL Server 2000 或 2005年数据库 OLE db 访问接口

  1. 邮件选项卡上的开始邮件合并组中,单击选择收件人,然后单击使用现有列表

    Word 功能区图像

  2. 在“选择数据源”对话框中,执行下列操作之一:

    • 若要使用现有.odc 文件,请双击.odc 文件。在导入的数据,并且您完成。

    • 要创建新的.odc 文件,请单击新建源,然后执行过程中的每个步骤。

      数据连接向导中显示。

  3. 欢迎使用数据连接向导页面中,单击Microsoft SQL Server

  4. 连接到数据库服务器页面上,执行下列操作:

    • 服务器名称框中输入数据库服务器的名称。

      如果数据库是您的计算机上,输入(本地)

    • 登录凭据,请执行下列操作之一:

      • 若要使用您的 Windows 用户名和密码,请单击使用 Windows 身份验证

      • 要使用的数据库的用户名和密码,请使用下面的用户名和密码,请单击,然后在相应的框中输入的数据库的用户名和密码。

  5. 单击“下一步”

  6. 选择数据库和表页上,在数据库框中选择的数据库、 表、 视图或用户定义的函数,在名称列中,选择,然后单击下一步

  7. 保存数据连接文件和完成页上,在文件名框中,输入.odc 文件的名称,然后单击完成

    若要更改文件夹的位置,这是默认情况下的我的数据源文件夹,请单击浏览

  8. (可选) 若要使连接文件更易于查找,您可以在说明友好名称搜索关键字框中输入的其他信息。

返回页首 返回节首

从 SQL Server 2000 或 2005年数据库使用的 ODBC 驱动程序导入数据

从 SQL Server 数据库使用的 ODBC 驱动程序导入数据的两个步骤。首先,如有必要,在您的计算机的 ODBC 驱动程序定义 DSN 的用户。第二步,从 SQL Server 数据库导入数据。

定义 DSN 的用户

  1. 打开 Microsoft Windows 控制面板,双击管理工具图标,然后双击数据源 (ODBC)图标。

  2. ODBC 数据库管理器对话框中,选择用户 DSN选项卡,,然后单击添加

  3. 创建新的数据源对话框中,选择SQL Server,然后单击完成

    显示创建新的数据源与 SQL Server对话框。

  4. 名称框中输入数据源名称。

  5. (可选) 在说明框中输入的数据源的说明。

  6. 服务器框中输入数据库服务器名称。

    如果数据库是您的计算机上,输入(本地)

  7. 单击“下一步”

  8. 在下SQL Server 应如何验证登录 ID 的真实性?,请执行下列操作之一:

    • 使用您的 Windows 用户名和密码,请单击与 Windows NT 身份验证使用网络登录 ID

    • 若要使用的数据库的用户名和密码,通过使用 SQL Server 身份验证的登录 ID 和用户输入的密码,请单击,然后在相应的框中输入数据库登录 ID 和密码。

  9. 单击两次下, 一步,然后单击完成

  10. 若要确保您输入了正确的信息,请单击测试数据源

  11. 执行下列操作之一:

    • 如果您收到一条错误消息,重新检查您在前面的步骤中输入的值。

    • 如果您收到消息"测试成功完成 !",单击确定

  12. 单击两次“确定”

有关各种对话框中的其他选项的详细信息,请单击帮助

从 SQL Server 数据库导入数据

  1. 邮件选项卡上的开始邮件合并组中,单击选择收件人,然后单击使用现有列表

    Word 功能区图像

  2. 在“选择数据源”对话框中,执行下列操作之一:

    • 若要使用现有.odc 文件,请双击.odc 文件。在导入的数据,并且您完成。

    • 要创建新的.odc 文件,请单击新建源,然后执行过程中的每个步骤。

      数据连接向导中显示。

  3. 欢迎使用数据连接向导页面中,单击ODBC/DSN

  4. 连接到 ODBC 数据源页中,选择您在上一节中定义数据源名称,然后单击下一步

  5. 选择数据库和表页上,在数据库框中选择的数据库、 表、 视图或函数下的名称列中,选择,然后单击下一步

  6. 保存数据连接文件和完成页上,在文件名框中,输入.odc 文件的名称,然后单击完成

    若要更改文件夹的位置,这是默认情况下的我的数据源文件夹,请单击浏览

  7. (可选) 若要使连接文件更易于查找,您可以在说明友好名称搜索关键字框中输入的其他信息。

返回页首 返回节首

返回页首

扩展你的 Office 技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×