使用数据连接向导将数据导入 Office Publisher、Visio 或 Word

重要:  本文是由机器翻译的,请参阅免责声明。请在 此处 中查找本文的英文版本以便参考。

Microsoft Office Publisher、Visio 或 Word 程序外部存在着海量数据,可以在其中每个程序内使用。但如何导入数据并保证数据安全呢?只需建立正确的连接即可。

您要做什么?

Office 数据连接概述

使数据访问更安全

创建或通过使用 Excel 中编辑 Office 数据连接文件

使用数据连接向导中的 office Publisher︰ 导入外部数据

Office Visio︰ 使用数据连接向导导入外部数据

Office Word︰ 使用数据连接向导导入外部数据

Office 数据连接概述

下面几节讨论外部数据连接的工作原理以及与其他应用程序和用户共享连接信息的方法。

了解有关数据连接的基础知识

程序中的数据可以来自文本文件、工作簿或数据库等外部数据源。此外部数据源通过数据连接与程序连接,数据连接是一组描述如何定位、登录以及访问外部数据源的信息。

连接到外部数据的主要好处在于:可以定期分析此数据而无需重复复制数据。重复复制数据是一种即费时又容易出错的操作。

连接信息可存储在工作簿中,也可以存储在 Office 数据连接 (ODC) 文件 (.odc) 或数据源名 (DSN) 文件 (.dsn) 等连接文件中。

要将外部数据导入程序,您必须能够访问该数据。如果要访问的外部数据源不在本地计算机上,您可能需要与数据库管理员联系,以便获得密码、用户权限或其他连接信息。如果数据源是一个数据库,请确保该数据库未以独占模式打开。如果数据源是一个文本文件或工作簿,请确保其他用户未将该文本文件或工作簿打开进行独占访问。

许多数据源还需要使用 ODBC 驱动程序或 OLE DB 提供程序来协调您的程序、连接文件和数据源之间的数据流。

下面的图表总结了有关数据连接的要点。

连接到外部数据

1. 可以连接到多种数据源:Microsoft SQL Server、Microsoft Office Access、Microsoft Office Excel 以及文本文件。

2. 每个数据源都有关联的 ODBC 驱动程序或 OLE DB 提供程序。

3. 连接文件定义了访问和检索数据源中的数据所需的所有信息。

4. 连接信息是从连接文件复制到程序中的。

共享连接

连接文件非常适合以一种统一的方式共享连接,使连接更易于发现,有助于增强安全性并且简化数据源管理。共享连接文件的最佳方法是将它们放在一个安全的受信任位置,如网络文件夹或 Microsoft Office SharePoint Designer 库中,在那里用户可以读取文件,但只有指定的用户可以修改文件。

可以使用 Excel 或数据连接向导创建 Office 数据连接 (ODC) 文件 (.odc),从而连接到新数据源。.odc 文件使用自定义 HTML 和 XML 标记存储连接信息。可以很方便地在 Excel 中编辑该文件的内容。

可以和其他用户共享连接文件,使他们具有与您相同的外部数据源访问权限。其他用户无需对数据源进行设置来打开连接文件,但他们可能需要在其计算机上安装访问外部数据所必需的 ODBC 驱动程序或 OLE DB 提供程序。

了解 Microsoft 数据访问组件

Microsoft 数据访问组件 (MDAC) 2.8 包含在 Microsoft Windows Server 2003 和 Microsoft Windows XP SP2 及更高版本中。使用 MDAC 可以连接到多种关系型和非关系型数据源并使用其中的数据。使用开放式数据库连接 (ODBC) 驱动程序或 OLE DB 提供程序可以连接到许多不同的数据源。这两种程序当中的任意一种都可由 Microsoft 构建和提供或由不同的第三方开发。安装 Microsoft Office 时,附加的 ODBC 驱动程序和 OLE DB 提供程序将添加到您的计算机中。

要查看您的计算机上安装的 OLE DB 提供程序的完整列表,请在数据链接文件中显示“数据链接属性”对话框,然后单击“提供程序”选项卡。

要查看您的计算机上安装的 ODBC 提供程序的完整列表,请显示“ODBC 数据库管理器”对话框,然后单击“驱动程序”选项卡。

还可以使用其他制造商提供的 ODBC 驱动程序和 OLE DB 提供程序,以便从除 Microsoft 数据源之外的数据源(包括其他类型的 ODBC 和 OLE DB 数据库)中获取信息。有关安装这些 ODBC 驱动程序或 OLE DB 提供程序的信息,请查阅数据库文档或与数据库供应商联系。

使用 ODBC 连接到数据源

下面几节将更加详细地介绍开放式数据库连接 (ODBC)。

ODBC 架构

在 ODBC 架构中,应用程序(如您的程序)连接到 ODBC 驱动程序管理器,后者随后使用特定 ODBC 驱动程序(如 Microsoft SQL ODBC 驱动程序)连接到数据源(如 Microsoft SQL Server 数据库)。

定义连接信息

要连接到 ODBC 数据源,请执行下列操作:

  1. 确保适当的 ODBC 驱动程序安装在包含数据源的计算机上。

  2. 通过使用“ODBC 数据源管理器”将连接信息存储到 Microsoft Windows 注册表或 .dsn 文件中来定义数据源名 (DSN),或者通过使用 Microsoft Visual Basic 代码中的连接字符串将连接信息直接传递给 ODBC 驱动程序管理器来定义。

    要定义数据源,请打开 Microsoft Windows 控制面板,双击“管理工具”图标,然后双击“数据源 (ODBC)”图标。

    有关不同选项的详细信息,请单击每个对话框中的“帮助”按钮。

计算机数据源

计算机数据源在特定计算机上的 Windows 注册表中以用户定义的名称存储连接信息。只能在定义计算机数据源的计算机上使用该数据源。计算机数据源分两种:用户类型和系统类型。用户数据源只能由当前用户使用,并且只对该用户可见。系统数据源可以由计算机上的所有用户使用,并且对于计算机上所有的用户都是可见的。因为计算机数据源有助于确保只有登录的用户才可以查看计算机数据源,并且远程用户无法将它复制到其他计算机上,所以如果需要提供更强的安全性能,计算机数据源特别有用。

文件数据源

文件数据源(也称作 DSN 文件)将连接信息存储在文本文件中,而不是 Windows 注册表中。通常使用起来文件数据源比计算机数据源更加灵活。例如,可以将文件数据源复制到装有正确 ODBC 驱动程序的任何计算机上,因而对于所有这些计算机,应用程序都可以有一致而准确的连接信息。也可以将文件数据源放置到单台服务器上,在网络上的多台计算机之间进行共享,并且可以方便地在一个位置维护连接信息。

文件数据源也可以是非共享的。非共享的文件数据源驻留在单台计算机上,并指向一个计算机数据源。使用非共享的文件数据源可以从文件数据源访问现有的计算机数据源。

使用 OLE DB 连接到数据源

下面几节将更加详细地介绍对象链接和嵌入数据库 (OLE DB)。

OLE DB 架构

在 OLE DB 架构中,访问数据的应用程序称作数据使用者(如 Publisher),而支持数据本机访问的程序称作数据库提供程序(如 Microsoft OLE DB Provider for SQL Server)。

定义连接信息

通用数据链接文件 (.udl) 中包含数据使用者用来通过数据源的 OLE DB 提供程序访问该数据源的连接信息。可以通过执行下列操作之一来创建连接信息:

  • 在数据连接向导中,使用“数据链接属性”对话框定义 OLE DB 提供程序的数据链接。

  • 创建一个具有 .udl 文件类型的空文本文件,然后编辑该文件,该文件将显示“数据链接属性”对话框。

返回页首

让数据访问更安全

连接到外部数据源或刷新数据时,了解潜在的安全问题并且清楚针对这些安全问题的相关措施非常重要。请使用下列准则和最佳做法帮助保证数据安全。

将数据连接存储在受信任位置

数据连接文件通常包含对数据源的一个或多个查询。怀有恶意企图的用户可以通过替换此文件来设计一个查询,以便访问机密信息并将其分发给其他用户或者执行其他有害操作。因此,请务必确保:

  • 连接文件由可靠的人员编写。

  • 连接文件是安全的并且来自受信任位置。

为了增强安全性,可能无法从您的计算机上连接到外部数据。要在打开工作簿时连接到数据,必须通过使用“信任中心”栏或将工作簿放在受信任位置来激活数据连接。

有关详细信息,请参阅创建、 删除或更改您的文件的受信任的位置添加、 删除或查看受信任的发布者查看我在信任中心的安全设置

安全使用凭据

访问外部数据源时通常需要用到用于验证用户身份的凭据(如用户名和密码)。请确保这些凭据是以安全的方式提供给您的,并且您没有无意间将这些凭据泄露给他人。

使用由大写字母、小写字母、数字和符号组合的强密码。弱密码不混合使用这些元素。例如,Y6dh!et5 是强密码;House27 是弱密码。密码长度应大于等于 8 个字符。最好使用包括 14 个或更多个字符的密码。

It is critical that you remember your password. If you forget your password, Microsoft cannot retrieve it. Store the passwords that you write down in a secure place away from the information that they help protect.

避免在连接到数据源时保存登录信息。此信息可能以纯文本形式存储在工作簿和连接文件中,恶意用户可以访问该信息并危及数据源的安全。

如果可能,请使用 Windows 身份验证(也称作受信任连接),它使用 Windows 用户帐户连接到 SQL Server。当用户通过 Windows 用户帐户进行连接时,SQL Server 将使用 Windows 操作系统中的信息验证帐户名和密码。在能够使用 Windows 身份验证之前,服务器管理员必须将 SQL Server 配置为使用这种身份验证模式。如果 Windows 身份验证不可用,请避免保存用户的登录信息。用户在每次登录时输入登录信息更加安全。

返回页首

使用 Excel 创建或编辑 Office 数据连接文件

您也许希望与其他用户或者在不同程序之间共享 Office 数据连接 (ODC) 文件 (.odc)。可以使用 Excel 创建或编辑 .odc 文件。

使用 Excel 创建新 ODC 文件

  1. 在计算机上找到“我的数据源”文件夹。

  2. 请执行下列操作之一:

    • 要创建任意类型的连接文件,请右键单击“+连接到新数据源.odc”文件,然后单击快捷菜单上的“在 Excel 中打开”

      Excel 随即启动。如果出现“Microsoft Office Excel 安全声明”消息,请单击“启用”

      数据连接向导的“欢迎使用‘数据连接向导’”页随即显示。请按照向导中的说明进行操作。

    • 要创建 SQL Server 连接文件,请右键单击“+新 SQL Server 连接.odc”文件,然后单击快捷菜单上的“在 Excel 中打开”

      Excel 随即启动,并且数据连接向导的“连接数据库服务器”页随即显示。

使用 Excel 编辑现有的 ODC 文件

  1. 找到计算机上包含 .odc 文件的文件夹,如“我的数据源”文件夹或者受信任的网络文件夹。

  2. 右键单击 .odc 文件,然后单击快捷菜单上的“在 Excel 中打开”

  3. 可能会出现“Microsoft Office Excel 安全声明”消息。如果您信任数据源,请单击“启用”

    该 .odc 文件检索的数据会显示在新工作簿的第一个工作表中,以确认您的连接是正确的。

  4. “数据”选项卡上的“连接”组中,单击“连接”

  5. “工作簿连接”对话框中,选择该连接,然后单击“属性”

  6. “连接属性”对话框中进行所需的更改。

    有关修改连接文件信息的详细信息,请参阅 Excel 帮助系统。

  7. 进行了所有的更改后,单击“定义”选项卡,然后单击“导出连接文件”

  8. “保存文件”对话框中,单击“保存”

  9. 关闭“连接属性”“工作簿连接”对话框,然后退出 Excel 而不保存新工作簿。

返回页首

Office Publisher:使用数据连接向导导入外部数据

在 Microsoft Office Publisher 中,您将导入外部数据使用邮件合并。使用邮件合并创建大量的大部分是相同的文档,但将包含一些唯一的信息,如要发送给您的顶级 100 客户产品发布。您还可以导入的文本文件,Excel 工作表和 Access 表或查询直接,而无需使用连接文件。有关详细信息,请参阅创建邮件合并

您要做什么?

使用 OLE db 访问接口导入文本文件

使用的 ODBC 驱动程序导入文本文件

使用导入数据从 Excel 97-2003年或 2007年工作簿的 OLE DB 提供程序

使用导入数据从 Excel 97-2003年或 2007年工作簿的 ODBC 驱动程序

使用导入数据从 Access 2000、 2003年或 2007年数据库 OLE db 访问接口

使用导入数据从 Access 2000、 2003年或 2007年数据库的 ODBC 驱动程序

使用导入数据从 SQL Server 2000 或 2005年数据库 OLE db 访问接口

从 SQL Server 2000 或 2005年数据库使用的 ODBC 驱动程序导入数据

使用 OLE DB 提供程序导入文本文件

导入逗号分隔值 (CSV) 文本文件 (.csv) 简单易行。如果文本文件是一个未使用计算机中定义的列表分隔符的 .csv 文件,或者文本文件不是 .csv 文件,则可以使用 Schema.ini 文件指定正确的文件格式。

导入文件

  1. “工具”菜单上,指向“邮寄和目录”,然后单击“邮件合并”“电子邮件合并”“目录合并”

  2. 请执行下列操作之一:

    • “邮件合并”任务窗格中,单击“创建或连接到收件人列表”

    • “电子邮件合并”任务窗格中,单击“创建或连接到收件人列表”

    • “目录合并”任务窗格中,单击“创建或连接到产品列表”

  3. “选取数据源”对话框中,执行下列操作之一:

    • 要使用现有的 .odc 文件,请双击该 .odc 文件。数据被导入,操作完成。

    • 要创建新的 .odc 文件,请单击“新建源”,然后按照过程中的每个步骤操作。

      数据连接向导随即出现。

  4. “欢迎使用‘数据连接向导’”页中,单击“其他/高级”

    “数据链接属性”对话框随即出现。

    有关各对话框中不同选项的详细信息,请单击“帮助”

  5. “提供程序”选项卡上,选择“Microsoft Jet 4.0 OLE DB 提供程序”,然后单击“下一步”

  6. “连接”选项卡上的“选择或输入数据库名称”框中,输入包含文本文件的文件夹的完整路径。

    为了帮助您找到文件夹,请单击该框旁边的“浏览”按钮。

  7. 单击“全部”选项卡,选择“扩展属性”,然后单击“编辑值”

  8. “属性值”框中,输入下列值之一:

    • 如果文本文件具有列标题,请输入文本;页眉 = 是

    • 如果文本文件不具有列标题,请输入文本;页眉 = 无

  9. 单击“确定”

  10. 要确保您输入的连接信息是正确的,请单击“连接”选项卡,然后单击“测试连接”

  11. 请执行下列操作之一:

    • 如果收到错误消息,请重新检查在前面步骤中输入的值。

    • 如果收到消息“测试连接成功”,请单击“确定”

  12. 单击“确定”

    数据连接向导再次出现。

  13. “选择数据库和表”页中的“名称”列下,选择要导入的文本文件,然后单击“下一步”

  14. “保存数据连接文件并完成”页中,在“文件名”框中为 .odc 文件输入一个名称,然后单击“完成”

    要更改文件夹位置(默认情况下是“我的数据源”文件夹),请单击“浏览”

  15. 或者,要使连接文件更易于发现,可以在“说明”“友好名称”“搜索关键字”框中输入附加信息。

使用 Schema.ini 文件指定不同的列表分隔符或文本文件格式

Schema.ini 文件是一种文本文件,它包含的条目可以覆盖 Windows 注册表中默认的文本驱动程序设置。通常,要使用 Schema.ini 文件,您必须执行下列操作:

  • 将 Schema.ini 文件存储在您要导入的文本文件所在的文件夹中。

  • 命名文件Schema.ini

  • 在 Schema.ini 文件的第一行上,键入要链接到的文本文件的名称,并用方括号将其括起来。

  • 添加附加信息以指定不同的文本文件格式。

下面几节显示了使用 Schema.ini 文件的常见示例。

示例:指定分号 (;) 作为分隔符

[Categories.txt] Format=Delimited(;)

Ex 足够︰ 指定制表符作为分隔符

[Products.txt] Format=TabDelimited

示例:指定固定宽度文件

[Shippers.txt]Format=FixedLengthCol1=ShipperID Text Width 11Col2=CompanyName Text Width 40Col3=Phone Text Width 24

返回页首 返回节首

使用 ODBC 驱动程序导入文本文件

使用 ODBC 驱动程序导入文本文件至少是一个两步骤的过程。首先,如有必要,请在计算机上为 ODBC 文本驱动程序定义一个用户 DSN。接着,使用该用户 DSN 导入文本文件。如果文本文件是一个未使用计算机中定义的列表分隔符的逗号分隔值 (.csv) 文件,或者文本文件不是 .csv 文件,则可以使用 Schema.ini 文件指定正确的文件格式。

定义用户 DSN

  1. 打开 Microsoft Windows 控制面板,双击“管理工具”图标,然后双击“数据源 (ODBC)”图标。

  2. “ODBC 数据库管理器”对话框中的“用户 DSN”选项卡上,单击“添加”

  3. “创建新数据源”对话框中,选择“Microsoft Text Driver (*.txt; *.csv)”,然后单击“完成”

    “ODBC Text 安装”对话框随即出现。

  4. “数据源名”中输入名称。

  5. 清除“使用当前目录”复选框。

  6. 单击“选择目录”

  7. “选择目录”对话框中,找到包含要导入的文本文件的文件夹,确保该文本文件显示在“文件名”框下方的列表中,然后单击“确定”

  8. 单击“确定”两次。

有关各对话框中不同选项的详细信息,请单击“帮助”

导入文件

  1. “工具”菜单上,指向“邮寄和目录”,然后单击“邮件合并”“电子邮件合并”“目录合并”

  2. 请执行下列操作之一:

    • “邮件合并”任务窗格中,单击“创建或连接到收件人列表”

    • “电子邮件合并”任务窗格中,单击“创建或连接到收件人列表”

    • “目录合并”任务窗格中,单击“创建或连接到产品列表”

  3. “选取数据源”对话框中,执行下列操作之一:

    • 要使用现有的 .odc 文件,请双击该 .odc 文件。数据被导入,操作完成。

    • 要创建新的 .odc 文件,请单击“新建源”,然后按照过程中的每个步骤操作。

      数据连接向导随即出现。

  4. “欢迎使用‘数据连接向导’”页中,单击“ODBC/DSN”

  5. “连接 ODBC 数据源”页上,选择刚创建的用户 DSN,然后单击“下一步”

  6. “选择数据库和表”页中,选择“名称”列下的文本文件,然后单击“下一步”

  7. “保存数据连接文件并完成”页中,在“文件名”框中为 .odc 文件输入一个名称,然后单击“完成”

    要更改文件夹位置(默认情况下是“我的数据源”文件夹),请单击“浏览”

  8. 或者,要使连接文件更易于发现,可以在“说明”“友好名称”“搜索关键字”框中输入附加信息。

使用 Schema.ini 文件指定不同的列表分隔符或文本文件格式

Schema.ini 文件是一种文本文件,它包含的条目可以覆盖 Windows 注册表中默认的文本驱动程序设置。通常,要使用 Schema.ini 文件,您必须执行下列操作:

  • 将 Schema.ini 文件存储在您要导入的文本文件所在的文件夹中。

  • 命名文件Schema.ini

  • 在 Schema.ini 文件的第一行上,键入要链接到的文本文件的名称,并用方括号将其括起来。

  • 添加附加信息以指定不同的文本文件格式。

下面几节显示了使用 Schema.ini 文件的常见示例。

示例:指定列标题

[Categories.txt] ColNameHeader=True

示例:指定分号 (;) 作为分隔符

[Categories.txt] Format=Delimited(;)

示例:指定制表符作为分隔符

[Products.txt] Format=TabDelimited

示例:指定固定宽度文件

[Shippers.txt]Format=FixedLengthCol1=ShipperID Text Width 11Col2=CompanyName Text Width 40Col3=Phone Text Width 24

返回页首 返回节首

使用 OLE DB 提供程序从 Excel 97-2003 或 2007 工作簿中导入数据

  1. “工具”菜单上,指向“邮寄和目录”,然后单击“邮件合并”“电子邮件合并”“目录合并”

  2. 请执行下列操作之一:

    • “邮件合并”任务窗格中,单击“创建或连接到收件人列表”

    • “电子邮件合并”任务窗格中,单击“创建或连接到收件人列表”

    • “目录合并”任务窗格中,单击“创建或连接到产品列表”

  3. “选取数据源”对话框中,执行下列操作之一:

    • 要使用现有的 .odc 文件,请双击该 .odc 文件。数据被导入,操作完成。

    • 要创建新的 .odc 文件,请单击“新建源”,然后按照过程中的每个步骤操作。

      数据连接向导随即出现。

  4. “欢迎使用‘数据连接向导’”页中,单击“其他/高级”

    “数据链接属性”对话框随即出现。

    有关各对话框中不同选项的详细信息,请单击“帮助”

  5. “提供程序”选项卡上,选择“Microsoft Office 12.0 Access 数据库引擎 OLE DB 提供程序”,然后单击“下一步”

  6. “连接”选项卡上的“数据源”框中,输入 Excel 工作簿的完整路径和文件名。

  7. 单击“全部”选项卡,选择“扩展属性”,然后单击“编辑值”

  8. “属性值”框中,输入下列值之一:

    • 如果工作簿中的数据有列标题,输入Excel 8.0;页眉 = 是

    • 如果工作簿中的数据不具有列标题,请输入Excel 8.0;页眉 = 无

  9. 单击“确定”

  10. 要确保您输入的连接信息是正确的,请单击“连接”选项卡,然后单击“测试连接”

  11. 请执行下列操作之一:

    • 如果收到错误消息,请重新检查在前面步骤中输入的值。

    • 如果收到消息“测试连接成功”,请单击“确定”

  12. “选择数据库和表”页中,选择“名称”列下的工作表,然后单击“下一步”

  13. 单击“确定”

    数据连接向导再次出现。

  14. “保存数据连接文件并完成”页中,在“文件名”框中为 .odc 文件输入一个名称,然后单击“完成”

    要更改文件夹位置(默认情况下是“我的数据源”文件夹),请单击“浏览”

  15. 或者,要使连接文件更易于发现,可以在“说明”“友好名称”“搜索关键字”框中输入附加信息。

返回页首 返回节首

使用 ODBC 驱动程序从 Excel 97-2003 或 2007 工作簿中导入数据

  1. “工具”菜单上,指向“邮寄和目录”,然后单击“邮件合并”“电子邮件合并”“目录合并”

  2. 请执行下列操作之一:

    • “邮件合并”任务窗格中,单击“创建或连接到收件人列表”

    • “电子邮件合并”任务窗格中,单击“创建或连接到收件人列表”

    • “目录合并”任务窗格中,单击“创建或连接到产品列表”

  3. “选取数据源”对话框中,执行下列操作之一:

    • 要使用现有的 .odc 文件,请双击该 .odc 文件。数据被导入,操作完成。

    • 要创建新的 .odc 文件,请单击“新建源”,然后按照过程中的每个步骤操作。

      数据连接向导随即出现。

  4. “欢迎使用‘数据连接向导’”页中,单击“ODBC/DSN”

  5. “连接 ODBC 数据源”页中,选择“Excel 文件”,然后单击“下一步”

  6. “选择工作簿”对话框中的“数据库名”框中,输入包含 Excel 工作簿的文件夹,选择列表中的工作簿,然后单击“确定”

  7. “选择数据库和表”页中的“名称”列下,选择要导入的工作表,然后单击“下一步”

  8. “保存数据连接文件并完成”页中,在“文件名”框中为 .odc 文件输入一个名称,然后单击“完成”

    要更改文件夹位置(默认情况下是“我的数据源”文件夹),请单击“浏览”

  9. 或者,要使连接文件更易于发现,可以在“说明”“友好名称”“搜索关键字”框中输入附加信息。

有关各对话框中不同选项的详细信息,请单击“帮助”

返回页首 返回节首

使用 OLE DB 提供程序从 Access 2000、2003 或 2007 数据库中导入数据

  1. “工具”菜单上,指向“邮寄和目录”,然后单击“邮件合并”“电子邮件合并”“目录合并”

  2. 请执行下列操作之一:

    • “邮件合并”任务窗格中,单击“创建或连接到收件人列表”

    • “电子邮件合并”任务窗格中,单击“创建或连接到收件人列表”

    • “目录合并”任务窗格中,单击“创建或连接到产品列表”

  3. “选取数据源”对话框中,执行下列操作之一:

    • 要使用现有的 .odc 文件,请双击该 .odc 文件。数据被导入,操作完成。

    • 要创建新的 .odc 文件,请单击“新建源”,然后按照过程中的每个步骤操作。

      数据连接向导随即出现。

  4. “欢迎使用‘数据连接向导’”页中,单击“其他/高级”

    “数据链接属性”对话框随即出现。

    有关各对话框中不同选项的详细信息,请单击“帮助”

  5. “提供程序”选项卡上,执行下列操作之一:

    • 如果数据库是 Microsoft Access 2000 或 Microsoft Office Access 2003 数据库,请选择“Microsoft Jet 4.0 OLE DB 提供程序”

    • 如果数据库是 Microsoft Office Access 2007 数据库,请选择“Microsoft Office 12.0 Access 数据库引擎 OLE DB 提供程序”

  6. 单击“下一步”

  7. “连接”选项卡上的“选择或输入数据库名称”框中,输入 Access 数据库的完整路径和文件名。

    如果您选择了“提供程序”选项卡上的“Microsoft Jet 4.0 OLE DB 提供程序”,为了帮助您找到数据库,请单击框旁边的“浏览”按钮。

  8. 要确保您输入的连接信息是正确的,请单击“连接”选项卡,然后单击“测试连接”

  9. 请执行下列操作之一:

    • 如果收到错误消息,请重新检查在前面步骤中输入的值。

    • 如果收到消息“测试连接成功”,请单击“确定”

  10. “选择数据库和表”页中,选择“名称”列下的表或查询,然后单击“下一步”

    注意: 链接表不会显示在此列表中。如果想导入链接表,请在执行导入操作前创建对 Access 数据库中链接表的查询。

  11. “保存数据连接文件并完成”页中,在“文件名”框中为 .odc 文件输入一个名称,然后单击“完成”

    要更改文件夹位置(默认情况下是“我的数据源”文件夹),请单击“浏览”

  12. 或者,要使连接文件更易于发现,可以在“说明”“友好名称”“搜索关键字”框中输入附加信息。

返回页首 返回节首

使用 ODBC 驱动程序从 Access 2000、2003 或 2007 数据库中导入数据

  1. “工具”菜单上,指向“邮寄和目录”,然后单击“邮件合并”“电子邮件合并”“目录合并”

  2. 请执行下列操作之一:

    • “邮件合并”任务窗格中,单击“创建或连接到收件人列表”

    • “电子邮件合并”任务窗格中,单击“创建或连接到收件人列表”

    • “目录合并”任务窗格中,单击“创建或连接到产品列表”

  3. “选取数据源”对话框中,执行下列操作之一:

    • 要使用现有的 .odc 文件,请双击该 .odc 文件。数据被导入,操作完成。

    • 要创建新的 .odc 文件,请单击“新建源”,然后按照过程中的每个步骤操作。

      数据连接向导随即出现。

  4. “欢迎使用‘数据连接向导’”页中,单击“ODBC/DSN”

  5. “连接 ODBC 数据源”页中,选择“MS Access 数据库”,然后单击“下一步”

    “选择数据库”对话框随即出现。

  6. “选择目录”对话框中,找到包含要导入的 Access 数据库的文件夹,确保该 Access 数据库显示在“文件名”框下方的列表中,然后单击“确定”

    数据连接向导再次出现。

  7. “选择数据库和表”页中,选择“名称”列下的表或查询,然后单击“下一步”

  8. “保存数据连接文件并完成”页中,在“文件名”框中为 .odc 文件输入一个名称,然后单击“完成”

    要更改文件夹位置(默认情况下是“我的数据源”文件夹),请单击“浏览”

  9. 或者,要使连接文件更易于发现,可以在“说明”“友好名称”“搜索关键字”框中输入附加信息。

有关各对话框中不同选项的详细信息,请单击“帮助”

返回页首 返回节首

使用 OLE DB 提供程序从 SQL Server 2000 或 2005 数据库中导入数据

  1. “工具”菜单上,指向“邮寄和目录”,然后单击“邮件合并”“电子邮件合并”“目录合并”

  2. 请执行下列操作之一:

    • “邮件合并”任务窗格中,单击“创建或连接到收件人列表”

    • “电子邮件合并”任务窗格中,单击“创建或连接到收件人列表”

    • “目录合并”任务窗格中,单击“创建或连接到产品列表”

  3. “选取数据源”对话框中,执行下列操作之一:

    • 要使用现有的 .odc 文件,请双击该 .odc 文件。数据被导入,操作完成。

    • 要创建新的 .odc 文件,请单击“新建源”,然后按照过程中的每个步骤操作。

      数据连接向导随即出现。

  4. “欢迎使用‘数据连接向导’”页中,单击“Microsoft SQL Server”

  5. “连接数据库服务器”页中,执行下列操作:

    • “服务器名称”框中输入数据库服务器的名称。

      如果数据库在您的计算机上,请输入“(本地)”

    • “登录凭据”下,执行下列操作之一:

      • 要使用 Windows 用户名和密码,请单击“使用 Windows 身份验证”

      • 要使用数据库用户名和密码,请单击“使用下列用户名和密码”,然后在相应的框中输入数据库用户名和密码。

  6. 单击“下一步”

  7. “选择数据库和表”页中,在“数据库”框中选择数据库,选择“名称”列下的表、视图或用户定义的函数,然后单击“下一步”

  8. “保存数据连接文件并完成”页中,在“文件名”框中为 .odc 文件输入一个名称,然后单击“完成”

    要更改文件夹位置(默认情况下是“我的数据源”文件夹),请单击“浏览”

  9. 或者,要使连接文件更易于发现,可以在“说明”“友好名称”“搜索关键字”框中输入附加信息。

返回页首 返回节首

使用 ODBC 驱动程序从 SQL Server 2000 或 2005 数据库中导入数据

使用 ODBC 驱动程序从 SQL Server 数据库中导入数据是一个两步骤的过程。首先,如有必要,请在计算机上为 ODBC 驱动程序定义一个用户 DSN。接着,从 SQL Server 数据库中导入数据。

定义用户 DSN

  1. 打开 Microsoft Windows 控制面板,双击“管理工具”图标,然后双击“数据源 (ODBC)”图标。

  2. “ODBC 数据库管理器”对话框中,选择“用户 DSN”选项卡,然后单击“添加”

  3. “创建新数据源”对话框中,选择“SQL Server”,然后单击“完成”

    “创建到 SQL Server 的新数据源”对话框随即出现。

  4. “名称”框中输入数据源名称。

  5. 或者在“说明”框中输入对该数据源的说明。

  6. “服务器”框中输入数据库服务器名称。

    如果数据库在您的计算机上,请输入“(本地)”

  7. 单击“下一步”

  8. “SQL Server 应该如何验证登录 ID 的真伪?”下,执行下列操作之一:

    • 要使用 Windows 用户名和密码,请单击“通过使用网络登录 ID 的 Windows NT 身份验证”

    • 要使用数据库用户名和密码,请单击“通过使用用户输入的登录 ID 和密码的 SQL Server 身份验证”,然后在相应的框中输入数据库登录 ID 和密码。

  9. 单击“下一步”两次,然后单击“完成”

  10. 要确保您输入的信息是正确的,请单击“测试数据源”

  11. 请执行下列操作之一:

    • 如果收到错误消息,请重新检查在前面步骤中输入的值。

    • 如果收到消息“测试成功!”,请单击“确定”

  12. 单击“确定”两次。

有关各对话框中不同选项的详细信息,请单击“帮助”

从 SQL Server 数据库中导入数据

  1. “工具”菜单上,指向“邮寄和目录”,然后单击“邮件合并”“电子邮件合并”“目录合并”

  2. 请执行下列操作之一:

    • “邮件合并”任务窗格中,单击“创建或连接到收件人列表”

    • “电子邮件合并”任务窗格中,单击“创建或连接到收件人列表”

    • “目录合并”任务窗格中,单击“创建或连接到产品列表”

  3. “选取数据源”对话框中,执行下列操作之一:

    • 要使用现有的 .odc 文件,请双击该 .odc 文件。数据被导入,操作完成。

    • 要创建新的 .odc 文件,请单击“新建源”,然后按照过程中的每个步骤操作。

      数据连接向导随即出现。

  4. “欢迎使用‘数据连接向导’”页中,单击“ODBC/DSN”

  5. “连接 ODBC 数据源”页中,选择在前一节中定义的数据源名,然后单击“下一步”

  6. “选择数据库和表”页中,在“数据库”框中选择数据库,选择“名称”列下的表、视图或函数,然后单击“下一步”

  7. “保存数据连接文件并完成”页中,在“文件名”框中为 .odc 文件输入一个名称,然后单击“完成”

    要更改文件夹位置(默认情况下是“我的数据源”文件夹),请单击“浏览”

  8. 或者,要使连接文件更易于发现,可以在“说明”“友好名称”“搜索关键字”框中输入附加信息。

返回页首 返回节首

返回页首

Office Visio:使用数据连接向导导入外部数据

在 Microsoft Office Visio 中导入外部数据,以便它可以直接添加到绘图中的形状。使用绘图监控信息以直观的方式,如网络图显示停机时间统计信息或显示进度栏和米进行汇总项目任务的流程图。以下是有关说明文本文件和 SQL Server 数据源。您还可以导入 Excel 工作表、 Access 表或查询,然后直接在文件列表不使用的连接文件的 SharePoint。有关详细信息,请参阅从 Excel、 SQL Server、 SharePoint 网站和其他外部源导入数据

您要做什么?

使用 OLE db 访问接口导入文本文件

使用的 ODBC 驱动程序导入文本文件

使用导入数据从 SQL Server 2000 或 2005年数据库 OLE db 访问接口

从 SQL Server 2000 或 2005年数据库使用的 ODBC 驱动程序导入数据

使用 OLE DB 提供程序导入文本文件

导入逗号分隔值 (CSV) 文本文件 (.csv) 简单易行。如果文本文件是一个未使用计算机中定义的列表分隔符的 .csv 文件,或者文本文件不是 .csv 文件,则可以使用 Schema.ini 文件指定正确的文件格式。

导入文件

  1. “数据”菜单上,单击“将数据链接到形状”

  2. 在数据选取器向导的第一页上,单击“其他 OLE DB 或 ODBC 数据源”

    数据连接向导随即出现。

  3. 单击“其他/高级”

    “数据链接属性”对话框随即出现。

    有关各对话框中不同选项的详细信息,请单击“帮助”

  4. “提供程序”选项卡上,选择“Microsoft Jet 4.0 OLE DB 提供程序”,然后单击“下一步”

  5. “连接”选项卡上的“选择或输入数据库名称”框中,输入包含文本文件的文件夹的完整路径。

    为了帮助您找到文件夹,请单击该框旁边的“浏览”按钮。

  6. 单击“全部”选项卡,选择“扩展属性”,然后单击“编辑值”

  7. “属性值”框中,输入下列值之一:

    • 如果文本文件具有列标题,请输入文本;页眉 = 是

    • 如果文本文件不具有列标题,请输入文本;页眉 = 无

  8. 单击“确定”

  9. 要确保您输入的连接信息是正确的,请单击“连接”选项卡,然后单击“测试连接”

  10. 请执行下列操作之一:

    • 如果收到错误消息,请重新检查在前面步骤中输入的值。

    • 如果收到消息“测试连接成功”,请单击“确定”

  11. 单击“确定”

    数据连接向导再次出现。

  12. “选择数据库和表”页中的“名称”列下,选择要导入的文本文件,然后单击“下一步”

  13. “保存数据连接文件并完成”页中,在“文件名”框中为 .odc 文件输入一个名称,然后单击“完成”

    要更改文件夹位置(默认情况下是“我的数据源”文件夹),请单击“浏览”

  14. 或者,要使连接文件更易于发现,可以在“说明”“友好名称”“搜索关键字”框中输入附加信息。

  15. 单击“完成”

    数据选取器向导再次出现。

  16. “选择数据连接”页中,执行下列操作之一:

    • 要使用刚才创建的 .odc 文件并接受数据源中的所有行和列,请单击“完成”

    • 要继续使用数据选取器向导,以便可以选择特定的列和行并且可以创建唯一的标识符,请单击“下一步”

      有关数据选取器向导中的每一页的详细信息,请按 F1。

使用 Schema.ini 文件指定不同的列表分隔符或文本文件格式

Schema.ini 文件是一种文本文件,它包含的条目可以覆盖 Windows 注册表中默认的文本驱动程序设置。通常,要使用 Schema.ini 文件,您必须执行下列操作:

  • 将 Schema.ini 文件存储在您要导入的文本文件所在的文件夹中。

  • 命名文件Schema.ini

  • 在 Schema.ini 文件的第一行上,键入要链接到的文本文件的名称,并用方括号将其括起来。

  • 添加附加信息以指定不同的文本文件格式。

下面几节显示了使用 Schema.ini 文件的常见示例。

示例:指定分号 (;) 作为分隔符

[Categories.txt] Format=Delimited(;)

示例:指定制表符作为分隔符

[Products.txt] Format=TabDelimited

示例:指定固定宽度文件

[Shippers.txt]Format=FixedLengthCol1=ShipperID Text Width 11Col2=CompanyName Text Width 40Col3=Phone Text Width 24

返回页首 返回节首

使用 ODBC 驱动程序导入文本文件

使用 ODBC 驱动程序导入文本文件至少是一个两步骤的过程。首先,如有必要,请在计算机上为 ODBC 文本驱动程序定义一个用户 DSN。接着,使用该用户 DSN 导入文本文件。如果文本文件是一个未使用计算机中定义的列表分隔符的逗号分隔值 (.csv) 文件,或者文本文件不是 .csv 文件,则可以使用 Schema.ini 文件指定正确的文件格式。

定义用户 DSN

  1. 打开 Microsoft Windows 控制面板,双击“管理工具”图标,然后双击“数据源 (ODBC)”图标。

  2. “ODBC 数据库管理器”对话框中的“用户 DSN”选项卡上,单击“添加”

  3. “创建新数据源”对话框中,选择“Microsoft Text Driver (*.txt; *.csv)”,然后单击“完成”

    “ODBC Text 安装”对话框随即出现。

  4. “数据源名”中输入名称。

  5. 清除“使用当前目录”复选框。

  6. 单击“选择目录”

  7. “选择目录”对话框中,找到包含要导入的文本文件的文件夹,确保该文本文件显示在“文件名”框下方的列表中,然后单击“确定”

  8. 单击“确定”两次。

有关各对话框中不同选项的详细信息,请单击“帮助”

导入文件

  1. “数据”菜单上,单击“将数据链接到形状”

  2. 在数据选取器向导的第一页上,单击“其他 OLE DB 或 ODBC 数据源”

    数据连接向导随即出现。

  3. “欢迎使用‘数据连接向导’”页中,单击“ODBC/DSN”

  4. “连接 ODBC 数据源”页上,选择刚创建的用户 DSN,然后单击“下一步”

  5. “选择数据库和表”页中,选择“名称”列下的文本文件,然后单击“下一步”

  6. “保存数据连接文件并完成”页中,在“文件名”框中为 .odc 文件输入一个名称,然后单击“完成”

    要更改文件夹位置(默认情况下是“我的数据源”文件夹),请单击“浏览”

  7. 或者,要使连接文件更易于发现,可以在“说明”“友好名称”“搜索关键字”框中输入附加信息。

  8. 单击“完成”

    数据选取器向导再次出现。

  9. “选择数据连接”页中,执行下列操作之一:

    • 要使用刚才创建的 .odc 文件并接受数据源中的所有行和列,请单击“完成”

    • 要继续使用数据选取器向导,以便可以选择特定的列和行并且可以创建唯一的标识符,请单击“下一步”

      有关数据选取器向导中的每一页的详细信息,请按 F1。

使用 Schema.ini 文件指定不同的列表分隔符或文本文件格式

Schema.ini 文件是一种文本文件,它包含的条目可以覆盖 Windows 注册表中默认的文本驱动程序设置。通常,要使用 Schema.ini 文件,您必须执行下列操作:

  • 将 Schema.ini 文件存储在您要导入的文本文件所在的文件夹中。

  • 命名文件Schema.ini

  • 在 Schema.ini 文件的第一行上,键入要链接到的文本文件的名称,并用方括号将其括起来。

  • 添加附加信息以指定不同的文本文件格式。

下面几节显示了使用 Schema.ini 文件的常见示例。

示例:指定列标题

[Categories.txt] ColNameHeader=True

示例:指定分号 (;) 作为分隔符

[Categories.txt] Format=Delimited(;)

示例:指定制表符作为分隔符

[Products.txt] Format=TabDelimited

示例:指定固定宽度文件

[Shippers.txt]Format=FixedLengthCol1=ShipperID Text Width 11Col2=CompanyName Text Width 40Col3=Phone Text Width 24

返回页首 返回节首

使用 OLE DB 提供程序从 SQL Server 2000 或 2005 数据库中导入数据

  1. “数据”菜单上,单击“将数据链接到形状”

  2. 在数据选取器向导的第一页上,单击“Microsoft SQL Server 2000 或 2005 数据库”

    数据连接向导随即出现。

  3. “连接数据库服务器”页中,执行下列操作:

    • “服务器名称”框中输入数据库服务器的名称。

      如果数据库在您的计算机上,请输入“(本地)”

    • “登录凭据”下,执行下列操作之一:

      • 要使用 Windows 用户名和密码,请单击“使用 Windows 身份验证”

      • 要使用数据库用户名和密码,请单击“使用下列用户名和密码”,然后在相应的框中输入数据库用户名和密码。

  4. 单击“下一步”

  5. “选择数据库和表”页中,在“数据库”框中选择数据库,选择“名称”列下的表、视图或用户定义的函数,然后单击“下一步”

  6. “保存数据连接文件并完成”页中,在“文件名”框中为 .odc 文件输入一个名称,然后单击“完成”

    要更改文件夹位置(默认情况下是“我的数据源”文件夹),请单击“浏览”

  7. 或者,要使连接文件更易于发现,可以在“说明”“友好名称”“搜索关键字”框中输入附加信息。

  8. 单击“完成”

    数据选取器向导再次出现。

  9. “选择数据连接”页中,执行下列操作之一:

    • 要使用刚才创建的 .odc 文件并接受数据源中的所有行和列,请单击“完成”

    • 要继续使用数据选取器向导,以便可以选择特定的列和行并且可以创建唯一的标识符,请单击“下一步”

      有关数据选取器向导中的每一页的详细信息,请按 F1。

返回页首 返回节首

使用 ODBC 驱动程序从 SQL Server 2000 或 2005 数据库中导入数据

使用 ODBC 驱动程序从 SQL Server 数据库中导入数据是一个两步骤的过程。首先,如有必要,请在计算机上为 ODBC 驱动程序定义一个用户 DSN。接着,从 SQL Server 数据库中导入数据。

定义用户 DSN

  1. 打开 Microsoft Windows 控制面板,双击“管理工具”图标,然后双击“数据源 (ODBC)”图标。

  2. “ODBC 数据库管理器”对话框中,选择“用户 DSN”选项卡,然后单击“添加”

  3. “创建新数据源”对话框中,选择“SQL Server”,然后单击“完成”

    “创建到 SQL Server 的新数据源”对话框随即出现。

  4. “名称”框中输入数据源名称。

  5. 或者在“说明”框中输入对该数据源的说明。

  6. “服务器”框中输入数据库服务器名称。

    如果数据库在您的计算机上,请输入“(本地)”

  7. 单击“下一步”

  8. “SQL Server 应该如何验证登录 ID 的真伪?”下,执行下列操作之一:

    • 要使用 Windows 用户名和密码,请单击“通过使用网络登录 ID 的 Windows NT 身份验证”

    • 要使用数据库用户名和密码,请单击“通过使用用户输入的登录 ID 和密码的 SQL Server 身份验证”,然后在相应的框中输入数据库登录 ID 和密码。

  9. 单击“下一步”两次,然后单击“完成”

  10. 要确保您输入的信息是正确的,请单击“测试数据源”

  11. 请执行下列操作之一:

    • 如果收到错误消息,请重新检查在前面步骤中输入的值。

    • 如果收到消息“测试成功!”,请单击“确定”

  12. 单击“确定”两次。

有关各对话框中不同选项的详细信息,请单击“帮助”

从 SQL Server 数据库中导入数据

  1. “数据”菜单上,单击“将数据链接到形状”

  2. 在数据选取器向导的第一页上,单击“其他 OLE DB 或 ODBC 数据源”

    数据连接向导随即出现。

  3. “欢迎使用‘数据连接向导’”页中,单击“ODBC/DSN”

  4. “连接 ODBC 数据源”页中,选择在前一节中定义的数据源名,然后单击“下一步”

  5. “选择数据库和表”页中,在“数据库”框中选择数据库,选择“名称”列下的表、视图或函数,然后单击“下一步”

  6. “保存数据连接文件并完成”页中,在“文件名”框中为 .odc 文件输入一个名称,然后单击“完成”

    要更改文件夹位置(默认情况下是“我的数据源”文件夹),请单击“浏览”

  7. 或者,要使连接文件更易于发现,可以在“说明”“友好名称”“搜索关键字”框中输入附加信息。

  8. 单击“完成”

    数据选取器向导再次出现。

  9. “选择数据连接”页中,执行下列操作之一:

    • 要使用刚才创建的 .odc 文件并接受数据源中的所有行和列,请单击“完成”

    • 要继续使用数据选取器向导,以便可以选择特定的列和行并且可以创建唯一的标识符,请单击“下一步”

      有关数据选取器向导中的每一页的详细信息,请按 F1。

返回页首 返回节首

返回页首

Office Word:使用数据连接向导导入外部数据

在 Microsoft Office Word 中,您将导入外部数据使用邮件合并。使用邮件合并创建一组文档,例如发送到多个客户或为假日卡邮寄地址标签工作表的套用信函。您还可以导入的文本文件,Excel 工作表和 Access 表或查询直接,而无需使用连接文件。有关详细信息,请参阅创建邮件合并

您要做什么?

使用 OLE db 访问接口导入文本文件

使用的 ODBC 驱动程序导入文本文件

使用导入数据从 Excel 97-2003年或 2007年工作簿的 OLE DB 提供程序

使用导入数据从 Excel 97-2003年或 2007年工作簿的 ODBC 驱动程序

使用导入数据从 Access 2000、 2003年或 2007年数据库 OLE db 访问接口

使用导入数据从 Access 2000、 2003年或 2007年数据库的 ODBC 驱动程序

使用导入数据从 SQL Server 2000 或 2005年数据库 OLE db 访问接口

从 SQL Server 2000 或 2005年数据库使用的 ODBC 驱动程序导入数据

使用 OLE DB 提供程序导入文本文件

导入逗号分隔值 (CSV) 文本文件 (.csv) 简单易行。如果文本文件是一个未使用计算机中定义的列表分隔符的 .csv 文件,或者文本文件不是 .csv 文件,则可以使用 Schema.ini 文件指定正确的文件格式。

导入文件

  1. “邮件”选项卡上的“开始邮件合并”组中,单击“选择收件人”,然后单击“使用现有列表”

    Word 功能区图像

  2. “选取数据源”对话框中,执行下列操作之一:

    • 要使用现有的 .odc 文件,请双击该 .odc 文件。数据被导入,操作完成。

    • 要创建新的 .odc 文件,请单击“新建源”,然后按照过程中的每个步骤操作。

      数据连接向导随即出现。

  3. “欢迎使用‘数据连接向导’”页中,单击“其他/高级”

    “数据链接属性”对话框随即出现。

    有关各对话框中不同选项的详细信息,请单击“帮助”

  4. “提供程序”选项卡上,选择“Microsoft Jet 4.0 OLE DB 提供程序”,然后单击“下一步”

  5. “连接”选项卡上的“选择或输入数据库名称”框中,输入包含文本文件的文件夹的完整路径。

    为了帮助您找到文件夹,请单击该框旁边的“浏览”按钮。

  6. 单击“全部”选项卡,选择“扩展属性”,然后单击“编辑值”

  7. “属性值”框中,输入下列值之一:

    • 如果文本文件具有列标题,请输入文本;页眉 = 是

    • 如果文本文件不具有列标题,请输入文本;页眉 = 无

  8. 单击“确定”

  9. 要确保您输入的连接信息是正确的,请单击“连接”选项卡,然后单击“测试连接”

  10. 请执行下列操作之一:

    • 如果收到错误消息,请重新检查在前面步骤中输入的值。

    • 如果收到消息“测试连接成功”,请单击“确定”

  11. 单击“确定”

    数据连接向导再次出现。

  12. “选择数据库和表”页中的“名称”列下,选择要导入的文本文件,然后单击“下一步”

  13. “保存数据连接文件并完成”页中,在“文件名”框中为 .odc 文件输入一个名称,然后单击“完成”

    要更改文件夹位置(默认情况下是“我的数据源”文件夹),请单击“浏览”

  14. 或者,要使连接文件更易于发现,可以在“说明”“友好名称”“搜索关键字”框中输入附加信息。

使用 Schema.ini 文件指定不同的列表分隔符或文本文件格式

Schema.ini 文件是一种文本文件,它包含的条目可以覆盖 Windows 注册表中默认的文本驱动程序设置。通常,要使用 Schema.ini 文件,您必须执行下列操作:

  • 将 Schema.ini 文件存储在您要导入的文本文件所在的文件夹中。

  • 命名文件Schema.ini

  • 在 Schema.ini 文件的第一行上,键入要链接到的文本文件的名称,并用方括号将其括起来。

  • 添加附加信息以指定不同的文本文件格式。

下面几节显示了使用 Schema.ini 文件的常见示例。

示例:指定分号 (;) 作为分隔符

[Categories.txt] Format=Delimited(;)

示例:指定制表符作为分隔符

[Products.txt] Format=TabDelimited

示例:指定固定宽度文件

[Shippers.txt]Format=FixedLengthCol1=ShipperID Text Width 11Col2=CompanyName Text Width 40Col3=Phone Text Width 24

返回页首 返回节首

使用 ODBC 驱动程序导入文本文件

使用 ODBC 驱动程序导入文本文件至少是一个两步骤的过程。首先,如有必要,请在计算机上为 ODBC 文本驱动程序定义一个用户 DSN。接着,使用该用户 DSN 导入文本文件。如果文本文件是一个未使用计算机中定义的列表分隔符的逗号分隔值 (.csv) 文件,或者文本文件不是 .csv 文件,则可以使用 Schema.ini 文件指定正确的文件格式。

定义用户 DSN

  1. 打开 Microsoft Windows 控制面板,双击“管理工具”图标,然后双击“数据源 (ODBC)”图标。

  2. “ODBC 数据库管理器”对话框中的“用户 DSN”选项卡上,单击“添加”

  3. “创建新数据源”对话框中,选择“Microsoft Text Driver (*.txt; *.csv)”,然后单击“完成”

    “ODBC Text 安装”对话框随即出现。

  4. “数据源名”中输入名称。

  5. 清除“使用当前目录”复选框。

  6. 单击“选择目录”

  7. “选择目录”对话框中,找到包含要导入的文本文件的文件夹,确保该文本文件显示在“文件名”框下方的列表中,然后单击“确定”

  8. 单击“确定”两次。

有关各对话框中不同选项的详细信息,请单击“帮助”

导入文件

  1. “邮件”选项卡上的“开始邮件合并”组中,单击“选择收件人”,然后单击“使用现有列表”

    Word 功能区图像

  2. “选取数据源”对话框中,执行下列操作之一:

    • 要使用现有的 .odc 文件,请双击该 .odc 文件。数据被导入,操作完成。

    • 要创建新的 .odc 文件,请单击“新建源”,然后按照过程中的每个步骤操作。

      数据连接向导随即出现。

  3. “欢迎使用‘数据连接向导’”页中,单击“ODBC/DSN”

  4. “连接 ODBC 数据源”页上,选择刚创建的用户 DSN,然后单击“下一步”

  5. “选择数据库和表”页中,选择“名称”列下的文本文件,然后单击“下一步”

  6. “保存数据连接文件并完成”页中,在“文件名”框中为 .odc 文件输入一个名称,然后单击“完成”

    要更改文件夹位置(默认情况下是“我的数据源”文件夹),请单击“浏览”

  7. 或者,要使连接文件更易于发现,可以在“说明”“友好名称”“搜索关键字”框中输入附加信息。

有关各对话框中不同选项的详细信息,请单击“帮助”

使用 Schema.ini 文件指定不同的列表分隔符或文本文件格式

Schema.ini 文件是一种文本文件,它包含的条目可以覆盖 Windows 注册表中默认的文本驱动程序设置。通常,要使用 Schema.ini 文件,您必须执行下列操作:

  • 将 Schema.ini 文件存储在您要导入的文本文件所在的文件夹中。

  • 将文件命名为 Schema.ini

  • 在 Schema.ini 文件的第一行上,键入要链接到的文本文件的名称,并用方括号将其括起来。

  • 添加附加信息以指定不同的文本文件格式。

下面几节显示了使用 Schema.ini 文件的常见示例。

示例:指定列标题

[Categories.txt] ColNameHeader=True

示例︰ 指定分号 字符 (;) 作为分隔符

[Categories.txt] Format=Delimited(;)

示例:指定制表符作为分隔符

[Products.txt] Format=TabDelimited

示例:指定固定宽度文件

[Shippers.txt]Format=FixedLengthCol1=ShipperID Text Width 11Col2=CompanyName Text Width 40Col3=Phone Text Width 24

返回页首 返回节首

使用 OLE DB 提供程序从 Excel 97-2003 或 2007 工作簿中导入数据

  1. “邮件”选项卡上的“开始邮件合并”组中,单击“选择收件人”,然后单击“使用现有列表”

    Word 功能区图像

  2. “选取数据源”对话框中,执行下列操作之一:

    • 要使用现有的 .odc 文件,请双击该 .odc 文件。数据被导入,操作完成。

    • 要创建新的 .odc 文件,请单击“新建源”,然后按照过程中的每个步骤操作。

      数据连接向导随即出现。

  3. “欢迎使用‘数据连接向导’”页中,单击“其他/高级”

    “数据链接属性”对话框随即出现。

    有关各对话框中不同选项的详细信息,请单击“帮助”

  4. “提供程序”选项卡上,选择“Microsoft Office 12.0 Access 数据库引擎 OLE DB 提供程序”,然后单击“下一步”

  5. “连接”选项卡上的“数据源”框中,输入 Excel 工作簿的完整路径和文件名。

  6. 单击“全部”选项卡,选择“扩展属性”,然后单击“编辑值”

  7. “属性值”框中,输入下列值之一:

    • 如果工作簿中的数据有列标题,输入Excel 8.0;页眉 = 是

    • 如果工作簿中的数据不具有列标题,请输入Excel 8.0;页眉 = 无

  8. 单击“确定”

  9. 要确保您输入的连接信息是正确的,请单击“连接”选项卡,然后单击“测试连接”

  10. 请执行下列操作之一:

    • 如果收到错误消息,请重新检查在前面步骤中输入的值。

    • 如果收到消息“测试连接成功”,请单击“确定”

  11. “选择数据库和表”页中,选择“名称”列下的工作表,然后单击“下一步”

  12. 单击“确定”

    数据连接向导再次出现。

  13. “保存数据连接文件并完成”页中,在“文件名”框中为 .odc 文件输入一个名称,然后单击“完成”

    要更改文件夹位置(默认情况下是“我的数据源”文件夹),请单击“浏览”

  14. 或者,要使连接文件更易于发现,可以在“说明”“友好名称”“搜索关键字”框中输入附加信息。

返回页首 返回节首

使用 ODBC 驱动程序从 Excel 97-2003 或 2007 工作簿中导入数据

  1. “邮件”选项卡上的“开始邮件合并”组中,单击“选择收件人”,然后单击“使用现有列表”

    Word 功能区图像

  2. “选取数据源”对话框中,执行下列操作之一:

    • 要使用现有的 .odc 文件,请双击该 .odc 文件。数据被导入,操作完成。

    • 要创建新的 .odc 文件,请单击“新建源”,然后按照过程中的每个步骤操作。

      数据连接向导随即出现。

  3. “欢迎使用‘数据连接向导’”页中,单击“ODBC/DSN”

  4. “连接 ODBC 数据源”页中,选择“Excel 文件”,然后单击“下一步”

  5. “选择工作簿”对话框中的“数据库名”框中,输入包含 Excel 工作簿的文件夹,选择列表中的工作簿,然后单击“确定”

  6. “选择数据库和表”页中的“名称”列下,选择要导入的工作表,然后单击“下一步”

  7. “保存数据连接文件并完成”页中,在“文件名”框中为 .odc 文件输入一个名称,然后单击“完成”

    要更改文件夹位置(默认情况下是“我的数据源”文件夹),请单击“浏览”

  8. 或者,要使连接文件更易于发现,可以在“说明”“友好名称”“搜索关键字”框中输入附加信息。

有关各对话框中不同选项的详细信息,请单击“帮助”

返回页首 返回节首

使用 OLE DB 提供程序从 Access 2000、2003 或 2007 数据库中导入数据

  1. “邮件”选项卡上的“开始邮件合并”组中,单击“选择收件人”,然后单击“使用现有列表”

    Word 功能区图像

  2. “选取数据源”对话框中,执行下列操作之一:

    • 要使用现有的 .odc 文件,请双击该 .odc 文件。数据被导入,操作完成。

    • 要创建新的 .odc 文件,请单击“新建源”,然后按照过程中的每个步骤操作。

      数据连接向导随即出现。

  3. “欢迎使用‘数据连接向导’”页中,单击“其他/高级”

    “数据链接属性”对话框随即出现。

    有关各对话框中不同选项的详细信息,请单击“帮助”

  4. “提供程序”选项卡上,执行下列操作之一:

    • 如果数据库是 Access 2000 或 Access 2003 数据库,请选择“Microsoft Jet 4.0 OLE DB 提供程序”

    • 如果数据库是 Office Access 2007 数据库,请选择“Microsoft Office 12.0 Access 数据库引擎 OLE DB 提供程序”

  5. 单击“下一步”

  6. “连接”选项卡上的“选择或输入数据库名称”框中,输入 Access 数据库的完整路径和文件名。

    如果您选择了“提供程序”选项卡上的“Microsoft Jet 4.0 OLE DB 提供程序”,为了帮助您找到数据库,请单击框旁边的“浏览”按钮。

  7. 要确保您输入的连接信息是正确的,请单击“连接”选项卡,然后单击“测试连接”

  8. 请执行下列操作之一:

    • 如果收到错误消息,请重新检查在前面步骤中输入的值。

    • 如果收到消息“测试连接成功”,请单击“确定”

  9. “选择数据库和表”页中,选择“名称”列下的表或查询,然后单击“下一步”

    注意: 链接表不会显示在此列表中。如果想导入链接表,请在执行导入操作前创建对 Access 数据库中链接表的查询。

  10. “保存数据连接文件并完成”页中,在“文件名”框中为 .odc 文件输入一个名称,然后单击“完成”

    要更改文件夹位置(默认情况下是“我的数据源”文件夹),请单击“浏览”

  11. 或者,要使连接文件更易于发现,可以在“说明”“友好名称”“搜索关键字”框中输入附加信息。

返回页首 返回节首

使用 ODBC 驱动程序从 Access 2000、2003 或 2007 数据库中导入数据

  1. “邮件”选项卡上的“开始邮件合并”组中,单击“选择收件人”,然后单击“使用现有列表”

    Word 功能区图像

  2. “选取数据源”对话框中,执行下列操作之一:

    • 要使用现有的 .odc 文件,请双击该 .odc 文件。数据被导入,操作完成。

    • 要创建新的 .odc 文件,请单击“新建源”,然后按照过程中的每个步骤操作。

      数据连接向导随即出现。

  3. “欢迎使用‘数据连接向导’”页中,单击“ODBC/DSN”

  4. “连接 ODBC 数据源”页中,选择“MS Access 数据库”,然后单击“下一步”

    “选择数据库”对话框随即出现。

  5. “选择目录”对话框中,找到包含要导入的 Access 数据库的文件夹,确保该 Access 数据库显示在“文件名”框下方的列表中,然后单击“确定”

    数据连接向导再次出现。

  6. “选择数据库和表”页中,选择“名称”列下的表或查询,然后单击“下一步”

  7. “保存数据连接文件并完成”页中,在“文件名”框中为 .odc 文件输入一个名称,然后单击“完成”

    要更改文件夹位置(默认情况下是“我的数据源”文件夹),请单击“浏览”

  8. 或者,要使连接文件更易于发现,可以在“说明”“友好名称”“搜索关键字”框中输入附加信息。

有关各对话框中不同选项的详细信息,请单击“帮助”

返回页首 返回节首

使用 OLE DB 提供程序从 SQL Server 2000 或 2005 数据库中导入数据

  1. “邮件”选项卡上的“开始邮件合并”组中,单击“选择收件人”,然后单击“使用现有列表”

    Word 功能区图像

  2. “选取数据源”对话框中,执行下列操作之一:

    • 要使用现有的 .odc 文件,请双击该 .odc 文件。数据被导入,操作完成。

    • 要创建新的 .odc 文件,请单击“新建源”,然后按照过程中的每个步骤操作。

      数据连接向导随即出现。

  3. “欢迎使用‘数据连接向导’”页中,单击“Microsoft SQL Server”

  4. “连接数据库服务器”页中,执行下列操作:

    • “服务器名称”框中输入数据库服务器的名称。

      如果数据库在您的计算机上,请输入“(本地)”

    • “登录凭据”下,执行下列操作之一:

      • 要使用 Windows 用户名和密码,请单击“使用 Windows 身份验证”

      • 要使用数据库用户名和密码,请单击“使用下列用户名和密码”,然后在相应的框中输入数据库用户名和密码。

  5. 单击“下一步”

  6. “选择数据库和表”页中,在“数据库”框中选择数据库,选择“名称”列下的表、视图或用户定义的函数,然后单击“下一步”

  7. “保存数据连接文件并完成”页中,在“文件名”框中为 .odc 文件输入一个名称,然后单击“完成”

    要更改文件夹位置(默认情况下是“我的数据源”文件夹),请单击“浏览”

  8. 或者,要使连接文件更易于发现,可以在“说明”“友好名称”“搜索关键字”框中输入附加信息。

返回页首 返回节首

使用 ODBC 驱动程序从 SQL Server 2000 或 2005 数据库中导入数据

使用 ODBC 驱动程序从 SQL Server 数据库中导入数据是一个两步骤的过程。首先,如有必要,请在计算机上为 ODBC 驱动程序定义一个用户 DSN。接着,从 SQL Server 数据库中导入数据。

定义用户 DSN

  1. 打开 Microsoft Windows 控制面板,双击“管理工具”图标,然后双击“数据源 (ODBC)”图标。

  2. “ODBC 数据库管理器”对话框中,选择“用户 DSN”选项卡,然后单击“添加”

  3. “创建新数据源”对话框中,选择“SQL Server”,然后单击“完成”

    “创建到 SQL Server 的新数据源”对话框随即出现。

  4. “名称”框中输入数据源名称。

  5. 或者在“说明”框中输入对该数据源的说明。

  6. “服务器”框中输入数据库服务器名称。

    如果数据库在您的计算机上,请输入“(本地)”

  7. 单击“下一步”

  8. “SQL Server 应该如何验证登录 ID 的真伪?”下,执行下列操作之一:

    • 要使用 Windows 用户名和密码,请单击“通过使用网络登录 ID 的 Windows NT 身份验证”

    • 要使用数据库用户名和密码,请单击“通过使用用户输入的登录 ID 和密码的 SQL Server 身份验证”,然后在相应的框中输入数据库登录 ID 和密码。

  9. 单击“下一步”两次,然后单击“完成”

  10. 要确保您输入的信息是正确的,请单击“测试数据源”

  11. 请执行下列操作之一:

    • 如果收到错误消息,请重新检查在前面步骤中输入的值。

    • 如果收到消息“测试成功!”,请单击“确定”

  12. 单击“确定”两次。

有关各对话框中不同选项的详细信息,请单击“帮助”

从 SQL Server 数据库中导入数据

  1. “邮件”选项卡上的“开始邮件合并”组中,单击“选择收件人”,然后单击“使用现有列表”

    Word 功能区图像

  2. “选取数据源”对话框中,执行下列操作之一:

    • 要使用现有的 .odc 文件,请双击该 .odc 文件。数据被导入,操作完成。

    • 要创建新的 .odc 文件,请单击“新建源”,然后按照过程中的每个步骤操作。

      数据连接向导随即出现。

  3. “欢迎使用‘数据连接向导’”页中,单击“ODBC/DSN”

  4. “连接 ODBC 数据源”页中,选择在前一节中定义的数据源名,然后单击“下一步”

  5. “选择数据库和表”页中,在“数据库”框中选择数据库,选择“名称”列下的表、视图或函数,然后单击“下一步”

  6. “保存数据连接文件并完成”页中,在“文件名”框中为 .odc 文件输入一个名称,然后单击“完成”

    要更改文件夹位置(默认情况下是“我的数据源”文件夹),请单击“浏览”

  7. 或者,要使连接文件更易于发现,可以在“说明”“友好名称”“搜索关键字”框中输入附加信息。

返回页首 返回节首

返回页首

注意: 机器翻译免责声明:本文是由无人工介入的计算机系统翻译的。Microsoft 提供机器翻译是为了帮助非英语国家/地区用户方便阅读有关 Microsoft 产品、服务和技术的内容。由于机器翻译的原因,本文可能包含词汇、语法或文法方面的错误。

扩展你的技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×