使用报表度量网站性能和使用率

重要:  本文是由机器翻译的,请参阅免责声明。请在 此处 中查找本文的英文版本以便参考。

如果您是负责管理一个网站,可能需要的一些常见问题有关网站,包括︰

  • 有多少人访问我的网站?

  • 网站的流量如何随时间变化?

  • 我的网站上的顶部用户是谁?

  • 流量来自何处我的网站上?

  • 什么是最常访问页面和我的网站上的资源?

  • 如何了解我们的工作流流程中的突出文档和其他资源的位置?

同时,为的经理的网站,您可能必须定期希望得到回答,如一些问题︰

  • 我是否可以删除,因为它们不是使用或旧的网站上是否有资源?

  • 如何在我的网站 (如未链接的文件、 慢页面和断开的超链接) 上查找问题之前它们是注意到,用户报告的?

这些问题可能看起来困难的但使用Microsoft Office SharePoint Designer 2007和Windows SharePoint Services 3.0网站或Microsoft Office SharePoint Server 2007网站,您可以轻松地回答这些问题通过使用Office SharePoint Designer 2007报表。本文介绍如何使用报表度量网站性能和使用率。

重要: 由Office SharePoint Designer 2007生成报表的数据保存在服务器托管该网站上。服务器管理员可以授予或拒绝他们访问这些报表。如果您请求的报表不包含任何数据,与服务器管理员联系以获得帮助。若要运行使用率报告,必须具有查看使用率数据权限和服务器管理员必须先启用使用率数据集合在服务器上。默认情况下,在服务器上的使用率数据集处于关闭状态。

您要做什么?

查看站点总览报表

查看有关文件的报告

查看有关共享的内容的报告

查看有关问题报告

查看使用率摘要报告

查看详细的使用率报告

您使用的数据结果的图表

对报表进行排序

筛选报表

复制报表

保存报表

查看站点总览报表

站点总览报表提供了您的网站上,以及链接到更详细的报表的概述。例如,您可以生成网站摘要报表在下图所示。

“站点总览”报表

若要生成您的网站站点总览报表︰

  1. 打开您要在Office SharePoint Designer 2007中运行报告的网站。

  2. 网站菜单上,指向报表,,然后单击站点总览

    生成报表。

注意: 您可以单击名称列以导航到更详细的报表中的超链接。例如,单击断开的超链接可直接导航至断开的超链接报表。

返回页首

查看有关文件的报告

您可以生成显示所有文件、 最近添加的文件、 最近更改的文件或较早的文件的报表。例如,如果您想要突出显示您的网站主页上或推广您的网站的新闻稿中的新内容,您可以使用最近添加文件报表迅速确定您的新内容。或者,您可以使用较旧文件报表标识的年龄要审阅的可能更新或删除的内容。

有关文件中运行报告,首先指定用于最近和更低版本的文件,您定义和还指定多少个月以按月显示在报表上︰

  1. 打开您要在Office SharePoint Designer 2007中运行报告的网站。

  2. 工具菜单上,单击应用程序选项

  3. 单击报表视图选项卡。

    显示“报表视图”选项卡的“应用程序选项”对话框

  4. "最近"文件是小于框中,输入识别新页的天数。

  5. "旧文件是多框中,输入的标识较旧的页面的天数。

  6. 显示的月数框中,输入按月应显示在报表的月数。

  7. 单击确定

    现在,您就可以运行报告了。

  8. 网站菜单上,指向报告文件,指向,然后单击要运行报告:

    • 所有文件    显示在网站中的所有文件的列表。

    • 最近添加的文件    显示您在步骤 4 中指定的天数内添加到网站的文件的列表。

    • 最近更改的文件    显示您在步骤 4 中指定的天数内的网站修改文件的列表。

    • 较早的文件    显示被视为"旧"由您在步骤 5 中指定的天数的文件的列表。

    • 签出状态    在您的网站以及当前签出状态的每个文件中显示文件的列表。(此报告还包括签出者版本已锁定日期数据列的格式。)

      在报表视图,用于报告关于文件,您可以单击列表中的选项,若要快速更改为较旧或最近的文件的设置。

      显示文件时间长短筛选菜单的报表视图

返回页首

查看有关共享的内容的报告

母版页,自定义和网站定义和样式表链接中包含的其他页面,可以包括共享的内容。Office SharePoint Designer 2007容易找到共享的内容。例如,如果您想要更改徽标上的所有页中您的网站,并使用格式控件页面的母版页,您可以使用母版页报表查找所有母版页应在其更改徽标。您可以使用样式表链接报表以查找所有需要更新以反映更改字体或格式,您希望应用跨您的网站中的样式表。

  1. 打开您要在Office SharePoint Designer 2007中运行报告的网站。

  2. 网站菜单上,指向报告,指向共享内容,,然后单击您想要运行的报告︰

    • 动态 Web 模板    在网站中,显示所有页的列表,指示是否将每个页面附加到动态 Web 模板的动态 Web 模板列 (如果是,哪一个)。

    • 母版页    在网站中,显示的所有页的列表,指示是否将每个页面附加到母版页的母版页列 (如果是,哪一个)。

    • 自定义页面    指明是否已自定义基于网站定义中的任意页面的自定义列,在网站中,显示所有页的列表。

    • 样式表链接    指明是否将每个页面附加到样式表的样式表链接列,在网站中,显示所有页的列表。

      注意: 显示样式表链接是静态样式表链接 (< 链接 > 标记)。此报表中不包含由 Microsoft ASP.NET 控件 (例如 < SharePoint:CssLink >) 生成的动态样式表链接。

返回页首

查看有关问题报告

有关问题Office SharePoint Designer 2007报表可以帮助您预测潜在的问题和用户会受到影响先解决这些问题。例如,您可以使用这些报表识别慢速网页、 定位断开的超链接,并查找要删除的候选,因为它们不链接到其他文件的文件。要运行报告问题,请首先设置如何定义慢速网页的首选项。

  1. 打开您要在Office SharePoint Designer 2007中运行报告的网站。

  2. 工具菜单上,单击应用程序选项

  3. 单击报表视图选项卡。

    显示“报表视图”选项卡的“应用程序选项”对话框

  4. 至少需要"慢速网页"框中,输入定义下载慢页面所需的多长时间的秒数。

  5. 假设连接速度为框中,输入千位每秒的平均用户的连接速度数。

  6. 单击“确定”。

    现在,您就可以运行报告了。

  7. 单击网站,指向报告、 指向问题,,然后单击要运行的报告︰

    • 未链接的文件    在网站中对其没有链接显示所有文件的列表。此列表可帮助您查找未使用应该从网站中删除的文件。请注意,此报告不考虑帐户生成的目录 Web 部件中Office SharePoint Server 2007网站如 ASP.NET 控件的链接。

    • 慢速网页     在网站中标识为加载在步骤中指定的定义下,3 和步骤 4 中指定的平均连接速度缓慢显示网页的列表。注意此报告反映加载页面标记所需的时间。它不考虑帐户生成 ASP.NET 控件的动态内容。

    • 超链接    显示在网站中的所有超链接的列表。运行此报告后,对话框询问您是否要验证的网站中的超链接。如果您希望Office SharePoint Designer 2007单步执行并验证每个超链接,请单击。此过程的结果是与每个标识为确定断开的超链接的列表。要编辑任何断开的链接,请在报表中,单击链接,然后单击报表视图中的文档窗口的右上角中显示的工具栏上的编辑超链接

      注意:  “编辑超链接”对话框

    • 组件错误    显示的任何组件的列表,如交互式按钮或计数器 (所有以前和通常称为 web 组件或机器人) — 的当前正在生成错误。您可以通过单击插入菜单上的Web 组件查看 Web 组件的列表。

返回页首

查看使用率摘要报告

网站使用率报告最紧急的一些问题的有关他们的站点,例如多少人正在使用的网站,可以最受欢迎的资源,供谁使用网站最大,并从访问者浏览到网站所有者具有该网站的帮助答案。使用率摘要报表包含摘要访问总数、 网页点击、 下载的字节数等。

“使用率摘要”报表

按照这些步骤以运行该使用率摘要报告︰

  1. 打开您要在Office SharePoint Designer 2007中运行报告的网站。

  2. 网站菜单上,指向报告用法,指向,然后单击使用率摘要

    生成报表。您可以单击任何名称列以查看详细的报表中的超链接项目。

返回页首

查看详细的使用率报告

您可以运行详细的使用率报告来回答有关用户如何访问您的网站。例如,虽然使用率摘要报表生成的上一节中显示的页面点击总数,每月的网页点击报告多少点击被计算在内的网站中的每个页面的详细信息。下面是运行详细的使用率报告的步骤︰

  1. 打开您要在Office SharePoint Designer 2007中运行报告的网站。

  2. 网站菜单上,指向报告用法,指向,然后单击您想要运行报告:

    • 每月摘要    按月总结数访问、 点击、 总点击、 和下载您的网站上的大小。

    • 每周摘要    按周总结数访问、 点击、 总点击、 和下载您的网站上的大小。

    • 每日摘要    按日期总结数访问、 点击、 总点击、 和下载您的网站上的大小。

    • 每月网页点击    总结对您的网站中的每个页面按月的总点击和点击数。

    • 每周网页点击    按周网站中的每个页面中汇总总点击和点击的数。

    • 每日网页点击    按网站中的每一页的一天中汇总总点击和点击的数。

    • 访问用户    所选的月份总结访问的用户数和其汇总的百分比。

    • 操作系统    总结了选月访问用户的操作系统和其汇总的百分比的计数。

    • 浏览器    总结了选月访问用户浏览器和其汇总的百分比的计数。

    • 引用域    总结所选的月份数访问来自特定域,以及其总计的百分比。

    • 引用的 Url    总结所选的月份数访问来自特定的 URL,以及其总计的百分比。

    • 搜索字符串    列出的搜索字符串中键入网站的搜索框中,以及其总计的百分比为的所选的月份的数量。

返回页首

您使用的数据结果的图表

可以轻松地创建图表显示使用数据图形的格式,以便更容易找到趋势和标识使用模式。

  1. 网站菜单上,指向报告用法,指向,然后单击您想要运行报告。

  2. 在文档窗口中,在图表列表中的右上角中的工具栏上单击您想要创建,如柱形图的图表类型。

    显示“图表”列表的“报表”视图中的工具栏

    在新窗口中打开报表。

    使用率数据图表

    注意: 默认情况下,图表数据会生成以及使用率报告。如果找不到图表的数据,当您尝试运行报告,在工具菜单上,单击应用程序选项,单击报表视图选项卡,然后进行确保选中包括图表时保存使用率报告复选框。

返回页首

对报表进行排序

在报表视图中,您可以通过单击列标题排序报表。

返回页首

筛选报表

可以缩小报告结果,以查看所需的信息。您可以在仅对一列的筛选器,或是在多个列以创建一个连续的筛选器的筛选器。

  1. 网站菜单上,指向报表,,然后单击您想要运行报告。

  2. 单击您要筛选的列标题旁边的箭头,然后单击您要筛选的数据。

    例如,筛选时按文件类型,您可以单击类型列标题旁边的箭头,然后依次bmp只显示位图文件在报表中。

    显示筛选菜单的“类型”列

  3. 如果您想要按多个列进行筛选,请为每个列重复步骤 2。

  4. 若要创建自定义筛选列,通过列标题中,单击箭头,然后单击(自定义)。输入搜索条件,然后再单击确定

    例如,您可以使用自定义自动筛选确定的所有.bmp 和.gif 图像文件,以在您的网站。

    “自定义自动筛选”对话框

  5. 若要清除筛选器的任何列中,单击该列,标题旁边的箭头,然后单击(全部)

注意: 当前应用设置网站关闭时保存的筛选器。如果找不到文件中的新运行报表,这些文件可能隐藏以前会话期间应用的筛选器。

若要从报表中删除所有筛选器,请右键单击任意列标题,,然后单击快捷菜单上的删除筛选器

返回页首

复制报表

运行报告后,您可能希望复制并粘贴到电子邮件或其他文档 (例如,Microsoft Office Excel 工作表) 的结果。您可以复制任何除站点总览报表的报表。

  1. 右键单击任何列标题在报表中有运行时,,然后单击快捷菜单上的复制报表

    选择了“复制报表”命令的“名称”列菜单

  2. 将数据粘贴到文档或消息。

返回页首

保存报表

您可以保存报表,如果您想要使用Microsoft Office Excel 2007来查看和分析结果或从其创建自定义的图表和图形。

  1. 网站菜单中,指向报表,,然后单击要运行报告。

  2. 文件菜单上,单击保存。或按 CTRL + S。

  3. 文件名框中,为报表中,键入一个名称,然后单击保存。报表将保存为.htm 文件在您的网站。

    在 Excel 中打开的报表

  4. 若要打开报表,请双击它。

    在Office Excel 2007中打开报表。

返回页首

注意: 机器翻译免责声明:本文是由无人工介入的计算机系统翻译的。Microsoft 提供机器翻译是为了帮助非英语国家/地区用户方便阅读有关 Microsoft 产品、服务和技术的内容。由于机器翻译的原因,本文可能包含词汇、语法或文法方面的错误。

扩展你的技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×