使用工作表数据创建 XML 数据文件和 XML 架构文件

重要:  本文是由机器翻译的,请参阅免责声明。请在 此处 中查找本文的英文版本以便参考。

如果您需要用工作表上的单元格区域创建 XML 数据文件和 XML 架构文件,可以使用 Excel 2003 XML 工具加载项 1.1 版来增强 Microsoft Excel 2007 和更高版本中现有的 XML 功能。

  1. 若要下载该加载项,请单击以下链接:Excel 2003 XML 工具加载项,然后按照下载页上的说明操作。

  2. 启动 Excel。

  3. 单击文件>选项>加载项

    在Excel 2007,单击Microsoft Office 按钮 Office 按钮图像 > Excel 选项>加载项

  4. “管理”框中,单击“Excel 加载项”,然后单击“转到”

  5. “加载宏”对话框中,单击“浏览”,找到 XmlTools.xla 文件,选择该文件,然后单击“确定”

    默认情况下,此文件存储在硬盘驱动器上的以下文件夹内:
    \Office Samples\OfficeExcel2003XMLToolsAddin。

  6. 验证“可用加载宏”列表中的“XmlTools”复选框是否已选中,然后单击“确定”加载该加载项。

  7. 要验证该加载项是否处于活动状态,请在“加载项”选项卡上的“菜单命令”类别中确保“XML 工具”命令菜单显示。

注意: 该加载项专为 Excel 2003 而开发。在文档和用户界面中称其为列表,现在在 Excel 2003 之后的 Excel 版本中称其为 Excel 表格。

有关如何使用该加载项的详细信息,请参阅使用 Excel 2003 XML 工具加载项 1.1 版一文。

  1. 输入要为其创建 XML 数据文件和 XML 架构文件的数据。数据必须以包括行和列的表格形式存在(又称为平面数据)。

  2. “加载项”选项卡上的“菜单命令”组中,单击“XML 工具”旁边的箭头,然后单击“将区域转换为 XML 列表”

  3. 将要转换的数据单元格区域作为绝对引用在文本框中输入。

    提示: 要更加容易地输入正确单元格引用,请在对话框中单击文本框右侧的按钮,在该区域的左上部单元格内单击且按住鼠标按钮不放,然后拖至该区域的右下部单元格。

  4. “首行包含列名称”下,如果首行包含数据,则选择“否”;如果首行包含列标题,则选择“是”,然后单击“确定”

    Excel 会自动创建 XML 架构,将单元格映射到该架构,然后创建 XML 表。

    重要:  如果 Visual Basic 编辑器出现并显示 Visual Basic for Applications (VBA) 错误消息,请执行下列操作:

    1. 单击“确定”。

    2. 在 VBA 代码模块中突出显示行中,删除行"50"。换言之,更改:
      XMLDoc 为 msxml2。DOMDocument50
      到:
      XMLDoc 为 msxml2。DOMDocument

    3. 按 F5 查找包含“XMLDoc As msxml2.DOMDocument50”的下一行,单击“确定”,然后如在步骤 2 中所执行的操作一样更改该行。

    4. 再次按 F5 查找和更改字符串的任何其他实例。

    5. 当按下 F5 并且 VBA 错误消息不再出现时,关闭 Visual Basic 编辑器以返回到您的工作簿。此时您的单元格区域已转换为 XML 表。

      注意: 要查看工作簿中的所有 XML 映射,请在“开发工具”选项卡上的“XML”组中单击“源”,以显示“XML 源”任务窗格。在该任务窗格的底部,单击“XML 映射”

      如果看不到“开发工具”选项卡,则执行下节中步骤 1 中的三个步骤,以将其添加到 Excel 功能区。

  1. 如果开发工具选项卡不可用,启用它。有关详细信息,请参阅显示开发工具选项卡

  2. “开发工具”选项卡上的“XML”组中,单击“导出”

    “开发人员”选项卡上的“导出”

    注意: 如果出现一个较小的“导出 XML”对话框,其中只包含“确定”“取消”按钮,则单击要使用的 XML 映射,然后单击“确定”。仅当未选择 XML 表,并且工作簿中包含多个 XML 映射时,才显示较小的“导出 XML”对话框。

  3. 在较大的“导出 XML”对话框的“文件名”框中,为 XML 数据文件键入一个名称。

  4. 单击“导出”

注意:  当创建 XML 映射并将 Excel 中的数据导出到 XML 文件时,可以导出的行数存在限制。从 Excel 导出到 XML 最多可保存 65536 行。如果您的文件包含超过 65536 行,则 Excel 将导出前面的 (#ROWS mod 65537) 行。例如,如果您的工作表具有 70000 行,则 Excel 将导出 70000 mod 65537 = 4464 行。我们的建议是:1) 改用 xlsx 或者 2) 将文件另存为 XML 电子表格 2003 (.xml),它将丢失映射,或者 3) 删除 65536 后面的所有行,然后再次导出,这样可保留映射,但会丢失文件末尾的数据。

  1. 选择映射 Excel 表格中的任何单元格。

  2. “加载项”选项卡上的“菜单命令”组中,单击“XML 工具”旁边的箭头,然后单击“为活动单元格处的 XML 架构创建 XSD 文件”

    Excel 将复制 XML 架构并将其粘贴到记事本内。

  3. 在记事本中,单击“文件”,然后单击“另存为”

  4. 键入文件名和文件类型,例如 ProdOrders.xsd,然后单击“保存”

需要更多帮助吗?

可随时在 Excel 技术社区中咨询专家,在解答社区获得支持,或在 Excel User Voice 上建议新功能或功能改进。

返回页首​​

注意: 机器翻译免责声明:本文是由无人工介入的计算机系统翻译的。Microsoft 提供机器翻译是为了帮助非英语国家/地区用户方便阅读有关 Microsoft 产品、服务和技术的内容。由于机器翻译的原因,本文可能包含词汇、语法或文法方面的错误。

扩展你的技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×