使用屏幕阅读器将 Access 表导出到 Excel 工作簿

使用屏幕阅读器将 Access 表导出到 Excel 工作簿

朗读符号与屏幕阅读器内容的标签。本主题介绍如何在 Office 中使用屏幕阅读器

本文属于Office 辅助功能内容集,适用于将屏幕阅读器程序与 Office 产品结合使用的视力障碍用户。 若要获取更多常规帮助,请参阅 Office 支持主页

通过键盘和屏幕阅读器使用 Access 将数据导出到 Excel 可以读取的文件格式。 我们已经通过 "讲述人"、"JAWS" 和 "NVDA" 对其进行了测试,但它可能与其他屏幕阅读器配合使用,只要它们遵循常见的辅助功能标准和技术。 你将了解如何使用 "导出向导" 将数据(如表、查询、窗体、报表或多记录视图中的选定记录)导出到多记录视图(如数据表到 Excel 兼容的文件)中。

注意: 

本主题内容

准备要导出的数据

在导出数据之前,请花一些时间查看数据并确定要如何导出数据。

  • 请确保数据中不包含任何错误指示器或错误值。 否则,在导出过程中可能会出现问题,并且可能会将 null 值插入 Excel 工作表单元格中。 有关疑难解答信息,请转到将数据导出到 Excel丢失值和错误值的疑难解答部分。

  • 确定是否要导出带有或不带格式的表或查询。 此决策影响导出的数据量和数据的显示格式。 有关导出已设置格式和未设置格式的数据的结果的详细信息,请转到 "将数据导出到 Excel" 中的"为导出操作准备"部分。

  • 选择目标工作簿和文件格式。 如果将包含格式的表、查询、窗体或报表导出到现有工作簿,则工作簿将被覆盖。

    注意: 报表只能以较旧的 * .xls 文件格式导出,不能以较新的 * .xlsx 文件格式导出。

导出数据

当您导出包含子窗体、子报表或子数据表的窗体、报表或数据表时,将只能导出主窗体、主报表或主数据表。 对于要导出到 Excel 的每个子窗体、子报表和子数据表,必须重复执行导出操作。

在一个导出操作中只能导出一个数据库对象。 但是,在完成单个导出操作之后,你可以将多个工作表合并到 Excel 中。

如果您没有准备好工作簿,它将在导出期间创建。 数据始终添加到新工作表中。

Access 当前不支持将宏或模块导出到 Excel 。

  1. 如果您有一个目标 Excel 工作簿准备好,请将其关闭。

  2. 导航到源数据库,然后选择要导出的对象。

    如果对象是表、查询或窗体,并且只想导出部分数据,请在数据表视图中打开对象,然后选择所需记录。 有关说明,请转到在数据表视图中打开对象

    注意: 不能导出报表的一部分。 但是,你可以选择或打开报表所基于的表或查询,然后导出该对象中的部分数据。

  3. 若要为 Excel 导出启动导出向导,请按 Alt + X,X。将打开 "导出-Excel 电子表格" 对话框。

  4. 执行下列操作之一:

    • 如果想要在导出期间创建新电子表格,请按 Alt + F 将焦点移动到 "文件名" 文本字段。 Access 建议源对象的名称作为导出文件的文件名。 若要更改名称,请删除建议的名称,然后键入新名称。

    • 如果您有要将数据导出到的现有 Excel 文件,请按 Alt + R 打开 "文件保存" 对话框,然后浏览找到所需的文件。 一旦你位于该文件上,按 Enter 将其选中。 该对话框将关闭,并且焦点将返回到 "导出-Excel 电子表格" 对话框。

  5. 按 Alt + T 将焦点移动到 "文件格式" 列表。 您将听到当前格式。 若要选择所需的文件格式,请按空格键展开列表,然后按向上或向下箭头键,直到听到所需的格式,然后按 Enter 将其选中。

  6. 如果要导出表或查询,并且想要导出带格式的数据,请按 Alt + W 移动到并选择 "导出带格式和布局的数据" 选项。

    注意: 如果您要导出窗体或报表,则默认情况下会选中此选项,您不能取消选中它。

  7. 如果希望目标 Excel 工作簿在导出后自动打开,请按 Alt + A 移动到,并选择 "完成导出操作后打开目标文件" 选项。

  8. 如果源对象已打开,并且在开始导出之前已在视图中选择了一个或多个记录,并且这些记录是要导出的记录,请按 Alt + S 移动到并选择 "仅导出所选记录"选项。 如果要导出视图中显示的所有记录,请不要选择此选项。

    注意: 如果未选择任何记录,则此选项不可用。

  9. 若要开始导出,请按 Tab 键,直到到达"确定"按钮,然后按 enter。

  10. 如果导出成功, Access 会提示你保存导出步骤,以便在不导出向导的情况下快速重复这些步骤。 若要选择此选项,请按 Alt + V。 若要命名文件,请按 Alt + A,然后键入文件名。 若要保存步骤文件,请按 Alt + S。

    如果导出因错误而失败, Access 将显示描述错误原因的消息。

    如果选择自动打开目标 Excel 工作簿,请按 Alt + Tab,直到听到工作簿的名称,然后查看其内容。

在数据表视图中打开对象

如果要导出的对象是表、查询或窗体,并且只想导出部分数据,则需要在数据表视图中打开对象以选择所需记录。

  1. 导航到导航树中的对象。

  2. 在对象上时,按 Shift + F10 打开上下文菜单。

  3. 在菜单中,按 Tab 键,直到到达"数据表视图" 选项,然后按 enter 将其选中。 对象将在数据表视图中打开。

    如果 "数据表视图" 选项不可用,则需要为对象启用视图。 有关说明,请转到为对象启用数据表视图

为对象启用 "数据表" 视图

  1. 当在导航树中的对象上时,按 Shift + F10 打开上下文菜单。

  2. 在菜单中,按 D 打开 "设计" 视图

  3. 在 "设计" 视图中,按 F4 打开 "属性表" 窗格。

  4. 按一次 F6。 焦点移到 "属性表" 窗格中的属性行。 将听到行号,后跟属性单元格的内容。

  5. 若要将焦点移动到 "选择类型" 下拉列表,请按 Shift + Tab,直到听到 "整个字段",后跟当前值和 "组合编辑"。 如果当前值为 "表单",则可以继续执行下一步。 否则,按 Alt + 向下键展开列表,然后按向上或向下箭头键,直到听到 "窗体",然后按 Enter 将其选中。

  6. 在 "属性表" 窗格中,按 tab 键,直到听到当前选定的选项卡项,例如 "数据选项卡项,已选择"。 如果当前选项卡是 "格式" 选项卡,则可以继续执行下一步。 否则,按向左或向右箭头键,直到听到: "格式选项卡项"。 将显示 "格式" 选项卡的属性。

  7. 在 "格式" 选项卡上,按 tab 键,直到听到: "第四行,不,已折叠"。 焦点位于 "允许数据表视图" 属性上。 若要将该属性设置为"是",请按 Alt + 向下键,然后按一次向上键,然后按 enter 选择新值。

  8. 若要关闭 "属性表" 窗格,请按 F4。

  9. 若要在数据表视图中打开所选对象,请按 Alt + J、D、W 和 H。

另请参阅

使用屏幕阅读器在 Access 桌面数据库中创建表格

使用屏幕阅读器在 Access 桌面数据库中创建查询

使用屏幕阅读器在 Access 桌面数据库中创建窗体

使用屏幕阅读器将 Access 表导出到文本文件

Access 的键盘快捷方式

使用屏幕阅读器浏览和导航 Access

适用于残障人士客户的技术支持

Microsoft 希望尽可能地为所有客户提供最佳体验。 如果你是残疾人士或对辅助功能存在疑问,请联系 Microsoft 辅助功能 Answer Desk 寻求技术帮助。 辅助功能 Answer Desk 支持团队接受过使用多种热门辅助技术的培训,并可使用英语、西班牙语、法语和美国手语提供帮助。 请访问 Microsoft 辅助功能 Answer Desk 网站,找出你所在地区的联系人详细信息。

如果你是政府版、商业版或企业版用户,请联系企业版辅助功能 Answer Desk

注意:  本页面是自动翻译的,可能包含语法错误或不准确之处。 我们的目的是使此内容能对你有所帮助。 能否告知我们此信息是否有所帮助? 下面是该参考内容的英文版

扩展你的 Office 技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×