使用外部数据源创建数据透视表

重要:  本文是由机器翻译的,请参阅免责声明。请在 此处 中查找本文的英文版本以便参考。

能够分析所有数据可帮助您做出更好的业务决策。但有时候很难知道从何开始,尤其是当您拥有大量数据存储在 Excel 外部(例如 Microsoft Access 或 Microsoft SQL Server 数据库或联机分析处理 (OLAP) 多维数据集文件)时。在这种情况下,您将连接到外部数据源,然后创建数据透视表以汇总、分析、浏览并显示该数据。

下面介绍了如何使用现有外部数据连接创建数据透视表:

  1. 单击工作表上的任意单元格。

  2. 单击“插入”>“数据透视表”。

    “插入”选项卡上的“数据透视表”按钮

  3. 在“创建数据透视表”对话框中的“请选择要分析的数据”下方,单击“使用外部数据源”。

    选中了“使用外部数据源”的“创建数据透视表”对话框

  4. 单击“选择连接”。

  5. 在“连接”选项卡上的“显示”框中,选中“所有连接”,或者选择包含要连接到的数据源的连接类别。

要重复使用或共享某个现有连接,请从“此工作簿中的连接”使用连接。

  1. 在连接列表中,选择所需连接,然后单击“打开”。

  2. 在“选择放置数据透视表的位置”下方,选择一个位置。

    • 要将数据透视表放在新工作表中,并以单元格 A1 为起始位置,请选择“新建工作表”。

    • 要将数据透视表放在活动工作表中,请选择“现有工作表”,然后在“位置”框中输入希望数据透视表开始的单元格。

  3. 单击“确定”

    Excel 将添加一个空数据透视表,并显示字段列表,以便您可以显示所需的字段重新排列它们以创建您自己的布局

    显示外部数据字段的字段列表

  4. 在字段列表节中,选中某个字段名称旁边的框以将该字段放在“字段列表”的区域节的默认区域中。

    通常,非数值字段将添加到“”区域,数值字段将添加到“数值”区域,而日期和时间字段将添加到“”区域。您可以根据需要将字段移动到不同区域。

    提示:  您还可以右键单击字段名称,然后选择“添加到报表筛选”、“添加到列标签”、“添加到行标签”或“添加到值”以将字段放在区域节的该区域中,或将字段从字段节拖动到区域节中的某个区域。

    通过右键单击区域部分中的字段,然后选择所需的区域或通过区域部分中的区域之间拖动字段,请使用字段列表的内容,进一步重新排列数据透视表数据

连接到新的外部数据源

要创建与 SQL Server 的新外部数据连接,并在 Excel 中导入为表格或数据透视表,请执行下列操作:

  1. 单击“数据”>“自其他源”。

“数据”选项卡上的“自其他源”按钮

  1. 单击所需连接。

    • 单击“来自 SQL Server”以创建与 SQL Server 表的连接。

    • 单击“来自 Analysis Services”以创建与 SQL Server 分析多维数据集的连接。

  2. 数据连接向导中,完成建立连接的步骤。

    • 在第 1 页上,输入数据库服务器并指定如何登录到该服务器。

    • 在第 2 页上,输入包含所需数据的数据库、表或查询。

    • 在第 3 页上,输入要创建的连接文件。

要创建与 Access 数据库的新连接,并在 Excel 中导入数据作为表格或数据透视表,请执行以下操作:

  1. 单击“数据”>“自 Access”。

“数据”选项卡上的“自 Access”按钮

  1. 在“选择数据源”对话框中,找到要连接到的数据库,然后单击“打开”。

  2. 在“选择表”对话框中,选择所需表,然后单击“确定”。

如果有多个表,请选中“启用多个表的选择”框,以便您可以选中所需表的框,然后单击“确定”。

  1. 在“导入数据”对话框中,选择要如何查看工作簿中的数据以及放置位置,然后单击“确定”。

表将自动添加到数据模型,并将 Access 数据库添加到工作簿连接。

有关数据透视表的更多信息

注意: 机器翻译免责声明:本文是由无人工介入的计算机系统翻译的。Microsoft 提供机器翻译是为了帮助非英语国家/地区用户方便阅读有关 Microsoft 产品、服务和技术的内容。由于机器翻译的原因,本文可能包含词汇、语法或文法方面的错误。

扩展你的技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×