使用切片器筛选数据透视表数据

在早期版本的 Microsoft Excel 中,您可以使用报表筛选器以筛选PivotTable report中的数据,但不是可以轻松地筛选多个项目时,请参阅当前筛选状态。在Microsoft Excel 2010,必须使用切片器来筛选数据的选项。切片器提供了您可以单击以筛选数据透视表数据的按钮。除了快速进行筛选,切片器还指示当前筛选状态,使其更易于理解完全中显示的内容筛选后的数据透视表报表。

Excel 功能区图像

当选择项时,该项目包括在筛选器和报表中将显示该项目的数据。例如,销售人员字段中选择 callahan 直至时,将显示仅包括 callahan 直至在该字段中的数据。

本文内容

切片器是什么?

使用切片器

在现有的数据透视表中创建切片器

创建独立切片器

设置格式的切片器

共享通过连接到另一个数据透视表切片器

断开连接或删除切片器

切片器是什么?

切片器易于使用筛选组件包含一组使您能够快速筛选数据透视表报表,而无需打开下拉列表以查找您要筛选的项目中的数据的按钮。

在多个项目使用正则数据透视表报表筛选器筛选器时,筛选器仅指示,筛选多个项目,并且您有打开的下拉列表以查找筛选的详细信息。但是,切片器清楚地标记应用,并提供详细信息,以便您可以轻松地了解筛选数据透视表中显示的数据的筛选器。

切片器通常与在其中创建数据透视表相关联。但是,您还可以创建独立的切片器的联机分析处理 (OLAP)多维数据集函数,从引用或可以在以后与任何数据透视表相关联的。

切片器通常会显示以下元素︰



数据透视表切片器元素

1.切片器页眉指示切片器中的项目的类别。

2.未选中的筛选按钮表示该项目不包括在筛选器。

3.筛选按钮所选指示的筛选器中包含的项目。

4.清除筛选按钮删除筛选器,通过选择切片器中的所有项目。

5.滚动条启用滚动时不是切片器中当前可见的多个项目。

6.边框移动并调整控件大小允许您更改大小和切片器的位置。

返回页首

使用切片器

有几种方式创建切片器来筛选数据透视表数据。在现有的数据透视表,您可以︰

  • 创建切片器与数据透视表相关联。

  • 创建切片器与数据透视表相关联的副本。

  • 使用现有切片器与另一个数据透视表相关联。

除了或而不是在现有的数据透视表中创建切片器,您还可以创建独立切片器,可以通过联机分析处理 (OLAP)多维数据集函数引用,或在以后可以与任何数据透视表关联。

由于您创建的每个切片器设计对某一特定的数据透视表字段进行筛选,可能是您将创建多个切片器来筛选数据透视表报表。

创建切片器后,它将与数据透视表中的分层显示,如果您有多个切片器配合工作表上显示。可以在工作表移动到其他位置的切片器,并根据需要调整其大小。

分层切片器

若要筛选数据透视表数据,您只需单击一项或多个切片器中的按钮。

筛选器已选中的切片器

以一致的外观的格式切片器

若要创建专业外观的报表或只需匹配相关联的数据透视表报表的格式切片器的格式,您可以应用统一的外观的切片器样式。通过应用不同的切片器可用预定义样式之一,则可以密切匹配颜色主题应用于数据透视表。自定义外观,您甚至可以创建您自己的切片器样式,就像您创建自定义数据透视表样式。

共享数据透视表之间的切片器

如果您在一个报表中,如商业智能 (BI) 报表正在处理,有许多不同的数据透视表,则可能要将相同的筛选器应用于某些或所有这些数据透视表。您可以共享您创建一个使用其他数据透视表的数据透视表中的切片器。无需为每个数据透视表中复制的筛选器 !

当您共享切片器时,您创建的连接到另一个数据透视表,其中包含您要使用切片器。对共享切片器所做的任何更改将立即体现连接到该切片器的所有数据透视表中。例如,如果您所在国家/地区切片器中使用 PivotTable1 来筛选数据的特定国家/地区,还会使用该切片器的 PivotTable2 将显示的相同的国家或地区的数据。

切片器连接到和使用多个数据透视表中称为共享切片器。只有一个数据透视表中使用的切片器称为本地切片器。数据透视表可以有本地和共享切片器。

返回页首

在现有的数据透视表中创建切片器

  1. 单击您要为其创建切片器数据透视表中的任意位置。

    这将显示数据透视表工具,添加选项设计选项卡。

  2. 选项选项卡上的排序和筛选组中,单击插入切片器

    Excel 功能区图像

  3. 插入切片器对话框中,选择您要为其创建切片器的数据透视表字段复选框。

  4. 单击“确定”。

    切片器显示所选的每个字段。

  5. 在每个切片器中,单击您想要筛选的项目。

    若要选择多个项目,按住 ctrl 键,,然后单击您想要筛选的项目。

返回页首

创建独立切片器

  1. 插入选项卡上,在筛选组中,单击切片器

    Excel 功能区图像

  2. 现有连接对话框中的显示框中,执行下列操作之一︰

    • 若要显示所有连接,请单击“所有连接”。默认情况下会选择此选项。

    • 若要只显示最近使用的连接的列表,请单击“此工作簿中的连接”

      此列表是从以下连接创建的:已经定义的连接、使用数据连接向导的“选择数据源”对话框创建的连接或者以前在该对话框中选择的连接。

    • 若要只显示计算机上可用的连接,请单击“此计算机的连接文件”

      此列表是从通常存储在“我的文档”中的“我的数据源”文件夹创建的。

    • 若要显示从网络访问的连接文件从可用的连接,请单击网络上的连接文件

      此列表被创建Microsoft Office SharePoint Server 2007或Microsoft SharePoint Server 2010网站上从数据连接库 (DCL)。DCL 是SharePoint Foundation网站包含 Office 数据连接 (ODC) 文件 (.odc) 的集合中的文档库。通常情况下,DCL 设置通过网站管理员,用户还可以配置的 SharePoint 网站,在外部连接对话框中显示来自此 DCL ODC 文件。

      提示   如果看不到所需的连接,您可以创建的连接。单击浏览更多,然后在选择数据源对话框中,单击新的源启动数据连接向导中,以便您可以选择您想要连接到数据源。

      注意   如果您的网络上的连接文件在此计算机上的连接文件类别中选择一个连接,连接文件复制到新的工作簿连接,为工作簿,然后用作新的连接信息。

  3. 选择连接中,单击所需的连接,然后单击打开

  4. 插入切片器对话框中,单击您要为其创建切片器的字段的复选框。

  5. 单击“确定”。

    为您选择的每个字段创建切片器。

返回页首

设置格式的切片器

  1. 单击要设置格式的切片器。

    这将显示切片器工具,添加选项卡。

  2. 选项选项卡上的切片器样式组中,单击所需的样式。

    若要查看所有可用的样式,单击更多按钮 按钮图像

    Excel 功能区图像

返回页首

共享通过连接到另一个数据透视表切片器

您可以通过将其连接到该数据透视表切片器共享与另一个数据透视表。您可以通过连接到该数据透视表从另一个数据透视表中插入切片器。

使另一个数据透视表中的切片器可供使用

  1. 单击您想要共享另一个数据透视表中的切片器。

    这将显示切片器工具,添加选项卡。

  2. 选项选项卡上的切片器组中,单击数据透视表连接

    Excel 功能区图像

  3. 数据透视表连接对话框中,选择要在其中切片器可用于数据透视表的复选框。

使用来自其他数据透视表切片器

  1. 创建数据透视表,其中包含您想要共享通过执行下列切片器的连接︰

    1. 数据选项卡的获取外部数据组中,单击现有连接

      Excel 功能区图像

    2. 现有连接对话框中的显示框中,确保已选中了所有连接

      提示   如果看不到所需的连接,您可以创建的连接。单击浏览更多,然后在选择数据源对话框中,单击新的源启动数据连接向导中,以便您可以选择您想要连接到数据源。

    3. 选择所需的连接,然后单击“打开”

    4. 导入数据对话框中,在选择您想要查看此工作簿中的数据的方式,下单击数据透视表

  2. 单击您要从另一个数据透视表中插入切片器数据透视表中的任意位置。

    这将显示数据透视表工具,添加选项设计选项卡。

  3. 选项选项卡上的排序和筛选组中,单击插入切片器箭头,然后单击切片器连接

    Excel 功能区图像

  4. 切片器连接对话框中,选择要使用的切片器的复选框。

  5. 单击“确定”。

  6. 在每个切片器中,单击您想要筛选的项目。

    若要选择多个项目,按住 ctrl 键,,然后单击您想要筛选的项目。

    注意   共享切片器的所有数据透视表将立即显示相同的筛选状态。

返回页首

断开连接或删除切片器

如果您不再需要的切片器,您可以将其断开从数据透视表,或可将其删除。

断开连接切片器

  1. 单击您要断开连接切片器数据透视表中的任意位置。

    这将显示数据透视表工具,添加选项设计选项卡。

  2. 选项选项卡上的排序和筛选组中,单击插入切片器箭头,然后单击切片器连接

    Excel 功能区图像

  3. 切片器连接对话框中,清除您想要断开连接切片器的任何数据透视表字段复选框。

删除切片器

执行下列操作之一:

  • 切片器中,单击,然后按 DELETE。

  • 切片器中,右键单击,然后单击删除 < 切片器名称 >

返回页首

注释: 

  • 机器翻译免责声明:本文是由无人工介入的计算机系统翻译的。Microsoft 提供机器翻译是为了帮助非英语国家/地区用户方便阅读有关 Microsoft 产品、服务和技术的内容。由于机器翻译的原因,本文可能包含词汇、语法或文法方面的错误。

  • 请在 此处 中查找本文的英文版本以便参考。你和 Microsoft 社区的其他成员可以使用 Community Translation Framework (CTF) 来改进本文。只需将鼠标悬停在文章中的句子上,然后在 CTF 小组件中单击“IMPROVE TRANSLATION”即可。 单击此处了解有关 CTF 的详细信息。 使用 CTF 即表示你同意服务条款

扩展你的技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×