使用不同语言检查拼写和语法

使用不同语言检查拼写和语法

如果你正在处理一个文档,且需要添加并非你通常使用的语言的文本,那么 Office 可以为你检查该文本的拼写和语法。 

如果您正在查找有关如何使用校对工具,或打开拼写或语法检查打开或关闭,请参阅:检查拼写和语法在 Office 2010 和更高版本

使用下面的选项卡来选择你正在使用的 Office 版本。

注意: 如果想键入非拉丁语系的语言(如阿拉伯语或中文),可通过语言栏来切换键盘布局。当改变键盘布局时,Office 将为你更改拼写和语法语言。有关详细信息,请参阅启用或更改键盘布局语言

若要准确地检查拼写和语法,Office 需要知道文本的语言。Office 使用三种常见方法来进行识别。 

  • 如果选中了“语言”对话框中的复选框“自动检测语言”,Office 会在你键入时尝试识别你正在使用的语言。然后它会调整拼写语言以匹配你的文本。这是设置拼写语言的最简便方法。 

  • Office 可以通过活动键盘布局来识别所键入文本的语言。当你更改键盘布局时,Office 将自动为你切换到合适的拼写语言。有关详细信息,请参阅启用或更改键盘布局语言

  • 如果自动检测语言未如预期那样起作用,以及如果你希望键入另一种语言的文本但同时保持键盘布局语言不变,那么可以手动设置语言来检查拼写和语法。 

如果需要手动设置语言,请按照以下步骤进行操作:

  1. 将光标放在文档中希望开始使用其他语言键入文档的地方。或者,如果已经键入文本,则选择该文本。

  2. 在“审阅”选项卡上的“语言”组中,单击“语言”,然后单击“设置校对语言”。

    设置校对语言

  3. 在“语言”对话框或“校对语言”窗格中,清除复选框“自动检测语言”。 

  4. 滚动到要使用的语言并选中它。

  5. 单击“确定”关闭“语言”对话框。

  6. 如果要输入你在步骤 4 中所选语言的文本,现在即可开始键入。如果你在步骤 1 中选中了某些文本,则现在会以合适的拼写语言对其进行检查。  

若要在检查数据库或工作簿的拼写时更改语言,请在拼写检查过程中更改词典语言:

  1. 在 Excel 中的“审阅”选项卡或 Access 中的“开始”选项卡上,单击“拼写检查”。

  2. 在“拼写检查”窗格或对话框中,选择“词典语言”列表中所需的语言。

如果所需的语言不可用,你可能需要 Office 语言包。有关详细信息,请参阅确定你是否需要 Office 2013 语言包或语言界面包Office 2016 语言配件包

如果你想要更改默认编辑语言以检查拼写,请参阅在 Office 中添加一种语言或设置语言首选项

在 InfoPath Designer 中,“设置校对语言”适用于当前窗体视图。在具有多个视图的窗体中,每个视图可以设置不同的校对语言。在 InfoPath Editor 中,“设置校对语言”适用于整个窗体。校对语言适用于整个视图。视图中的所有文本都标记为同一种语言。

若要更改窗体的语言,请执行下列操作:

  1. 在“开始”选项卡上,单击“拼写检查”下的箭头,然后单击“设置校对语言”。

  2. 在“语言”对话框中,单击所需的语言。

  3. 开始键入,或者检查拼写。

创建新文档时设置校对语言

  1. 在新文档中,单击你想要开始使用另一种语言编写的位置。

  2. 在“审阅”选项卡上,单击“拼写检查”,然后单击“设置校对语言

    在“审阅”选项卡上,单击“拼写”>“设置校对语言”

  3. 滚动浏览列表以选择所需的语言,然后单击“确定”。

    Word Online 中“设置校对语言”列表的图像。

  4. 开始使用你所选择的语言进行键入。

  5. 若要切换回原始语言,请重复步骤 3 和 4。

编辑现有文档时设置校对语言

  1. 打开你想要更改其语言的现有文档。

  2. 单击“编辑文档”,然后单击“Word Online”。

    在 Word Online 中编辑

  3. 选中并右键单击文本,然后单击“设置校对语言”。

    单击鼠标右键,然后单击“设置校对语言”

  4. 滚动浏览列表以选择所需的语言,然后单击“确定”。

    Word Online 中“设置校对语言”列表的图像。

  5. 开始使用你所选择的语言进行键入。

  6. 若要切换回原始语言,请重复步骤 3 和 4。

另请参阅

注释: 

若要在 Access 中设置语言,只需键入要使用的语言即可。

或者,如果希望更改仅与某一部分文本相关联的语言,请选中文本,检查拼写,然后在“拼写检查”对话框中更改词典语言。

更改整个数据库的词典语言:

  1. 打开要更改词典语言的 Access 数据库。

  2. 单击“Microsoft Office 按钮Office 按钮图像 ,然后单击“Access 选项”。

    “Access 选项”按钮

  3. 单击“校对”。

  4. 在“词典语言”列表中,单击要使用的词典语言,然后单击“确定”。

  5. 要检查拼写,请选择要检查的记录,然后单击在开始选项卡上的拼写 按钮图像

    注释: 

    • 拼写检查器使用所选的词典语言检查数据库中的拼写。若要检查多语言数据库中的拼写,则必须更改词典语言并为数据库中的每种语言检查拼写。

    • 如果你的 2007 Microsoft Office 系统 版本不提供你要键入的语言的校对工具(例如拼写检查器),则可能需要语言包。有关详细信息,请参阅我是否需要语言包或语言界面包?

若要在 Excel 中设置语言,只需键入要使用的语言即可。

或者,如果希望更改仅与某一部分文本相关联的语言,请选中文本,检查拼写,然后在“拼写检查”对话框中更改词典语言。

更改整个工作簿的词典语言:

  1. 单击“Microsoft Office 按钮Office 按钮图像 ,然后单击“Excel 选项”。

    “Excel 选项”按钮

  2. 单击“校对”。

  3. 在“词典语言”列表中,选择要使用的词典语言,然后单击“确定”。

  4. 若要检查工作表的拼写,请在“审阅”选项卡的“校对”组中,单击“拼写检查按钮图像

    注释: 

    • 若要检查多语言工作簿中的拼写,则必须更改词典语言并为每个工作表或单元格中所使用的每种语言检查拼写。

    • 如果你的 2007 Microsoft Office 系统 版本不提供你要键入的语言的校对工具(例如拼写检查器),则可能需要语言包。有关详细信息,请参阅我是否需要语言包或语言界面包?

若要在 InfoPath 中设置语言,只需键入要使用的语言即可。

或者,如果希望更改仅与某一部分文本相关联的语言,请选中文本,检查拼写,然后在“拼写检查”对话框中更改词典语言。

更改整个 InfoPath 模板或窗体的词典语言:

  1. 在“工具”菜单上,单击“设置语言按钮图像

  2. 在“语言”对话框中,单击要使用的语言。

  3. 开始键入新语言。

  4. 若要切换回原始语言或切换至其他语言,请重复步骤 1-2。在步骤 2 中,选择要使用的新语言。

  5. 若要检查窗体的拼写,请在“审阅”选项卡的“校对”组中,单击“拼写检查按钮图像

    注意: 如果你的 2007 Microsoft Office 系统 版本不提供你要键入的语言的校对工具(例如拼写检查器),则可能需要语言包。有关详细信息,请参阅我是否需要语言包或语言界面包?

若要在 OneNote 中设置语言,只需键入要使用的语言即可。

或者,如果希望更改仅与某一部分文本相关联的语言,请选中文本,检查拼写,然后在“检查拼写”任务窗格中更改词典语言。

设置笔记的词典语言:

  1. 选择要设置语言的笔记,或将光标置于要启动新笔记的位置。

  2. 在“工具”菜单上,单击“设置语言按钮图像

  3. 在“设置语言”任务窗格中,选择要使用的语言。

  4. 若要切换回原始语言或切换至其他语言,请重复步骤 1-3。在步骤 3 中,选择要使用的新语言。

  5. 若要检查拼写,在“工具”菜单上,指向“拼写检查”,然后单击“拼写检查按钮图像

    注意: 如果你的 2007 Microsoft Office 系统 版本不提供你要键入的语言的校对工具(例如拼写检查器),则可能需要语言包。有关详细信息,请参阅我是否需要语言包或语言界面包?

若要在 Outlook 中设置语言,只需键入要使用的语言即可。

或者,如果希望更改仅与某一部分文本相关联的语言,请选中文本,检查拼写,然后在“拼写和语法”对话框中更改词典语言。

更改整个邮件的词典语言:

  1. 在“邮件”选项卡上的“校对”组中,单击“拼写检查”下的箭头,然后单击“设置语言按钮图像

  2. 在“语言”对话框中,选择希望使用的语言。

    如果语言前面 按钮图像 拼写和语法图标,则说明了该语言安装了校对工具,例如拼写检查器、 语法检查器和同义词库。如果语言前面没有 按钮图像 拼写和语法图标,您可以键入和编辑文本,但不能检查拼写或语法,或使用了该语言的同义词库。

  3. 若要切换回原始语言或切换至其他语言,请重复步骤 1-3。在步骤 3 中,选择要使用的新语言。

  4. 若要检查邮件的拼写,请单击邮件选项卡上的拼写 按钮图像

    注释: 

    • 如果执行这些步骤之后,拼写检查器未正确识别拼写错误,请尝试清除“语言”对话框(步骤 2)中的“自动检测语言”复选框。

    • 如果你的 2007 Microsoft Office 系统 版本不提供你要键入的语言的校对工具(例如拼写检查器),则可能需要语言包。有关详细信息,请参阅我是否需要语言包或语言界面包?

若要在 PowerPoint 中设置语言,只需键入要使用的语言即可。

或者,如果希望更改仅与某一部分文本相关联的语言,请选中文本,检查拼写,然后在“拼写和语法”对话框中更改词典语言。

更改整个幻灯片的词典语言:

  1. 在“审阅”选项卡的“校对”组中,单击“语言按钮图像

  2. 在“语言”对话框中,选择希望使用的语言。

    如果该语言前面带有“拼写和语法”图标 按钮图像 ,则表明为该语言安装了拼写检查器、语法检查器和同义词库等校对工具。如果该语言前面没有“拼写和语法”图标 按钮图像 ,你可以键入和编辑文本,但无法针对该语言检查拼写/语法或使用同义词库。

  3. 若要切换回原始语言或切换至其他语言,请重复步骤 1-2。在步骤 2 中,选择要使用的新语言。

  4. 若要检查幻灯片的拼写,请单击“审阅”选项卡上的“拼写检查按钮图像

    注释: 

    • 在 PowerPoint 中,必须在每张幻灯片上都使用拼写检查器。

    • 如果你的 2007 Microsoft Office 系统 版本不提供你要键入的语言的校对工具(例如拼写检查器),则可能需要语言包。有关详细信息,请参阅我是否需要语言包或语言界面包?

若要在 Publisher 中设置语言,只需键入要使用的语言即可。

或者,如果希望更改仅与某一部分文本相关联的语言,请选中文本,检查拼写,然后在“拼写检查”对话框中更改词典语言。

更改整个发布的词典语言:

  1. 在“工具”菜单上,单击“语言”,然后单击“设置语言”。

  2. 在“语言”对话框中,选择希望使用的语言。

  3. 若要切换回原始语言或切换至其他语言,请重复步骤 1-3。在步骤 3 中,选择要使用的新语言。

  4. 若要检查拼写,在“工具”菜单上,指向“拼写检查”,然后单击“拼写检查按钮图像

    • 若要检查多页发布的所有页面中的拼写,请确保选中“检查拼写”对话框上的“检查所有文章”复选框。

    • 如果你的 2007 Microsoft Office 系统 版本不提供你要键入的语言的校对工具(例如拼写检查器),则可能需要语言包。有关详细信息,请参阅我是否需要语言包或语言界面包?

若要在 Visio 中设置语言,只需键入要使用的语言即可。

更改 Visio 中特定文本的词典语言:

  1. 选择现有文本内容。或者,以你要使用的语言键入一段新文本,然后选中该文本。

  2. 在“格式”菜单上单击“文本”,然后单击“字体”选项卡。

  3. 在“语言”列表中,单击要使用的语言。

    注意: 如果你的 2007 Microsoft Office 系统 版本不提供你要键入的语言的校对工具(例如拼写检查器),则可能需要语言包。有关详细信息,请参阅我是否需要语言包或语言界面包?

  1. 将光标放在文档中希望开始使用其他语言键入文本的地方。或者,如果要更改与现有文本内容关联的语言,请选中该文本。

  2. 在“审阅”选项卡的“校对”组中,单击“设置语言按钮图像

  3. 在“语言”对话框中,选择希望使用的语言。

    如果语言之前 按钮图像 拼写和语法图标,则意味着校对工具,如拼写检查语法检查器和同义词库已经安装了该语言。如果语言前面没有 按钮图像 拼写和语法图标,您可以键入和编辑文本,但不能检查拼写或语法,或使用了该语言的同义词库。

  4. 若要切换回原始语言或切换至其他语言,请重复步骤 1-3。在步骤 3 中,选择要使用的新语言。

    注释: 

    • 如果执行这些步骤之后,拼写检查器未正确识别拼写错误,请尝试清除“语言”对话框(步骤 3)中的“自动检测语言”复选框。

    • 如果你的 2007 Microsoft Office 系统 版本不提供你要键入的语言的校对工具(例如拼写检查器),则可能需要语言包。有关详细信息,请参阅我是否需要语言包或语言界面包?

另请参阅

注释: 

  • 机器翻译免责声明:本文是由无人工介入的计算机系统翻译的。Microsoft 提供机器翻译是为了帮助非英语国家/地区用户方便阅读有关 Microsoft 产品、服务和技术的内容。由于机器翻译的原因,本文可能包含词汇、语法或文法方面的错误。

  • 请在 此处 中查找本文的英文版本以便参考。你和 Microsoft 社区的其他成员可以使用 Community Translation Framework (CTF) 来改进本文。只需将鼠标悬停在文章中的句子上,然后在 CTF 小组件中单击“IMPROVE TRANSLATION”即可。 单击此处了解有关 CTF 的详细信息。 使用 CTF 即表示你同意服务条款

扩展你的技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×