以表单形式插入数据视图

重要:  本文是由机器翻译的,请参阅免责声明。请在 此处 中查找本文的英文版本以便参考。

表单是您要从用户处收集数据的任何 Microsoft SharePoint Web 应用程序的重要部分。数据视图构建 ASP.NET 窗体技术,以便您可以插入它们的数据的只读视图或窗体可以在其中用户编写返回到数据源使用浏览器。使用Microsoft Office SharePoint Designer 2007,您可以快速插入数据视图作为窗体,以便用户可以进行并将更改保存到这些类型的数据源: 列表、 库、 数据库连接和本地 XML 文件。请注意,以表单形式插入的数据视图,可与这些类型的数据源。

本文介绍了如何插入数据视图作为窗体。此外,本文向您介绍如何创建要用作数据源,以便您可以按照以及示例的示例 XML 文件。

重要: 本文讨论在 SharePoint 网站上运行Windows SharePoint Services 3.0的服务器中创建数据视图。此功能不可用,如果您的网站不运行Windows SharePoint Services 3.0的服务器上。

本文内容

开始之前

为什么以表单形式插入数据视图?

创建一个.xml 文件作为示例数据源

以表单形式插入数据视图

使用浏览器中编辑数据

建议的后续步骤

开始之前

Office SharePoint Designer 2007具有两个不同的功能使用户能够使用浏览器中编辑数据视图中的数据:

  • 插入数据视图作为窗体    当您创建数据视图时,您可以选择将其作为单个项目或多项目窗体插入。窗体始终处于编辑模式,并显示一条记录,或许多。用户可以修改数据并插入新记录,通过浏览器中,但他们不能删除记录。当用户需要快速一次编辑多条记录中的数据时,您可能需要多项目窗体。

  • 将链接添加到现有的数据视图    您可以添加到现有的数据视图的链接,以便用户可以编辑,删除或插入的数据源中的记录。用户单击记录以将该项目放在编辑模式下的编辑链接。如果将链接添加到数据视图以表单形式插入的链接替换表单按钮。此外,如果将链接添加到以表单形式插入数据视图中,数据视图中将不再显示窗体字段默认设置。在视图中,它将仅显示数据。有关详细信息,请参阅文章编辑、 删除或插入数据视图中的记录

插入数据视图作为窗体后,您可以筛选、 排序,请和对数据进行分组,应用条件格式,或创建公式列。如果用户对数据进行更改,然后保存这些更改,任何筛选、 排序顺序、 条件格式或公式列应用自动反映了更新后的数据。您还可以保存或默认显示在窗体的取消按钮添加内置表单操作。在另请参阅部分中,您可以找到有关内置表单操作的详细信息的链接。

返回页首

为什么以表单形式插入数据视图?

数据视图是数据源的可自定义视图。您可以插入 ASPX 页视图或窗体作为数据视图。为视图插入的数据视图允许您要设置格式的数据,演示文稿,但不是能编辑数据本身。

但是,如果插入相同的数据视图作为窗体,您可以编辑的数据,通过浏览器和所做的更改写回,并将其存储在原始数据源。使用Office SharePoint Designer 2007,您可以快速创建一个三种类型的窗体从现有数据源:

  • 单项目窗体显示一条记录以表单形式 — 与在其自己的行中,每个字段以及用作行标题的字段名称,以便您可以编辑一次一条记录中的数据。窗体提供了您可以单击以查看下一步或上一记录的导航链接。

    以单记录表单形式插入的数据视图

  • 多项目窗体以表单形式显示多个记录,与在其自己的列中的每个字段以及为列标题的字段名称 —,以便您可以快速编辑多条记录中的数据,然后同时保存所做的更改。

    以多记录表单形式插入的数据视图

  • 新项目窗体显示为单个记录的空白字段 — 与在其自己的行中,每个字段以及用作行标题的字段名称 —,以便您可以添加到数据的数据源一次一条记录。您可能想要包括的记录的所有相关字段,以便可以同时保存所有数据。

    为以表单形式插入的数据视图新建项目表单

可以为 SharePoint 列表、 库、 数据库连接和本地 XML 文档创建数据视图作为窗体插入。插入数据视图时, Office SharePoint Designer 2007将可扩展标记语言 (XML) 形式的数据源检索数据,并使用可扩展样式表语言转换 (XSLT) 来显示该数据。使用任何数据视图中,您可以通过使用Office SharePoint Designer 2007修改窗体。

数据视图插入您的页面后,您也可以在Office SharePoint Designer 2007使用所见即所得工具添加或删除列、 更改字体格式,或将颜色应用。在使用Office SharePoint Designer 2007中可用的所见即所得工具设置格式的数据视图中时可扩展样式表语言 (XSL) 直接插入 HTML。可以编辑的 XSL 直接在代码视图中时,您还可以使用格式设置工具, Office SharePoint Designer 2007快速应用 XSL 中轻松地不知道 XSL。

返回页首

创建一个.xml 文件作为示例数据源

罗斯文商贸,gourmet 食品分布公司,跟踪其库存 XML 文件中。低库存时,工作组成员的该产品呼叫供应商和订单。建议他们为窗体中插入数据视图,以便份订单的团队成员可以立即更新订购量。该方法罗斯文商贸将始终拥有最新信息在其当前库存。

下面的过程要求使用.xml 文件作为数据源。如果您没有.xml 文件中您的 SharePoint 网站,必须首先创建罗斯文商贸产品列表。创建列表后,您可以插入数据视图作为窗体以更新列表中包含的数据。

创建视图

  1. 文件菜单上,单击打开网站

  2. 打开网站对话框中,浏览到并选择您的 SharePoint 网站,然后单击打开

  3. 如果出现提示,请在连接到对话框中,键入您的用户名和密码,,然后单击确定

  4. “文件”菜单上,单击“新建”

  5. 新建对话框中,在页面选项卡上,单击在左侧窗格中的常规,然后双击右侧的下一个窗格中的文本文件

    在您的网站中将打开一个新的文本文件。

  6. 通过选择它们,然后按 CTRL + C 复制下面的代码行。

    <?xml version="1.0" encoding="utf-8"?>
    <ProductsRoot>
    <Products>
    <ProductID>1</ProductID>
    <ProductName>Chai</ProductName>
    <SupplierID>1</SupplierID>
    <CategoryID>1</CategoryID>
    <QuantityPerUnit>10 boxes x 20 bags</QuantityPerUnit>
    <UnitPrice>18</UnitPrice>
    <UnitsInStock>39</UnitsInStock>
    <UnitsOnOrder>0</UnitsOnOrder>
    <ReorderLevel>10</ReorderLevel>
    <Discontinued>0</Discontinued>
    </Products>
    <Products>
    <ProductID>2</ProductID>
    <ProductName>Chang</ProductName>
    <SupplierID>1</SupplierID>
    <CategoryID>1</CategoryID>
    <QuantityPerUnit>24 - 12 oz bottles</QuantityPerUnit>
    <UnitPrice>19</UnitPrice>
    <UnitsInStock>17</UnitsInStock>
    <UnitsOnOrder>40</UnitsOnOrder>
    <ReorderLevel>25</ReorderLevel>
    <Discontinued>0</Discontinued>
    </Products>
    <Products>
    <ProductID>3</ProductID>
    <ProductName>Aniseed Syrup</ProductName>
    <SupplierID>1</SupplierID>
    <CategoryID>2</CategoryID>
    <QuantityPerUnit>12 - 550 ml bottles</QuantityPerUnit>
    <UnitPrice>10</UnitPrice>
    <UnitsInStock>13</UnitsInStock>
    <UnitsOnOrder>70</UnitsOnOrder>
    <ReorderLevel>25</ReorderLevel>
    <Discontinued>0</Discontinued>
    </Products>
    <Products>
    <ProductID>4</ProductID>
    <ProductName>Chef Anton's Cajun Seasoning</ProductName>
    <SupplierID>2</SupplierID>
    <CategoryID>2</CategoryID>
    <QuantityPerUnit>48 - 6 oz jars</QuantityPerUnit>
    <UnitPrice>22</UnitPrice>
    <UnitsInStock>53</UnitsInStock>
    <UnitsOnOrder>0</UnitsOnOrder>
    <ReorderLevel>0</ReorderLevel>
    <Discontinued>0</Discontinued>
    </Products>
    <Products>
    <ProductID>5</ProductID>
    <ProductName>Chef Anton's Gumbo Mix</ProductName>
    <SupplierID>2</SupplierID>
    <CategoryID>2</CategoryID>
    <QuantityPerUnit>36 boxes</QuantityPerUnit>
    <UnitPrice>21.35</UnitPrice>
    <UnitsInStock>0</UnitsInStock>
    <UnitsOnOrder>0</UnitsOnOrder>
    <ReorderLevel>0</ReorderLevel>
    <Discontinued>1</Discontinued>
    </Products>
    </ProductsRoot>
  7. 在Office SharePoint Designer 2007,将光标放在页面顶部的,然后按 CTRL + V 粘贴您刚刚复制拖动到页面的代码。

  8. “文件”菜单上,单击“另存为”

  9. 另存为对话框中,在文件名框中,键入视图

  10. 保存类型列表中,单击XML,,然后单击保存

返回页首

以表单形式插入数据视图

当您通过使用数据源详细信息任务窗格以表单形式插入数据视图时,您首先将数据视图插入页。然后选择在数据源库任务窗格管理 SharePoint 网站的可用数据源的数据源。选择数据源后,数据源详细信息任务窗格随即打开。在数据源详细信息任务窗格中,选择您想要显示,然后将其插入数据视图中的字段。

数据表单基于 ASP.NET 2.0 技术。若要创建数据视图,您必须从开始 ASP.NET 页 (.aspx 文件)。在此示例中,将创建一个新的 ASP.NET 页,然后使用数据源详细信息任务窗格以表单形式插入数据视图。

  1. “文件”菜单上,单击“新建”

  2. 新建对话框中,在页面选项卡上,单击常规,然后双击ASPX

    打开窗体标记的新页面。

    ASP.NET form 标记

  3. 数据视图菜单上,单击插入数据视图

    在页面上,现在显示空数据视图和数据源库任务窗格随即打开。

    空数据视图

    既然您已插入数据视图中,您就可以添加数据。

  4. 数据源库任务窗格中,找到您的数据源,单击它,,然后单击显示数据

    在示例中,在XML 文件,下单击视图,,然后单击显示数据。如果XML 文件标题折叠,请单击加号 (+) 以将其展开。

  5. 数据源详细信息任务窗格中,单击要插入数据视图中的字段。

    提示: 若要选择多个字段,请在按住 CTRL 的同时单击它们。

    在示例中,在ProductsRoot文件夹中,在产品下单击ProductName。按下并按住 CTRL 的同时单击库存UnitsOnOrder,然后再订购量

    在“数据源详细信息”任务窗格中选定的域

  6. 单击插入为选定的域,然后单击多项目窗体以将所选的数据插入数据视图作为窗体。

    注意: 单项目窗体作为窗体的一次显示一条记录。多项目窗体显示多个记录,具有其自己的列和字段名称的列标题中的每个字段。

    您现在在数据源详细信息任务窗格中选择的字段将显示在窗体中。

    注意: 此示例使用.xml 文件,因为数据视图中的每个字段是可编辑。但是,具体取决于数据源的类型,则可能某些字段可能不能编辑。例如,如果您的数据源是 SharePoint 列表并选择要包括在窗体字段为创建者或修改者的此类系统,这些字段不是可编辑。

    选择的数据显示为表单

    插入数据视图作为窗体后,您可以使用所见即所得工具,如格式工具栏修改字体、 对齐的文本,或将颜色应用。应用到数据视图中的数据点的新格式时, Office SharePoint Designer 2007将格式应用于所有 XML 中同一级别的数据通过修改 XSLT 样式表附加到该页上。例如,在上图中,如果您选择德威,然后单击格式工具栏上的加粗Office SharePoint Designer 2007同一格式应用于所有产品名称字段中显示的内容。

    同一格式应用于同一级上的所有数据

  7. 文件菜单上,单击另存为。在另存为对话框中,在文件名框中,键入您的文件的名称,然后单击保存

返回页首

使用浏览器中编辑数据

保存包含窗体的页面后,您可以在浏览器中预览和修改窗体中的数据。

字段类型和数据输入

此示例使用 XML 文件用作数据源。XML 文件是纯文本文件,因为不能指定的单个字段必须包含的值的类型。例如,没有要防止输入并在字段中保存文本应包含数字,如 UnitsOnOrder。

但是,如果您的数据源是 SQL 数据源,如 SQL 数据库或 SharePoint 列表或库,可能本身的数据源中指定的字段类型。这种情况下,如果您使用窗体需要数字,然后单击保存字段中输入文本出现一条错误消息解释的数据源控件未能执行更新命令的浏览器中。这意味着您不能接受的数据源字段的窗体中输入值。如果您收到这样一条错误消息,在浏览器中,单击后退然后单击取消放弃所做的更改的窗体或可接受的数据源的窗体字段中输入值。

因此,当设计窗体中Office SharePoint Designer 2007,您可能想要时字段需要特定类型的输入列标题中包含文本。

在浏览器中使用窗体

  1. 在Office SharePoint Designer 2007,在文件菜单中,单击在浏览器中的预览,然后单击浏览器类型和要使用的大小。

    键盘快捷方式单击您想要在文件夹列表中,预览的页面,然后按 F12。

    在浏览器中显示的窗体的页面。

    浏览器中显示的多记录表单

  2. 现在,您可以修改任何窗体字段在数据视图中显示的信息。您也可以更改同时在多条记录中的多个字段中的信息。当您完成修改数据表单中的时,单击保存以提交到数据源的更改,或单击取消放弃更改。

    要关注的示例中,在产品名称列中,包含字词字段中德威,将光标放在单词末尾德威一次,按空格键,然后键入茶专注。在订购量列中,在德威记录中,键入40。在订购量列中,在厨师 Anton Cajun Seasoning 记录中,键入35,然后再单击保存。在浏览器中显示已更新的记录的表单。

    显示更新记录后的数据表单

返回页首

建议的后续步骤

数据视图是强大、 完全可自定义的数据的实时视图。既然您已经学习了如何插入数据视图作为窗体时,您可能希望了解操作方法:

  • 在数据视图中筛选数据   您可以轻松地筛选数据视图中的数据,以便显示的数据完全您想要查看的数据。有关详细信息,请参阅在数据视图中筛选数据

  • 排序数据视图中的对数据进行分组和   可以快速排序或分组数据视图中的数据。例如,您可以轻松地进行排序按字母顺序列表。有关详细信息,请参阅排序数据视图中的对数据进行分组和

  • 向数据视图应用条件格式   您可以应用特定格式向数据视图时数据视图中的数据符合特定条件。有关详细信息,请参阅向数据视图应用条件格式

  • 创建数据视图中的公式栏   您可以创建计算的列的数据视图中显示的数据的计算结果。例如,可以乘以单价的库存单位数,并在单独的列中显示项目的总计值。有关详细信息,请参阅创建数据视图中的公式栏

  • 数据视图中修改列   您可以轻松地添加、 删除或重新排列数据视图中的列。有关详细信息,请参阅修改数据视图中的列

  • 数据视图中显示示例数据   数据视图中,您可以轻松地显示示例数据。

返回页首

注意: 机器翻译免责声明:本文是由无人工介入的计算机系统翻译的。Microsoft 提供机器翻译是为了帮助非英语国家/地区用户方便阅读有关 Microsoft 产品、服务和技术的内容。由于机器翻译的原因,本文可能包含词汇、语法或文法方面的错误。

扩展你的技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×