从 Excel 2007 工作表数据创建 Visio 2007 数据透视关系图

注意: 我们希望能够尽快以你的语言为你提供最新的帮助内容。本页面是自动翻译的,可能包含语法错误或不准确之处。我们的目的是使此内容能对你有所帮助。可以在本页面底部告诉我们此信息是否对你有帮助吗?请在此处查看本文的英文版本以便参考。

本文内容

注意: 本文已完成其工作,随后将不再使用。为防止出现“找不到页面”问题,我们将删除已知无效的链接。如果创建了指向此页面的链接,请删除这些链接,以便与我们一起为用户提供通畅的 Web 连接。

数据透视关系图就像是一种图表, 它像 Excel 数据透视表或数据透视图那样显示数据。数据透视关系图是与数据保持连接的层次结构图表 (类似于组织结构图的结构), 因此您可以在数据允许的不同配置中以直观的方式查看数据。

生成数据透视关系图

若要创建数据透视关系图, 请从 Excel 中的 "数据设置" 开始, 对于数据透视表 (列中包含一行标题和值的数据), 然后执行下列操作之一。

  • 如果 Excel 数据的格式设置为表格, 请在 "表格工具设计" 选项卡上, 单击 "导出" 选项, 然后单击 "将表格导出到 Visio 数据透视关系图"。

  • 无论 Excel 数据的格式为表格还是区域, 您也可以从 Visio 创建数据透视关系图。若要执行此操作, 请在 "文件" 菜单上, 依次指向 "新建" 和 "业务", 然后单击 "数据透视图"。按照向导中的步骤选择您的 Excel 文件, 如有必要, 请选择该文件中的特定工作表或区域。然后, 只需继续单击 "下一步", 直到显示 "完成" 选项。单击 "完成" 以创建您的表格。

    使用此向导创建数据透视关系图时, 源数据可能源自 Excel 工作簿、Access 数据库、Windows SharePoint Services 列表、SQL Server 数据库或另一个 OLEBD (对象链接的嵌入数据库) 或 ODBC (打开的数据库连接) 兼容的数据源。

    重要: 如果您的 Excel 文件包含其自己的工作表上的任何图表, 请使用此处提供的方法, 通过 Excel 中的 "表格工具设计" 选项卡生成数据透视关系图。或者, 在启动 Visio 数据透视关系图向导之前打开 Excel 文件。该向导无法访问包含图表工作表的 Excel 文件, 除非该文件当前处于打开状态。

使用上述两种方法中的任何一种, 都将生成 "数据透视关系图" 页, 其中包含一个形状, 用于指定图表的顶层和一个标识源数据、上次更新以及就地的任何筛选器的形状, 如下图所示。

Visio 2007 中“数据透视图”页面上的形状

请注意, 数据透视图窗格中的所有可用字段都在 "数据透视关系图" 窗格中提供, 划分为多个类别 (相当于数据透视表中的行字段或列字段) 和总计 (相当于数据透视表中的值字段)。

返回页首

设置数据透视关系图的格式和管理

只需单击即可将类别从 "数据透视关系图" 窗格应用到页面, Visio 将生成适用的形状。此外, 在窗格中, 选择要显示在每个形状中的总和。在下面的示例中, 按业务区域显示每个人的培训成本。

显示培训成本的数据透视图,按业务范围细分

以下是帮助你创建所需的数据透视关系图的一些关键提示。

  • 上面的数据透视关系图示例中的总和列为每个人的成本, 因为这是 Excel 数据中适用的列标题的名称。但是, 因为在这种情况下, 你实际显示的是部门的总培训成本, 所以你可能需要更改字段名称。若要更改任何类别或汇总字段的名称, 使其在图表中显示, 请单击当您指向 "数据透视关系图" 窗格中的字段时显示的箭头, 然后单击 "配置列"。根据需要编辑名称, 然后单击"确定"。字段名称将在整个表中自动更改。

  • 若要进一步分解类别, 请选择表示要拆分的类别的形状, 然后单击要查看其详细信息的类别。例如, 若要显示业务开发部门中每个人的成本, 请选择包含该总计的业务开发形状, 然后单击 "数据透视关系图" 窗格中的 "名称"。结果如下所示。

    显示培训成本的数据透视图,按业务开发员工细分

    由于你可以显示单个形状的详细信息, 因此当你想要为所有形状添加新子类别时, 必须选择类别中的所有形状。请确保选择包含总和的形状的一部分, 而不是形状标题。若要快速选择类别中的所有形状, 请在 "数据透视关系图" 窗格中指向类别名称, 单击出现的下拉箭头, 然后单击 "全选"。

  • 您可以像处理 Visio 图表中的任何形状一样对形状进行格式设置和调整大小。若要同时调整多个形状的大小, 请选择要调整其大小的所有形状, 然后从所选区域周围的图柄拖动以将其调整为一个组。

  • 若要更改汇总的编号格式, 请在 "数据透视关系图" 菜单上, 单击 "编辑数据图形"。或者, 在 "数据透视关系图" 窗格中, 单击 "其他操作", 然后单击 "编辑数据图形"。然后, 请执行下列操作:

    1. 选择包含要更改其格式的字段名称的数据图形, 然后单击 "编辑项目"。

    2. 在 "值格式" 字段中, 单击省略号以打开 "数据格式" 对话框, 您可以在其中指定所需的数字格式。

  • 数据透视关系图中包含类别中每个形状的总和的形状称为透视节点。通过使用 "数据透视关系图" 菜单或窗格上的 "应用形状" 选项, 可将更有趣的形状应用于透视节点。只需选择要对其应用形状的数据透视节点, 然后在 "应用形状" 对话框中, 单击某个形状, 然后单击"确定"。"部门工作流对象" 模具中的形状可通过此对话框自动使用。

    若要使您的数据透视关系图可使用其他形状, 请在 "文件" 菜单上, 指向 "形状", 然后选择所需的模具。打开新模具后, 它将在 "应用形状" 对话框中的模具下拉列表中可用

  • 若要访问图表中任意字段的筛选选项, 请单击指向 "数据透视关系图" 窗格中的某个字段时显示的箭头, 然后单击 "配置列"。

  • 从 "数据透视关系图" 菜单中, 您可以管理图表布局, 在图表中对所选形状进行排序, 将所选形状合并到一个形状中 (当您想要在一个图表中分解多个类别时, 这可能是一种很好的方式来节省空间), 并将数据透视关系图的各种选项。

    使用 "数据透视关系图" 菜单中提供的 "数据透视关系图选项" 对话框, 更改表的名称, 选择显示或隐藏图表元素, 并修改数据源, 如下面的图像所示。

    Visio 2007 中的“数据透视图选项”对话框

返回页首

如何在数据透视关系图中编辑已应用形状的屏幕提示?

如果将形状应用于透视节点, 如前面的列表中所述, 您可能希望更改指向该形状时显示的屏幕提示。但是, 如果您选择了形状, 然后单击 "插入" 菜单, 并希望找到 "编辑形状屏幕提示" 选项, 您可能会看到 "选项形状屏幕提示"。后一个选项表示当前没有为所选内容存在屏幕提示。

您看不到 "编辑" 选项的原因是, 您的选择实际上是一组形状。应用的形状将自动与 Pivot 节点组合。若要编辑已应用形状的现有屏幕提示, 请在应用的形状上单击一次 (这将选择组), 然后单击第二次 (这比双击慢) 以只选择组内所应用的形状。选中形状本身后, 您将看到每个形状图柄中的x 。只要选择形状, 单击 "插入" 菜单, "编辑形状屏幕提示" 选项将可用。

感谢您的技术支持工程师 Jagadeesh Parameswaran, 这是一项 Visio 2007 测试团队的 intrepid 成员, 本章还有其他几个提示。

返回页首

扩展你的 Office 技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×