从 Excel、SQL Server、SharePoint 网站和其他外部源导入数据

注意: 我们希望能够尽快以你的语言为你提供最新的帮助内容。本页面是自动翻译的,可能包含语法错误或不准确之处。我们的目的是使此内容能对你有所帮助。可以在本页面底部告诉我们此信息是否对你有帮助吗?请在此处查看本文的英文版本以便参考。

可以快速导入和使用Microsoft Office Visio 专业版 2007直接在您的形状上显示的数据。第一步是连接到数据源,并将数据导入您的绘图。第二步是将导入的数据链接到形状。

本文内容

步骤 1: 导入数据

步骤 2: 将数据行链接到绘图中的形状

步骤 1: 导入数据

在第一个步骤中,您可以使用数据选取器向导将数据导入到外部数据窗口。

外部数据窗口中显示的数据是次导入的源数据的快照。您可以更新以匹配您的源数据中的更改绘图中的数据。但是,您无法通过更改绘图中的数据刷新数据源。请参阅刷新导入的数据

  1. “数据”菜单上,单击“将数据链接到形状”

  2. 在“数据选取器向导”的第一页上,选择要使用下面哪些类型的数据源:

    • Microsoft Office Excel 工作簿

    • Microsoft Office Access 数据库

    • Microsoft Windows SharePoint Services 列表

    • Microsoft SQL Server 数据库

    • 其他 OLEDB 或 ODBC 数据源

    • 以前创建的连接

  3. 完成向导的剩余步骤。

    注意: 如果在向导的第一页上选择的选项不是 Excel 工作簿、Access 数据库或 SharePoint 列表,则在完成“数据选取器向导”的过程中,您可能会被临时转移到“数据连接向导”中。

    对大多数向导页提供了具体的帮助。要访问帮助,请按 F1 或单击帮助按钮。

在数据连接向导的最后一页上单击完成后,外部数据窗口将显示导入数据将显示在网格中。

返回页首

步骤 2: 将数据行链接到绘图中的形状

有三种方法可将数据行链接到绘图中的形状:您可以将行链接到现有形状(每次一行)、可以自动将行链接到形状,还可以根据数据创建形状。

将行链接到现有形状(每次一行)

这种方法是最适合形状相对较少的现有绘图。

  • “外部数据”窗口中将一行拖到绘图中的某一形状上。

    数据将显示在该形状中,而且在“外部数据”窗口中,在该行的左侧会出现一个链接图标。

    将行拖到形状上

    注意: 

    • 您可以将单个行链接到多个形状,但不能将多个行链接到单个形状。

    • 若要更改或增强的形状和数据的外观,请参阅使用数据图形增强数据

    • 要显示“外部数据”窗口,请在“视图”菜单上,单击“外部数据窗口”

自动将行链接到现有形状

这种方法是最适合使用大量的形状的现有绘图。这只有形状具有数据已在它们,您可以与数据源中的数据。

  1. “数据”菜单上,单击“自动链接”

  2. 按照“自动链接向导”中的步骤操作。

    您的数据将显示在您的形状。若要更改或增强的形状和数据的外观,请参阅使用数据图形增强数据

对大多数向导页提供了具体的帮助。若要访问帮助,请按 F1 或单击“帮助”图标。

根据数据创建形状

如果您绘图尚不具有形状,并且您不需要使用特定形状,这种方法是最佳。

  1. 单击“形状”窗口中的某一形状。

  2. “外部数据”窗口中将某一行或一组行拖到绘图的空白区域上。

    单击该形状的一个实例显示拖动到绘图上的每一行。

返回页首

扩展你的 Office 技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×