从 Excel、Access、SharePoint 网站、SQL Server 和其他外部源导入数据

注意: 我们希望能够尽快以你的语言为你提供最新的帮助内容。 本页面是自动翻译的,可能包含语法错误或不准确之处。 我们的目的是使此内容能对你有所帮助。 可以在本页面底部告诉我们此信息是否对你有帮助吗? 请在此处查看本文的英文版本以便参考。

在 Visio 中, 您可以直接在形状上快速导入和显示数据。 第一步是连接到数据源并将数据导入到绘图中。 第二步是将导入的数据链接到形状。

步骤 1: 导入数据

在此第一步中, 使用数据选取器向导导入数据。

显示在 "外部数据" 窗口中的数据是导入时源数据的快照。 可以更新绘图中的数据, 以匹配源数据中的更改。 但是, 不能通过更改绘图中的数据来刷新数据源。 请参阅刷新导入的数据

  1. “数据”选项卡上的“外部数据”组中,单击“将数据链接到形状”

  2. 在 "数据选取器向导" 的第一页上, 选择要使用以下哪些类型的数据源:

    • Microsoft Excel 工作簿

    • Microsoft Access 数据库

    • Microsoft SharePoint Foundation 列表

    • Microsoft SQL Server 数据库

    • 其他 OLEDB 或 ODBC 数据源

    • 以前创建的连接

  3. 完成向导的其余部分。

    注意: 如果在向导第一页上选择了 "Excel 工作簿"、"Access 数据库" 或 "SharePoint 列表" 以外的选项, 则在完成 "数据选取器向导" 过程中可能会暂时转移到 "数据连接向导"。

在 "数据连接向导" 的最后一页上单击 "完成" 后, 将显示 "外部数据" 窗口, 其中显示了一个网格中显示的导入数据。

步骤 2: 将数据行链接到绘图中的形状

有三种方法可将数据行链接到绘图中的形状: 您可以一次将行链接到现有形状, 也可以将这些行自动链接到形状, 也可以从数据创建形状。

方法 1: 将行链接到现有形状一次一个

此方法最适用于具有相对较少的形状的现有绘图。

  • 将行从 "外部数据" 窗口拖到绘图中的形状上。

    注意: 如果看不到 "外部数据" 窗口, 请转到 "数据" 选项卡, 然后在 "显示/隐藏" 组中, 选择 "外部数据" 窗口旁边的复选框。

    你的数据将显示在形状中, 并且 "外部数据" 窗口中的行左侧将显示 "链接" 图标。

    将行拖到形状上

    注意: 

    • 你可以将单个行链接到多个形状, 但不能将多个行链接到单个形状。

    • 若要更改或增强形状和数据的外观, 请参阅利用数据图形增强数据

    • 若要显示 "外部数据" 窗口, 请在 "视图" 菜单上, 单击 "外部数据窗口"。

方法 2: 自动将行链接到现有形状

此方法最适用于具有大量形状的现有绘图。 只有当形状中已有数据可以与数据源中的数据相匹配时, 此操作才有效。

  1. 在Visio 2016 和较新版本中: 在 "数据" 菜单上, 单击 "全部刷新", 然后选择 "刷新后自动链接" (如果尚未选中)。

    在Visio 2013 和早期版本中: 在 "数据" 菜单上, 单击 "自动链接"。

  2. 按照 "自动链接向导" 中的步骤操作。

    你的数据将显示在你的形状中。 若要更改或增强形状和数据的外观, 请参阅利用数据图形增强数据

方法 3: 从数据创建形状

如果你的绘图尚未有形状, 并且无需使用特定形状, 则此方法最佳。

  1. 单击 "形状" 窗格中的形状。

  2. 将一行或 "外部数据" 窗口中的一组行拖动到绘图中的空白区域。

    你单击的形状的一个实例将针对你拖到绘图中的每一行显示。

扩展你的 Office 技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×