从 SharePoint 列表创建 Access 窗体和报表

重要:  本文是由机器翻译的,请参阅免责声明。请在 此处 中查找本文的英文版本以便参考。

您可以从 SharePoint 列表创建窗体和报表,并将其用作视图。已安装的 Access 2007 的 SharePoint 网站的用户可以通过使用 SharePoint 列表视图菜单打开这些窗体和报表。您可以将视图的列表的默认视图的访问。

通过使用Access 2007创建的视图存储在Windows SharePoint Services服务器上的数据库文件。当打开 Access 视图的 SharePoint 列表中,Access 会启动,并且它将显示窗体或报表。因为数据库存储在 SharePoint 网站上,可以由其他网站的用户打开视图。用户不需要知道上的 SharePoint 网站,才能使用视图中包含 Access 视图的数据库文件的位置。此外,用户甚至不必不知道如何启动 Access,这通过 SharePoint 网站自动处理。

注意: 用户需要在其计算机上安装 Access 2007 才能在 SharePoint 网站上创建、使用或修改 Access 视图。

您要做什么?

创建 SharePoint 列表的 Access 视图

请查看 SharePoint 列表的默认视图的访问

使用 SharePoint 列表的 Access 视图

修改 SharePoint 列表的 Access 视图

创建 SharePoint 列表的 Access 视图

创建 SharePoint 列表的 Access 视图时,Access 会自动启动。在 Access 中,可以根据各种窗体和报表模板来创建视图,然后可以自定义视图。通过在 SharePoint 网站上发布视图,可以轻松地使其可供其他用户使用。

注意: 要创建 SharePoint 列表的视图,您需要具有 Windows SharePoint Services 的“管理列表”权限,此权限默认情况下包含在“设计”权限级别中。

按照以下步骤创建在浏览器中查看的 SharePoint 列表的 Access 视图。

  1. 在 SharePoint 网站上,在“视图”菜单 下拉菜单 上单击“创建视图”

  2. “创建视图”页上,单击“Access 视图”

    此时 Access 会启动,然后提示您保存将包含新视图的数据库的本地副本。

  3. “保存本地副本”对话框中,浏览到计算机上您想保存此副本的位置,在“文件名”框中键入本地副本的名称,然后单击“保存”

    Access 保存并打开本地副本,然后“创建 Access 视图”对话框将会出现。

  4. “创建 Access 视图”对话框中,双击您想创建的视图类型。

    Access 创建新视图,并在“布局”视图下打开它。

  5. 可以在“布局”视图下自定义新视图,也可以切换到“设计”视图。

    在“布局”视图中,可以对视图中的控件(例如标签和字段)执行调整大小和重排操作,但无法向视图添加其他控件。“布局”视图提供了数据预览,使您能够更轻松地看到所做的更改在完成的视图中如何显示。

    在“设计”视图中,可以对控件执行调整大小和重排操作,也可以向视图添加其他控件。但是,“设计”视图未提供数据预览。

    可以在“设计”视图和“布局”视图之间随意切换。如果使用“设计”视图向视图添加控件,则之后可以切换到“布局”视图,然后在预览数据的同时在视图上排列这些控件。

  6. 进行了自定义之后,在“消息栏”上单击“发布到 SharePoint 网站”

    工具栏

    此时会出现“发布到 Web 服务器”对话框。

    如果“消息栏”未出现,则通过执行以下操作显示它:

    • “数据库工具”选项卡上的“显示/隐藏”组中,单击“消息栏”

  7. 默认情况下,Access 将视图保存在数据库文件中,而此文件位于 SharePoint 网站上的“共享文档”库中 — 该网站包含您从中创建了视图的列表。在大多数情况下,这可能是您想要的结果,但是,您可以在“发布到 Web 服务器”对话框中的“保存位置”框内选择另一个库,以更改用于存储数据库的文档库。通过这样做,可以更明确地控制谁能够访问视图,以及用户能够以只读模式还是编辑模式来打开视图。SharePoint 网站还可能拥有为发布 Access 视图而建立的特定库,在这种情况下,您可能要更改“保存位置”,以选择正确的库。

    SharePoint 网站的管理员可以帮助您选择正确的库。

  8. Access 在“发布到 Web 服务器”对话框的“文件名”框中为数据库提供了名称。此名称与您保存为本地副本的数据库的名称匹配。如果需要,可以更改此名称,但在大多数情况下,应接受建议的名称,以便更轻松地记住哪个本地数据库对应于您在 SharePoint 网站上发布的数据库。

  9. 单击“发布”将数据库保存到 SharePoint 网站。

返回页首

请查看 SharePoint 列表的默认视图的访问

当您进行访问的视图的 SharePoint 列表的默认视图时,Access 视图时将自动打开用户打开列表,如果这些用户有权在其计算机上安装。

重要: 如果进行了 Access 视图的默认视图,列表访问者不具有 Access 2007 安装不能用于列表。

  1. 设置菜单上,打开 SharePoint 列表中,单击列表设置

  2. 列表设置页面上,单击视图,中的您想要将设置为默认视图访问视图的名称。

  3. 编辑视图页面中,选择设为默认视图,然后单击确定

返回页首

使用 SharePoint 列表的 Access 视图

要使用 SharePoint 列表的 Access 视图,请从列表的“视图”菜单中选择 Access 视图。

  • “视图”菜单 下拉菜单 上,单击 Access 视图的名称。Access 启动,然后以只读模式显示视图。

    在只读模式下,可以更改视图中的数据和打印视图,但无法更改视图的设计。如果想更改视图的设计,请参阅本文的下一节修改 SharePoint 列表的 Access 视图

返回页首

修改 SharePoint 列表的 Access 视图

要修改 Access 视图的设计,请保存包含 Access 视图的数据库的本地副本,然后进行更改。之后,可以使用视图的本地副本;或者,如果在 SharePoint 网站上有适当的权限,则可以发布新的视图。

注意: 不管您具有什么 Windows SharePoint Services 权限级别,均可以修改 Access 视图的本地副本。但是,要将修改的视图发布到 SharePoint 网站,您需要具有 Windows SharePoint Services 的“管理列表”权限,此权限默认情况下包含在“设计”权限级别中。如果创建了 Access 视图,则您应该已具有“管理列表”权限。如果不清楚,请与 SharePoint 网站管理员联系,以确定您是否具有所需的权限。

  1. 在 Access 视图打开的情况下,在“消息栏”上单击“另存为”

    “消息栏”上的“另存为”按钮

    注意: 如果“消息栏”未出现,则通过执行以下操作显示它:

    • “数据库工具”选项卡上的“显示/隐藏”组中,单击“消息栏”

  2. 在 Access 提示您关闭视图和所有其他打开的对象时,单击“是”

    此时会出现“另存为”对话框。

  3. “保存位置”框中,指定想将本地副本保存到的位置,在“文件名”框中键入本地副本的名称,然后单击“保存”

    Access 保存数据库的本地副本,然后打开它。

  4. 请执行下列操作之一:

    • 要更改视图的布局但不添加新的控件,请在“导航窗格”中右键单击视图,然后在快捷菜单上单击“布局视图”

      在“布局”视图中,可以对视图中的控件(例如标签和字段)执行调整大小和重排操作,但无法向视图添加其他控件。“布局”视图提供了数据预览,使您能够更轻松地看到所做的更改在完成的视图中如何显示。

    • 要在视图中添加或删除控件(例如标签或字段),请在“导航窗格”中右键单击视图,然后在快捷菜单上单击“设计视图”

      在“设计”视图中,可以对控件执行调整大小和重排操作,也可以向视图添加其他控件。但是,“设计”视图未提供数据预览。

      注意: 如果选择在“设计”视图中编辑视图,并计划将修改的视图发布到 SharePoint 网站,则不要向视图添加任何不属于 SharePoint 列表的字段。

  5. 可以在“设计”视图和“布局”视图之间随意切换。如果使用“设计”视图向视图添加控件,则之后可以切换到“布局”视图,然后在预览数据的同时在视图上排列这些控件。

将修改的 Access 视图发布到 SharePoint 网站

修改完视图后,如果在 SharePoint 网站上具有“管理列表”权限,则可以按照以下步骤发布修改的视图。

要获得“管理列表”权限,请与 SharePoint 网站的管理员联系。

  1. 将视图保存在数据库的本地副本中。

  2. “消息栏”上,单击“发布到 SharePoint 网站”

    工具栏

    注意: 如果没有“管理列表”权限,则“消息栏”不会显示“发布到 SharePoint 网站”按钮。如果“消息栏”未出现,则通过执行以下操作显示它:

    • “数据库工具”选项卡上的“显示/隐藏”组中,单击“消息栏”

  3. “发布到 Web 服务器”对话框中,单击“发布”

返回页首

注意: 机器翻译免责声明:本文是由无人工介入的计算机系统翻译的。Microsoft 提供机器翻译是为了帮助非英语国家/地区用户方便阅读有关 Microsoft 产品、服务和技术的内容。由于机器翻译的原因,本文可能包含词汇、语法或文法方面的错误。

扩展你的技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×