从 Excel 2007 工作表数据创建 Visio 2007 数据透视关系图

重要:  本文是由机器翻译的,请参阅免责声明。请在 此处 中查找本文的英文版本以便参考。

《Advanced Microsoft Office Documents 2007 Edition Inside Out》的书籍封面

高级的 Microsoft® Office 文档 2007年版内向外
通过张 Krieger

张 Krieger是 Microsoft Office System MVP 以及作者的书籍高级 Microsoft Office Documents 2007 Edition Inside OutMicrosoft Office 文档设计器。作为专业文档顾问,她帮助许多 Microsoft office 开发企业解决方案的全局公司并告诉大量专业人员以了解如何 Office 程序"认为。"构建精美的文档张定期写的多个 Microsoft 网页,并经常提供了 Microsoft Office 网络广播。

若要了解有关 2007 Microsoft Office system 中的其他书籍的详细信息,请访问Microsoft 出版

本文内容

生成数据透视关系图

格式设置和管理数据透视关系图

如何可以编辑数据透视关系图中的某个应用形状屏幕的提示?

这是一个 2007 Office 发布版我十大常用功能。数据透视关系图是什么它听起来就像-仅显示数据的图表喜欢的 Excel 数据透视表或数据透视图。数据透视关系图是 (类似于结构的组织结构图) 保持连接到数据的分层图,以便您可以自行查看直观地中为许多不同配置为允许您的数据的数据。

生成数据透视关系图

若要创建您的数据透视关系图从数据透视表 (列标题的单个行中的数据) 和中的所有单元格的值与 Excel 中的数据设置开始,然后执行下列操作之一。

  • 如果 Excel 数据的格式设置为表中,在表格工具设计选项卡上,单击导出选项,然后单击将表导出为 Visio 数据透视关系图

  • 是否 Excel 数据的格式设置为表格或区域,您可以从 Visio 创建您的数据透视关系图。要执行此操作,请在文件菜单上,指向新建业务,指向,然后单击数据透视关系图。按照向导以选择您的 Excel 文件,如有必要,选择特定的工作表或区域中该文件。然后,只需继续单击下一步,直到显示完成选项。单击完成以创建您的表。

    当您创建数据透视关系图,使用此向导时,源数据可以作为 Excel 工作簿、 Access 数据库、 Windows SharePoint Services 列表、 SQL Server 数据库,或另一个中 OLEBD (对象链接的嵌入数据库) 或 ODBC (开放式数据库连接) 兼容的数据源。

    重要: 如果您的 Excel 文件包含其自己的工作表上的任何图表,使用此处提供以从 Excel 中的表格工具设计选项卡生成数据透视关系图的方法。或者,在启动 Visio 数据透视关系图向导之前打开的 Excel 文件。该向导将无法访问包含的图表工作表,除非文件位于当前打开的 Excel 文件。

使用上述方法之一,数据透视关系图页面会生成单个形状,以指定该图表的最上层级别和形状识别的源数据、 最后一个更新和位置中的任何筛选器下图中所示。

Visio 2007 中“数据透视图”页面上的形状

请注意,中的数据透视关系图窗格中,提供了所有可用字段的数据透视关系图划分为类别 (相当于数据透视表中的行或列字段) 和汇总 (相当于数据透视表中的数值字段)。

返回页首

格式设置和管理数据透视关系图

只需单击要从数据透视关系图窗格中的类别应用于页面和 Visio 将生成适用的形状。此外窗格中,选择您要在每个形状中显示的总计。在下面的示例中,按业务范围显示每个人的培训成本。

显示培训成本的数据透视图,按业务范围细分

下面是一些关键的提示来帮助您创建所需的数据透视关系图。

  • 在数据透视关系图上例中的总被列为每个人的成本,因为这是 Excel 数据中的相应列标题的名称。但是,因为您实际上在此例中显示的部门的总培训成本,您可能想要更改的字段名称。若要更改的任何类别或汇总的字段名称,将显示在图表中,单击当您指向数据透视关系图窗格中的域,然后单击配置列时出现的箭头。根据需要编辑的名称,然后单击确定。字段名称将自动更改整个表内。

  • 准备好进一步的类别,请选择表示您想要中断,然后单击您要查看详细信息的类别的类别的形状。例如,若要显示的业务开发部门的每个人的成本,选择包含汇总的业务发展形状,然后单击数据透视关系图窗格中的名称。结果如下所示。

    显示培训成本的数据透视图,按业务开发员工细分

    可以显示单个形状的明细数据,因为您必须在类别中选择所有形状,当您想要添加的所有新的子类别。请务必选择的总计和形状标题不包含的形状的一部分。若要快速选择该类别中的所有形状,指向数据透视关系图窗格中的类别名称,单击下拉箭头显示,然后单击全都选

  • 您可以设置格式和调整形状的大小,就像 Visio 图表中的任何形状。若要同时调整多个形状的大小,请选择所有形状可调整大小,然后拖动控点以调整其作为一个组所选内容周围从。

  • 若要更改的数字格式进行汇总,在数据透视关系图菜单上,单击编辑数据图形。或者,在数据透视关系图窗格中,单击其他操作,然后单击编辑数据图形。然后,请执行下列操作 ︰

    1. 选择数据图形包含您要更改的格式,然后单击编辑项目的字段名称。

    2. 值格式字段中,单击省略号以打开数据格式对话框,您可以指定数字格式,您需要。

  • 数据透视关系图中的形状包含在类别中的每个形状的汇总称为透视节点。通过使用数据透视关系图菜单或窗格上的应用形状选项,您可以应用于数据透视节点更有趣的形状。只需选择您要应用形状,然后在应用形状对话框中的数据透视节点单击形状,然后单击确定。从部门工作流对象模具的形状是自动通过此对话框提供。

    若要为数据透视图中,在文件菜单上,提供其他形状指向形状,然后选择所需的模具。一旦打开新模具,变为可用从应用形状对话框中的模具下拉列表

  • 若要访问该图表中的任何字段的筛选选项,请单击当您指向数据透视关系图窗格中的字段,然后单击配置列时出现的箭头。

  • 数据透视关系图菜单上,可以管理图表布局、 排序图表中的所选的形状,将所选的形状合并到单个形状 (可以是您要在单独的图表中的多个类别出中断时节省空间的好方法),并设置多种选项为您的数据透视关系图。

    使用数据透视关系图选项对话框,可从数据透视关系图菜单上,若要更改的表的名称,选择要显示或隐藏图表元素和修改数据源,后面的图像中看到。

    Visio 2007 中的“数据透视图选项”对话框

返回页首

如何可以编辑数据透视关系图中的某个应用形状屏幕的提示?

如果前面的列表中所述对数据透视节点,应用形状,您可能希望更改指向形状时出现的屏幕提示。但是,如果您选择的形状,然后单击插入菜单上要查找编辑形状屏幕提示选项时,您可能会看到形状屏幕提示的选项。第二种选项表明没有屏幕提示当前存在所选内容。

看不到编辑选项的原因是您的选择是实际一组形状。使用数据透视节点自动分组应用的形状。若要编辑应用于形状的现有屏幕提示,请单击一次应用于形状 (选择组),然后单击一次 (这是双击比慢) 到仅选择组合中应用的形状。选中形状本身后,您将看到每个形状手柄内部显示x 。选中刚形状后,单击插入菜单,然后编辑形状屏幕提示选项将不可用。

到支持工程师 Jagadeesh Parameswaran intrepid Visio 2007 测试团队成员,此感谢您和其他一些提示这一章。

返回页首

注意: 机器翻译免责声明:本文是由无人工介入的计算机系统翻译的。Microsoft 提供机器翻译是为了帮助非英语国家/地区用户方便阅读有关 Microsoft 产品、服务和技术的内容。由于机器翻译的原因,本文可能包含词汇、语法或文法方面的错误。

扩展你的技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×