从工作簿中删除 XML 映射信息

注意:  我们希望能够尽快以你的语言为你提供最新的帮助内容。 本页面是自动翻译的,可能包含语法错误或不准确之处。我们的目的是使此内容能对你有所帮助。可以在本页面底部告诉我们此信息是否对你有帮助吗? 请在此处查看本文的 英文版本 以便参考。

安全说明: XML 映射及其数据源信息保存在工作簿中,而不是保存在特定的工作表中。恶意用户可使用 Visual Basic for Applications (VBA) 宏来查看这些可能敏感的映射信息。此外,如果您将工作簿保存为启用宏的 Excel Open XML 格式的文件,则可通过 Microsoft 记事本或其他文本编辑程序来查看这些映射信息。

从工作簿中删除 XML 映射的数据源定义

如果您想要继续使用映射信息,但删除可能敏感的数据源信息,那么您可以从工作簿中删除 XML 架构的数据源定义。在此情况下,您仍然可以导出 XML 数据。

此过程会永久地从 XML 映射中删除当前的数据源定义。

  1. 单击某个映射的单元格以选择您想要的 XML 映射。

  2. 如果“开发工具”选项卡不可用,请通过执行下列操作来显示该选项卡:

    1. 文件选项卡上,单击选项>自定义功能区

    2. 选择开发工具复选框。

  3. 开发工具选项卡上,单击映射属性

    “开发工具”选项卡

  4. “XML 映射属性”对话框中的“数据源”下,清除“在工作簿中保存数据源定义”复选框。

    默认情况下将选中此选项。清除此选项并不会从工作表中删除任何数据。

重要: 数据源定义包含有关导入的 XML 数据的连接信息。删除此信息可阻止他人查看该信息,但您仍然可以将映射的数据导出到 XML 文件中。不过,如果您重新导入该 XML 数据文件,数据源定义将再次随文件被保存。

从工作簿中删除 XML 映射

如果在删除 XML 映射之前删除工作表,那么有关数据源以及可能的其他敏感信息的映射信息仍将保存在工作簿中。如果您要更新工作簿以删除敏感信息,则请确保在删除工作表之前删除了 XML 映射,以便映射信息永久地从工作簿中删除。

  1. 如果“开发工具”选项卡不可用,请通过执行下列操作来显示该选项卡:

    1. 文件选项卡上,单击选项>自定义功能区

    2. 选择开发工具复选框。

  2. “开发工具”选项卡上的“XML”组中,单击“源”

    “开发工具”选项卡

  3. “XML 源”任务窗格中,单击“XML 映射”

    将显示“XML 映射”对话框。

    地图对话框

  4. 选择要删除的 XML 映射。

  5. 单击“删除”,然后单击“确定”

注意: 删除一个 XML 映射只会删除该 XML 映射本身,而不会删除该 XML 映射当前映射到的任何数据。

返回页首

从工作簿中删除 XML 映射的数据源定义

如果您想要继续使用映射信息,但删除可能敏感的数据源信息,那么您可以从工作簿中删除 XML 架构的数据源定义。在此情况下,您仍然可以导出 XML 数据。

此过程会永久地从 XML 映射中删除当前的数据源定义。

  1. 单击某个映射的单元格以选择您想要的 XML 映射。

  2. 如果“开发工具”选项卡不可用,请通过执行下列操作来显示该选项卡:

    1. 单击“Office 按钮Office 按钮图像 ,然后单击“Excel 选项”。

    2. “常用”类别中的“使用 Excel 时采用的首选项”下,选中“在功能区中显示‘开发工具’选项卡”复选框,然后单击“确定”

  3. “开发工具”选项卡上的“XML”组中,单击“映射属性”

    功能区中的 XML 组

  4. “XML 映射属性”对话框中的“数据源”下,清除“在工作簿中保存数据源定义”复选框。

    默认情况下将选中此选项。清除此选项并不会从工作表中删除任何数据。

重要: 数据源定义包含有关导入的 XML 数据的连接信息。删除此信息可阻止他人查看该信息,但您仍然可以将映射的数据导出到 XML 文件中。不过,如果您重新导入该 XML 数据文件,数据源定义将再次随文件被保存。

返回页首

从工作簿中删除 XML 映射

如果在删除 XML 映射之前删除工作表,那么有关数据源以及可能的其他敏感信息的映射信息仍将保存在工作簿中。如果您要更新工作簿以删除敏感信息,则请确保在删除工作表之前删除了 XML 映射,以便映射信息永久地从工作簿中删除。

  1. 如果“开发工具”选项卡不可用,请通过执行下列操作来显示该选项卡:

    1. 单击“Office 按钮Office 按钮图像 ,然后单击“Excel 选项”。

    2. “常用”类别中的“使用 Excel 时采用的首选项”下,选中“在功能区中显示‘开发工具’选项卡”复选框,然后单击“确定”

  2. “开发工具”选项卡上的“XML”组中,单击“源”

    功能区中的 XML 组

  3. “XML 源”任务窗格中,单击“XML 映射”

    将显示“XML 映射”对话框。

  4. 选择要删除的 XML 映射。

  5. 单击“删除”,然后单击“确定”

注意: 删除一个 XML 映射只会删除该 XML 映射本身,而不会删除该 XML 映射当前映射到的任何数据。

返回页首

需要更多帮助吗?

可随时在 Excel 技术社区中咨询专家,在解答社区获得支持,或在 Excel User Voice 上建议新功能或功能改进。

扩展你的 Office 技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×