从一个集中位置为当前数据库设置用户选项

重要:  本文是由机器翻译的,请参阅免责声明。请在 此处 中查找本文的英文版本以便参考。

若要自定义多个用户设置,例如 ︰ 对象窗口的显示方式,以启用键盘快捷方式,并启用自动更正打开当前Microsoft Access 2010数据库的选项,请在当前数据库类别中使用的选项。在客户端模式下,您可以设置从Access 2010这些选项。

客户端模式和 Web 模式下有哪些?

客户端模式   客户端模式是您使用标准的 Access 应用程序创建的模式。在此模式下,所有标准功能 (控件、 数据类型、 宏操作、 属性和等等) 都可供使用。当使用 Access 2010 打开使用早期版本的 Access 创建的数据库应用程序时,Access 2010 将在客户端模式下打开。

Web 模式   Web 模式是用于创建 Access Web 应用程序的模式。在此模式下,以便您可以只需添加的 Web 兼容功能配置窗体、 表、 查询和等等的设计环境。

注意: 若要使这些更改,必须打开您的数据库和一些设置的更改将应用只有关闭并重新打开数据库之后。

您要做什么?

自定义当前数据库的选项

选择对象窗口显示方式设置

允许使用 Access 键盘快捷方式

设置当前数据库的文件管理选项

选择当前数据库的导航选项

设置选项以跟踪和更正当前数据库中的字段名称

设置当前数据库的筛选选项

自定义当前数据库的选项

您可以快速自定义当前应用程序或数据库中的一些功能包括应用程序的名称和徽标的显示方式、 对象窗口的显示方式,以及如何管理文件。

  1. 从当前打开的数据库,请单击文件选项卡。

  2. 单击选项,然后选择设置从应用程序选项

    焦点为当前数据库选项的 Access 选项对话框

设置

说明

应用程序标题

指定要在当前数据库的窗口标题栏中显示的自定义名称。

应用程序图标

选择当前数据库的图标。键入图像文件的名称或单击浏览以定位图像文件。将选定的图标将显示在窗口的标题栏中。

用作窗体和报表图标:

选中此选项时,应用程序图标将显示在当前数据库的所有窗体和报表选项卡中。如果未启用文档选项卡,则不显示该图标。

显示窗体

指定打开当前数据库时显示的窗体。如果不希望在打开数据库时显示任何窗体,请保留默认设置“(无)”。

Web 显示窗体

当选中时,将让用户设置、 更改或删除在 Web 显示的窗体。

显示状态栏:

当选中时,将在访问工作区底部显示状态栏。

  1. 如果您更改了选项要求您关闭并重新打开数据库,并单击文件选项卡。

  2. 单击关闭数据库

  3. 若要重新打开,单击打开,然后选择数据库。

返回页首

选择对象窗口显示方式设置

在早期版本的 Access 中,在自己的窗口中打开的所有对象,然后处理多个 windows 意味着不断调整其大小。Access 2007 中包含的一系列对象窗口的顶部的选项卡中显示所有打开的对象的选项。使用此选项,它就越容易在打开的对象,通过单击所需的选项卡之间切换。您可以设置以下的显示选项,从当前数据库类别中的文档窗口选项区域。

设置

说明

重叠窗口

选中此选项时,多个打开的对象将以相互重叠的方式显示。

对象窗口以重叠视图显示的情况

选项卡式的文档

选中此选项时,即使打开了多个对象,一次也只能看到一个对象。

选中了“选项卡式文档”选项时打开的对象的显示方式图像

您可以使用选项卡式文档设置,而无需显示文档选项卡。当用户需要以一次使用一个对象,则会很有帮助。如果清除此选项,请务必包括另一个导航选项,若要允许用户切换到不同的对象。

显示文档选项卡:

如果选中“选项卡式文档”选项,则还可以选中此选项,以便显示所有打开对象的选项卡。

在窗体上使用应用了主题的 Windows 控件

选中此选项时,将对当前数据库中窗体和报表的控件使用 Windows 主题。

启用布局视图

Access 状态栏上,并显示当您右键单击对象选项卡上的快捷菜单中,选中,显示布局视图按钮。清除此选项,如果用户不能在布局视图中打开窗体和报表。

注意: 清除此选项后,布局视图将不可用作为视图组或任何快捷菜单上的选项。

为数据表视图中的表启用设计更改

选中此选项时,将允许通过“数据表”视图更改表的设计。

检查截断的数字字段

当选中时,Access 将显示为数字"# # #"列时太窄无法显示整个值。如果未选中的选项,可见的列中的值将被截尾基于什么可以容纳的列中。

图片属性存储格式

当选中时,Access 将图像存储为其原始格式。选择此选项可减小数据库大小。

将所有图片数据转换成位图(与 Access 2003 和更早的版本兼容)

当选中时,Access 将创建的 Windows 位图或设备无关的位图格式中的原始图像文件的副本。选择此选项以在 Office Access 2003 和更早版本创建的数据库中查看图像。

返回页首

允许使用 Access 键盘快捷方式

选中“使用 Access 特殊键”选项后,用户可以在当前数据库中使用以下键盘快捷方式:

结果

F11

显示或隐藏导航窗格。

Ctrl+G

在 Visual Basic 编辑器中显示立即窗口。

Alt+F11

启动 Visual Basic 编辑器。

Ctrl+Break

Access 项目时,按该组合键停止从服务器检索记录的访问。

返回页首

设置当前数据库的文件管理选项

这些文件管理设置将仅应用于的数据库时选择的选项处于打开状态。

设置

说明

关闭时压缩

当选中时,您将其关闭时自动压缩数据库。

保存时从文件属性中删除个人信息

选中此选项时,将在保存文件时自动从文件属性中删除个人信息。

返回页首

选择当前数据库的导航选项

通过以下选项,可以自定义当前应用程序的导航操作:

导航选项设置

设置

说明

显示导航窗格

如果清除此选项,则打开当前数据库时将不显示导航窗格。

导航选项

选中此选项时,可以更改导航窗格中显示的类别和组,并可设置对象在当前数据库中打开方式的选项。

功能区名称

选择自定义功能区组的名称。

快捷菜单栏:

设置或更改快捷菜单的默认菜单栏。

允许全部菜单

如果清除此复选框,则仅开始选项卡会显示功能区上。此外,当您单击文件选项卡的保存另存为命令不可用。

允许默认快捷菜单

打开或关闭右击导航窗格中的数据库对象或者窗体或报表上的控件时出现的快捷(弹出)菜单。必须关闭并重新打开当前数据库才能使指定选项生效。

返回页首

设置选项以跟踪和更正当前数据库中的字段名称

名称自动更正选项要求 Access 以跟踪和更正窗体、 报表和查询中的字段名称引用。您当前的数据库,可以设置以下选项 ︰

设置

说明

跟踪名称自动更正信息

当选中时,Access 存储更正命名错误所需的信息。可以使用对象相关性功能。但是,Access 不修复错误,直到选中执行名称自动更正选项。

执行名称自动更正

当选中时,Access 将发生修复名称错误。如果您选择跟踪名称自动更正信息选项,并将此选项保留为空,Access 存储数据的任何错误,直到您选择此选项。

记录名称自动更正的更改

Access 记录在修复名称错误时对数据库的更改。Access 将数据保存在名为 AutoCorrect.log 的表。

返回页首

设置当前数据库的筛选选项

可以通过使用“按窗体筛选”定义筛选器对窗体中显示的信息排序,并可为当前数据库选择“按窗体筛选”窗口的显示值。

此部分中的选项来控制几项功能,例如,显示为按窗体筛选窗口中给定字段的值列表的大小。您可以选择用户是否在外部文件显示值的索引或非索引字段以及链接表的选项。您也可以选择是否值列表显示在窗体控件中使用按窗体筛选时的选项。

设置

说明

局部索引字段:

选中此选项时,将在“按窗体筛选”窗口的值列表中显示局部索引字段中的值。

局部索非引字段:

“按窗体筛选”窗口的值列表中显示局部非索引字段中的值。

ODBC 字段:

显示您使用开放式数据库连链接到的表中的值。

读取的记录超过以下数目时不再显示列表

输入您希望 Access 会显示值列表筛选器的表单操作的记录中的最大的数。如果完成列表所需的记录数超过指定的数字,将不会显示值列表。所有值列表将都包含唯一值,即使未索引的字段。默认值为 1000年。

返回页首

注意: 机器翻译免责声明:本文是由无人工介入的计算机系统翻译的。Microsoft 提供机器翻译是为了帮助非英语国家/地区用户方便阅读有关 Microsoft 产品、服务和技术的内容。由于机器翻译的原因,本文可能包含词汇、语法或文法方面的错误。

扩展你的技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×