了解如何修改新数据库

重要:  本文是由机器翻译的,请参阅免责声明。请在 此处 中查找本文的英文版本以便参考。

每个模板都是随附了Microsoft Office Access 2007是一个完整的跟踪应用程序,包含预定义的表、 窗体、 报表、 查询、 宏和关系。这些模板设计要立即有用的-现成,以便您可以创建基于模板和启动并正常获取快速为新数据库。但是,有时可能要修改新数据库的时 — 例如,若要添加或重命名字段,或更改报表。

本文介绍如何执行最常见的修改,您可能希望将应用于已从模板创建的数据库。查看有关特定区域的更多深入信息的文章的链接。

你要做什么?

了解表和字段的基础知识

向表添加字段

从表中删除字段

重命名字段或表

向窗体或报表添加字段

添加存储文档、 文件或图像的字段

更改字段的显示方式

了解表和字段的基础知识

创建数据库时,将数据存储在表中,基于主题的行和列的列表。存储您想要跟踪字段 (也称为列) 中的信息项。例如,在联系人表中,可能的姓氏、 名字、 电话号码和地址创建字段。对于产品表中,您可能为产品名称、 产品 ID 和价格创建字段。

请务必仔细选择字段。例如,它通常是个好主意,创建用于存储计算的值的字段。在大多数情况下,您可以拥有Office Access 2007需要时计算的值。当您选择域时,请尝试将信息存储在其最小的有用部分。例如,而不是单个字段中的完整名称,请考虑单独存储的第一个和最后一个名称。通常,如果需要报告、 排序、 搜索,或对信息项执行计算,请将其放入字段本身。

有关设计数据库和选择字段的详细信息,请参阅文章数据库设计基础

字段具有某些定义特征。例如,每个域具有唯一标识表中的字段的名称。域也具有的选择以匹配的信息将存储的数据类型。数据类型以及确定可以存储的值和可对这些值中,执行的操作,要为每个值留出的存储空间的方式。每个域也具有名为定义的字段的外观或行为特征的属性的设置相关联的组。例如,格式属性定义的字段显示布局-即,它时应如何显示显示。

返回页首

向表添加字段

在数据表视图中可以轻松地将字段添加到表中。但是,也可以在设计视图中将字段添加到表中。在数据表视图中,在“添加新字段”列标题下的单元格中键入一些数据即可添加字段。

Access 中包含“添加新字段”列的数据表

1.一个新的空白字段。

在数据表视图中添加字段

  1. 单击“Office 按钮Office 按钮图像 ,然后单击“打开”。

  2. 在“打开”对话框中,选择并打开数据库。

  3. 在导航窗格中,双击要向其添加新字段的表。

    该表将在数据表视图中打开。

  4. “添加新字段”列标题下的单元格中键入数据。

    如果该表已包含很多字段,可能需要滚动到右侧以查看列标题为“添加新字段”的列。

在新列中输入数据时, Office Access 2007使用键入识别适当的数据类型的字段的信息。例如,如果您在列中,如 1/1/2007 中,键入日期Office Access 2007识别为日期,并将数据类型为日期/时间域设置您输入的信息。如果 Access 没有足够的信息从您输入确定数据类型,则将数据类型设置为文本。

如果您希望显式设置数据类型和格式的字段,将覆盖选择该Office Access 2007做出,您可以执行此操作通过单击数据表选项卡上的数据类型和格式组中的命令。

显式设置数据类型

  • 数据表选项卡上的数据类型和格式组中,单击数据类型,旁边的下拉列表中的箭头,然后选择数据类型。 Access 功能区图像的数据类型和“格式”组

  • 单击所需的数据类型。

显式设置格式

  1. 数据表选项卡上的数据类型和格式组中,单击格式,旁边的下拉列表中的箭头,然后选择格式。 Access 功能区图像的数据类型和“格式”组

  2. 单击所需的格式。

通过添加新字段标题下面的单元格中键入信息将添加字段时, Office Access 2007自动为字段指定一个名称。这些名称开头的第一个字段,将第二个字段,Field2 Field1,依此类推。很好的做法使用域的更多的描述性名称。您可以通过右键单击其标题,然后单击快捷菜单上的重命名列重命名字段。

除了在数据表视图中添加字段,您可以在设计视图中添加字段。数据表视图,您可以设置只是最常见的字段属性,因为您可能会发现您需要使用设计视图设置的属性,在数据表视图中不可用。

在设计视图中添加字段

  1. 单击“Office 按钮Office 按钮图像 ,然后单击“打开”。

  2. 在“打开”对话框中,选择并打开数据库。

  3. 在导航窗格中,右键单击要向其中添加新字段的表,然后单击快捷菜单上的“设计视图”

    表即在设计视图中打开。

  4. “字段名称”列中,单击第一个空行并键入新字段的名称。

  5. “数据类型”列中单击相邻单元格,然后从列表中选择数据类型。

  6. 要保存所做的更改,请单击“快速访问工具栏”上的“保存”

有关如何添加新字段的详细信息,请参阅文章插入、 添加或创建新表中的字段

注意: 向表中添加新字段时,字段不会自动添加到现有窗体和报表中。若要在这些窗体和报表中显示该字段,则必须手动添加。

返回页首

从表中删除字段

如果可能,请不要从提供的模板生成一个数据库中删除域 — 很可能会在其他数据库对象,例如窗体和报表会使用该字段。因此,删除该字段将产生问题当您尝试使用其他使用的字段的数据库对象 — 数据库对象将不会按预期工作。您将需要删除所有的对象,这些对象正常工作的顺序中使用它对字段的任何引用。

如果确定必须从通过模板生成的数据库中删除字段,可以在数据表视图或设计视图中执行此操作。请记住,如果其他数据库对象引用了已删除字段,则必须修改这些对象以删除引用。例如,如果报表包含一个绑定到已删除字段的控件,运行该报表时,则会因 Access 无法找到该字段的数据而显示一条错误消息。

如果删除字段,则会永久删除该字段中存储的所有信息。因此,应慎用删除字段操作,并且在删除字段之前应创建数据库备份副本。

您可以删除域之前,必须确保它不参与任何表关系。如果您尝试删除的字段存在的关系,Access 会警告您必须先删除关系。如何删除表关系的分步说明,请参阅部分中删除表关系

在数据表视图中删除字段

  1. 单击“Office 按钮Office 按钮图像 ,然后单击“打开”。

  2. 在“打开”对话框中,选择并打开数据库。

  3. 在导航窗格中,双击要从中删除字段的表。

    该表将在数据表视图中打开。

  4. 选择要删除的字段(列)。

    提示: 若要选择字段(列),请单击字段选择器(列标题)。

  5. 按 Delete。

    - 或 -

    数据表选项卡上的字段和列组中,单击删除

注意: 在数据表视图中,不能删除属于表主键的字段。若要删除主键字段,必须使用设计视图。

有关主键的详细信息,请参阅添加、 设置、 更改或删除主键一文。

在设计视图中删除字段

  1. 单击“Office 按钮Office 按钮图像 ,然后单击“打开”。

  2. 在“打开”对话框中,选择并打开数据库。

  3. 在导航窗格中,右键单击要从中删除字段的表,然后单击快捷菜单上的“设计视图”

    表即在设计视图中打开。

  4. 选择要删除的字段(行)。

    提示: 若要选择行,请单击行选择器。

  5. 按 Delete。

    - 或 -

    设计选项卡的工具组中,单击删除行

  6. 要保存所做的更改,请单击“快速访问工具栏”上的“保存”

在删除字段之前,必须确保它没有参与任何表关系。如果尝试删除已建立关系的字段,Access 会提出警告必须先删除这些关系。若要删除表关系,请执行下列操作。

删除表关系

  1. 单击“Office 按钮Office 按钮图像 ,然后单击“打开”。

  2. 在“打开”对话框中,选择并打开数据库。

  3. 如果参与表关系的表处于打开状态,则请关闭它们。不能删除打开的表之间的表关系。

  4. “数据库工具”选项卡上的“显示/隐藏”组中,单击“关系”

  5. 如果参与表关系的表不可见,请执行下列操作:

    1. 设计选项卡上的显示/隐藏组中,单击表名称

    2. 显示表对话框中,选择要添加,请单击添加,然后单击关闭的表。

  6. 单击要删除的表关系的关系线(当选中时,关系线以加粗显示),然后按 Delete。

返回页首

重命名字段或表

如果可能,应避免重命名字段或表中的所提供的模板生成的数据库,很可能会在其他数据库对象,例如窗体和报表中使用该字段或表。因此,重命名字段或表可以创建后果,当您尝试使用其他使用的字段或表的数据库对象。其他对象可能无法按预期如果他们仍引用旧名称。对于其他对象正常工作,必须为新的名称更改原来的名称。如果在Access 选项对话框中的当前数据库类别中选择执行名称自动更正复选框,则系统将自动完成此工作大部分。

您可能想要更改显示在数据表视图中的列标题中的文本。无需重命名字段,可以执行此操作。如果您想要更改的列标题的文本,并且不希望重命名字段,,请参阅部分中更改列标题中显示的文本

必要时,您可以重命名导航窗格中的表或重命名数据表视图或设计视图中的字段。执行此操作之前,您应考虑启用名称自动更正选项中,如果未打开。

打开名称自动更正选项

重命名数据库对象,如字段、 表、 窗体或报表,您通常希望名称更改传播到整个数据库。否则,引用旧名称的对象将不会按预期工作。Office Access 2007提供名称自动更正功能,这有助于传播名称更改。默认情况下,为Office Access 2007中的所有新数据库启用名称自动更正。但是,如果它处于关闭状态,您可以执行下列操作以将其打开。

打开名称自动更正选项

  1. 单击“Microsoft Office 按钮” Office 按钮图像 ,然后单击“Access 选项”。

  2. “Access 选项”对话框的左侧窗格中,单击“当前数据库”

  3. “名称自动更正选项”下,依次选中“跟踪名称自动更正信息”“执行名称自动更正”复选框。

  4. 如果要保留一个表来记录由“名称自动更正”执行的所有更改,请选中“记录名称自动更正更改”复选框。

  5. 单击“确定”。

  6. 要保存所做的更改,请单击“快速访问工具栏”上的“保存”

注意: “名称自动更正”功能不同于“自动更正”功能。“名称自动更正”功能更正对象间的引用,而“自动更正”功能则更正经常拼错的词或短语。

在数据表视图中重命名字段

  1. 单击“Office 按钮Office 按钮图像 ,然后单击“打开”。

  2. 在“打开”对话框中,选择并打开数据库。

  3. 在导航窗格中,双击要在其中重命名字段的表。

    该表将在数据表视图中打开。

  4. 右键单击要重命名的字段的列标题,然后单击快捷菜单上的“重命名列”

  5. 键入字段的新名称,然后按 Enter。

在设计视图中重命名字段

  1. 单击“Office 按钮Office 按钮图像 ,然后单击“打开”。

  2. 在“打开”对话框中,选择并打开数据库。

  3. 在导航窗格中,右键单击要重命名的字段所在的表,然后单击快捷菜单上的“设计视图”

    表即在设计视图中打开。

  4. “字段名称”列中单击要重命名的字段的单元格。

    提示: 若要选择整个字段名称,请指向名称第一个字符的左侧,直到指针变为箭头,然后单击。

  5. 编辑文本以重命名字段。

  6. 要保存所做的更改,请单击“快速访问工具栏”上的“保存”

重命名表

在导航窗格中可以直接重命名表和大多数其他数据库对象。

  1. 单击“Office 按钮Office 按钮图像 ,然后单击“打开”。

  2. 在“打开”对话框中,选择并打开数据库。

  3. 在导航窗格中,右键单击要重命名的表,然后单击快捷菜单上的“重命名”

    注意: 在重命名表之前,必须先关闭引用该表的所有打开的对象。

  4. 键入新名称,再按 Enter。

  5. 要保存所做的更改,请单击“快速访问工具栏”上的“保存”

更改显示在列标题中的文本

题注是您可以通过设置字段的标题属性分配到的字段的标题。标题无关的字段名称,每个字段都有字段名称,也可以有标题。例如,您可能希望域名称为单个单词不含空格。然后可以使用标题属性以创建包含空格的更多的描述性名称。在数据表视图和标签和查询、 窗体和报表中的标题,access 将显示字段名称代替的标题。

如果您不提供标题属性的文本,字段名称使用默认情况下。

如果您想要更改在数据表视图中的列标题中显示的名称,您可以无需更改字段名称通过设置字段的标题属性。若要更改字段的标题属性,请执行下列操作:

  1. 单击“Office 按钮Office 按钮图像 ,然后单击“打开”。

  2. 在“打开”对话框中,选择并打开数据库。

  3. 在导航窗格中,右键单击要更改的标题所在的表,然后单击快捷菜单上的“设计视图”

    表即在设计视图中打开。

  4. 单击要设置其标题属性的字段的字段名称列中的单元格。

  5. 在下部“字段属性”下面的“常规”选项卡上单击“标题”

  6. 为字段键入新标题。

  7. 要保存所做的更改,请单击“快速访问工具栏”上的“保存”

下次在数据表视图中打开该表时,列标题中显示标题,而不是字段名称。

返回页首

向窗体或报表添加字段

创建基于模板的数据库时,您的数据库将包含大量内置、 预先设计的窗体和报表,您可以立即使用。您可能会发现,但是,您想要将其他域添加到窗体或报表。将字段添加到窗体或报表时,您创建称为控件

控件简介

控件是显示数据、 执行的操作,并允许您查看和使用增强的用户界面,如标签和图像的信息的对象。控件可以绑定、 未绑定和计算。

  • 绑定控件   这是的控件的数据源是表或查询中的字段。绑定的控件用于显示数据库中的字段中的值。值可以是文本、 日期、 数字、 是/否值、 图片或图形。文本框是最常见的绑定控件类型。例如,在显示员工姓氏的窗体上的文本框可能从雇员表中的姓氏字段获得此信息。

  • 未绑定控件   没有为此类型的控件 (字段或表达式) 的数据源。使用未绑定的控件以显示信息、 线条、 矩形和图片。例如,显示的窗体标题标签是未绑定的控件。

  • 计算控件   这是的控件的数据源是表达式,而不是一个字段。通过定义表达式的控件的数据源,可以在控件中指定所需的值。表达式是运算符的组合 (如=+ ),控件名称、 字段名称、 返回单个值,以及常量值的函数。例如,下面的表达式计算项 25%折扣的价格常量值 (0.75) 单价字段中的值相乘。

= [单价] * 0.75

表达式所使用的数据可以来自窗体的基础表或查询中的字段,也可以来自窗体上的控件。有关表达式的详细信息,请访问本文请参阅节中的链接。

在文本框中可以绑定的控件、 未绑定的控件或计算的控件。当您创建窗体,使用绑定、 未绑定和计算的控件,它可能是最有效来添加和排列所有绑定的控件首先,尤其是当窗体控件的大多数。然后,您可以添加完成设计通过使用设计视图中的设计选项卡上的控件组中的工具的未绑定控件和计算控件。

通过标识控件从中获得其数据的字段,可以将文本框控件绑定到字段。通过将字段从“字段列表”窗格拖动到窗体上,可以创建绑定到选定字段的控件。“字段列表”窗格显示窗体的基础表或查询的字段。若要显示“字段列表”窗格,请在“设计”选项卡的“工具”组中,单击“添加现有字段”。默认情况下,将字段从“字段列表”窗格拖动到窗体的设计网格上时,Access 将插入一个文本框。

或者,可以在控件本身或在控件的属性表中的控件来源值框中键入字段名称字段绑定到控件。属性表定义该控件,如其名称的特征,其数据,以及其格式的源。

使用“字段列表”窗格是创建绑定文本框的最佳方式,原因有两个:

  • 绑定文本框附带有标签,默认情况下该标签采用字段名称(或在基础表或查询中为该字段定义的标题)作为其标题,因此不必自己键入标题。

  • 绑定的文本框继承许多相同的设置的基础表或查询 (如格式小数位数,和输入掩码属性) 中的字段。因此,您可以确保每次创建绑定到该字段的文本框,这些属性的字段保持相同。

如果您已创建未绑定的控件,并且想要绑定到某个字段,请将该控件ControlSource属性设置为域的名称。

在布局视图中向窗体或报表添加字段

创建窗体或报表后,可以在布局视图中轻松地微调其设计。通过引导您使用的实际的实时数据,您可以调整字段宽度并重新排列字段。您可以将新字段放在窗体或报表,并设置窗体或报表和其控件的属性。

若要切换到布局视图中,在导航窗格中,右键单击窗体或报表中,,然后单击快捷菜单上的布局视图。或者,您可以单击 Access 状态栏中,在布局视图按钮,或您可以右键单击窗体或报表的文档选项卡,然后单击快捷菜单上的布局视图

切换至布局视图

  • 在导航窗格中,右键单击窗体或报表,然后单击快捷菜单上的“布局视图”

    - 或 -

    单击 Access 状态栏上的布局视图按钮。

    - 或 -

    右键单击窗体或报表的文档选项卡,然后单击快捷菜单上的“布局视图”

窗体或报表即显示在布局视图中。

打开属性表

  • “排列”选项卡上的“工具”组中,单击“属性表”

    键盘快捷方式按 F4。

您可以使用字段列表窗格中将字段从基础表或查询添加到您的设计。若要显示字段列表窗格中,在格式选项卡上的控件组中,单击添加现有字段。然后,您可以拖动到设计直接从字段列表窗格拖动字段。

显示“字段列表”窗格

  • 在“格式”选项卡上的“控件”组中,单击“添加现有字段”。

从“字段列表”窗格添加字段

  • 若要添加单个字段,请将字段从“字段列表”窗格拖动到报表上要显示该字段的节中。

  • 若要一次添加多个字段,请按住 Ctrl 并单击所需的字段。将选中的字段拖到窗体或报表上。

将字段放置到报表节中后,Access 将为每个字段创建绑定文本框控件,并自动在每个字段旁边放置一个标签控件。

有关窗体和报表的详细信息,请参阅文章创建窗体使用窗体工具创建简单报表

返回页首

添加存储文档、文件或图像的字段

您可以使用Office Access 2007添加字段来存储一个或多个文档、 文件或图像的附件数据类型。您可以使用附件字段单个字段中存储多个文件。您甚至可以在该字段中存储多个文件的类型。例如,在雇用候选数据库中,可以将一个或多个简历,除了照片,附加到每个联系人记录。

将附件字段添加到表中

  1. 单击“Office 按钮Office 按钮图像 ,然后单击“打开”。

  2. 在“打开”对话框中,选择并打开数据库。

  3. 在导航窗格中,右键单击要向其添加字段的表,然后单击快捷菜单上的“设计视图”

    表即在设计视图中打开。

  4. “字段名称”列中,单击第一个空行并键入新字段的名称。

  5. “数据类型”列中单击相邻单元格,然后从列表中选择“附件”

  6. 要保存所做的更改,请单击“快速访问工具栏”上的“保存”

    Access 可能会显示一条消息,提示您保存表之后将无法撤消更改。这意味着无法将该字段转换成其他数据类型,但如果您认为有错,可以删除该字段。

  7. 单击“是”确认更改。

将“附件”字段添加到表后,可以使用“附件”对话框向记录添加文档、文件或图像。

向字段添加附件

  1. 单击“Office 按钮Office 按钮图像 ,然后单击“打开”。

  2. 在“打开”对话框中,选择并打开数据库。

  3. 在导航窗格中,双击要向其添加附件的表。

    该表将在数据表视图中打开。

  4. 在表中,双击附件字段。

    将出现“附件”对话框。

  5. 单击“添加”

    将出现“选择文件”对话框。

  6. 使用“查找范围”列表通过浏览找到要附加到记录的文件,选择一个或多个文件,然后单击“打开”

    注意,可以选择任何受支持的数据类型的多个文件。

  7. “附件”对话框中,单击“确定”以将文件添加到表中。

    Access 将文件添加到字段,并相应增加指示附件数量的数字。

  8. 根据需要重复上述步骤,将文件添加到当前字段或表中的其他字段。

有关附件字段的详细信息,请参阅文章附加文件和图形到数据库中的记录

返回页首

更改字段的显示方式

您可以自定义字段显示时的显示方式。例如,可以设置用于在整个数据库,如在窗体和报表,或在数据表视图中打开表时的显示格式。若要设置显示格式,您可以设置字段的格式属性。该字段的格式属性自动继承的新窗体和报表的创建。

在数据表视图中设置显示格式

  1. 单击“Office 按钮Office 按钮图像 ,然后单击“打开”。

  2. 在“打开”对话框中,选择并打开数据库。

  3. 在导航窗格中,双击包含要设置其格式的字段的表。
    在数据表视图中打开表。

  4. 单击要设置其显示格式的字段。

  5. 数据表选项卡上的数据类型和格式组中,单击格式,旁边的下拉列表中的箭头,然后选择格式。 Access 功能区图像的数据类型和“格式”组

    该字段即以新显示格式显示。

在设计视图中设置显示格式

  1. 单击“Office 按钮Office 按钮图像 ,然后单击“打开”。

  2. 在“打开”对话框中,选择并打开数据库。

  3. 在导航窗格中,右键单击包含要更改其显示格式的字段的表,然后单击快捷菜单上的“设计视图”

    表即在设计视图中打开。

  4. 单击要设置其显示格式的字段。

  5. “字段属性”下的“常规”选项卡上,单击“格式”框。

  6. 单击下拉列表,然后选择一种显示格式。

  7. 要保存所做的更改,请单击“快速访问工具栏”上的“保存”

有关如何更改字段的外观的详细信息,请参阅文章数据行和列中的格式

返回页首

注意: 机器翻译免责声明:本文是由无人工介入的计算机系统翻译的。Microsoft 提供机器翻译是为了帮助非英语国家/地区用户方便阅读有关 Microsoft 产品、服务和技术的内容。由于机器翻译的原因,本文可能包含词汇、语法或文法方面的错误。

扩展你的技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×