Перейти до основного
Office
Створення діаграми на основі форми в настільних базах даних Access за допомогою невізуального екрана

Створення діаграми на основі форми в настільних базах даних Access за допомогою невізуального екрана

Символ читання вголос із надписом "Вміст невізуального екрана". У цьому розділі з Office використовуватиметься невізуальний екран

Ця стаття призначена для користувачів із вадами зору, які використовують невізуальний екран із продуктами Office. Вона входить до набору вмісту, присвяченого спеціальним можливостям Office. Загальну довідку див. на головній сторінці служби підтримки Office.

Використовуйте Access_1st_NoVer з клавіатурою та невізуальним екраном, щоб створити секторну, стовпчасту або лінійчату діаграму у формі. Ми тестували її за допомогою екранного диктора, ЩЕЛЕП та NVDA, але вона може працювати з іншими невізуальним екраном, доки вони не відповідають спільним стандартам і методам спеціальних можливостей. Ви також дізнаєтеся, як форматувати, змінювати розмір або рухати діаграму.

Діаграму можна додати до форми, щоб візуалізувати дані. Діаграму можна зв’язати з таблицею або запитом і налаштувати, установивши різні властивості.

Щоб дізнатися більше про діаграми та про те, як визначити, яку діаграму потрібно створити, перейдіть до розділу вибір найкращого типу діаграми для вашого списку потреб у розділі створення діаграми у формі або звіті.

Примітки.: 

  • Нові можливості Office_365 запроваджуються для абонентів цієї служби поступово, тому у вашій програмі деякі з них можуть бути наразі відсутні. Щоб дізнатись, як почати користуватися новими функціями раніше за інших, приєднайтеся до програми оцінювання Office.

  • Докладні відомості про роботу невізуальних екранів із Microsoft Office див. в цій статті.

У цій статті

Створення діаграми

Щоб успішно створити діаграму в Access_1st_NoVer, прив'яжіть діаграму до джерела даних, наприклад таблиці або запиту, а також Зіставте поля з розмірами діаграми.

  1. Перейдіть до форми, для якої потрібно створити діаграму, і натисніть клавіші Shift + F10. Відкриється контекстне меню. Натисніть клавішу D, щоб відкрити форму в режимі конструктора.

  2. Щоб вибрати тип діаграми, натисніть клавіші Alt + J, D, H, 1. Відкриється меню "діаграма". Виконайте одну з таких дій:

    • Щоб створити секторну діаграму, натисніть клавішу P.

    • Щоб створити стовпчасту діаграму, натисніть клавішу с.

    • Щоб створити лінійчату діаграму, натисніть клавішу л.

  3. Натисніть клавішу Enter. У формі буде вставлено шаблонну діаграму. Відкриється область " Параметри діаграми ".

  4. Щоб пересунути фокус до області Параметри діаграми , натискайте клавішу F6, доки не пролунає елемент в області. Можливо, вам доведеться попросити колегу, щоб ви могли визначити область.

  5. Якщо потрібно, щоб перемістити фокус на вкладку дані , натискайте клавіші SHIFT + TAB, доки не почуєте поточну вкладку. Потім натискайте клавішу зі стрілкою вправо, доки не пролунає фраза "Data Tab" (вкладка "дані"). Відобразяться властивості табуляції.

  6. Щоб вибрати або змінити тип джерела даних для діаграми, натискайте клавішу TAB, доки не пролунає фраза "Source Data" (джерело даних), а потім введіть поточний тип джерела, наприклад "Таблиця". Щоб змінити тип джерела даних, натискайте клавішу зі стрілкою вліво або вправо, доки не почуєте потрібний тип джерела.

  7. Натисніть клавішу Tab. Ви почуєте ім'я поточного джерела даних, а потім – "поле зі списком". Якщо не вибрано джерело даних, ви чуєте: "поле зі списком". Щоб вибрати або змінити джерело даних, натискайте клавішу зі стрілкою вниз, доки не почуєте потрібне джерело, а потім натисніть клавішу вводу.

    За замовчуванням зразок перетворюється на справжню діаграму, у якій вимірами Вісь (категорія) і Значення (вісь Y) слугують перші два поля в джерелі даних. Часто перший стовпець у таблиці – це первинний ключ, і його, можливо, не потрібно використовувати як вимір на діаграмі.

  8. Щоб створити діаграму, потрібно виділити принаймні два поля в параметрах осі (категорія), легенда (ряди)і значень (Вісь Y) . Щоб переходити до параметра, натискайте клавішу TAB, доки не почуєте потрібний параметр, наприклад "вісь, Категорія". Натискайте клавішу зі стрілкою вгору або вниз, доки не почуєте ім'я потрібного поля. Якщо поле подано як прапорець, натисніть клавішу пробіл, щоб вибрати його. Якщо поле – перемикач, він автоматично вибирається під час переміщення. Щоб отримати докладні відомості про кожен параметр і дії, які вони роблять на діаграмі, перейдіть до розділу Параметри даних , крок 3, у розділі створення діаграми у формі або звіті.

Форматування діаграм

Ви можете відформатувати діаграму та її різні елементи. Також можна форматувати окремі ряди даних, які відповідають легенді діаграми, як-от набір значень у вигляді стовпця, лінії або секторного фрагмента. Параметри форматування залежать від типу діаграми.

Щоб отримати докладні відомості про властивості ряду даних, які можна відформатувати, перейдіть до розділу Параметри формату , крок 3, у розділі створення діаграми у формі або звіті.

Форматування секторної діаграми

Ви можете змінити властивості секторної діаграми, використовуючи область " аркуш властивостей ". Можливо, вам доведеться попросити колегу, щоб допомогти вибрати властивості, які потрібно змінити на кроці 8.

  1. Відкрийте форму з діаграмою в режимі конструктора , як описано в розділі створення діаграми.

  2. Натискайте клавішу F6, доки не пролунає фраза "робоча область", а потім – ім'я форми.

  3. Щоб пересунути фокус на діаграму, натискайте клавішу TAB, доки не почуєте номер діаграми, наприклад "діаграма 19, згорнута".

  4. Натисніть клавішу F4, щоб відкрити область " аркуш властивостей ".

  5. Натисніть клавішу F6 один раз. Фокус переходить до рядка властивостей в області " аркуш властивостей ". Ви почуєте номер рядка, а потім – вміст у клітинці властивості.

  6. В області " аркуш властивостей " Параметри, які впливають на вигляд діаграми, зазвичай відображаються на вкладці " Формат ". Щоб перейти до вкладки та вибрати її, натискайте клавішу TAB, доки не почуєте вибраний елемент вкладки, наприклад "елемент вкладки" дані ", вибрано. Натискайте клавішу зі стрілкою вліво або вправо, доки не пролунає фраза "Формат елемента табуляції". Відобразяться властивості вкладки Формат .

    Порада.: Якщо потрібно перевірити всі доступні властивості діаграми, перейдіть на вкладку Усі .

  7. Щоб пересунути фокус до списку властивостей на вибраній вкладці, натисніть клавішу табуляції один раз.

  8. Щоб переглянути властивості вибраної вкладки, натискайте клавішу зі стрілкою вгору або вниз. Щоб розгорнути підменю, натисніть клавіші Alt + стрілка вниз. Щоб вибрати елемент у вкладеному меню, натискайте клавішу зі стрілкою вгору або вниз, доки не почуєте потрібний параметр, а потім натисніть клавішу вводу, щоб вибрати його. Щоб змінити текстові поля, введіть нове значення в полі.

  9. Щоб закрити область " аркуш властивостей ", натисніть клавішу F4.

Форматування стовпця або лінійчатої діаграми

  1. Відкрийте форму з діаграмою в режимі конструктора , як описано в розділі створення діаграми.

  2. Натискайте клавішу F6, доки не пролунає фраза "робоча область", а потім – ім'я форми.

  3. Щоб пересунути фокус на діаграму, натискайте клавішу TAB, доки не почуєте номер діаграми, наприклад "діаграма 19, згорнута".

  4. Щоб пересунути фокус до області Параметри діаграми , натискайте клавішу F6, доки не пролунає елемент в області. Можливо, вам доведеться попросити колегу, щоб ви могли визначити область.

  5. Щоб вибрати вкладку Формат , натискайте клавіші SHIFT + TAB, доки не пролунає фраза поточна вкладка, а потім натискайте клавішу зі стрілкою вправо, доки не пролунає фраза "Format Tab" (формат табуляції).

  6. Щоб пересунути фокус до списку властивостей на вкладці Формат , натисніть клавішу табуляції один раз.

  7. Щоб переходити на вкладку Формат , натисніть клавішу SR + стрілка вправо або вліво. Щоб розгорнути меню, натисніть клавіші Alt + стрілка вниз. Щоб переглянути меню, натискайте клавішу зі стрілкою вгору або вниз. Щоб вибрати параметр, натисніть клавішу пробіл або вхід. Щоб змінити текстові поля, введіть нове значення в полі.

Змінення розміру діаграми

  1. Відкрийте форму з діаграмою в режимі конструктора , як описано в розділі створення діаграми.

  2. Натискайте клавішу F6, доки не пролунає фраза "робоча область", а потім – ім'я форми.

  3. Щоб пересунути фокус на діаграму, натискайте клавішу TAB, доки не почуєте номер діаграми, наприклад "діаграма 19, згорнута".

  4. Натисніть клавіші SHIFT + клавіші зі стрілками, щоб змінити розмір діаграми. Можливо, вам знадобиться колега, який допоможе визначити відповідні розміри для діаграми.

Переміщення діаграми

  1. Відкрийте форму з діаграмою в режимі конструктора , як описано в розділі створення діаграми.

  2. Натискайте клавішу F6, доки не пролунає фраза "робоча область", а потім – ім'я форми.

  3. Щоб пересунути фокус на діаграму, натискайте клавішу TAB, доки не почуєте номер діаграми, наприклад "діаграма 19, згорнута".

  4. За допомогою клавіш зі стрілками переміщайте діаграму. Можливо, вам знадобиться колега, який допоможе визначити відповідну позицію для діаграми.

Пов’язання діаграми з даними у формі або звіті

Щоб діаграма взаємодіяла з даними у формі або звіті, зв’яжіть її з джерелом даних форми або звіту. Після цього можна задати відповідне значення поля для дочірніх полів зв'язати та зв'язати основні поля властивостей даних діаграми.

  1. Створення форми або звіту, прив'язаного до джерела даних. Щоб отримати докладні вказівки, скористайтеся невізуальним екраном, щоб створити форму в настільних базах даних Access або використати невізуальний екран, щоб створити звіт у настільних базах даних Access.

  2. У формі або звіті додайте діаграму відповідно до інструкцій у розділі створення діаграми. Вибравши джерело даних, виберіть таке саме джерело, що й у формі або звіті.

  3. Відкрийте форму або звіт у режимі конструктора відповідно до інструкцій у розділі створення діаграми.

  4. Щоб пересунути фокус на діаграму, натискайте клавішу TAB, доки не почуєте номер діаграми, наприклад "діаграма 19, згорнута".

  5. Натисніть клавішу F4, щоб відкрити область " аркуш властивостей ".

  6. Натисніть клавішу F6 один раз. Фокус переходить до рядка властивостей в області " аркуш властивостей ". Ви почуєте номер рядка, а потім – вміст у клітинці властивості.

  7. Щоб перейти до вкладки дані та вибрати його, натискайте клавішу TAB, доки не почуєте вибраний елемент вкладки, наприклад "Формат елемента табуляції, вибраний". Натискайте клавішу зі стрілкою вліво або вправо, доки не пролунає фраза: "елемент вкладки даних". Відобразяться властивості вкладки " дані ".

  8. Попросіть колегу, щоб ви могли перенести фокус до поля властивості зв'язати дочірні поле або зв'язати основні поля .

  9. У полі вибрано властивість натисніть клавіші Shift + F10, щоб відкрити контекстне меню. Щоб відкрити діалогове вікно компонувальника полів підформи , натисніть клавішу б.

  10. У діалоговому вікні компонувальник полів підформи містяться окремі меню для полів Master і дочірні поля. Щоб переміститися в діалоговому вікні, натисніть клавішу SR + стрілка вправо або вліво. Щоб розгорнути список полів "основні" або "дочірні", натисніть клавіші Alt + стрілка вниз. Щоб переглянути список, натискайте клавішу зі стрілкою вниз. Щоб вибрати поле, на яке потрібно створити посилання, натисніть клавішу вводу. Можливо, вам доведеться попросити колегу, щоб допомогти вам зорієнтуватися в діалоговому вікні.

    Порада.: Якщо ви не знаєте, яке поле використовувати, натискайте клавішу SR + стрілка вправо, доки не дійдете до кнопки " запропонувати ", а потім натисніть клавішу пробіл, щоб вибрати його. Access_1st_NoVer вставляє Рекомендовані поля в полі виділена властивість.

  11. Збережіть форму або звіт.

  12. Переконайтеся, що діаграму працює належним чином у поданні форми або звіту . Наприклад, щоб оновити діаграму, потрібно відфільтрувати форму або звіт за полем Категорії. Можливо, вам доведеться попросити колегу, щоб переконатися в тому, що ви перевіряєте діаграму.

Див. також

Створення таблиць у настільних базах даних Access за допомогою невізуального екрана

Створення запиту в локальних базах даних Access за допомогою невізуального екрана

Створення форми в настільних базах даних Access за допомогою невізуального екрана

Експорт таблиці Access до книги Excel за допомогою невізуального екрана

Використання невізуального екрана для приведення даних Excel до настільних баз даних Access

Сполучення клавіш в Access

Огляд і навігація в Access за допомогою невізуального екрана

Технічна підтримка клієнтів з особливими потребами

Корпорація Майкрософт прагне забезпечити якомога кращі умови роботи для всіх своїх клієнтів. Якщо у вас є особливі потреби або ви маєте запитання щодо спеціальних можливостей, зверніться по технічну підтримку до служби Microsoft Disability Answer Desk. Її фахівці чудово знають, як використовувати численні спеціальні засоби, і можуть надавати допомогу англійською, іспанською, французькою й американською мовами жестів. Щоб отримати контактні дані для свого регіону, перейдіть на сайт служби Microsoft Disability Answer Desk.

Якщо ви користувач у державній установі, комерційній організації або на підприємстві, зверніться до корпоративної служби підтримки Disability Answer Desk.

Примітка.:  Цю сторінку перекладено за допомогою засобу автоматичного перекладу, тому вона може містити смислові, синтаксичні або граматичні помилки. Ми вважаємо, що цей вміст стане вам у пригоді. Повідомте нас, чи була ця інформація корисною. Для довідки цю статтю можна переглянути англійською мовою.

Удосконалення навичок роботи з Office
Ознайомтеся з навчальними матеріалами
Отримуйте нові функції раніше за інших
Приєднайтеся до оцінювачів Office

Ця інформація корисна?

Дякуємо за ваш відгук!

Дякуємо, що знайшли час і надіслали нам відгук! Можливо, у нас не буде часу відповісти на кожен коментар, але докладемо максимум зусиль, щоб переглянути їх усі. Вас цікавить, як ми використовуємо ваші відгуки?

×