Надсилання даних форми до бібліотеки документів

Увага! : Цю статтю перекладено за допомогою служби машинного перекладу; див. застереження. Версію цієї статті англійською мовою див. тут для отримання довідки.

Існує можливість зберігання і впорядкування всіх форм користувачів у бібліотеці документів на сервері зі службами Microsoft Windows SharePoint. У бібліотеці документів користувачі можуть заповнювати форми, створені на основі шаблонів форм, експортувати дані із заповнених форм до програм Microsoft Office Excel 2003 або Microsoft Office Excel 2007 або виконувати злиття даних із кількох форм до однієї форми.

Для надання користувачам дозволу надсилати форми, створені на основі шаблону форми, до бібліотеки документів можна додати до шаблону форми допоміжний зв’язок даних для надсилання. Після додавання зв’язку даних для надсилання можна настроїти шаблон форми для надсилання користувачами даних із форми до бібліотеки документів. Після цього у програмі Microsoft Office InfoPath до панелі інструментів Стандартна буде додано кнопку Надіслати, а до меню Файл форми — команду Надіслати. Можна також настроїти параметри надсилання таким чином:

  • Змінити текст кнопки Надіслати на панелі інструментів Стандартна або команди Надіслати в меню Файл.

  • Змініть сполучення клавіш для кнопки Надіслати на панелі інструментів Стандартна та команди Надіслати в меню Файл.

  • Створіть настроюване повідомлення, яке відображатиметься під час надсилання форм.

  • Визначити, чи потрібно залишити форму після надсилання відкритою, закрити її або відкрити іншу пусту форму.

Додавання зв’язку даних для надсилання

  1. У меню Tools виберіть команду Submit Options.

  2. У діалоговому вікні Submit Options установіть прапорець Allow users to submit this form.

  3. Виберіть команду Надіслати дані форми до одного розташування, а потім виберіть у списку пункт Бібліотека документів SharePoint.

  4. Натисніть кнопку Додати.

  5. У майстрі зв’язків даних у полі Бібліотека документів введіть розташування бібліотеки документів SharePoint.

  6. У полі Ім'я файлу введіть ім’я, яке буде використовуватися для визначення форми в бібліотеці документів.

    Порада : Можна також використати формулу, щоб переконатися в унікальності кожного імені форми.

    Інструкції

    1. Натисніть кнопку Вставити формулу зображення кнопки .

    2. У діалоговому вікні Вставлення формули виконайте одну з таких дій:

      • Для використання поля у формулі натисніть кнопку Вставити поле або групу, виберіть потрібне поле в діалоговому вікні Вибір поля або групи, а потім натисніть кнопку ОК.

      • Для використання функції у формулі натисніть кнопку Вставити функцію, виберіть потрібну функцію в діалоговому вікні Вставлення функції і натисніть кнопку ОК.

        Порада : Якщо для функції потрібні певні параметри, виберіть функцію в діалоговому вікні Вставлення функції, натисніть кнопку ОК, а потім у полі Формула діалогового вікна Вставлення формули двічі клацніть додану функцію та виберіть поле або групу. Посилання та додаткові відомості про функції див. у розділі Див. також.

      • Для додавання значення або математичного оператора до формули введіть значення або символ для математичного оператора у полі Формула.

    Операція

    Символ

    Додавання

    +

    Віднімання

    -

    Множення

    *

    Ділення

    /

    • Примітка : Якщо у формулі використовується оператор ділення (/), переконайтеся, що перед ним і після нього стоїть пробіл. Якщо перед і після оператора не стоїть пробіл, символ «/» розпізнається програмою InfoPath як роздільник кроків розташування XPath, а не як оператор ділення.

    • Щоб перевірити синтаксис формули, в діалоговому вікні Вставлення формули виберіть пункт Перевірити формулу.

      Посилання на додаткові відомості про формули див. у розділі Див. також.

  7. Для перезапису всіх наявних форм із однаковими іменами в бібліотеці документів установіть прапорець Дозволити перезаписувати наявний файл.

  8. Натисніть кнопку Далі.

  9. На наступній сторінці майстра введіть у полі Enter a name for this data connection описове ім'я цього підключення для надсилання даних.

  10. Перевірте правильність інформації в розділі Зведення, відтак натисніть кнопку Готово.

    1. Щоб змінити ім'я кнопки Надіслати », що відображається на панелі інструментів Стандартна і команди Надіслати , що з'являється в меню файл » під час заповнення форми, введіть нове ім'я в полі " назва ", у діалоговому вікні Параметри надсилання .

      Порада : Якщо потрібно призначити цій кнопці та команді сполучення клавіш, амперсанда (&) перед символом, який потрібно використати як сполучення клавіш. Наприклад, щоб призначити сполучення клавіш ALT + B як сполучення клавіш для команди і кнопка " Надіслати ", введіть Su & bmit.

  11. Щоб заборонити користувачам викликати команду Submit або натискати кнопку Submit на панелі інструментів Standard під час заповнення форми, зніміть прапорець Show the Submit menu item and the Submit toolbar button.

    1. За замовчуванням після надсилання заповненої форми вона залишається відкритою в InfoPath і з'являється повідомлення про успішне надсилання. Щоб змінити цю поведінку, натисніть кнопку Advanced і виконайте одну з таких дій.

      1. Щоб після надсилання заповненої форми вона закривалася або створювалася нова пуста форма, виберіть відповідний параметр у списку After submit.

      2. Щоб створити спеціальні повідомлення, які мають відображатися в разі успішного та невдалого надсилання форми, установіть прапорець Use custom messages і введіть бажаний текст повідомлень у поля On success і On failure.

        Порада : Повідомлення в полі On failure має вказувати користувачам потрібні дії, якщо форму не вдалося надіслати. Наприклад, у ньому можна рекомендувати користувачам зберегти форму та звернутися до певної особи за вказівками.

      3. Щоб заборонити показ повідомлення після надсилання форми, зніміть прапорець Show success and failure messages.

На початок сторінки

Примітка : Застереження про машинний переклад: Цю статтю перекладено комп’ютерною системою без втручання людини. Корпорація Майкрософт пропонує таку послугу, щоб іншомовні користувачі могли дізнаватися про продукти, служби й технології Microsoft. Оскільки статтю перекладено за допомогою служби машинного перекладу, вона може містити смислові, синтаксичні або граматичні помилки.

Отримуйте нові функції раніше за інших
Приєднайтеся до оцінювачів Office

Ця інформація корисна?

Дякуємо за ваш відгук!

Дякуємо за відгук! Схоже, вам може стати в нагоді допомога одного з наших спеціалістів служби підтримки Office, з яким ми вас можемо з’єднати.

×