Перейти до основного
Office
Експорт таблиці Access до книги Excel за допомогою невізуального екрана

Експорт таблиці Access до книги Excel за допомогою невізуального екрана

Символ читання вголос із надписом "Вміст невізуального екрана". У цьому розділі з Office використовуватиметься невізуальний екран

Ця стаття призначена для користувачів із вадами зору, які використовують невізуальний екран із продуктами Office. Вона входить до набору вмісту, присвяченого спеціальним можливостям Office. Загальну довідку див. на головній сторінці служби підтримки Office.

Щоб експортувати дані до формату файлу, який Excel_generic може читати, використовуйте Access_1st_NoVer з клавіатурою та невізуальним екраном. Ми тестували її за допомогою екранного диктора, ЩЕЛЕП та NVDA, але вона може працювати з іншими невізуальним екраном, доки вони не відповідають спільним стандартам і методам спеціальних можливостей. Ви дізнаєтеся, як використовувати майстер експорту, щоб експортувати дані, наприклад таблицю, запит, форму, звіт або вибрані записи в поданні з кількома записами, наприклад у табличному поданні з Excel_generic сумісним файлом.

Примітки.: 

  • Нові можливості Office_365 запроваджуються для абонентів цієї служби поступово, тому у вашій програмі деякі з них можуть бути наразі відсутні. Щоб дізнатись, як почати користуватися новими функціями раніше за інших, приєднайтеся до програми оцінювання Office.

  • Докладні відомості про роботу невізуальних екранів із Microsoft Office див. в цій статті.

У цій статті

Підготування даних для експорту

Перш ніж експортувати дані, скористайтеся моментом, щоб переглянути дані та вирішити, як її потрібно експортувати.

  • Переконайтеся, що дані не містять індикаторів помилок і значень помилок. В іншому разі проблеми можуть виникати під час експорту, а Null-значення можна вставляти в Excel_generic клітинки аркуша. Щоб отримати відомості про виправлення неполадок, перейдіть до розділу Виправлення неполадок із відсутніми та неправильними значеннями в експорті даних до програми Excel.

  • Визначте, чи потрібно експортувати таблицю або запит із форматуванням або без нього. Це рішення впливає на обсяг даних, які експортуються, а також формат відображення даних. Щоб отримати докладні відомості про результати експортування відформатованих та неформатованої даних, перейдіть до розділу підготовка до операції експорту в експорті даних до Excel.

  • Виберіть цільову книгу та формат файлу. Якщо експортувати таблицю, запит, форму або звіт із форматуванням до наявної книги, книгу буде перезаписано.

    Примітка.: Звіти можна експортувати лише у форматі файлу з розширенням XLS, а не в новішому форматі файлу *. XLSX.

Експорт даних

Під час експортування форми, звіту або даних у табличному поданні, які містять підформи, підзвіти та підтаблиці, буде експортовано лише головну форму, звіт або дані в табличному поданні. Потрібно повторити операцію експортування для кожної підформи, підзвіту та підпорядкованої таблиці, яку потрібно експортувати до Excel_generic.

За допомогою однієї операції експортування можна експортувати лише один об’єкт бази даних. Проте ви можете об'єднати кілька аркушів у Excel_generic після виконання окремих операцій експортування.

Якщо у вас немає книги Готово, її буде створено під час експорту. Дані завжди додаються до нового аркуша.

Access_1st_NoVer наразі не підтримує експортування макросів або модулів до Excel_generic.

  1. Якщо у вас є місце призначення Excel_generic книгу Готово, закрийте її.

  2. Перейдіть до вихідної бази даних і виберіть об'єкт, який потрібно експортувати.

    Якщо об'єкт – це таблиця, запит або форма, і потрібно експортувати лише частину даних, відкрийте об'єкт у вікні табличного подання даних і виберіть потрібні записи. Щоб отримати вказівки, виберіть елемент відкрити об'єкт у вікні табличного подання даних.

    Примітка.: Не можна експортувати частину звіту. Проте ви можете вибрати або відкрити таблицю або запит, на основі якого створено звіт, а потім експортувати частину даних у цьому об'єкті.

  3. Щоб запустити майстер експорту для експорту Excel_generic, натисніть клавіші ALT + X, X. Відкриється діалогове вікно експорт – електронна таблиця Excel .

  4. Виконайте одну з таких дій:

    • Якщо потрібно створити нову електронну таблицю під час експорту, натисніть клавіші ALT + ф, щоб перенести фокус до текстового поля " ім'я файлу ". Access_1st_NoVer пропонує ім'я вихідного об'єкта як ім'я файлу для експортованого файлу. Щоб змінити ім'я, видаліть пропоноване ім'я та введіть нове ім'я.

    • Якщо наявний Excel_generic файл, до якого потрібно експортувати дані, натисніть клавіші ALT + R, щоб відкрити діалогове вікно збереження файлу , і знайдіть потрібний файл. Після того як ви працюєте з файлом, натисніть клавішу вводу, щоб вибрати його. Діалогове вікно закриється, а фокус повернеться до діалогового вікна експорт – електронна таблиця Excel .

  5. Натисніть клавіші ALT + т, щоб пересунути фокус до списку формат файлу . Ви почуєте поточний формат. Щоб вибрати потрібний формат файлу, натисніть клавішу пробіл, щоб розгорнути список, а потім натискайте клавішу зі стрілкою вгору або вниз, доки не почуєте потрібний формат, а потім натисніть клавішу вводу, щоб вибрати його.

  6. Якщо ви експортуєте таблицю або запит і хочете експортувати відформатовані дані, натисніть клавіші ALT + W, щоб переходити до параметрів і вибрати параметр експортувати дані за допомогою параметра форматування та макет .

    Примітка.: Якщо ви експортуєте форму або звіт, цей параметр вибирається за замовчуванням, і його не можна скасувати.

  7. Якщо Excel_generic потрібно, щоб програма призначення автоматично відкривався після експорту, натисніть клавіші ALT + а, щоб перейти до кнопки відкрити файл призначення після завершення операції експортування .

  8. Якщо вихідний об'єкт відкрито, і ви вибрали один або кілька записів у поданні перед початком експорту, і ці записи, які потрібно експортувати, натисніть сполучення клавіш ALT + S, щоб перейти до кнопки експортувати лише вибрані записи . Якщо потрібно експортувати всі записи, які відображаються в поданні, не вибирайте цей параметр.

    Примітка.: Якщо не вибрано жодного запису, цей параметр недоступний.

  9. Щоб почати експорт, натискайте клавішу TAB, доки не дійдете до кнопки OK , а потім натисніть клавішу вводу.

  10. Якщо експорт виконано успішно, Access_1st_NoVer запропонує зберегти кроки експорту, щоб швидко повторити їх, не виконавши майстер експорту. Щоб вибрати цей параметр, натисніть клавіші ALT + V. Щоб надати ім'я файлу, натисніть клавіші ALT + а, а потім введіть ім'я файлу. Щоб зберегти файл кроків, натисніть клавіші ALT + S.

    Якщо не вдалося виконати експорт через помилку, Access_1st_NoVer відображає повідомлення, яке описує причину помилки.

    Якщо ви вибрали автоматичне відкриття місця призначення Excel_generic книзі, натискайте клавіші Alt + клавіша табуляції, доки не почуєте назву книги, а потім перегляньте його вміст.

Відкриття об'єкта в поданні табличного подання даних

Якщо об'єкт, який потрібно експортувати, – це таблиця, запит або форма, і потрібно експортувати лише частину даних, потрібно відкрити об'єкт у вікні табличного подання даних , щоб вибрати потрібні записи.

  1. Перейдіть до об'єкта в дереві навігації.

  2. Коли на об'єкті натисніть клавіші Shift + F10, щоб відкрити контекстне меню.

  3. У меню натискайте клавішу TAB, доки не дійдете до параметра табличного подання даних , а потім натисніть клавішу вводу, щоб вибрати його. Об'єкт відкриється в поданні табличного подання даних.

    Якщо параметр табличного подання даних недоступний, потрібно ввімкнути подання для об'єкта. Щоб отримати вказівки, виберіть елемент увімкнути режим табличного подання даних для об'єкта.

Увімкнення режиму табличного подання даних для об'єкта

  1. Щоб відкрити контекстне меню, натисніть клавіші Shift + F10, коли об'єкт у дереві для переходу.

  2. У меню натисніть клавішу г, щоб відкрити Режим конструктора.

  3. У режимі конструкторанатисніть клавішу F4, щоб відкрити область " аркуш властивостей ".

  4. Натисніть клавішу F6 один раз. Фокус переходить до рядка властивостей в області " аркуш властивостей ". Ви почуєте номер рядка, а потім – вміст у клітинці властивості.

  5. Щоб перемістити фокус до розкривного списку тип вибору , натискайте клавіші SHIFT + TAB, доки не пролунає фраза "ціле поле", а потім поточне значення, а також "зі списком редагувати". Якщо поточне значення – форма, можна перейти до наступного кроку. В іншому разі натисніть клавіші Alt + стрілка вниз, щоб розгорнути список, а потім натискайте клавішу зі стрілкою вгору або вниз, доки не почуєте фразу "форма", а потім натисніть клавішу пробіл, щоб вибрати його.

  6. В області " аркуш властивостей " натискайте клавішу TAB, доки не пролунає фраза "вибраний елемент вкладки", наприклад "елемент вкладки даних", вибрано. Якщо поточна вкладка – вкладка Формат , можна перейти до наступного кроку. В іншому разі натискайте клавішу зі стрілкою вліво або вправо, доки не пролунає фраза "Format Tab (формат)". Відобразяться властивості вкладки Формат .

  7. На вкладці Формат натискайте клавішу TAB, доки не пролунає фраза "Row Four, No, згорнутого". Фокус міститься в властивості " Дозволити подання даних ". Щоб установити значення так, натисніть клавіші Alt + стрілка вниз, а потім натискайте клавішу зі стрілкою вгору, а потім натисніть клавішу вводу, щоб вибрати нове значення.

  8. Щоб закрити область " аркуш властивостей ", натисніть клавішу F4.

  9. Щоб відкрити виділений об'єкт у вікні табличного подання даних, натисніть клавіші ALT + е, г, в, а потім – H.

Див. також

Створення таблиць у настільних базах даних Access за допомогою невізуального екрана

Створення запиту в локальних базах даних Access за допомогою невізуального екрана

Створення форми в настільних базах даних Access за допомогою невізуального екрана

Експорт таблиці Access до текстового файлу за допомогою невізуального екрана

Сполучення клавіш в Access

Огляд і навігація в Access за допомогою невізуального екрана

Технічна підтримка клієнтів з особливими потребами

Корпорація Майкрософт прагне забезпечити якомога кращі умови роботи для всіх своїх клієнтів. Якщо у вас є особливі потреби або ви маєте запитання щодо спеціальних можливостей, зверніться по технічну підтримку до служби Microsoft Disability Answer Desk. Її фахівці чудово знають, як використовувати численні спеціальні засоби, і можуть надавати допомогу англійською, іспанською, французькою й американською мовами жестів. Щоб отримати контактні дані для свого регіону, перейдіть на сайт служби Microsoft Disability Answer Desk.

Якщо ви користувач у державній установі, комерційній організації або на підприємстві, зверніться до корпоративної служби підтримки Disability Answer Desk.

Примітка.:  Цю сторінку перекладено за допомогою засобу автоматичного перекладу, тому вона може містити смислові, синтаксичні або граматичні помилки. Ми вважаємо, що цей вміст стане вам у пригоді. Повідомте нас, чи була ця інформація корисною. Для довідки цю статтю можна переглянути англійською мовою.

Удосконалення навичок роботи з Office
Ознайомтеся з навчальними матеріалами
Отримуйте нові функції раніше за інших
Приєднайтеся до оцінювачів Office

Ця інформація корисна?

Дякуємо за ваш відгук!

Дякуємо, що знайшли час і надіслали нам відгук! Можливо, у нас не буде часу відповісти на кожен коментар, але докладемо максимум зусиль, щоб переглянути їх усі. Вас цікавить, як ми використовуємо ваші відгуки?

×