Як змінити настройки Windows для надання спільного доступу до бази даних Диспетчера бізнес-контактів користувачам на інших комп’ютерах?

Увага! : Цю статтю перекладено за допомогою служби машинного перекладу; див. застереження. Версію цієї статті англійською мовою див. тут для отримання довідки.

Ознаки

Ви або адміністратор повинні змінити деякі настройки Microsoft Windows на комп’ютері, перш ніж надавати спільний доступ до бази даних Диспетчера бізнес-контактів користувачам на інших комп’ютерах. В іншому випадку користувачі не зможуть підключитися до спільної бази даних на цьому комп’ютері.

Примітка :  Якщо ви використовуєте операційну систему Windows XP Home, базу даних можна спільно використовувати лише на одному комп’ютері, оскільки в цій версії не підтримується надання спільного доступу в мережі.

Увага! :  Наведені нижче зміни може внести лише адміністратор.

Причина

Засоби Windows, такі як брандмауер Windows і простий спільний доступ до файлів, призначені для захисту даних на комп’ютері. Щоб надати іншим користувачам доступ до даних на своєму комп’ютері, потрібно змінити настройки цих засобів.

Вирішення

Примітка :  Усі ці настройки можна змінити за допомогою майстра керування спільним доступом. Ці процедури необхідні лише зрідка.

Увійдіть на комп’ютер із правами адміністратора та змініть зазначені нижче настройки. (Якщо у вас немає прав адміністратора, передайте ці відомості адміністратору, щоб він змінив настройки замість вас).

Внесення змін до настройок Windows

Нижченаведені вказівки допоможуть вам або адміністратору зрозуміти вплив цих змін і переглянути поточні настройки, перш ніж додавати зміни вручну.

Операційна система Windows XP

  • Змінення настройок брандмауера Windows

    Щоб надати користувачам доступ до спільної бази даних із віддалених комп’ютерів, потрібно надати дозвіл на підключення (це називається "виняток") через брандмауер Windows. Крім того, потрібно додати до списку винятків спільний доступ до файлів і принтерів.

    Примітка :  Базу даних Диспетчера бізнес-контактів не можна використовувати спільно з користувачами на іншому комп’ютері, якщо в Центрі безпеки Microsoft у діалоговому вікні Брандмауер Windows на вкладці Загальні встановлено прапорець Заборонити виняткові ситуації. За замовчуванням винятки заборонено. Якщо змінити настройки брандмауера, для надбудови "Диспетчер бізнес-контактів для Outlook" буде автоматично знято цей прапорець, щоб надати дозвіл на доступ до спільної бази даних. Іноді через поточні настройки брандмауера системі Windows не вдається автоматично зняти прапорець Заборонити виняткові ситуації. Тоді його потрібно зняти вручну.

    За замовчуванням винятки брандмауера настроюються лише для локальної підмережі, до якої входить відповідний комп’ютер. Локальна підмережа позначається числом, яке використовується разом з IP-адресою комп’ютера, щоб розділяти велику мережу на менші. Через це до спільної бази даних можуть отримувати доступ лише користувачі, комп’ютери яких входять до цієї підмережі.

    Ось як можна надати доступ до спільної бази даних користувачу, комп’ютер якого не входить до вашої підмережі.

    1. У меню кнопки Пуск виберіть Панель керування.

    2. На панелі керування перейдіть до класичного вигляду.

    3. Двічі клацніть піктограму Брандмауер Windows.

    4. У діалоговому вікні Брандмауер Windows перейдіть на вкладкуВинятки.

    5. Виберіть пункт Microsoft Small Business і натисніть кнопку Змінити.

    6. Натисніть кнопку Змінити область.

    7. Виберіть один із таких параметрів:

      • Виберіть параметр Настроюваний список, а потім введіть одну або кілька IP-адрес через крапку з комою.

      • Виберіть параметр Будь-який комп’ютер (у тому числі з Інтернету).

    8. Натисніть кнопку OK, щоб закрити всі діалогові вікна.

      Додаткові відомості про брандмауер

      Якщо на комп’ютері використовується інший брандмауер замість того, що входить до складу операційної системи Microsoft Windows (наприклад, брандмауер мережевого маршрутизатора або антивірусної програми), можливо, у випадку надання спільного доступу до даних для комп’ютера за межами брандмауера для надбудови "Диспетчер бізнес-контактів для Outlook" не вдасться відкрити порт, потрібний для спільного використання бази даних. Якщо виникнуть неполадки під час використання бази даних спільно з користувачами, комп’ютери яких розташовано за межами брандмауера, необхідно відкрити порт ТСР 5356, щоб спільно використовувати базу даних. Докладні відомості про відкриття цього порту див. в документації для відповідного брандмауера.

      Якщо ви видалите всі до спільної бази даних, зміни, внесені до настройок брандмауера комп'ютера та Microsoft SQL Server Native Client мережні протоколи, якщо ви вирішили надати спільний доступ до баз даних все ще будуть діяти. Якщо потрібно відновити до брандмауера та мережні протоколи SQL Server власного клієнта власні настройки за замовчуванням, спочатку припинити надання спільного доступу до кожної бази даних а потім видаліть бази даних. Додаткові відомості про закрити спільний доступ до бази даних розділ надати спільний доступ до даних Диспетчера бізнес-контактів з іншими користувачами та Видалити бази даних у Диспетчері бізнес-контактів.

  • Змінення настройок спільного доступу до файлів і принтерів

    Іноді для надбудови "Диспетчер бізнес-контактів для Outlook" не можна автоматично настроїти потрібні параметри брандмауера Windows. У цьому випадку потрібно вручну ввімкнути спільний доступ до файлів і принтерів як виняток.

    Установіть прапорець Спільний доступ до файлів і принтерів.

    1. Натисніть кнопку Пуск і виберіть пункт Панель керування.

    2. На панелі керування клацніть піктограму Брандмауер Windows.

    3. У діалоговому вікні Брандмауер Windows перейдіть на вкладкуВинятки.

    4. На вкладці Винятки встановіть прапорець Спільний доступ до файлів і принтерів і натисніть кнопку OK.

  • Змінення настройок простого спільного доступу до файлів

    Функція простого спільного доступу до файлів дає змогу визначити всіх віддалених користувачів як користувачів із дозволом "Гість". Щоб керувати доступом до бази даних, потрібно надати дозвіл на доступ до неї окремим користувачам. Щоб зробити це, необхідно зняти прапорець Використовувати простий спільний доступ до файлів.

    Зніміть прапорець Простий спільний доступ до файлів.

    1. Натисніть кнопку Пуск і виберіть пункт Панель керування.

    2. На панелі керування клацніть піктограму Параметри папки.

    3. У діалоговому вікні Параметри папки відкрийте вкладку Вигляд.

    4. На вкладці Вигляд зніміть прапорець Використовувати простий спільний доступ до файлів (рекомендовано).

    5. Натисніть кнопку OK, щоб закрити всі діалогові вікна.

Windows Vista

  • Змінення настройок брандмауера Windows

    1. Натисніть кнопку Пуск і виберіть пункт Панель керування.

    2. На панелі керування перейдіть до класичного вигляду.

    3. Двічі клацніть піктограму Брандмауер Windows.

    4. У діалоговому вікні Брандмауер Windows поруч із пунктом Брандмауер Windows увімкнуто натисніть кнопку Змінити настройки.

    5. У діалоговому вікні Настройки брандмауера Windows перейдіть на вкладку Винятки.

    6. Виберіть пункт Microsoft Small Business і натисніть кнопку Властивості.

    7. Натисніть кнопку Змінити область.

    8. Виконайте одну з таких дій:

      • Клацніть параметр Будь-який комп’ютер (у тому числі з Інтернету).

      • Виберіть параметр Настроюваний список, а потім введіть одну або кілька IP-адрес, розділивши їх комами.

    9. Натисніть кнопку OK, щоб закрити всі діалогові вікна.

      Примітка :  Надбудову "Диспетчер бізнес-контактів для Outlook" не можна запустити, якщо в діалоговому вікні Настройки брандмауера Windows на вкладці Загальні встановлено прапорець Блокувати всі вхідні підключення. За замовчуванням винятки заборонено. Якщо змінити настройки брандмауера для надбудови "Диспетчер бізнес-контактів для Outlook", буде автоматично знято цей прапорець, щоб надати дозвіл на доступ до спільної бази даних. Іноді через поточні настройки брандмауера Windows не вдається автоматично зняти прапорець Блокувати всі вхідні підключення. Тоді його потрібно зняти вручну.

  • Змінення настройок спільного доступу до файлів і принтерів

    Іноді для надбудови "Диспетчер бізнес-контактів для Outlook" не можна автоматично настроїти потрібні параметри брандмауера Windows. У цьому випадку потрібно вручну ввімкнути спільний доступ до файлів і принтерів як виняток.

    Установіть прапорець Спільний доступ до файлів і принтерів.

    1. Натисніть кнопку Пуск і виберіть пункт Панель керування.

    2. На панелі керування перейдіть до класичного вигляду.

    3. Двічі клацніть піктограму Брандмауер Windows.

    4. У діалоговому вікні Брандмауер Windows в області ліворуч клацніть посилання Дозвіл програми через брандмауер Windows.

    5. На вкладці Винятки встановіть прапорець Спільний доступ до файлів і принтерів і натисніть кнопку OK.

Windows 7

  • Змінення настройок брандмауера Windows

    1. Натисніть кнопку Пуск і виберіть пункт Панель керування.

    2. Клацніть категорію Система й безпека, а потім виберіть пункт Брандмауер Windows.

    3. В області ліворуч клацніть посилання Додаткові параметри.

      Примітка :  Якщо відобразиться повідомлення Служба захисту користувачів, натисніть кнопку Так.

    4. В області ліворуч у вікні Брандмауер Windows із додатковими настройками безпеки клацніть пункт Вхідні правила.

    5. У центральній області в списку Вхідні правила двічі клацніть пункт Microsoft Small Business.

    6. У діалоговому вікні Microsoft Small Business – властивості перейдіть на вкладку Область.

    7. Виконайте одну з таких дій:

      • У розділах Локальна IP-адреса та Віддалена IP-адреса виберіть параметр Будь-яка IP-адреса.

      • У розділах Локальна IP-адреса та Віддалена IP-адреса виберіть параметр Ці IP-адреси та додайте одну або кілька IP-адрес.

    Примітка :  Щоб отримати докладні відомості про ці параметри, виберіть посилання Докладно про настройку області.

    1. Натисніть кнопку OK.

  • Змінення настройок спільного доступу до файлів і принтерів

    1. Натисніть кнопку Пуск і виберіть пункт Панель керування.

    2. Клацніть категорію Система й безпека, а потім виберіть пункт Брандмауер Windows.

    3. В області ліворуч виберіть посилання Дозволити програму або функцію через брандмауер Windows.

    4. Натисніть кнопку Змінити параметри.

      Примітка :  Якщо відобразиться повідомлення Служба захисту користувачів, натисніть кнопку Так.

    5. У списку Дозволені програми та функції установіть прапорець поруч із параметром Спільний доступ до файлів і принтерів і натисніть кнопку OK.

Змінення конфігурації програми Microsoft SQL Server Express

Змінення конфігурації програми Microsoft SQL Server Express 2008, щоб користувачі віддалених комп’ютерів мали дозвіл на доступ до спільної бази даних

За замовчуванням під час інсталяції програми SQL Server Express 2008 для надбудови "Диспетчер бізнес-контактів для Outlook" надається можливість підключення лише для користувачів на локальному комп’ютері.

Коли база даних Диспетчера бізнес-контактів стає спільною, для надбудови "Диспетчер бізнес-контактів для Outlook" автоматично активується підтримка мережі, щоб користувачі на інших комп'ютерах могли підключатися до спільної бази даних, увімкнувши протокол TCP/IP та протокол іменованих каналів.

Щоб вручну активувати підтримку мережі та надати користувачам дозвіл на підключення до бази даних із віддаленого комп’ютера, зробіть ось що:

  1. Відкрийте меню Пуск і наведіть курсор миші на пункт Усі програми.

  2. Виберіть пункт Microsoft SQL Server 2008.

  3. Послідовно клацніть елементи Інструменти настроювання та Диспетчер конфігурацій SQL Server.

  4. У вікні Диспетчер конфігурацій SQL Server в області ліворуч розгорніть елемент Настроювання мережі SQL Server і виберіть пункт Протоколи для MSSMLBIZ.

  5. В області праворуч клацніть правою кнопкою миші пункт Іменовані канали та виберіть команду Увімкнути.

  6. У вікні в області праворуч клацніть правою кнопкою миші пункт TCP/IP й виберіть команду Увімкнути.

Закрийте вікно Диспетчер конфігурацій SQL Server.

На початок сторінки

Примітка : Застереження про машинний переклад: Цю статтю перекладено комп’ютерною системою без втручання людини. Корпорація Майкрософт пропонує таку послугу, щоб іншомовні користувачі могли дізнаватися про продукти, служби й технології Microsoft. Оскільки статтю перекладено за допомогою служби машинного перекладу, вона може містити смислові, синтаксичні або граматичні помилки.

Отримуйте нові функції раніше за інших
Приєднайтеся до оцінювачів Office

Ця інформація корисна?

Дякуємо за ваш відгук!

Дякуємо за відгук! Схоже, вам може стати в нагоді допомога одного з наших спеціалістів служби підтримки Office, з яким ми вас можемо з’єднати.

×