Створення злиття

Увага! : Цю статтю перекладено за допомогою служби машинного перекладу; див. застереження. Версію цієї статті англійською мовою див. тут для отримання довідки.

Злиття використовується для створення великої кількості документів, які є майже ідентичними, але містять певну унікальну інформацію. Наприклад, за допомогою злиття можна створити настроювані публікації, які містять особисті відомості користувачів. Можна також використати злиття для створення оголошення про товар, щоб надіслати його 100 найголовнішим клієнтам. Текст публікації завжди однаковий, але імена й адреси клієнтів — різні.

Використайте область завдань Злиття для покрокового виконання процедури злиття. Щоб відкрити область завдань Злиття в новій або наявній публікації відкрийте меню Знаряддя, виберіть послідовно пункти Поштові розсилки й каталоги та Злиття.

У цій статті

Створення або підключення до списку одержувачів

Підготовка публікації

Створення Об'єднаних публікації

Скасування злиття

Створення або підключення до списку одержувачів

Щоб виконати злиття, потрібно відкрити нову або наявну публікацію та підключитися до файлу джерела даних, який містить унікальну інформацію для додавання до публікації. Файл даних може містити список імен і адрес, дані про продукт або зображення. Файл даних може мати такі формати:

  • списки контактів Microsoft Office Outlook;

  • аркуші Microsoft Office Excel;

  • таблиці Microsoft Office Word;

  • таблиці баз даних Microsoft Office Access;

  • текстові файли, стовпці в яких розділені знаками табуляції або комами, а строки — символами абзацу

Можна підключитися до наявного списку чи джерела даних або можна створити новий список одержувачів. Якщо потрібно використовувати лише окремі записи у списку, можна фільтрувати список за спеціальними критеріями. Можна також сортувати елементи в алфавітному порядку.

Примітка : Якщо сторінки публікації потрібно злити із зображеннями, джерело даних має містити імена файлів або шляхи до потрібних файлів зображень. Не додавайте зображення до джерела даних.

Використання наявного списку

  1. У групі Створення списку одержувачів виберіть параметр Використання наявного списку та виберіть посилання Далі: Створення або підключення до списку одержувачів.

    За промовчанням у Microsoft Publisher джерела даних зберігаються в папці Мої джерела даних. Можливо, потрібно буде перейти до іншого розташування джерела даних.

  2. У діалоговому вікні Вибір джерела даних виберіть потрібне джерело даних.

  3. Натисніть кнопку Відкрити.

    Залежно від вибраного типу джерела даних можуть відображатися діалогові вікна, що вимагають введення певних відомостей.

    Наприклад, якщо джерелом даних є книга Microsoft Office Excel із відомостями на кількох аркушах, потрібно вибрати аркуш, що містить потрібні відомості, а потім натиснути кнопку ОК.

Вибір із контактів Outlook

  1. У групі Створення списку одержувачів виберіть пункт Вибрати з контактів Outlook, після чого виберіть посилання Далі: Створення або підключення до списку одержувачів.

  2. Якщо відобразиться запит на вибір профілю пошти, виберіть потрібний профіль і натисніть кнопку ОК.

  3. У діалоговому вікні Вибір контактів виберіть потрібний список контактів і натисніть кнопку OK.

    Всі контакти в папці відображаються в діалоговому вікні Одержувачі злиття, в якому можна фільтрувати та сортувати список одержувачів для включення до злиття.

Створення нового списку

Створіть новий список за відсутності наявного списку, до якого можна підключитися.

  1. У групі Створення списку одержувачів виберіть параметр Введення нового списку та виберіть посилання Далі: Створення або підключення до списку одержувачів.

  2. У діалоговому вікні Новий список адрес введіть відомості для першого запису у відповідних полях. Не обов’язково заповнювати всі поля.

  3. Коли введення відомостей для першого запису завершено, натисніть кнопку Створити запис.

  4. Повторіть кроки 2 та 3, доки не буде завершено додавання записів, відтак натисніть кнопку OK.

  5. У діалоговому вікні Збереження списку адрес введіть ім’я списку адрес у полі Ім’я файлу та виберіть папку для збереження списку.

    За промовчанням у Microsoft Publisher джерела даних зберігаються в папці Мої джерела даних. Рекомендовано зберігати список адрес у цій папці, оскільки в ній також виконується пошук джерела даних за промовчанням.

    Всі контакти у списку відображаються в діалоговому вікні Одержувачі злиття, в якому можна фільтрувати та сортувати список одержувачів для включення до злиття.

Вибір одержувачів

У діалоговому вікні Одержувачі злиття можна вибрати одержувачів для додавання до злиття. Встановіть прапорці поруч з одержувачами, яких потрібно додати, і зніміть прапорці поруч з одержувачами, яких потрібно виключити.

Якщо у списку потрібно використати лише певні записи, можна застосувати фільтр за певним полем або критерієм. Після фільтрування списку записи можна включати або виключати за допомогою прапорців.

Фільтрування елементів списку

  1. Клацніть стрілку поруч із заголовком стовпця елемента, за яким потрібно виконати фільтрування.

  2. Виберіть один із таких параметрів:

    • (Пусті). Буде відображено всі записи, в яких відповідне поле пусте.

    • (Непусті) відображає всі записи, відповідні поля яких містять відомості.

    • (Додатково) відкриває діалогове вікно Фільтр і сортування, призначене для фільтрування за кількома критеріями. Можна також вибрати пункт Фільтр у розділі Уточнити список одержувачів у діалоговому вікні Одержувачі злиття, щоб відкрити діалогове вікно Фільтр і сортування.

      Порада : Якщо джерело даних містить записи з однаковими даними, а стовпець містить не більше десяти унікальних значень, можна добирати за певними даними. Наприклад, якщо є декілька адрес, в яких як країну або регіон зазначено Австралію, то можна добрати за словом Австралія.

      У діалоговому вікні Одержувачі злиття відображаються лише зазначені записи. Щоб заново відобразити всі записи, виберіть параметр (Усі)

Якщо потрібно відобразити елементи в алфавітному порядку, можна виконати сортування елементів у списку.

Сортування елементів списку

  • У діалоговому вікні Одержувачі злиття клацніть заголовок стовпця елемента, за яким потрібно виконати сортування.

    Наприклад, якщо потрібно відображати елементи списку в алфавітному порядку за прізвищем, виберіть заголовок стовпця Прізвище.

  • Щоб швидко вибрати або скасувати вибір усіх елементів, установіть або зніміть прапорець заголовка стовпця.

  • Для сортування за кількома критеріями виберіть пункт Сортування у групі Уточнити список одержувачів у діалоговому вікні Одержувачі злиття. У діалоговому вікні Фільтр і сортування виберіть критерії, за якими потрібно сортувати.

Натисніть кнопку ОК, щоб повернутися до області завдань Злиття.

На початок сторінки

Підготовка публікації

Під час злиття об’єднуються документ, який містить однакові для всіх копій відомості, і унікальні для кожної копії покажчики місця заповнення інформації. Після створення публікації вставте потрібний додатковий текст, який має відображатися в кожній версії публікації злиття, наприклад, привітання, а також покажчики місця заповнення унікальних даних, наприклад, адреси.

Якщо цього ще не зроблено, вставте текстове поле, введіть текст, який має відображатися в кожній версії публікації злиття, і додайте покажчики місця заповнення унікальної інформації.

Вставлення текстового поля

  1. На панелі інструментів об'єкти натисніть кнопку Текстове поле Зображення кнопки .

  2. У публікації наведіть вказівник на місце, в якому має відображатися один кут текстового поля, і перетягніть вказівник по діагоналі, доки текстове поле не матиме потрібний розмір.

Вставлення тексту, який потрібно відобразити в кожній версії

  • Клацніть у текстовому полі та введіть текст, який має відображатися в кожній версії публікації злиття.

Вставлення полів даних у публікацію

  1. У публікації клацніть у текстовому полі, до якого слід додати поле даних.

  2. Вставте будь-які з таких елементів:

    Блок адреси з ім’ям, адресою та іншими відомостями

    1. У області завдань Злиття (Крок 2: Підготовка публікації) в розділі Інші елементи виберіть посилання Блок адреси.

    2. У діалоговому вікні Вставлення блока адреси виберіть елементи адреси, які слід включити, відтак натисніть кнопку ОК.

      Примітка : Якщо імена поле даних у джерелі даних не збігаються з іменами полів даних, які використовуються у програмі Publisher для блоків адреси, можливо, знадобиться натиснути кнопку Добір полів у діалоговому вікні Вставлення блока адреси. У діалоговому вікні Добір полів за допомогою розкривних списків виберіть у джерелі даних поля, які відповідають полям у програмі Publisher.

    Рядок привітання

    1. В області завдань Злиття (Крок 2: Підготовка публікації) в розділі Інші елементи виберіть посилання Рядок привітання.

    2. У діалоговому вікні Вставити рядок привітання виберіть формат рядка привітання, який містить звертання, ім’я та розділовий знак, який іде після імені.

    3. Виберіть текст, який відображатиметься, якщо програмі Publisher не вдасться інтерпретувати ім’я одержувача, наприклад, якщо джерело даних не містить імені або прізвища одержувача, а лише назву установи.

    4. Натисніть кнопку OK.

      Примітка : Якщо імена полів даних у джерелі даних не збігаються з іменами полів, які використовуються у програмі Publisher для рядка привітання, можливо, знадобиться натиснути кнопку Добір полів у діалоговому вікні Рядок привітання. У діалоговому вікні Добір полів за допомогою розкривних списків виберіть у джерелі даних поля, які відповідають полям програми Publisher.

    Поля «адреса»

    1. В області завдань Злиття (Крок 2: Підготовка публікації) у групі Інші елементи виберіть пункт Поля адрес.

    2. У діалоговому вікні Вставлення поля адреси виберіть кожен елемент адреси, який слід додати.

      Примітка : Якщо імена полів даних у джерелі даних не відповідають іменам, які використовуються в Publisher для полів адрес, можливо, знадобиться натиснути кнопку Добір полів у діалоговому вікні Вставлення поля адреси. У діалоговому вікні Добір полів використайте розкривні списки для вибору полів у джерелі даних, які відповідатимуть полям у Publisher.

    Інших полів відомостей

    В області завдань Злиття (Крок 2: Підготовка публікації) перетягніть поле, яке потрібно додати, зі списку Підготовка публікації до текстового поля, створеного для публікації.

Форматування полів даних

За потреби можна застосувати форматування до полів даних і будь-якого іншого доданого тексту (наприклад, привітання Привіт або звертання Шановний...), щоб змінити вигляд об’єднаних даних. Щоб форматувати об’єднані дані, потрібно форматувати поля даних у публікації злиття.

  1. У публікації злиття виберіть поле з відомостями, які слід форматувати.

  2. У меню Формат виберіть пункт Шрифт, а потім виберіть потрібні параметри.

Попередній перегляд даних одержувача в полях даних публікації

Наразі можна переглядати публікацію зі справжніми даними в об’єднаних полях.

  1. Для попереднього перегляду публікації виконайте одну з таких дій:

    • Щоб переглянути записи в порядку, натисніть кнопку навігації кнопки вперед Кнопка «Назад» бачити кожного запису, як виглядатиме Об'єднаних публікації.

      Відомості з першого запису джерела даних заповнюють поля злиття. Не можна редагувати записи джерела даних на сторінках публікації, але можна форматувати, переміщати та видаляти поля даних.

    • Щоб знайти та переглянути певний запис у джерелі даних, виберіть посилання Знайти одержувача та введіть умови пошуку в діалоговому вікні Пошук елемента.

  2. За потреби внесіть зміни до списку одержувачів. Виконайте одну з таких дій:

    • Щоб вилучити зі злиття певного одержувача, натисніть кнопку Виключити одержувача.

    • Щоб змінити список одержувачів, виберіть посилання Редагувати список одержувачів і введіть зміни в діалоговому вікні Одержувачі злиття.

  3. Після завершення злиття публікації та вставлення всіх полів злиття виберіть команду Зберегти як у меню Файл. Введіть ім’я публікації в полі Ім’я файлу та натисніть кнопку Зберегти.

  4. Виберіть посилання Далі: Створення злитих публікацій.

На початок сторінки

Створення об’єднаної публікації

В області завдань Злиття в розділі Створення злитих публікацій можна виконати такі дії:

  • Надрукувати об’єднану публікацію (наприклад, для надсилання поштою)

  • Переглянути об’єднану публікацію (щоб побачити її вигляд, перш ніж буде надруковано всі версії та вирішено всі потенційні питання)

  • Зберегти об’єднану публікацію для подальшого використання

  • Додати об’єднані сторінки до іншої публікації

Попередній перегляд об’єднаної публікації

  • Виберіть посилання Попередній перегляд друку.

Друк об’єднаної публікації

  1. Виберіть посилання Друк.

  2. У діалоговому вікні Друк виберіть потрібні параметри та натисніть кнопку OK.

    Увага! : Друк наборів даних злиття, наприклад, різні імена й адреси – на кожному аркуші паперу, виберіть пункт кілька сторінок на аркуші , у розділі Параметри друку . Якщо вибрати кілька копій на аркуші, кожного аркуша паперу міститиме кілька копій однакові дані.

    EuropeRegistry-BP-Настроювання-5-1

Збереження об’єднаної публікації для подальшого використання

Якщо ви хочете змінення Об'єднаних сторінок, зберегти їх для подальшого використання або роздрукувати їх пізніше, можна збирати та зберегти всі об'єднані сторінки як один новий об'єднані публікації, яка містить фактичних даних, наприклад імена й адреси, замість поля злиття.

  1. Виберіть посилання Злиття в нову публікацію.

    Створено нову публікацію з використанням об’єднаних сторінок.

  2. У новій публікації виберіть посилання Зберегти публікацію на панелі завдань Злиття. Введіть ім’я нової публікації в полі Ім’я файлу та натисніть кнопку Зберегти.

Додавання об’єднаних сторінок до наявної публікації

Якщо потрібно додати об’єднані сторінки в кінці наявної публікації, переконайтеся, що публікація злиття відповідає наявній публікації за такими параметрами:

  • Розмір сторінки (висота й ширина)

  • Подання сторінки (односторонній або двосторонній аркуш)

  • Тип публікації (для Інтернету або друку)

  • Порядок сторінок (зліва направо або справа наліво)

Об’єднані сторінки додаються до нової або наявної публікації, але їх не можна додати їх до відкритої публікації. Якщо публікація, до якої потрібно додати сторінки, відкрита, збережіть і закрийте публікацію до завершення злиття.

  1. Виберіть посилання Додати до наявної публікації.

  2. У діалоговому вікні Відкриття публікації знайдіть публікацію, до якої потрібно додати об’єднані сторінки, і натисніть кнопку Відкрити.

    Об’єднані сторінки буде додано до наявної публікації.

  3. У наявній публікації виберіть посилання Зберегти публікацію в області завдань Злиття, щоб зберегти оновлення.

Збереження публікації зі злиттям

Якщо зберегти публікацію з полями злиття, ви також зможете відредагувати поля злиття та створити нову злиту публікацію з новими полями злиття або оновленим списком одержувачів. Щоб зберегти публікацію зі злиттям, виконайте такі дії:

  1. Переконайтеся, що ви працюєте з публікацією зі злиттям.

  2. У меню Файл виберіть команду Зберегти.

  3. Введіть ім’я для публікації зі злиттям і натисніть кнопку Зберегти.

На початок сторінки

Скасування злиття

Злиття можна скасувати, відключивши публікацію злиття або шаблон злиття в каталог від відповідного джерело даних.

  1. У меню Знаряддя наведіть вказівник миші на пункт Поштові розсилки й каталоги, а потім виберіть пункт Скасувати злиття.

  2. У відповідь на запит підтвердити скасування злиття натисніть кнопку Так.

Публікацію буде відключено від джерела даних.

Примітка : У разі скасування процесу злиття всі поля, окрім полів адреси, рядків привітання та блоків адрес, буде перетворено на звичайний текст.

На початок сторінки

Примітка : Застереження про машинний переклад: Цю статтю перекладено комп’ютерною системою без втручання людини. Корпорація Майкрософт пропонує таку послугу, щоб іншомовні користувачі могли дізнаватися про продукти, служби й технології Microsoft. Оскільки статтю перекладено за допомогою служби машинного перекладу, вона може містити смислові, синтаксичні або граматичні помилки.

Отримуйте нові функції раніше за інших
Приєднайтеся до оцінювачів Office

Ця інформація корисна?

Дякуємо за ваш відгук!

Дякуємо за відгук! Схоже, вам може стати в нагоді допомога одного з наших спеціалістів служби підтримки Office, з яким ми вас можемо з’єднати.

×