Створення або запуск макросу

У програмі Word можна автоматизувати часто виконувані завдання, створюючи та запускаючи макроси. Макрос – це набір команд та інструкцій, об’єднаних в одну команду для автоматичного виконання завдання.

Щоб заощадити час на завданнях, які часто виконуються, об’єднайте кроки в макросі. Спочатку запишіть макрос, а потім запустіть його, натиснувши кнопку на панелі швидкого доступу або сполучення клавіш. Це залежить від настройок.

  1. На вкладці Вигляд у групі Макроси виберіть команду Записати макрос.

    Команда "Записати макрос"

  2. Введіть ім’я макросу.

    Поле "Ім’я макросу"

  3. Щоб використовувати цей макрос у будь-яких нових документах, переконайтеся, що в рядку Зберегти макрос у вказано значення Усі документи (Normal.dotm).

    Рядок вибору розташування для збереження макросу

  4. Щоб запускати макрос за допомогою кнопки, натисніть кнопку кнопці.

    Призначення макросу кнопці

  5. Клацніть новий макрос (він називатиметься Normal.NewMacros.<ім’я макросу>) та натисніть кнопку Додати.

    Макрос і кнопка "Додати"

  6. Натисніть кнопку Змінити.

    Кнопка "Змінити" у вікні "Настроювання панелі швидкого доступу"

  7. Виберіть зображення кнопки, введіть потрібне ім’я та двічі натисніть кнопку OK.

    Параметри кнопки у вікні "Змінення кнопки"

  8. Тепер необхідно записати кроки виконання завдання. Клацніть команди або натисніть клавіші для кожного кроку в завданні. Програма Word запише всі ваші клацання та натискання клавіш.

    Примітка : Під час записування макросу використовуйте клавіатуру, щоб виділити текст. Макроси не записують дії, виконані за допомогою миші.

  9. Щоб зупинити записування, відкрийте вкладку Вигляд, у групі Макроси виберіть команду Зупинити запис.

    Команда "Зупинити записування"

Кнопка для нового макросу з’явиться на панелі швидкого доступу.

Кнопка макросу на панелі швидкого доступу

Щоб запустити макрос, натисніть цю кнопку.

  1. На вкладці Вигляд у групі Макроси виберіть команду Записати макрос.

    Команда "Записати макрос"

  2. Введіть ім’я макросу.

    Поле "Ім’я макросу"

  3. Щоб використовувати цей макрос у будь-яких нових документах, переконайтеся, що в рядку Зберегти макрос у вказано значення Усі документи (Normal.dotm).

    Рядок вибору розташування для збереження макросу

  4. Щоб макрос запускався натисканням сполучення клавіш, натисніть кнопку клавішам.

    Призначення макросу сполученню клавіш

  5. У поле Нове сполучення клавіш введіть потрібне сполучення клавіш.

  6. Перевірте, чи введену комбінацію ще не призначено для чогось іншого. Якщо призначено, спробуйте іншу комбінацію клавіш.

  7. Щоб використовувати це сполучення клавіш у будь-яких нових документах, переконайтеся, що в рядку Зберегти зміни до вказано значення Normal.

  8. Натисніть кнопку Призначити.

  9. Тепер необхідно записати кроки виконання завдання. Клацніть команди або натисніть клавіші для кожного кроку в завданні. Програма Word запише всі ваші клацання та натискання клавіш.

    Примітка : Під час записування макросу використовуйте клавіатуру, щоб виділити текст. Макроси не записують дії, виконані за допомогою миші.

  10. Щоб зупинити записування, відкрийте вкладку Вигляд, у групі Макроси виберіть команду Зупинити запис.

    Команда "Зупинити записування"

Щоб запустити макрос, натисніть відповідне сполучення клавіш.

Щоб запустити макрос, натисніть кнопку на панелі швидкого доступу, скористайтеся сполученням клавіш або ж запустіть його зі списку Макроси.

  1. Відкрийте вкладку Вигляд, у списку Макроси виберіть команду Макроси.

    Команда "Макроси"

  2. У списку в розділі Ім’я макросу клацніть макрос, який слід запустити.

  3. Натисніть кнопку Виконати.

Щоб макрос з одного документа був доступний в інших нових документах, його потрібно додати до шаблону Normal.dotm.

  1. Відкрийте документ, що містить макрос.

  2. Відкрийте вкладку Вигляд, у списку Макроси виберіть команду Макроси.

    Команда "Макроси"

  3. Натисніть кнопку Організатор.

    Кнопка "Організатор" у вікні "Макрос"

  4. Клацніть макрос, який слід додати до шаблону Normal.dotm, і натисніть кнопку Копіювати.

  1. Послідовно виберіть елементи Файл > Параметри > Настроювання стрічки.

  2. У списку Вибрати команди виберіть елемент Макроси.

  3. Виберіть потрібний макрос.

  4. У списку Настроїти стрічку виберіть вкладку та спеціальну групу, куди слід додати макрос.

Якщо спеціальної групи немає, натисніть кнопку Додати групу. Потім натисніть кнопку Перейменувати та введіть назву для спеціальної групи.

  1. Натисніть кнопку Додати.

  2. Натисніть кнопку Перейменувати, щоб вибрати зображення макросу та ввести потрібне ім’я.

  3. Двічі натисніть кнопку OK.

  1. На вкладці Розробник у групі Код натисніть кнопку Макроси.

  2. У полі Ім’я макросу введіть ім’я для макросу.

    Примітка : Якщо новому макросу призначити ім’я, що збігається з іменем вбудованого макросу у Word, нові дії макросу замінять вбудований макрос. Щоб переглянути список вбудованих макросів, у списку Макроси з клацніть Команд Word.

  3. У списку Макроси з клацніть шаблон або документ, у якому потрібно зберегти макрос.

    Щоб зробити макрос доступним в усіх документах, обов’язково клацніть Normal.dotm.

  4. Натисніть кнопку Створити, щоб відкрити редактор Visual Basic.

Якщо ви відкриєте редактор Visual Basic, можливо, вам знадобиться дізнатися більше про роботу з Visual Basic for Applications. Щоб отримати докладні відомості, клацніть Довідка Microsoft Visual Basic у меню Довідка або натисніть клавішу F1.

Ви можете записати послідовність дій або створити макрос із нуля, ввівши код мовою Visual Basic for Applications у Редактор Visual Basic.

Примітка : Щоб працювати з макросами в програмі Office Word 2007, потрібно відобразити вкладку Розробник.

  1. Натисніть кнопку Microsoft Office Зображення кнопки Office , а потім – Параметри Word.

  2. Виберіть категорію Найуживаніші.

  3. У розділі Основні параметри роботи з Word установіть прапорець Відображати вкладку "Розробник" на стрічці.

    Примітка : Стрічка – це компонент інтерфейсу користувача Microsoft Office Fluent.

  1. На вкладці Розробник у групі Код натисніть кнопку Записати макрос.

    Група "Код" на вкладці "Розробник"
  2. У полі Ім’я макросу введіть ім’я для макросу.

    Примітка : Якщо новому макросу призначити ім’я, що збігається з іменем вбудованого макросу в програмі Office Word 2007, нові дії макросу замінять вбудований макрос. Щоб переглянути список вбудованих макросів, на вкладці Розробник у групі Код натисніть кнопку Макроси. У списку Макроси з виберіть пункт Команд Word.

  3. У списку Зберегти макрос у клацніть шаблон або документ, у якому потрібно зберегти макрос.

    Увага! : Щоб зробити макрос доступним в усіх документах, обов’язково клацніть Normal.dotm.

  4. У полі Опис введіть опис макросу.

  5. Виконайте одну з таких дій:

    • Розпочніть записування.    Щоб розпочати записування макросу, не призначаючи його кнопці на панелі швидкого доступу або сполученню клавіш, натисніть кнопку OK.

    • Створіть кнопку.    Щоб призначити макрос кнопці на панелі швидкого доступу, зробіть ось що.

      1. Клацніть кнопці.

      2. У розділі Настроювання панелі швидкого доступу виберіть документ (або всі документи), для яких на панель швидкого доступу потрібно додати макрос.

        Увага! : Щоб зробити макрос доступним в усіх документах, обов’язково клацніть Normal.dotm.

      3. У діалоговому вікні Вибрати команди клацніть макрос, який ви записуєте, а потім натисніть кнопку Додати.

      4. Щоб налаштувати кнопку, клацніть Змінити.

      5. У полі Символ виберіть потрібний символ для кнопки.

      6. У полі Коротке ім’я введіть ім’я макросу, яке потрібно відобразити.

      7. Двічі натисніть кнопку OK, щоб розпочати записування макросу.

        Вибраний символ відобразиться на панелі швидкого доступу. Введене ім’я відображатиметься, якщо на цей символ навести вказівник миші.

    • Призначте сполучення клавіш.    Щоб призначити макрос сполученню клавіш, зробіть ось що.

      1. Клацніть клавішам.

      2. У полі Команди виберіть макрос, який ви записуєте.

      3. У полі Нове сполучення клавіш введіть потрібну послідовність клавіш, а потім натисніть кнопку Призначити.

      4. Натисніть кнопку Закрити, щоб розпочати записування макросу.

  6. Виконайте дії, які потрібно включити в макрос.

    Примітка : Під час записування макросу можна клацати мишею команди й параметри, але не виділяти текст. Для виділення тексту використовується клавіатура. Докладні відомості про виділення тексту за допомогою клавіатури див. в статті Виділення тексту.

  7. Щоб припинити записування дій, клацніть Зупинити записування в групі Код.

Змінення сполучення клавіш для макросу

  1. Натисніть кнопку Microsoft Office  Зображення кнопки Office , а потім – Параметри Word.

  2. Виберіть команду Настроювання.

  3. Поруч із пунктом Сполучення клавіш клацніть Настроїти.

  4. У списку Категорії клацніть елемент Макроси.

  5. У списку Макроси клацніть макрос, який потрібно змінити.

  6. У полі Нове сполучення клавіш введіть потрібне сполучення клавіш.

  7. У полі Поточні сполучення перевірте, чи сполучення клавіш, яке ви призначаєте, не використовується для іншого завдання.

  8. У списку Зберегти зміни до виберіть варіант, який відповідає місцю, з якого потрібно запускати макрос.

    Увага! : Щоб зробити макрос доступним в усіх документах, обов’язково клацніть Normal.dotm.

  9. Натисніть кнопку Закрити.

  1. На вкладці Розробник у групі Код натисніть кнопку Макроси.

    Група "Код" на вкладці "Розробник"

  2. У списку в розділі Ім’я макросу клацніть макрос, який потрібно запустити.

  3. Натисніть кнопку Виконати.

  1. На вкладці Розробник у групі Код натисніть кнопку Макроси.

    Група "Код" на вкладці "Розробник"

  2. У полі Ім’я макросу введіть ім’я для макросу.

    Примітка : Якщо новому макросу призначити ім’я, що збігається з іменем вбудованого макросу в програмі Office Word 2007, нові дії макросу замінять вбудований макрос. Щоб переглянути список вбудованих макросів, у списку Макроси з клацніть Команд Word.

  3. У списку Макроси з клацніть шаблон або документ, у якому потрібно зберегти макрос.

    Щоб зробити макрос доступним в усіх документах, обов’язково клацніть Normal.dotm.

  4. Натисніть кнопку Створити, щоб відкрити редактор Visual Basic.

Якщо ви відкриєте редактор Visual Basic, можливо, вам знадобиться дізнатися більше про роботу з Visual Basic for Applications. Щоб отримати докладні відомості, клацніть Довідка Microsoft Visual Basic у меню Довідка або натисніть клавішу F1.

Отримуйте нові функції раніше за інших
Приєднайтеся до оцінювачів Office

Ця інформація корисна?

Дякуємо за ваш відгук!

Дякуємо за відгук! Схоже, вам може стати в нагоді допомога одного з наших спеціалістів служби підтримки Office, з яким ми вас можемо з’єднати.

×