Перехід до опублікованого шаблону форми в бібліотеці SharePoint

Увага! : Цю статтю перекладено за допомогою служби машинного перекладу; див. застереження. Версію цієї статті англійською мовою див. тут для отримання довідки.

У цій статті

Огляд

Попередня інформація

Отримати робочу копію шаблону форми

Крок 1: Публікування шаблону форми в бібліотеці документів

Крок 2: Копіювання та повторне зв'язування наявних форм

Огляд

Після публікування шаблону форми в бібліотеці документів для заповнення користувачами може знадобитися переміщення цього шаблону форми до іншої бібліотеки документів. Наприклад, може знадобитися перемістити шаблон форми на сервер із більшим обсягом пам’яті, щоб більше користувачів мали змогу заповнювати форму одночасно. Можливо, деякі користувачі вже заповнили форми, створені на основі шаблону форми, збереженому у вихідній бібліотеці документів. У разі переміщення шаблону форми до нової бібліотеки документів може виникнути потреба також перемістити наявні форми. Перед архівацією або видаленням старої бібліотеки документів потрібно також переконатися, що ці наявні форми працюватимуть у новій бібліотеці документів.

Порада : Перед переміщенням опублікованих шаблонів форми до нової бібліотеки документів створіть план, який сповіщатиме, що форми було переміщено до нової бібліотеки документів. Нову бібліотеку документів потрібно використати для збереження нових форм або змінення наявних. План має також містити опис процесу архівації або видалення вихідної бібліотеки документів.

Щоб перемістити шаблон форми та наявні форми до нової бібліотеки документів, спочатку потрібно опублікувати робочу копію шаблону форми в новій бібліотеці документів. Робочою копією є версія, яка зберігається на комп'ютері або у програмі керування версіями, наприклад, Microsoft Visual SourceSafe.

Порада : За відсутності робочої копії шаблону форми на комп'ютері можна зберегти копію шаблону форми з вихідної бібліотеки документів для використання як робочої копії.

Після публікування робочої копії в новій бібліотеці документів усі форми зі старої бібліотеки документів потрібно скопіювати до нової бібліотеки, відтак повторно зв'язати форми в новій бібліотеці з останнім опублікованим шаблоном форми.

За необхідності внесення змін унаслідок переміщення шаблону форми внесіть ці зміни перед публікуванням шаблону форми. Наприклад, розташування зовнішніх джерел даних, які використовуються формами, створеними на основі цього шаблону форми, може також змінитися внаслідок переміщення шаблону форми. У такому разі перед публікуванням шаблону форми потрібно змінити зв’язок даних у шаблоні форми на нове розташування зовнішніх джерел даних. Посилання на докладніші відомості щодо змінення зв’язків даних див.у розділі Див. також.

Примітка : Публікування шаблону форми – це не так само, як збереження шаблону форми. Під час публікування шаблону форми, майстер публікацій додає розташування та обробки інструкцій до шаблону форми, щоб користувачі мали змогу відкривати форми, на основі цього шаблону форми. Під час збереження шаблону форми, зберігається копію шаблону форми, так само, як під час збереження файлу на комп'ютері. Майстер публікації завжди повинні використовувати, коли ви хочете, щоб зробити шаблон форми для заповнення користувачами.

На початок сторінки

Перш ніж почати

Перед переміщенням шаблону форми та будь-яких форм, створених на основі цього шаблону форми, до нової бібліотеки документів знадобляться такі елементи:

  • Робоча копія шаблону форми    Це копія шаблону форми, яку буде змінено та повторно опубліковано в новій бібліотеці документів. Робочу копію можна зберегти на комп'ютері або у програмі керування версіями, наприклад, Visual SourceSafe.

  • Розташування нових зовнішніх джерел даних    Якщо форми, створені на основі шаблону форми, використовують змінені зовнішні джерела даних, знадобляться нові розташування зовнішніх джерел даних. Дізнайтеся в адміністратора про наявність у користувачів відповідних дозволів на використання зовнішніх джерел даних. Якщо шаблон форми використовує настройки у файлі зв’язку даних для підключення до зовнішнього джерела даних, перевірте, чи файл зв’язку даних було оновлено за допомогою нового розташування зовнішнього джерела даних.

  • Відповідні права на сервері з Windows SharePoint Services 3.0    Для публікування шаблону форми та копіювання наявних форм зі старої бібліотеки документів до нової потрібно мати відповідні права на сервері. Перевірте в адміністратора наявність цих прав.

На початок сторінки

Отримання робочої копії шаблону форми

Якщо потрібно змінити шаблон форми, опублікований у бібліотеці документів або у спільному мережному розташуванні, за відсутності робочої копії шаблону форми, можна зберегти робочу копію з розташування для публікації на комп'ютері.

Порада : Для керування робочими копіями шаблонів форми краще використати програму керування версіями, наприклад, Microsoft Visual SourceSafe.

Збереження на комп'ютері копії шаблону форми з бібліотеки документів

  1. У браузері відкрийте бібліотеку документів, в якій було опубліковано шаблон форми.

  2. У меню настройки виберіть пункт Параметрита натисніть кнопку Настройки бібліотеки форм.

  3. У групі Загальні параметри натисніть кнопку Додаткові параметри.

  4. У розділі Шаблон документа натисніть кнопку Змінити шаблон.

    У Microsoft Office InfoPath буде відкрито шаблон форми.

  5. У діалоговому вікні Microsoft Office InfoPath натисніть кнопку Так.

  6. У меню Файл виберіть команду Зберегти як.

  7. У діалоговому вікні Microsoft Office InfoPath натисніть кнопку OK.

  8. У діалоговому вікні Збереження документа знайдіть розташування, в якому потрібно зберегти копію шаблону форми, та натисніть кнопку Зберегти.

Збереження на комп'ютері копії шаблону форми зі спільної мережної папки

  1. У меню файл виберіть макет шаблону форми.

  2. У групі Відкрити шаблон форми виберіть пункт На моєму комп’ютері.

  3. Відкрийте спільну мережну папку опублікованого шаблона форми, клацніть шаблон і натисніть кнопку Open.

  4. У меню Файл виберіть команду Зберегти як.

  5. У діалоговому вікні Microsoft Office InfoPath натисніть кнопку OK.

  6. У діалоговому вікні Save As відкрийте папку (відмінну від папки початкової публікації), в якій має бути збережено копію шаблона форми, і натисніть кнопку Save.

На початок сторінки

Крок 1: Публікування шаблону форми в новій бібліотеці документів

  1. У режимі конструктора відкрийте робочу копію шаблону форми.

  2. У меню Файл виберіть команду Опублікувати.

  3. У майстрі публікацій виберіть пункт На сервері SharePoint зі службами InfoPath Forms Services або без них і натисніть кнопку Далі.

  4. У полі Введіть розташування сайту SharePoint або InfoPath Forms Services введіть розташування сайту SharePoint, що містить нову бібліотеку документів, до якої потрібно перемістити шаблон форми, відтак натисніть кнопку Далі.

  5. На наступній сторінці майстра виберіть пункт Бібліотека документів, відтак натисніть кнопку Далі.

  6. Виберіть пункт Створити нову бібліотеку документів, відтак натисніть кнопку Далі.

  7. На наступній сторінці майстра введіть ім'я й опис нової бібліотеки документів, відтак натисніть кнопку Далі.

  8. Виберіть поля в шаблоні форми, які потрібно відобразити як стовпці в поданні бібліотеки документів за промовчанням.

    Інструкції

    1. Натисніть кнопку Додати.

    2. Виберіть поле, яке потрібно додати як стовпець до бібліотеки документів, і виконайте одну з таких дій.

      • Введіть ім’я стовпця в полі Ім’я стовпця.

      • Виберіть стовпець на вузлі у списку Site column group, виберіть ім'я в полі Column name і натисніть кнопку OK.

        Примітка : Якщо вибрано повторюване поле для відображення даних у бібліотеці документів, можна вибрати спосіб відображення поля в бібліотеці документів, клацнувши значення у списку Function. Доступні варіанти: відображення першого значення в полі, останнього значення в полі, кількості значень у полі, а також злиття всіх значень.

    3. Натисніть кнопку ОК.

    Посилання на докладніші відомості про відображення даних у стовпцях бібліотеки документів див. у розділі Див. також.

  9. Натисніть кнопку Далі.

  10. На наступній сторінці майстра перевірте правильність відображених відомостей, відтак натисніть кнопку Публікація.

  11. Щоб відкрити бібліотеку документів і перевірити процес заповнення форми, створеної на основі цього шаблону форми, встановіть прапорець Відкрити цю бібліотеку документів, відтак натисніть кнопку Закрити.

    Бібліотека документів буде відкрито у браузері. У разі натискання кнопки Створити на панелі інструментів списку в Microsoft Office InfoPath буде відкрито форму, створену на основі цього шаблону форми.

Після публікування шаблону форми в новій бібліотеці документів можна скопіювати наявні форми, створені на основі попередньої версії шаблону форми, зі старої бібліотеки бібліотеки до нової. Після копіювання наявних форм їх можна повторно зв'язати з новою версією шаблону форми. Якщо не зв'язати наявні форми, їх не можна буде відкрити.

На початок сторінки

Крок 2: Копіювання та повторне зв'язування наявних форм

Ця процедура передбачає, що обидві бібліотеки документів перебувають на сервері з Windows SharePoint Services 3.0.

  1. Відкрийте стару бібліотеку документів у браузері.

  2. У меню Вигляд виберіть пункт Подання провідника.

  3. Натисніть і утримуйте клавішу CTRL, виберіть усі форми, які потрібно перемістити, відтак клацніть правою кнопкою миші одну з форм.

  4. У діалоговому вікні Internet Explorer натисніть кнопку Так, відтак у контекстному меню виберіть команду Копіювати.

  5. Відкрити нову бібліотеку документів.

  6. У розділі Вибір подання виберіть пункт Подання провідника.

  7. Клацніть правою кнопкою миші в пустій області вікна папки.

  8. У діалоговому вікні Internet Explorer натисніть кнопку Так, відтак у контекстному меню виберіть команду Вставити.

  9. У меню Вигляд виберіть пункт Повторне зв'язування документів.

  10. У стовпці Повторне зв'язування встановіть прапорець для кожної форми, яку потрібно зв'язати з новим шаблоном форми.

  11. На панелі інструментів списку виберіть елемент Повторно зв’язати вибрані документи.

Після повторного зв'язування наявних форм із новим шаблоном форми можна буде змінити наявні форми, скопійовані до нової бібліотеки документів, або заповнити нові форми, створені на основі щойно опублікованого шаблону форми.

На початок сторінки

Примітка : Застереження про машинний переклад: Цю статтю перекладено комп’ютерною системою без втручання людини. Корпорація Майкрософт пропонує таку послугу, щоб іншомовні користувачі могли дізнаватися про продукти, служби й технології Microsoft. Оскільки статтю перекладено за допомогою служби машинного перекладу, вона може містити смислові, синтаксичні або граматичні помилки.

Отримуйте нові функції раніше за інших
Приєднайтеся до оцінювачів Office

Ця інформація корисна?

Дякуємо за ваш відгук!

Дякуємо за відгук! Схоже, вам може стати в нагоді допомога одного з наших спеціалістів служби підтримки Office, з яким ми вас можемо з’єднати.

×