Надсилання даних форми в повідомленні електронної пошти

Увага! : Цю статтю перекладено за допомогою служби машинного перекладу; див. застереження. Версію цієї статті англійською мовою див. тут для отримання довідки.

Існує можливість додавання до шаблону форми допоміжного зв’язку даних для надсилання, який дозволить користувачам надсилати дані в повідомленнях електронної пошти. Для визначення адреси електронної пошти, на яку потрібно надсилати форму, рядка теми повідомлення електронної пошти та імені форми можна використовувати статичні значення, значення на основі даних у формі або формули. Можна також вибрати відображення форми в тексті повідомлення електронної пошти або як вкладення до повідомлення.

Якщо шаблон форми настроєно для додавання форми як вкладення до повідомлення електронної пошти, можна також вкласти до повідомлення шаблон форми. У разі додавання форми й шаблону форми як вкладення до повідомлення електронної пошти можна бути впевненим, що одержувач повідомлення зможе відкрити форму за допомогою програми Microsoft Office InfoPath, навіть якщо в нього немає шаблону форми, кешованого на комп’ютері. Для відкриття вкладення користувач повинен мати інстальовану програму InfoPath.

Під час надсилання даних форми в повідомленні електронної пошти у програмі InfoPath створюється повідомлення електронної пошти з даними форми, після чого повідомлення надсилається до одержувачів, визначених під час створення зв’язку даних. Якщо користувачі, що отримують заповнені форми, використовують програму Microsoft Office Outlook 2007, вони можуть додати вкладену папку до папки «Вхідні» для зберігання усіх отриманих форм InfoPath і настроїти цю папку для відображення даних форм у вигляді стовпців у програмі Outlook.

Після додавання зв’язку даних для надсилання потрібно настроїти шаблон форми для надсилання даних користувачами. У результаті під час відкриття форми у програмі InfoPath автоматично додається кнопка Надіслати до панелі інструментів Стандартна і команда Надіслати — до меню Файл. Можна також настроїти параметри надсилання для шаблону форми таким чином:

  • Змінити текст кнопки Надіслати на панелі інструментів Стандартна та команди Надіслати в меню Файл.

  • Змініть сполучення клавіш для кнопки Надіслати на панелі інструментів Стандартна та команди Надіслати в меню Файл.

  • Створити настроюване повідомлення, яке відображатиметься під час надсилання форм.

  • Визначити, чи потрібно залишити форму після надсилання відкритою, закрити її або відкрити іншу пусту форму.

На початок сторінки

Додавання зв’язку даних для надсилання

  1. У меню Tools виберіть команду Submit Options.

  2. У діалоговому вікні Submit Options установіть прапорець Allow users to submit this form.

  3. Натисніть кнопку Надіслати дані форми до одного розташування, а потім у списку виберіть Електронна пошта.

  4. Натисніть кнопку Додати.

  5. У майстрі зв’язків даних у відповідних полях введіть адреси електронної пошти одержувачів, тему повідомлення електронної пошти й будь-який вступний текст і натисніть кнопку Далі.

    Порада : Можна також визначити формулу для створення значення в кожному полі, крім поля Вступ.

    Інструкції

    1. Натисніть кнопку Вставити формулу зображення кнопки .

    2. У діалоговому вікні Вставлення формули виконайте одну з таких дій:

      • Для використання поля у формулі натисніть кнопку Вставити поле або групу, виберіть потрібне поле в діалоговому вікні Вибір поля або групи, а потім натисніть кнопку ОК.

      • Для використання функції у формулі натисніть кнопку Вставити функцію, виберіть потрібну функцію в діалоговому вікні Вставлення функції і натисніть кнопку ОК.

        Порада : Якщо для функції потрібні певні параметри, виберіть функцію в діалоговому вікні Вставлення функції, натисніть кнопку ОК, а потім у полі Формула діалогового вікна Вставлення формули двічі клацніть додану функцію та виберіть поле або групу. Посилання та додаткові відомості про функції див. у розділі Див. також.

      • Для додавання значення або математичного оператора до формули введіть значення або символ для математичного оператора у полі Формула.

    Операція

    Символ

    Додавання

    +

    Віднімання

    -

    Множення

    *

    Ділення

    /

    • Примітка : Якщо у формулі використовується оператор ділення (/), переконайтеся, що перед ним і після нього стоїть пробіл. Якщо перед і після оператора не стоїть пробіл, символ «/» розпізнається програмою InfoPath як роздільник кроків розташування XPath, а не як оператор ділення.

    • Щоб перевірити синтаксис формули, в діалоговому вікні Вставлення формули виберіть пункт Перевірити формулу.

      Посилання на додаткові відомості про формули див. у розділі Див. також.

  6. На наступній сторінці майстра виконайте одну з таких дій:

    1. Для відображення форми в тексті повідомлення електронної пошти натисніть кнопку Надіслати лише активне подання форми без вкладення.

    2. Для надсилання даних форми як вкладення до повідомлення електронної пошти, натисніть кнопку Надіслати дані форми як вкладення, встановіть прапорець Вкласти шаблон форми, щоб користувачі могли відкрити форму і введіть ім’я форми у полі Ім'я вкладення. Можна також визначити поле або використати формулу, щоб переконатися в унікальності кожного імені форми.

      Інструкції

      1. Натисніть кнопку Вставити формулу зображення кнопки .

      2. У діалоговому вікні Вставлення формули виконайте одну з таких дій:

        • Для використання поля у формулі натисніть кнопку Вставити поле або групу, виберіть потрібне поле в діалоговому вікні Вибір поля або групи, а потім натисніть кнопку ОК.

        • Для використання функції у формулі натисніть кнопку Вставити функцію, виберіть потрібну функцію в діалоговому вікні Вставлення функції і натисніть кнопку ОК.

          Порада : Якщо для функції потрібні певні параметри, виберіть функцію в діалоговому вікні Вставлення функції, натисніть кнопку ОК, а потім у полі Формула діалогового вікна Вставлення формули двічі клацніть додану функцію та виберіть поле або групу. Посилання та додаткові відомості про функції див. у розділі Див. також.

        • Для додавання значення або математичного оператора до формули введіть значення або символ для математичного оператора у полі Формула.

      Операція

      Символ

      Додавання

      +

      Віднімання

      -

      Множення

      *

      Ділення

      /

      • Примітка : Якщо у формулі використовується оператор ділення (/), переконайтеся, що перед ним і після нього стоїть пробіл. Якщо перед і після оператора не стоїть пробіл, символ «/» розпізнається програмою InfoPath як роздільник кроків розташування XPath, а не як оператор ділення.

      • Щоб перевірити синтаксис формули, в діалоговому вікні Вставлення формули виберіть пункт Перевірити формулу.

        Посилання на додаткові відомості про формули див. у розділі Див. також.

      Примітка : Для відкриття даних форми у вигляді вкладення користувач повинен мати інстальовану програму InfoPath.

  7. Натисніть кнопку Далі.

  8. На наступній сторінці майстра введіть у полі Enter a name for this data connection описове ім'я цього підключення для надсилання даних.

  9. Перевірте правильність інформації в розділі Зведення, відтак натисніть кнопку Готово.

    1. Щоб змінити ім'я кнопки Надіслати », що відображається на панелі інструментів Стандартна і команди Надіслати , що з'являється в меню файл » під час заповнення форми, введіть нове ім'я в полі " назва ", у діалоговому вікні Параметри надсилання .

      Порада : Якщо потрібно призначити цій кнопці та команді сполучення клавіш, амперсанда (&) перед символом, який потрібно використати як сполучення клавіш. Наприклад, щоб призначити сполучення клавіш ALT + B як сполучення клавіш для команди і кнопка " Надіслати ", введіть Su & bmit.

  10. Щоб заборонити користувачам викликати команду Submit або натискати кнопку Submit на панелі інструментів Standard під час заповнення форми, зніміть прапорець Show the Submit menu item and the Submit toolbar button.

    1. За замовчуванням після надсилання заповненої форми вона залишається відкритою в InfoPath і з'являється повідомлення про успішне надсилання. Щоб змінити цю поведінку, натисніть кнопку Advanced і виконайте одну з таких дій.

      • Щоб після надсилання заповненої форми вона закривалася або створювалася нова пуста форма, виберіть відповідний параметр у списку After submit.

      • Щоб створити спеціальні повідомлення, які мають відображатися в разі успішного та невдалого надсилання форми, установіть прапорець Use custom messages і введіть бажаний текст повідомлень у поля On success і On failure.

        Порада : Повідомлення в полі On failure має вказувати користувачам потрібні дії, якщо форму не вдалося надіслати. Наприклад, у ньому можна рекомендувати користувачам зберегти форму та звернутися до певної особи за вказівками.

      • Щоб заборонити показ повідомлення після надсилання форми, зніміть прапорець Show success and failure messages.

На початок сторінки

Примітка : Застереження про машинний переклад: Цю статтю перекладено комп’ютерною системою без втручання людини. Корпорація Майкрософт пропонує таку послугу, щоб іншомовні користувачі могли дізнаватися про продукти, служби й технології Microsoft. Оскільки статтю перекладено за допомогою служби машинного перекладу, вона може містити смислові, синтаксичні або граматичні помилки.

Отримуйте нові функції раніше за інших
Приєднайтеся до оцінювачів Office

Ця інформація корисна?

Дякуємо за ваш відгук!

Дякуємо за відгук! Схоже, вам може стати в нагоді допомога одного з наших спеціалістів служби підтримки Office, з яким ми вас можемо з’єднати.

×