Змінення опублікованого шаблону форми

Увага! : Цю статтю перекладено за допомогою служби машинного перекладу; див. застереження. Версію цієї статті англійською мовою див. тут для отримання довідки.

Щоб внести зміни до опублікованого шаблону форми, змініть робочу копію шаблону форми, відтак повторно опублікуйте робочу копію у вихідному розташуванні для публікації.

У цій статті

Огляд

Отримати робочу копію шаблону форми

Повторне публікування зміненого шаблону форми в бібліотеці документів

Повторне публікування зміненого шаблону форми у спільній мережній папці

Огляд

Перед зміненням опублікованого шаблону форми слід пам’ятати, що ці зміни можуть вплинути на наявні форми, створені на основі цього шаблону форми. Наприклад, якщо змінити джерело даних у шаблоні форми, це може спричинити остаточне видалення даних у наявних формах, створених на основі цього шаблону.

Втрату даних можуть спричинити такі зміни шаблону форми:

  • Змінення типу поля або групи з повторюваного на неповторюваний

  • Змінення типу даних поле з форматуванням

  • Перейменування, переміщення або видалення поля або групи з джерела даних

    Примітка : Під час видалення елемента керування з шаблону форми поле або група, прив’язані до цього елемента керування, а також дані в цьому полі або групі залишаються у джерелі даних. Проте, дані в полі або групі не відображатимуться у формі, оскільки було видалено елемент керування, прив’язаний до поля або групи. Якщо видалити елемент керування з шаблону форми, для відображення даних поля або групи, прив’язаної до видаленого елемента керування, додайте до шаблону форми інший елемент керування, відтак прив’яжіть його до наявного поля або групи.

Для змінення опублікованого шаблону форми спочатку змініть робочу копію цього шаблону форми. Робочою копією є версія, яка зберігається на комп'ютері або у програмі керування версіями, наприклад, Microsoft Visual SourceSafe. Після змінення робочої копії її можна опублікувати в розташуванні для публікації. Якщо робоча копія шаблону форми відсутня, а шаблон форми опубліковано в бібліотеці документів на сервері зі службами Microsoft Windows SharePoint або у спільній мережній папці, копію шаблону форми з розташування для публікації можна зберегти на комп'ютері. Ця збережена версія стає робочою копією. Після цього можна змінити робочу копію та повторно її опублікувати у вихідному розташуванні для публікації. У разі публікування зміненого шаблону форми у вихідному розташуванні для публікації шаблон форми, який було опубліковано раніше, буде перезаписано зміненою версією.

Публікування шаблону форми – це не так само, як збереження шаблону форми. Під час публікування шаблону форми, майстер публікацій додає розташування та обробки інструкцій до шаблону форми, щоб користувачі мали змогу відкривати форми, на основі цього шаблону форми. Під час збереження шаблону форми, зберігається копію шаблону форми, так само, як під час збереження файлу на комп'ютері. Майстер публікації завжди повинні використовувати, коли ви хочете, щоб зробити шаблон форми для заповнення користувачами.

На початок сторінки

Отримання робочої копії шаблону форми

Якщо потрібно змінити шаблон форми, опублікований у бібліотеці документів або у спільному мережному розташуванні, за відсутності робочої копії шаблону форми, можна зберегти робочу копію з розташування для публікації на комп'ютері.

Порада : Для керування робочими копіями шаблонів форми краще використати програму керування версіями, наприклад, Microsoft Visual SourceSafe.

Збереження на комп'ютері копії шаблону форми з бібліотеки документів

  1. У браузері відкрийте бібліотеку документів, в якій було опубліковано шаблон форми.

  2. У меню настройки виберіть пункт Параметрита натисніть кнопку Настройки бібліотеки форм.

  3. У групі Загальні параметри натисніть кнопку Додаткові параметри.

  4. У розділі Шаблон документа натисніть кнопку Змінити шаблон.

    У Microsoft Office InfoPath буде відкрито шаблон форми.

  5. У діалоговому вікні Microsoft Office InfoPath натисніть кнопку Так.

  6. У меню Файл виберіть команду Зберегти як.

  7. У діалоговому вікні Microsoft Office InfoPath натисніть кнопку OK.

  8. У діалоговому вікні Збереження документа знайдіть розташування, в якому потрібно зберегти копію шаблону форми, та натисніть кнопку Зберегти.

Збереження на комп'ютері копії шаблону форми зі спільної мережної папки

  1. У меню файл виберіть макет шаблону форми.

  2. У групі Відкрити шаблон форми виберіть пункт На моєму комп’ютері.

  3. Відкрийте спільну мережну папку опублікованого шаблона форми, клацніть шаблон і натисніть кнопку Open.

  4. У меню Файл виберіть команду Зберегти як.

  5. У діалоговому вікні Microsoft Office InfoPath натисніть кнопку OK.

  6. У діалоговому вікні Save As відкрийте папку (відмінну від папки початкової публікації), в якій має бути збережено копію шаблона форми, і натисніть кнопку Save.

Примітка : Не зберігайте шаблон форми у спільній мережній папці, в якій шаблон форми було опубліковано раніше. У разі збереження шаблону форми у спільній мережній папці наявний шаблон форми буде перезаписано. У разі перезаписування наявного шаблону форми не можна буде відкрити наявні форми, створені на основі цього шаблону форми.

На початок сторінки

Повторне публікування зміненого шаблону форми в бібліотеці документів

Працюючи з шаблоном форми, який було раніше опубліковано в бібліотеці документів, після внесення всіх потрібних змін до робочої копії шаблону форми його можна повторно опублікувати в бібліотеці документів.

  1. У меню Файл виберіть команду Опублікувати.

  2. У майстрі публікацій виберіть пункт На сервері SharePoint зі службами InfoPath Forms Services або без них і натисніть кнопку Далі.

  3. На наступній сторінці майстра введіть розташування сайту SharePoint, на якому раніше було опубліковано шаблон форми, відтак натисніть кнопку Далі.

  4. На наступній сторінці майстра виберіть пункт Бібліотека документів, відтак натисніть кнопку Далі.

  5. На наступній сторінці майстра виберіть пункт Оновити шаблон форми в наявній бібліотеці документів, клацніть бібліотеку документів, в якій було раніше опубліковано шаблон форми, відтак натисніть кнопку Далі.

  6. Виберіть поля в шаблоні форми, які потрібно відобразити як стовпці в поданні бібліотеки документів за промовчанням.

    Інструкції

    1. Натисніть кнопку Додати.

    2. Виберіть поле, яке потрібно додати як стовпець до бібліотеки документів, і виконайте одну з таких дій.

      • Введіть ім’я стовпця в полі Ім’я стовпця.

      • Виберіть стовпець на вузлі у списку Site column group, виберіть ім'я в полі Column name і натисніть кнопку OK.

        Примітка : Якщо вибрано повторюване поле для відображення даних у бібліотеці документів, можна вибрати спосіб відображення поля в бібліотеці документів, клацнувши значення у списку Function. Доступні варіанти: відображення першого значення в полі, останнього значення в полі, кількості значень у полі, а також злиття всіх значень.

    3. Натисніть кнопку ОК.

    Посилання на докладніші відомості про відображення даних у стовпцях бібліотеки документів див.у розділі Див. також.

  7. На наступній сторінці майстра натисніть кнопку Публікація.

    Якщо шаблон форми опубліковано, на останній сторінці майстра з'явиться підтвердження.

  8. Виконайте одну з таких дій:

    1. Щоб відкрити бібліотеку документів і перевірити процес заповнення форми, створеної на основі цього шаблону форми, встановіть прапорець Відкрити цю бібліотеку документів і натисніть кнопку Закрити. Бібліотека документів відкриється у браузері. У разі натискання кнопки Створити на панелі інструментів списку в InfoPath відкриється форма, створена на основі цього шаблону форми.

      Порада : Якщо потрібно повідомити користувачів, що шаблон форми доступний для заповнення, надішліть їм повідомлення електронної пошти з посиланням на бібліотеку документів, де шаблон форми було опубліковано.

    2. Щоб надіслати користувачам форму та шаблон форми електронною поштою, установіть прапорець Надіслати форму одержувачам електронної пошти, а потім натисніть кнопку Закрити.

      Відкриється повідомлення електронної пошти з формою в тексті повідомлення, щоб ви могли заповнити її та надіслати користувачам. Якщо ваші користувачі мають програму Microsoft Office Outlook 2007, вони зможуть заповнити форму, коли відкриють повідомлення електронної пошти. Ті ж, хто мають програму Outlook попередньої версії або іншу програму електронної пошти, отримають повідомлення з вкладеними формою та шаблоном форми. Вони можуть відкрити вкладення шаблону форми та інсталювати шаблон форми на своєму комп’ютері, а потім відкрити вкладення форми та заповнити форму в програмі InfoPath.

      Порада : У полі Introduction в повідомленні електронної пошти зазначте, що користувачі повинні відкривати вкладення лише від надійних відправників.

На початок сторінки

Повторне публікування зміненого шаблону форми у спільній мережній папці

Працюючи з шаблоном форми, який було раніше опубліковано у спільній мережній папці, після внесення всіх потрібних змін до робочої копії шаблону форми його можна повторно опублікувати у спільній мережній папці.

  1. У меню Файл виберіть команду Опублікувати.

  2. У майстрі публікацій виберіть пункт У мережному розташуванні та натисніть кнопку Далі.

  3. На наступній сторінці майстра натисніть кнопку Огляд.

  4. Перейдіть до спільної мережної папки, де було опубліковано вихідний шаблон форми, клацніть ім'я шаблону форми, відтак натисніть кнопку ОК.

  5. На наступній сторінці майстра перевірте правильність шляху й імені шаблону форми в полі Ім'я шаблону форми, відтак натисніть кнопку Далі.

  6. На наступній сторінці майстра якщо у вас є додаткові шляхи цій спільній мережній папці, наприклад на загальнодоступних сторінкам Уніфікований покажчик ресурсу (URL), введіть шлях у поле.

  7. Натисніть кнопку Далі.

  8. На наступній сторінці майстра натисніть кнопку Публікація.

    Якщо шаблон форми опубліковано, на останній сторінці майстра з'явиться підтвердження.

  9. Виконайте одну з таких дій:

    • Щоб відкрити бібліотеку документів і перевірити процес заповнення форми, створеної на основі цього шаблону форми, встановіть прапорець Відкрити цю бібліотеку документів, відтак натисніть кнопку Закрити. Бібліотека документів відкриється у веб-браузері. У разі натискання кнопки Створити в меню Настройки в InfoPath відкриється форма, створена на основі цього шаблону форми.

      Порада : Якщо потрібно повідомити користувачів, що шаблон форми доступний для заповнення, надішліть їм повідомлення електронної пошти з посиланням на бібліотеку документів, де шаблон форми було опубліковано.

    • Щоб надіслати користувачам форму та шаблон форми електронною поштою, установіть прапорець Надіслати форму одержувачам електронної пошти, а потім натисніть кнопку Закрити.

      Відкриється повідомлення електронної пошти з формою в тексті повідомлення, щоб ви могли заповнити її та надіслати користувачам. Якщо ваші користувачі мають програму Microsoft Office Outlook 2007, вони зможуть заповнити форму, коли відкриють повідомлення електронної пошти. Ті ж, хто мають програму Outlook попередньої версії або іншу програму електронної пошти, отримають повідомлення з вкладеними формою та шаблоном форми. Вони можуть відкрити вкладення шаблону форми та інсталювати шаблон форми на своєму комп’ютері, а потім відкрити вкладення форми та заповнити форму в програмі InfoPath.

      Порада : У полі Introduction в повідомленні електронної пошти зазначте, що користувачі повинні відкривати вкладення лише від надійних відправників.

На початок сторінки

Примітка : Застереження про машинний переклад: Цю статтю перекладено комп’ютерною системою без втручання людини. Корпорація Майкрософт пропонує таку послугу, щоб іншомовні користувачі могли дізнаватися про продукти, служби й технології Microsoft. Оскільки статтю перекладено за допомогою служби машинного перекладу, вона може містити смислові, синтаксичні або граматичні помилки.

Отримуйте нові функції раніше за інших
Приєднайтеся до оцінювачів Office

Ця інформація корисна?

Дякуємо за ваш відгук!

Дякуємо за відгук! Схоже, вам може стати в нагоді допомога одного з наших спеціалістів служби підтримки Office, з яким ми вас можемо з’єднати.

×