Visio ile Web sitenizi denetim altına alma

Not: En güncel yardım içeriklerini, mümkün olduğunca hızlı biçimde kendi dilinizde size sunmak için çalışıyoruz. Bu sayfanın çevirisi otomasyon aracılığıyla yapılmıştır ve bu nedenle hatalı veya yanlış dil bilgisi kullanımları içerebilir. Amacımız, bu içeriğin sizin için faydalı olabilmesini sağlamaktır. Buradaki bilgilerin faydalı olup olmadığını bu sayfanın sonunda bize bildirebilir misiniz? Kolayca başvurabilmek için İngilizce makaleye buradan ulaşabilirsiniz.

Bir Web sitesinin günlük işlemleri yönetiyorsanız, sitenin genel yapısını ve akış Temizle resmini varsa, geliştirme değişiklikleri izleme ve izlemek ve kopuk köprüleri onarma için önemli olduğunu bilirsiniz. Tüm görevleri ve diğer Microsoft Office Visio Professional Web sitesi haritası araçlarıyla yapabilirsiniz.

Ne yapmak istiyorsunuz?

Sitenizin içeriğini eşleme

Sitenizi hataları otomatik olarak denetleme

Sitenize değişiklikleri izleme

Sitenizin içeriğini eşleme

Sitenizi yönetme geçerli durumunun çözümleme ile başlar. Sitenizi eşlerken bir güncel, grafiksel gösterimine sitenin yapısını ve içeriğini oluşturun.

Sitedeki bağlantıların gerçek hiyerarşik yapısını gösteren bir Web sitesi haritası

Her şekli site haritası bağlantısını Web sitenizde temsil eder ve her şekil için bir bağlantı türü ve konum hakkında bilgi içerir. Bir şekli sağ tıklatarak doğrudan şekilden Web konumuna göz atabilirsiniz.

  1. Visio'da, Dosya menüsünde Yeni'ninüzerine gelin, yazılım ve veritabanıüzerine gelin ve sonra Web sitesi haritası' ı tıklatın.

  2. Bir site adresi Site Haritası Oluştur iletişim kutusunda, aşağıdakilerden birini girin:

    • HTTP sunucusu için Adres kutusuna, eşlemek istediğiniz Web sitesinin adresini girin.

    • Bir ağ sunucusunda veya yerel sabit sürücü için Gözat' ı tıklatın, site haritanızı kökünde istediğiniz dosyaya gidin ve ' ı tıklatın.

  3. Site Haritası Oluştur iletişim kutusunda düzeyleri sayısı üst sınırı ve bulunacaktır bağlantıların sayısı ayarlarını gözden geçirmek için Ayarlar ' ı tıklatın.

  4. Ayarlarını değiştirmek için aşağıdakilerden birini yapın:

    • Düzen sekmesinde, kaç düzeyleri saptanan istediğiniz veya bir ağaç sıkıştırma veya bir Akış Çizelgesiçizimi olup olmadığı gösterilir sayısı gibi bir Web sitesi haritası düzen stilini değiştirin.

    • Uzantıları sekmesinde eşlemek istediğiniz dosyaları (.doc, .jpg veya gibi .exe) türünü seçin.

    • Protokoller sekmesinde eşlemek istediğiniz protokolleri (örneğin, mailto, ftp veya NNTP) seçin.

    • Öznitelikler sekmesinde, bağlantılar için arama yapmak istediğiniz HTML öznitelikleri (örneğin, HREF, SRC veya kod) seçin.

    • Gelişmiş sekmesinde, arama ölçütlerinizi ayrıntılandırmak seçenekleri seçin.

    • Tamam’a tıklayın.

  5. Site Haritası Oluştur iletişim kutusunda Tamam' ı tıklatın.

  6. Dosya menüsünde, site haritası kaydetmek için Kaydet' i tıklatın.

Sayfanın Başı

Sitenizi hataları otomatik olarak denetleme

Sitenizin bağlantıları etkin ve hatasız koruma en önemli Web sitesi yönetimi görevidir.

Sitenizi eşlerken, Visio, belirttiğiniz parametreler içindeki her bağlantı izleyen ve bulduğu hataları izler. Bunları aracılığıyla kırmızı X'ler şekillerle olarak filtre penceresinde ve listesi penceresinde, site haritası hatalı bağlantılar görünür. Bu windows Web sitesi haritası menüsünü göremiyorsanız, Windowsüzerine ve sonra Liste penceresini veya Filtre penceresinitıklatın. Çalışmanızı izleme ve gerekli onarımları yapmanıza yardımcı olmak için bunların ilişkili hatalı kopuk bağlantı listesini hemen oluşturabilirsiniz.

Site yapısını gösteren bir Web sitesi haritası; kırmızı X içeren şekiller bozuk bağlantıları gösterir

Sitenizde hatalı bağlantıları gösteren bir rapor oluşturma

  1. Bir hata raporu oluşturmak istediğiniz site haritası açın.

  2. Web sitesi haritası menüsünde, Raporlar' ın üzerine, Web sitesi haritası hatalı bağlantılar' ı tıklatın ve ardından Çalıştır' ı tıklatın.

  3. Hangi tür dosyaları (örneğin, Excel veya XML) istediğiniz kaydedilmiş bilgileri seçin ve Tamam' ı tıklatın.

    Visio köprü hatalı tüm bağlantıları gösteren bir rapor oluşturur.

  4. Raporunuzu açarsa, Microsoft Office Excel gibi bir Visio dışında bir programı adlandırın ve raporu kaydedin.

Bozuk bağlantıları düzeltme

Bazı kopuk bağlantı tarafından zaman aşımı hataları nedeniyle. Bu hataların çözmek için bağlantıyı sağ tıklatın ve sonra yenileme veya Yenileme üst' ı tıklatın.

Diğer kopuk bağlantı Site bulunamadı, erişim reddedildi veya parola gerekli veya yanlış dosya adları, yanlış dosya konumları ve bir 404 veya dosya bulunamadı hata iletisi tetikleyerek eksik dosyaları neden olduğu. Bunlardan herhangi birini Web sitenizdeki sabit gerekir.

Web sitenizi ve Web sitesi haritası dinamik olarak bağlı değildir; aşağıdakilerden birini değiştirmek otomatik olarak diğer etkilemez. Bozuk bağlantıları Web sitesinde düzeltme sonra site haritası güncelleştirebilirsiniz şekli sağ tıklatarak kopuk bağlantıyı temsil eden tıklattıktan sonra Köprü yenileyin. Kırmızı X kaybolur.

Sayfanın Başı

Sitenize değişiklikleri izleme

Sitenizde çalışan birkaç geliştiriciler varsa, bunların çalışmayı izleme hızlı bir şekilde tam zamanlı görev olabilir. Web sitesi haritası Karşılaştırma raporu kullanarak, belirli bir zaman aralığında yapılan değişiklikleri Some sitenizi iki sürümü karşılaştırabilirsiniz. Raporu iki sürümlerini karşılaştırır ve farkları listesi oluşturur. Bunu yalnızca haritalar yalnızca birinde görünen bağlantıları tanımlar, ancak ayrıca aşağıdaki iki haritalar bağlantı değişiklikleri listelenmektedir:

  • Hata durumu

  • Dosya başlık

  • Dosya boyutu

  • Dosya değiştirme tarihi

Örneğin, her haftanın sitede çalışmanın Some istediğinizi varsayalım. Sadece site hafta başındaki ve sonundaki yeniden eşleyin. Ardından değişiklikleri gösteren bir rapor oluşturmak için iki haritalar karşılaştırın. Ayrıca, bir Web sitesi projeniz üzerinde hedef olup olmadığını görmek haftanın için planlanmış çalışmayla programı karşı raporu ölçüsü olabilir.

Web sitesi haritalar karşılaştırma

  1. Web sitenizin en son haritayı açın.

  2. Web sitesi haritası menüsünde, önceki belgeyle Karşılaştır' ı tıklatın.

  3. Karşılaştır, dosyayı seçin ve ' ı tıklatın, istediğiniz Web sitesi haritası göz atın.

    Visio iki haritalar karşılaştırır ve farkları listeleyen bir HTML raporu oluşturur.

  4. Ad ve raporu kaydedin.

Sayfanın Başı

Office yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×