Toplam hakkında bilgi edinin

Not: En güncel yardım içeriklerini, mümkün olduğunca hızlı biçimde kendi dilinizde size sunmak için çalışıyoruz. Bu sayfanın çevirisi otomasyon aracılığıyla yapılmıştır ve bu nedenle hatalı veya yanlış dil bilgisi kullanımları içerebilir. Amacımız, bu içeriğin sizin için faydalı olabilmesini sağlamaktır. Buradaki bilgilerin faydalı olup olmadığını bu sayfanın sonunda bize bildirebilir misiniz? Kolayca başvurabilmek için İngilizce makaleye buradan ulaşabilirsiniz.

TOPLA işlevi hakkında daha fazla bilgi edinin

Bir hücre aralığının Toplamını hızlıca almak istiyorsanız aralığı seçip Excel penceresinin sağ alt kısmına bakmanız yeterlidir.

Bir hücre aralığı seçip Durum Çubuğu’na bakma ekran görüntüsü


Bu durum çubuğudur ve tek bir hücre veya birden çok hücre olsun, seçtiğiniz her şeye ilişkin bilgileri görüntüler. Durum Çubuğu’na sağ tıklarsanız belirleyebileceğiniz tüm seçeneklerin gösterildiği bir özellik iletişim kutusu açılır. Öznitelikleri işaretlediyseniz seçtiğiniz aralığın değerleri de gösterilir. 

Çalışma sayfanıza bir TOPLA formülü eklemenin en kolay yolu Otomatik Toplam Sihirbazı’nı kullanmaktır. Toplamak istediğiniz aralığın hemen üst veya altındaki boş bir hücreyi seçin ve Şerit’teki Giriş veya Formül sekmelerinde Otomatik Toplam > Toplam’a basın. Otomatik Toplam Sihirbazı toplanacak aralığı otomatik olarak algılar ve sizin yerinize formülü oluşturur. Toplanacak aralığın sol veya sağındaki bir hücreyi seçtiğinizde yatay olarak da çalışabilir. Bu işlev bitişik olmayan aralıklarda çalışmaz ancak bu konuyu sonraki bölümde ele alacağız.

Otomatik olarak bir Topla formülü oluşturmak için Otomatik Toplam Sihirbazı’nı kullanabilirsiniz.  Aralığın üstünden/altından veya solundan/sağından toplamak için bir aralık seçin ve Şerit’teki Formül sekmesine gidip Otomatik Toplam ve TOPLAM’ı seçin.


Otomatik Toplam iletişim kutusu, benzer diğer yaygın işlevleri de seçmenizi sağlar:

Dikey Otomatik Toplam

B6 hücresinde Otomatik Toplam Topla formülü gösterilir: =TOPLA(B2:B5)

Otomatik Toplam Sihirbazı, toplanacak aralık için otomatik olarak B2:B5 hücrelerini algıladı. Onaylamak için Enter tuşuna basmanız yeterlidir. Daha fazla hücre eklemeniz/hariç tutmanız gerekirse istediğiniz seçimi yapana kadar Shift Tuşu > istediğiniz ok tuşuna basılı tutun ve işiniz bitince Enter tuşuna basın.

IntelliSense işlev Kılavuzu: topla (Sayı1; [sayı2],...) işlevin altındaki kayan etiket, IntelliSense Kılavuzu. SUM veya işlev adına tıklarsanız, bu işlev, bu işlevin yardım konusuna götürür. Tek işlev öğelerini tıklatırsanız, formüldeki temsilci parçaları vurgulanacaktır. Bu formülde yalnızca bir numara başvurusu olduğundan B2: B5 vurgulanır. IntelliSense etiketi herhangi bir işlev için görüntülenir.

Yatay Otomatik Toplam

D2 hücresinde Otomatik Toplam Topla formülü gösterilir: =TOPLA(B2:C2)

Bitişik olmayan aralıklarla TOPLA işlevini kullanma.  C8 hücresindeki formül: =TOPLA(C2:C3,C5:C6). Formülün =TOPLA(Hafta1,Hafta2) olması için Adlandırılmış Aralıklar da kullanabilirsiniz.

Otomatik Toplam Sihirbazı genellikle yalnızca bitişik aralıklar için çalışır, bu nedenle toplam aralığınızda boş satır veya sütun varsa, Excel ilk boşluktur duracaktır. Bu durumda, tek tek aralıkları tek tek eklediğiniz seçime göre TOPLAMıNı almanız gerekir. Bu örnekte, B4 hücresinde verileriniz varsa, Excel bir bitişik aralığı tanıyacak şekilde = topla (C2: C6) oluşturur.

Ctrl + sol tıklatmaile birden çok bitişik olmayan aralıklar oluşturabilirsiniz. Öncelikle, "= topla (" yazın ve farklı aralıklarınızı seçin ve Excel sizin için aralıklar arasına otomatik olarak virgül ayırıcısını ekler. İşiniz bittiğinde ENTER tuşuna basın.

İpucu: Topla işlevini hızlıca bir hücreye eklemek için alt + = tuşlarını kullanabilirsiniz. Böylece yapmanız gereken tek şey aralığınızı seçin.

Not: Excel 'in farklı işlev aralıklarını renge göre vurgulayarak, C2: C3 bir renk ve C5: C6 başka bir işlevdir. Başvurulan Aralık farklı bir çalışma sayfasında veya farklı bir çalışma kitabındaysa, Excel bunu tüm işlevler için yapacak. Yardımcı teknolojiyle geliştirilmiş erişilebilirlik Için, "Hafta1", "Week2" gibi adlandırılmış aralıklarıkullanabilir ve sonra da Formülünüzde onlara başvurabilir:

=TOPLA(Hafta1,Hafta2)

  1. TOPLA işlevini diğer işlevlerin tamamıyla kullanabilirsiniz. Aşağıda aylık ortalamayı hesaplayan bir örnek verilmiştir:

    TOPLA işlevini diğer işlevlerle kullanma.  M2 hücresindeki formül: =TOPLA(A2:L2)/BAĞ_DEĞ_DOLU_SAY(A2:L2).  Not: Mayıs-Kasım sütunları anlaşılırlık için gizlenmiştir.
    • =TOPLA(A2:L2)/BAĞ_DEĞ_DOLU_SAY(A2:L2)

  2. A2:L2 TOPLAMINI A2:L2’deki boş olmayan hücre sayısına böler (Mayıs ile Aralık arası boştur).

  1. Bazen birden fazla çalışma sayfasındaki belirli bir hücreyi toplamanız gerekir. Her sayfaya ve hücreye tıklayarak hücre değerlerini toplamak için yalnızca “+” kullanmak isteyebilirsiniz, ancak bu işlem yorucudur ve hata eğilimlidir.

    • =Sayfa1!A1+Sayfa2!A1+Sayfa3!A1

    Bunu bir 3B veya 3 Boyutlu TOPLA ile çok daha kolay gerçekleştirebilirsiniz:

    3B Topla - D2 hücresindeki formül: =TOPLA(Sayfa1:Sayfa3!A2)
    • =TOPLA(Sayfa1:Sayfa3!A1)

    Bu formül Sayfa 1’den Sayfa 3’e kadar tüm sayfalardaki A1 hücrelerini toplar.

    Bu özellikle her ay için bir sayfanız varsa (Ocak-Aralık) ve değerleri bir özet sayfasında toplamanız gerekiyorsa yararlıdır.

    Adlandırılmış Sayfalardaki 3B TOPLA işlevi.  D2 hücresindeki formül: =TOPLA(Ocak:Aralık!A2)
    • =TOPLA(Ocak:Aralık!A2)

    Bu formül Ocak’tan Aralık’a kadar tüm sayfalardaki A2 hücresini toplar.

    Notlar: Çalışma sayfalarınızın adlarında "Ocak satışları" gibi boşluklar varsa, formüldeki sayfa adlarına başvururken kesme işareti kullanmanız gerekir. İlk kez çalışma sayfasının adından önce ve sonra yeniden kesme

    • =TOPLA(‘Ocak Satışları:Aralık Satışları’!A2)

    3B yöntemi ORTALAMA, MİN ve MAK gibi diğer işlevlerle de çalışır:

    • =ORTALAMA(Sayfa1:Sayfa3!A1)

    • =MIN(Sayfa1:Sayfa3!A1)

    • =MAK(Sayfa1:Sayfa3!A1)

İşlemin kendisini yaparak ve TOPLA gibi Excel işlevlerini kullanarak Matematik işlemlerini Excel ile kolayca gerçekleştirebilirsiniz. Aşağıdaki tablo ilgili işlevlerle birlikte, kullanabileceğiniz işleçleri listeler. İşleçleri klavyenizdeki sayıların bulunduğu sıradan veya varsa 10 sayı bulunan tuş takımından girebilirsiniz. Örneğin Shift+8 çarpma işlemi için yıldız işaretini (*) girer.

İşleç

İşlem

Örnekler

+

Toplama

=1+1

=A1+B1

=TOPLA(A1:A10)+10

=TOPLA(A1:A10)+B1

-

Çıkarma

=1-1

=A1-B1

=TOPLA(A1:A10)-10

=TOPLA(A1:A10)-B1

*

Çarpma

=1*1

=A1*B1

=TOPLA(A1:A10)*10

=TOPLA(A1:A10)*B1

=ÇARPIM(1,1) - ÇARPIM işlevi

/

Bölme

=1/1

=A1/B1

=TOPLAM(A1:A10)/10

=TOPLAM(A1:A10)/B1

=BÖLÜM(1,1) - BÖLÜM işlevi

^

Üs

=1^1

=A1^B1

=TOPLA(A1:A10)^10

=TOPLA(A1:A10)^B1

=KUVVET(1,1) - KUVVET işlevi

Daha fazla bilgi için, bkz. Excel'i hesap makineniz olarak kullanma.

Diğer örnekler

  1. Topladığınız hücre aralığına bir Yüzde İndirimi uygulamak istediğinizi varsayalım.

    TOPLA ile İşleçleri kullanma.  B16 hücresindeki formül =TOPLA(A2:A14)*-%25.  -%25, =TOPLA(A2:A14)*E2 gibi bir hücre başvurusu olsaydı formül düzgün oluşturulurdu
    • =TOPLA(A2:A14)*-%25

    Bu, toplanan aralığın% 25 ' i olur, ancak formülde% 25 ' i kullanabilir ve bunu değiştirmeniz zor olabilir. % 25 ' i bir hücreye eklemeyi ve bunun yerine açık ve kolay bir şekilde değiştirildiğinde, bunun gibi durumlarda çok daha iyidir:

    • =TOPLA(A2:A14)*E2

    Çarpmak yerine bölmek için “*” simgesini “/” ile değiştirmeniz yeterlidir: =TOPLA(A2:A14)/E2

  2. Bir TOPLA işlevine değer eklemek veya işlevden değer çıkarmak

    i. + veya - kullanarak bir Topla işlevine kolayca değer ekleyebilir veya işlevden değer çıkartabilirsiniz, örneğin:

    • =TOPLA(A1:A10)+E2

    • =TOPLA(A1:A10)-E2

Ayrıca Bkz:

TOPLA işlevi

Office yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×