Formüller ve işlevler

TOPLA işlevi

TOPLA işlevi

Not: En güncel yardım içeriklerini, mümkün olduğunca hızlı biçimde kendi dilinizde size sunmak için çalışıyoruz. Bu sayfanın çevirisi otomasyon aracılığıyla yapılmıştır ve bu nedenle hatalı veya yanlış dil bilgisi kullanımları içerebilir. Amacımız, bu içeriğin sizin için faydalı olabilmesini sağlamaktır. Buradaki bilgilerin faydalı olup olmadığını bu sayfanın sonunda bize bildirebilir misiniz? Kolayca başvurabilmek için İngilizce makaleye buradan ulaşabilirsiniz.

Matematik ve trigonometri işlevlerinden biri olan TOPLA işlevi, değerleri toplar. Ayrı değerler, hücre başvuruları, aralıklar veya bunların üçünü birlikte kullanabilirsiniz.

Örneğin:

  • =TOPLA(A2:A10)

  • =TOPLA(A2:A10, C2:C10)

Tarayıcınız video desteklemiyor. Microsoft Silverlight, Adobe Flash Player veya Internet Explorer 9’u yükleyin.

TOPLA(sayı1,[sayı2],...)

Bağımsız değişken adı

Açıklama

sayı1    (Gerekli)

Toplamak istediğiniz ilk sayı. Bu 4 gibi bir sayı, B6 gibi bir hücre başvurusu veya B2:B8 gibi bir hücre aralık olabilir.

sayı2-255    (İsteğe bağlı)

Bu, toplamak istediğiniz ikinci sayıdır. Bu şekilde, en çok 255 sayı belirtebilirsiniz.

Bu bölümde TOPLA işleviyle çalışılan en iyi yöntemler ele alınacaktır. Bunların çoğunu diğer işlevlerle çalışırken de uygulayabilirsiniz.

=1+2 veya =A+B Yöntemi – =1+2+3 veya =A1+B1+C2 ifadelerini girerek tamamen doğru sonuçlar almak mümkün olsa da bu yöntemler bazı nedenlerle hataya eğilimlidir:

  1. Yazım hataları - Şunun gibi daha fazla ve/veya daha büyük veriler girmeye çalıştığınızı düşünün:

    • =14598,93+65437.90+78496,23

    Sonra da girişlerinizin doğru olduğunu doğrulamaya çalıştığınızı düşünelim. Bu değerleri tek tek hücrelere yerleştirmek ve bir TOPLA formülü kullanmak daha kolaydır. Ek olarak bu değerleri hücrelerde biçimlendirebilir, böylece formülde daha okunabilir olmalarını sağlayabilirsiniz.

    Değerleri doğrudan formüllere yazmak yerine TOPLA işlevini kullanın.  D5 hücresindeki formül =TOPLA(D2:D4)
  2. Sayı yerine metinlere başvurulduğunda oluşan #DEĞER! hataları

    Şunun gibi bir formül kullanırsanız:

    • =A1+B1+C1 veya =A1+A2+A3

    Kötü formül yapısı örneği.  D2 hücresindeki formül: =A2+B2+C2

    Başvurulan hücrelerde sayısal olmayan (metin) değerler varsa, #VALUE döndüren formülünüz kesilebilir! hatası döndürür. TOPLA, metin değerlerini yoksayacaktır ve size yalnızca sayısal değerlerin toplamını verir.

    Doğru formül yapısı.  =A2+B2+C2 yerine D2 hücresindeki formül şu şekildedir: =TOPLA(A2:C2)
  3. Satır veya sütun silme nedeniyle oluşan #BAŞV! hatası

    Bir sütunun silinmesi nedeniyle oluşan #BAŞV! hatası.  Formül =A2+#BAŞV!+B2 olarak değiştirildi

    Bir satır veya sütun silerseniz formül, silinen satırı hariç tutacak şekilde güncelleştirilmez ve bir #BAŞV! hatası döndürür, ancak TOPLA işlevi otomatik olarak güncelleştirilir.

    TOPLA işlevi eklenen veya silinen hücre satır ve sütunlara göre otomatik olarak ayarlanır
  4. Formüller satır veya sütun eklendiğinde başvuruları güncelleştirmez

    Satır eklerseniz =A+B+C formülleri güncelleştirilmez

    Bir satır veya sütun eklerseniz, formül, Topla işlevinin otomatik olarak güncelleşen uzun bir süre (formülde başvurulan aralığın dışında olmadığı sürece) satır ekleme Bu, özellikle formülünüzü güncelleştirmek isterseniz önemlidir ve bu, yakalayabileceğiniz tamamlanmamış sonuçlarla ayrıcaksa.

    Bir sütun eklendiğinde =TOPLA(A2:C2) formülünden =TOPLA(A2:D2) formülüne kadar otomatik olarak genişleyen bir TOPLA formülünün gösterildiği örnek
  5. Tek tek Hücre Başvuruları ve Aralıkları olan TOPLA işlevi karşılaştırılması

    Şunun gibi bir formül kullanırsanız:

    • =TOPLA(A1,A2,A3,B1,B2,B3)

    Aynı nedenlerle başvurulan aralıkta satır eklerken veya silerken aynı derece hata yapma ihtimaliniz olur. Şunun gibi tek tek aralıklar kullanmak çok daha iyidir:

    • =TOPLA(A1:A3,B1:B3)

    Bu işlev satır eklediğinizde veya sildiğinizde değerleri güncelleştirir.

Sorun

Nerede sorun çıktı?

TOPLA işlevim sonucu değil, ##### simgelerini gösteriyor.

Sütun genişliklerinizi kontrol edin. ##### simgeleri genel olarak bir sütunun sonucu gösteremeyecek kadar dar olduğu anlamına gelir.

TOPLA işlevim sonucu değil, formülü metin olarak gösteriyor.

Hücrenin metin olarak biçimlendirilmediğini doğrulayın. Söz konusu hücre veya aralığı seçin ve Hücreleri Biçimlendir iletişim kutusunu açmak için Ctrl+1 tuşlarını kullanın, sonra da Sayı sekmesine tıklayıp istediğiniz biçimi seçin. Hücre metin olarak biçimlendirildiyse ve siz biçimi değiştirdikten sonra değişmezse, biçimin değişmesini zorlamak için F2 > Enter tuşlarını kullanmanız gerekebilir.

TOPLA işlevim güncelleştirilmiyor.

Hesaplama’nın Otomatik olarak ayarlandığından emin olun. Formül sekmesinde , hesaplama seçenekleri'ne gidin. Çalışma sayfasının hesaplama yapmasını zorlamak için F9 tuşunu da kullanabilirsiniz.

Hesaplamanın Otomatik olarak ayarlandığından emin olun.  Formül sekmesinden Hesaplama Seçenekleri’ne gidin.

Bazı değerler eklenmez.

Yalnızca işlev başvurusundaki veya aralıktaki sayısal değerler toplanabilir. Boş hücreler, DOĞRU gibi mantıksal değerler veya metinler yoksayılır.

Beklenen sonuç yerine #AD? hatası görüntülenir.

Bu, genellikle bir formülün yanlış yazıldığı anlamına gelir (=TOPLA(A1:A10) yerine, =topl(A1:A10) gibi).

TOPLA işlevim tam sayı gösteriyor ancak ondalık değerleri de göstermeli

Hücre biçimlendirmenizi kontrol ederek ondalık değerlerin gösterildiğinden emin olun. Söz konusu hücre veya aralığı seçin ve Hücreleri Biçimlendir iletişim kutusunu açmak için Ctrl+1 tuşlarını kullanın, sonra da Sayı sekmesine tıklayıp virgülden sonra kaç basamak gösterilmesini istediğinizden emin olarak tercih ettiğiniz biçimi seçin.

  1. Yalnızca sayıları eklemek/çıkarmak/çarpmak/bölmek istiyorum Excel 'Deki temel matematik matematiğiningörüntü serilerini görün veya Excel 'i hesap makineniz olarak kullanın.

  2. Nasıl daha fazla/az ondalık basamak görüntüleyebilirim? Sayı biçiminizi değiştirebilirsiniz. Söz konusu hücre veya aralığı seçin ve Hücreleri Biçimlendir İletişim kutusunu açmak için Ctrl+1 tuşlarını kullanın, sonra da Sayı sekmesine tıklayıp istediğiniz ondalık basamakları belirtecek biçimi seçin.

  3. Saatleri nasıl toplayabilir veya çıkarabilirim? Saatleri birkaç farklı yöntemle toplayıp çıkarabilirsiniz. Örneğin, bordrolama işlemi için 08:00 - 24:00 arasındaki farkı hesaplamak üzere =("24:00"-"08:00")*24 kullanın, bitiş zamanından başlangıç zamanını çıkarın. Excel’in saatleri günün bir parçası olarak hesapladığını unutmayın; bu nedenle toplam saatleri almak için değeri 24 ile çarpmanız gerekir. Kullandığımız ilk örnekte, başlangıçtan sona kadar öğle arası hariç toplam saati (toplamda 8,5 saat) hesaplamak için =((B2-A2)+(D2-C2))*24 kullanırız.

    Yalnızca saatlerle dakikaları ekliyorsanız ve bu şekilde görüntülenmesini istiyorsanız, 24 ile çarpmaya gerek kalmadan toplayabilirsiniz. Bu nedenle, atanan görevler için yalnızca saatler ve dakikaların toplamına (5:36 veya 5 saat 36 dakika) ihtiyacımız olduğu için ikinci örnekte =SUM(A6:C6) kullanıyoruz.

    Saatleri hesaplama

    Daha fazla bilgi için bkz. Saat toplama veya çıkarma.

  4. Tarihler arasındaki farkı nasıl hesaplayabilirim? Tarihleri saatler gibi toplayıp çıkarabilirsiniz. İki tarih arasındaki gün sayısını hesaplamak için kullanabileceğiniz oldukça yaygın bir örnek aşağıda verilmiştir. =B2-A2 formülü kadar basittir. Tarih ve Saatler ile birlikte çalışırken dikkat edilmesi gereken nokta, Bitiş Tarihi/Saati ile başlayıp bu değerden Başlangıç Tarihini/Saatini çıkarmanız gerektiğidir.

    Tarihler arasındaki farkları hesaplama

    Tarihlerle çalışmanın diğer yolları Için bkz: iki tarih arasındaki farkı hesaplama.

  5. Yalnızca görünen hücreleri nasıl toplarım? Bazen satırları el ile gizlediğinizde veya belli verileri görüntülemek için Otomatik Filtre’yi kullandığınızda, yalnızca görünen hücreleri toplamak isteyebilirsiniz. ALTTOPLAM işlevini kullanabilirsiniz. Bir Excel tablosunda toplam satırı kullanıyorsanız, Toplam açılan menüsünden seçtiğiniz herhangi bir işlev otomatik olarak ara toplam olarak girilecektir. Excel tablosundaki verileri toplama konusunda daha fazla bilgi edinin.

Daha fazla yardım mı gerekiyor?

Sorularınızı Excel Teknoloji Topluluğu’ndaki uzmanlara sorabilir, Yanıt topluluğu’ndan destek alabilir ya da Excel için UserVoice platformuna yeni bir özellik veya iyileştirme önerisi sunabilirsiniz.

Ayrıca Bkz:

Toplam hakkında bilgi edinin

ETOPLA işlevi yalnızca tek bir ölçüte uyan değerleri toplar

ÇOKETOPLA işlevi yalnızca birden çok ölçüte uyan değerleri toplar

EĞERSAY işlevi yalnızca tek bir ölçüte uyan değerleri sayar

ÇOKEĞERSAY işlevi yalnızca birden çok ölçüte uyan değerleri sayar

Excel’deki formüllere genel bakış

Bozuk formülleri önleme

Formüllerdeki hataları bulma ve düzeltme

Windows için Excel'deki klavye kısayolları

Mac için Excel'deki klavye kısayolları

Matematik ve Trigonometri işlevleri

Excel işlevleri (alfabetik)

Excel işlevleri (Kategoriye göre)

Office yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×