Formüller ve işlevler

TOPLA işlevi

TOPLA işlevi

Not: En güncel yardım içeriklerini, mümkün olduğunca hızlı biçimde kendi dilinizde size sunmak için çalışıyoruz. Bu sayfanın çevirisi otomasyon aracılığıyla yapılmıştır ve bu nedenle hatalı veya yanlış dil bilgisi kullanımları içerebilir. Amacımız, bu içeriğin sizin için faydalı olabilmesini sağlamaktır. Buradaki bilgilerin faydalı olup olmadığını bu sayfanın sonunda bize bildirebilir misiniz? Kolayca başvurabilmek için İngilizce makaleye buradan ulaşabilirsiniz.

Topla işlevi, Matematik ve Trigonometri işlevleri, birini değerleri toplar. Tek tek değerleri, hücre başvuruları veya aralıklar veya tüm üç karışımı ekleyebilirsiniz.

Örneğin:

  • =TOPLA(A2:A10)

  • =TOPLA(A2:A10, C2:C10)

Tarayıcınız video desteklemiyor. Microsoft Silverlight, Adobe Flash Player veya Internet Explorer 9’u yükleyin.

TOPLA(sayı1,[sayı2],...)

Bağımsız değişken adı

Açıklama

sayı1    (Gerekli)

Toplamak istediğiniz ilk sayı. Bu 4 gibi bir sayı, B6 gibi bir hücre başvurusu veya B2:B8 gibi bir hücre aralık olabilir.

sayı2-255    (İsteğe bağlı)

Bu, toplamak istediğiniz ikinci sayıdır. Bu şekilde, en çok 255 sayı belirtebilirsiniz.

Bu bölümde, TOPLA işlevi ile çalışmaya yönelik en iyi uygulamalardan bazıları anlatacak. Bu çok diğer işlevleri ile çalışmak için uygulanabilir.

=1+2 veya =A+B Yöntemi – =1+2+3 veya =A1+B1+C2 ifadelerini girerek tamamen doğru sonuçlar almak mümkün olsa da bu yöntemler bazı nedenlerle hataya eğilimlidir:

  1. Yazım hataları - Şunun gibi daha fazla ve/veya daha büyük veriler girmeye çalıştığınızı düşünün:

    • =14598,93+65437.90+78496,23

    Girdileriniz doğru olduğunu doğrulamak daha sonra deneyin. Bu değerleri tek tek hücrelere yerleştirin ve Topla formülü kullanmak daha kolaydır. Ayrıca, çok daha okunur hale getirme hücrelerdeki sonra formülde olduğunuzda olduğunuzda değerleri biçimlendirebilirsiniz.

    Değerleri doğrudan formüllere yazmak yerine TOPLA işlevini kullanın.  D5 hücresindeki formül =TOPLA(D2:D4)
  2. Sayı yerine metinlere başvurulduğunda oluşan #DEĞER! hataları

    Şunun gibi bir formül kullanırsanız:

    • =A1+B1+C1 veya =A1+A2+A3

    Kötü formül yapısı örneği.  D2 hücresindeki formül: =A2+B2+C2

    Bir #VALUE verip vermeyeceğini Başvurulan hücreler içinde herhangi bir sayısal olmayan (metin) değerleri varsa formülünüzü bölebilir! bir hata oluştu. Topla, metin değerleri yoksayılır ve yalnızca sayısal değerlerin toplamını verir.

    Doğru formül yapısı.  =A2+B2+C2 yerine D2 hücresindeki formül şu şekildedir: =TOPLA(A2:C2)
  3. Satır veya sütun silme nedeniyle oluşan #BAŞV! hatası

    Bir sütunun silinmesi nedeniyle oluşan #BAŞV! hatası.  Formül =A2+#BAŞV!+B2 olarak değiştirildi

    Bir satır veya sütun silerseniz formül, silinen satırı hariç tutacak şekilde güncelleştirilmez ve bir #BAŞV! hatası döndürür, ancak TOPLA işlevi otomatik olarak güncelleştirilir.

    TOPLA işlevi eklenen veya silinen hücre satır ve sütunlara göre otomatik olarak ayarlanır
  4. Formüller satır veya sütun eklendiğinde başvuruları güncelleştirmez

    Satır eklerseniz =A+B+C formülleri güncelleştirilmez

    Satır veya sütun eklerseniz, formül (formülde başvurulan aralığının dışında olmadığınız sürece) nerede TOPLA işlevi otomatik olarak güncelleşir eklenen satırı içerecek şekilde güncelleştirmez. Bunu değil yakalamasını tamamlanmamış sonuçlarıyla bırakır gibi bu güncelleştirmek için formülünüzü beklediğiniz ve bunu değildir, özellikle önemli olur.

    Bir sütun eklendiğinde =TOPLA(A2:C2) formülünden =TOPLA(A2:D2) formülüne kadar otomatik olarak genişleyen bir TOPLA formülünün gösterildiği örnek
  5. Tek tek Hücre Başvuruları ve Aralıkları olan TOPLA işlevi karşılaştırılması

    Şunun gibi bir formül kullanırsanız:

    • =TOPLA(A1,A2,A3,B1,B2,B3)

    Eşit oranda hata ekleme veya aynı nedenlerle başvurulan aralıktaki satırları silindiğinde olasılığı demektir. Tek tek aralıkları gibi kullanmak çok daha iyi olur:

    • =TOPLA(A1:A3,B1:B3)

    Bu işlev satır eklediğinizde veya sildiğinizde değerleri güncelleştirir.

Sorun

Nerede sorun çıktı?

TOPLA işlevim sonucu değil, ##### simgelerini gösteriyor.

Sütun genişliklerini denetleyin. ### genellikle sütun formül sonucunu görüntülemek için çok dar olduğu anlamına gelir.

TOPLA işlevim sonucu değil, formülü metin olarak gösteriyor.

Hücreye metin olarak biçimlendirilmemiştir denetleyin. Hücreyi veya aralığı söz konusu seçin ve Hücreleri Biçimlendir iletişim kutusunu açmak sonra Sayı sekmesini tıklatın ve istediğiniz biçimi seçmek için Ctrl + 1 kullanın. Hücreye metin olarak biçimlendirilmiş ve biçimi değiştirdikten sonra değiştirmiyor, kullanmanız gerekebilir F2 > Enter biçimini değiştirmek için zorlamak için.

TOPLA işlevim güncelleştirilmiyor.

Hesaplama Otomatikolarak ayarlandığından emin olun. Formül sekmesine gitmek için Hesaplama seçenekleri. Çalışma sayfası hesaplamak için zorlamak için F9'a da kullanabilirsiniz.

Hesaplamanın Otomatik olarak ayarlandığından emin olun.  Formül sekmesinden Hesaplama Seçenekleri’ne gidin.

Bazı değerler eklenmez.

Yalnızca işlev başvurusundaki veya aralıktaki sayısal değerler toplanabilir. Boş hücreler, DOĞRU gibi mantıksal değerler veya metinler yoksayılır.

Beklenen sonuç yerine #AD? hatası görüntülenir.

Bu, genellikle bir formülün yanlış yazıldığı anlamına gelir (=TOPLA(A1:A10) yerine, =topl(A1:A10) gibi).

TOPLA işlevim tam sayı gösteriyor ancak ondalık değerleri de göstermeli

Hücre biçimlendirmenizi kontrol ederek ondalık değerlerin gösterildiğinden emin olun. Söz konusu hücre veya aralığı seçin ve Hücreleri Biçimlendir iletişim kutusunu açmak için Ctrl+1 tuşlarını kullanın, sonra da Sayı sekmesine tıklayıp virgülden sonra kaç basamak gösterilmesini istediğinizden emin olarak tercih ettiğiniz biçimi seçin.

  1. Yalnızca sayıları Toplamak/Çıkarmak/Çarpmak/Bölmek istiyorum Excel’de Temel Matematik İşlemleri veya Excel’i hesap makineniz olarak kullanma video serilerine göz atın.

  2. Nasıl ben Göster daha fazla/daha az ondalık basamak? Sayı biçiminizi değiştirebilirsiniz. Hücreyi veya aralığı söz konusu seçin ve Ctrl + 1Hücreleri Biçimlendir iletişim kutusunu açmak sonra Sayı sekmesini tıklatın ve istediğiniz ondalık basamak sayısını belirtmek emin olmak istediğiniz biçimi seçin.

  3. Saatleri nasıl toplayabilir veya çıkarabilirim? Saatleri birkaç farklı yöntemle toplayıp çıkarabilirsiniz. Örneğin, bordrolama işlemi için 08:00 - 24:00 arasındaki farkı hesaplamak üzere =("24:00"-"08:00")*24 kullanın, bitiş zamanından başlangıç zamanını çıkarın. Excel’in saatleri günün bir parçası olarak hesapladığını unutmayın; bu nedenle toplam saatleri almak için değeri 24 ile çarpmanız gerekir. Kullandığımız ilk örnekte, başlangıçtan sona kadar öğle arası hariç toplam saati (toplamda 8,5 saat) hesaplamak için =((B2-A2)+(D2-C2))*24 kullanırız.

    Yalnızca saatlerle dakikaları ekliyorsanız ve bu şekilde görüntülenmesini istiyorsanız, 24 ile çarpmaya gerek kalmadan toplayabilirsiniz. Bu nedenle, atanan görevler için yalnızca saatler ve dakikaların toplamına (5:36 veya 5 saat 36 dakika) ihtiyacımız olduğu için ikinci örnekte =SUM(A6:C6) kullanıyoruz.

    Saatleri hesaplama

    Daha fazla bilgi için bkz. Saat toplama veya çıkarma.

  4. Tarihleri arasındaki fark nasıl alırım? Süreleriyle gibi ekleyebilir ve tarihleri çıkarma. Aşağıda, iki tarih arasındaki gün sayısını sayım çok yaygın bir örnek verilmiştir. = B2-A2kadar basit bir işlemdir. Tarih ve saatlerle çalışmak için başlangıç ile Bitiş tarihi/saati ve başlangıç tarihi/saati çıkarma anahtardır.

    Tarihler arasındaki farkları hesaplama

    Tarihlerle çalışmanın diğer yolları için bkz.: İki tarih arasındaki gün sayısını hesaplama.

  5. Yalnızca görünen hücreleri nasıl toplarım? Bazen satırları el ile gizlediğinizde veya belli verileri görüntülemek için Otomatik Filtre’yi kullandığınızda, yalnızca görünen hücreleri toplamak isteyebilirsiniz. ALTTOPLAM işlevini kullanabilirsiniz. Bir Excel tablosunda toplam satırı kullanıyorsanız, Toplam açılan menüsünden seçtiğiniz herhangi bir işlev otomatik olarak ara toplam olarak girilecektir. Excel tablosundaki verileri toplama konusunda daha fazla bilgi edinin.

Daha fazla yardım mı gerekiyor?

Sorularınızı Excel Teknoloji Topluluğu’ndaki uzmanlara sorabilir, Yanıt topluluğu’ndan destek alabilir ya da Excel için UserVoice platformuna yeni bir özellik veya iyileştirme önerisi sunabilirsiniz.

Ayrıca Bkz:

Topla hakkında daha fazla bilgi edinin

ETOPLA işlevi yalnızca, tek bir ölçüte uyan değerleri toplar

ÇOKETOPLA işlevi yalnızca, birden çok ölçüte uyan değerleri toplar

EĞERSAY işlevi yalnızca, tek bir ölçüte uyan değerleri sayar

ÇOKEĞERSAY işlevi yalnızca, birden çok ölçüte uyan değerleri sayar

Excel'deki formüllere genel bakış

Bozuk formülleri önleme

Formüllerdeki hataları bulma ve düzeltme

Windows için Excel'de klavye kısayolları

Mac için Excel klavye kısayolları

Matematik ve Trigonometri işlevleri

Excel işlevleri (alfabetik)

Excel işlevleri (kategoriye göre)

Office yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×