TOPLA.ÇARPIM işlevindeki #DEĞER! hatasını düzeltme

Not: En güncel yardım içeriklerini, mümkün olduğunca hızlı biçimde kendi dilinizde size sunmak için çalışıyoruz. Bu sayfanın çevirisi otomasyon aracılığıyla yapılmıştır ve bu nedenle hatalı veya yanlış dil bilgisi kullanımları içerebilir. Amacımız, bu içeriğin sizin için faydalı olabilmesini sağlamaktır. Buradaki bilgilerin faydalı olup olmadığını bu sayfanın sonunda bize bildirebilir misiniz? Kolayca başvurabilmek için İngilizce makaleye buradan ulaşabilirsiniz.

Bu konu, TOPLA.ÇARPIM işlevinde çalışırken #DEĞER! hatasıyla karşılaşılan en yaygın senaryoları kapsar.

Sorun: Dizi bağımsız değişkenlerinin boyutları aynı değil

Dizi bağımsız değişkenlerinin tümü aynı boyutta olmalıdır. Değillerse, #DEĞER! hatası alırsınız. Örneğin, Dizi 1'de 3 satırlık ve 2 sütunluk bir aralığa başvuruluyorsa, Dizi 2 de aynı aralığı göstermelidir.

Hataya neden olan TOPLA.ÇARPIM formülü: =TOPLA.ÇARPIM(D2:D13,E2:E10) - ilk aralıkla eşleşmesi için E10'un E13 ile değiştirilmesi gerekir.
  • =TOPLA.ÇARPIM(D2:D13,E2:E10)

Başarısız olur, çünkü başvurulan aralıkların satır sayısı aynı değildir (ilk aralıkta 13 satır varken, ikincisinde yalnızca 10 satır vardır).

Çözüm: Formülü şu şekilde değiştirin:

  • =TOPLA.ÇARPIM(D2:D13,E2:E13)

Böylelikle, her iki aralığın da başlangıç ve bitiş satır sayıları aynı olur. Sonra formülü yeniden deneyin.

TOPLA.ÇARPIM hatasını düzeltmek için verilerdeki #DEĞER! hatasını düzeltin

Sorun: Aralıktaki bir veya birden çok hücre metin içeriyor

Başvurulan aralıktaki bir veya birden çok hücre metin içeriyorsa veya Metin veri türünde biçimlendirilmişse, #DEĞER! hatası alırsınız. Metin, başka bir formülün hesaplanması sonucu elde edilmiş olabileceği gibi, yalnızca hücre doğru biçimlendirilmemiş de olabilir.

E15 hücresindeki formülde #DEĞER! hatası gösterilir çünkü E sütununda bir #DEĞER! hatası vardır.

Çözüm: Metin içeren veya metin olarak biçimlendirilmiş hücre olup olmadığını denetleyin ve bunları doğru veri türüne ayarlayın.

İşlevlerle ilgili bir sorunuz mu var?

Excel topluluk forumuna soru gönderin

Excel’i geliştirmemize yardımcı olun

Excel’in sonraki sürümünü nasıl geliştirebileceğimiz konusunda önerileriniz var mı? Varsa lütfen Excel User Voice forumundaki başlıkları gözden geçirin.

Ayrıca Bkz:

#DEĞER! hatasını düzeltme

TOPLA.ÇARPIM işlevi

Excel’deki formüllere genel bakış

Bozuk formülleri önleme

Formüllerde hataları algılama

Tüm Excel işlevleri (alfabetik)

Tüm Excel işlevleri (kategoriye göre)

Office yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×