SharePoint listesinden Access formları ve raporları oluşturma

Not: En güncel yardım içeriklerini, mümkün olduğunca hızlı biçimde kendi dilinizde size sunmak için çalışıyoruz. Bu sayfanın çevirisi otomasyon aracılığıyla yapılmıştır ve bu nedenle hatalı veya yanlış dil bilgisi kullanımları içerebilir. Amacımız, bu içeriğin sizin için faydalı olabilmesini sağlamaktır. Buradaki bilgilerin faydalı olup olmadığını bu sayfanın sonunda bize bildirebilir misiniz? Kolayca başvurabilmek için İngilizce makaleye buradan ulaşabilirsiniz.

SharePoint listesinden formlar ve raporlar oluşturabilir ve bunları görünümler olarak kullanabilirsiniz. Access 2007 'in yüklü olduğu SharePoint sitesinin kullanıcıları, SharePoint listesinin Görünüm menüsünü kullanarak bu formları ve raporları açabilir. Bir Access görünümünü listenin varsayılan görünümünde yapabilirsiniz.

Access 2007 kullanarak oluşturduğunuz görünümler, Windows SharePoint Services sunucusundaki bir veritabanı dosyasında depolanır. SharePoint listesinin bir Access görünümünü açtığınızda, Access başlatılır ve formu veya raporu görüntüler. Veritabanı SharePoint sitesinde depolandığından, görünüm sitenin diğer kullanıcılarıyla açılabilir. Kullanıcının, SharePoint sitesinde, görünümü kullanmak için Access görünümünü içeren veritabanı dosyasının konumunu bilmesi gerekmez. Ayrıca, kullanıcının Access 'i nasıl başlatabileceğini de bilmesi gerekmez; Bu, SharePoint sitesi tarafından otomatik olarak gerçekleştirilir.

Not: Bir kullanıcının, bir SharePoint sitesinde Access görünümü oluşturmak, kullanması veya değiştirmek için bilgisayarında Access 2007 yüklü olması gerekmektedir.

Ne yapmak istiyorsunuz?

SharePoint listesinin Access görünümünü oluşturma

Access görünümünü SharePoint listesinin varsayılan görünümü yapma

SharePoint listesinin erişim görünümünü kullanma

SharePoint listesinin erişim görünümünü değiştirme

SharePoint listesinin Access görünümünü oluşturma

SharePoint listesinin Access görünümünü oluşturduğunuzda, Access otomatik olarak başlatılır. Access 'Te, görünümünüzü çeşitli form ve rapor şablonlarına dayandırabilirsiniz ve ardından görünümünüzü özelleştirebilirsiniz. SharePoint sitesinde görünümünüzü yayımlayarak, bu siteyi başka kullanıcıların kullanımına kolayca yapabilirsiniz.

Not: SharePoint listesinin görünümünü oluşturmak Için, varsayılan olarak tasarım izin düzeyine dahil edilen Windows SharePoint Services Listeleri Yönet iznine sahip olmanız gerekir.

Tarayıcınızda görüntülediğiniz bir SharePoint listesinin Access görünümünü oluşturmak için aşağıdaki yordamı kullanın.

  1. SharePoint sitesinde, Görünüm menüsünde Aşağı açılır menü öğesine Görünüm Oluştur'u tıklatın.

  2. Görünüm Oluştur sayfasında Access görünümü'nü tıklatın.

    Access başlatılır ve yeni görünümünüzü içerecek veritabanının yerel bir kopyasını kaydetmenizi ister.

  3. Yerel kopya kaydet iletişim kutusunda, bilgisayarınızda kopyayı kaydetmek istediğiniz konuma gidin, dosya adı kutusuna yerel kopya için bir ad yazın ve Kaydet'i tıklatın.

    Access Yerel kopyayı kaydeder ve açar ve ardından Access görünümü oluştur iletişim kutusu görüntülenir.

  4. Access görünümü oluştur iletişim kutusunda, oluşturmak istediğiniz görünüm türüne çift tıklayın.

    Access yeni görünümünüzü oluşturur ve Düzen görünümünde açar.

  5. Yeni görünümünüzü Düzen görünümünde özelleştirebilir veya Tasarım görünümüne geçebilirsiniz.

    Düzen görünümünde, görünümünüzden (Etiketler ve alanlar gibi) denetimleri yeniden boyutlandırabilir ve yeniden düzenleyebilirsiniz ancak görünümünüze başka denetimler ekleyemezsiniz. Düzen görünümü, değişikliklerinizin tamamlandı görünümünde nasıl görüneceğini görmeyi kolaylaştıran bir veri önizlemesi sağlar.

    Tasarım görünümünde denetimleri yeniden boyutlandırabilir, yeniden düzenleyebilir ve görünümünüze ek denetimler ekleyebilirsiniz. Ancak Tasarım görünümü bir veri önizleme sağlamaz.

    Tasarım görünümü ve Düzen görünümü arasında istediğiniz kadar geçiş yapabilirsiniz. Görünümünüze denetim eklemek için Tasarım görünümünü kullanıyorsanız, daha sonra verileri önizlemede görüntülerken Düzen görünümüne geçerek görünümde bu denetimleri düzenleyebilirsiniz.

  6. Özelleştirmelerinizi yaptıktan sonra, Ileti çubuğunda, SharePoint sitesine yayımla'ya tıklayın.

    araç çubuğu

    Web sunucusuna yayınla iletişim kutusu görüntülenir.

    Ileti çubuğu görünmezse, aşağıdakileri yaparak görüntüleyin:

    • Veritabanı araçları sekmesinin Göster/Gizle grubunda ileti çubuğu'na tıklayın.

  7. Access, varsayılan olarak görünümü SharePoint sitesindeki Paylaşılan Belgeler kitaplığında bulunan bir veritabanı dosyasına kaydeder — bu site, görünümü oluşturduğunuz listeyi içerir. Çoğu durumda bu, istediğiniz gibi olabilir, ancak Web sunucusuna yayınla Iletişim kutusundaki Kaydet kutusunda farklı bir kitaplık seçerek veritabanını depoladığınız belge kitaplığını değiştirebilirsiniz. Görünüme kimlerin erişimi olduğunu ve kullanıcıların görünümü salt okunur modunda veya düzenleme modunda açabilip açamayacağını daha özel olarak denetlemek için bunu yapabilirsiniz. SharePoint sitesinde, Access görünümleri için ayarlanmış belirli kitaplıklar olabilir; bu durumda, doğru kitaplığı seçmek için kayıt konumunu değiştirmeniz gerekebilir.

    SharePoint sitesinin yöneticisi doğru kitaplığı seçmenizi sağlayabilir.

  8. Access, Web sunucusuna yayınla Iletişim kutusundaki dosya adı kutusuna veritabanı için bir ad sağlar. Bu ad, yerel kopya olarak kaydettiğiniz veritabanının adıyla eşleşir. İsterseniz adı değiştirebilirsiniz, ancak çoğu durumda önerilen adı kabul etmeniz gerekirse, bu, SharePoint sitesinde yayımladığınız veritabanına hangi yerel veritabanının ait olduğunu anımsamanızı sağlayacaktır.

  9. Veritabanını SharePoint sitesine kaydetmek için Yayımla 'ya tıklayın.

Sayfanın Başı

Access görünümünü SharePoint listesinin varsayılan görünümü yapma

Bir SharePoint listesinin varsayılan görünümünü bir Access görünümünde açtığınızda, kullanıcılar bu kullanıcıların bilgisayarlarında erişimi yüklüyse, kullanıcılar listeyi açtığında Access görünümü otomatik olarak açılır.

Önemli: Access 'i varsayılan görünümde bir Access görünümü yaparsanız, Access 2007 'in yüklü olmadığı liste ziyaretçileri listeyi kullanamayacak.

  1. SharePoint listesi açık olduğunda Ayarlar menüsünde Liste ayarları'nı tıklatın.

  2. Liste ayarları sayfasında, Görünümleraltında, varsayılan görünümü oluşturmak istediğiniz Access görünümünün adını tıklatın.

  3. Görünümü Düzenle sayfasında, bunu varsayılan görünüm yap 'ı ve ardından Tamam'ı tıklatın.

Sayfanın Başı

SharePoint listesinin erişim görünümünü kullanma

SharePoint listesinin erişim görünümünü kullanmak Için, listenin Görünüm menüsünden Access görünümünü seçersiniz.

  • Görünüm menüsünde Aşağı açılır menü öğesine erişim görünümünün adını tıklatın. Access başlatılır ve görünümü salt okunur modda görüntüler.

    Salt okunur modunda, görünümdeki verileri değiştirebilir ve görünümü yazdırabilirsiniz, ancak görünüm tasarımını değiştiremezsiniz. Görünüm tasarımını değiştirmek istiyorsanız, bu makalenin sonraki bölümüne bakın, SharePoint listesinin Access görünümünü değiştirin.

Sayfanın Başı

SharePoint listesinin erişim görünümünü değiştirme

Access görünümünün tasarımını değiştirmek Için, Access görünümünü içeren veritabanının yerel bir kopyasını kaydedersiniz ve sonra da değişiklikler yapabilirsiniz. Ardından, görünümün yerel kopyanızı veya SharePoint sitesinde uygun izinleriniz varsa yeni görünümü yayımlayabilirsiniz.

Not: % Z0z_ izin düzeyinden bağımsız olarak bir Access görünümünün yerel kopyasını değiştirebilirsiniz. Ancak, değiştirilmiş görünümünüzü SharePoint sitesinde yayımlamak için, varsayılan olarak tasarım izin düzeyine dahil edilen Windows SharePoint Services Listeleri Yönet iznine sahip olmanız gerekir. Access görünümünü oluşturduysanız, listeleri Yönet iznine sahip olmanız gerekir. Emin değilseniz, ihtiyacınız olan izinlere sahip olup olmadığınızı belirlemek için SharePoint site yöneticinize başvurun.

  1. Access görünümü açıkken, Ileti çubuğundafarklı kaydet'i tıklatın.

    İleti Çubuğu'nda Farklı Kaydet düğmesi

    Not: Ileti çubuğu görünmezse, aşağıdakileri yaparak görüntüleyin:

    • Veritabanı araçları sekmesinin Göster/Gizle grubunda ileti çubuğu'na tıklayın.

  2. Access, görünümü ve diğer tüm açık nesneleri kapatmanızı sorduğunda Evet 'i tıklatın.

    Farklı Kaydet iletişim kutusu görüntülenir.

  3. Kayıt yeri kutusunda, Yerel kopyayı kaydetmek istediğiniz konumu belirtin, dosya adı kutusuna yerel kopya için bir ad yazın ve Kaydet'i tıklatın.

    Access, veritabanının yerel kopyasını kaydeder ve ardından açar.

  4. Aşağıdakilerden birini yapın:

    • Yeni denetimleri eklemeden görünümün düzenini değiştirmek Için, gezinti bölmesi 'nde görünümü sağ tıklatın ve kısayol menüsünde Düzen görünümü 'nü tıklatın.

      Düzen görünümünde, görünümünüzden (Etiketler ve alanlar gibi) denetimleri yeniden boyutlandırabilir ve yeniden düzenleyebilirsiniz ancak görünümünüze başka denetimler ekleyemezsiniz. Düzen görünümü, değişikliklerinizin tamamlandı görünümünde nasıl görüneceğini görmeyi kolaylaştıran bir veri önizlemesi sağlar.

    • Görünümde (Etiketler veya alanlar gibi) denetimleri eklemek veya kaldırmak Için, gezinti bölmesi 'nde görünümü sağ tıklatın ve kısayol menüsünde Tasarım görünümü 'nü tıklatın.

      Tasarım görünümünde denetimleri yeniden boyutlandırabilir, yeniden düzenleyebilir ve görünümünüze ek denetimler ekleyebilirsiniz. Ancak Tasarım görünümü bir veri önizleme sağlamaz.

      Not: Görünümü Tasarım görünümünde düzenlemeyi seçerseniz ve gözden geçirilmiş görünümü SharePoint sitesine yayımlamayı düşünüyorsanız, görünüme SharePoint listesinin parçası olmayan hiçbir alan eklemeyin.

  5. Tasarım görünümü ve Düzen görünümü arasında istediğiniz kadar geçiş yapabilirsiniz. Görünümünüze denetim eklemek için Tasarım görünümünü kullanıyorsanız, daha sonra verileri önizlemede görüntülerken Düzen görünümüne geçerek görünümde bu denetimleri düzenleyebilirsiniz.

Değiştirilmiş Access görünümünü SharePoint sitesine yayımlama

Görünümü değiştirmeyi bitirdikten sonra SharePoint sitesinde Listeleri Yönet izniniz varsa, aşağıdaki yordamı kullanarak değiştirilmiş görünümü yayımlayabilirsiniz.

Listeleri yönetme izni edinmek Için SharePoint sitesinin yöneticisine başvurun.

  1. Görünümü, veritabanının yerel kopyasına kaydedin.

  2. Ileti çubuğunda, SharePoint sitesine yayımla'ya tıklayın.

    araç çubuğu

    Not: Listeleri Yönet izniniz yoksa, Ileti çubuğundaSharePoint sitesine yayımla düğmesi görüntülenmez. Ileti çubuğu görünmezse, aşağıdakileri yaparak görüntüleyin:

    • Veritabanı araçları sekmesinin Göster/Gizle grubunda ileti çubuğu'na tıklayın.

  3. Web sunucusunda Yayımla Iletişim kutusunda Yayımla'ya tıklayın.

Sayfanın Başı

Office yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×