Microsoft Access 2010 'deki yenilikler

Microsoft Access 2010 'da web veritabanları oluşturabilir ve bunları bir SharePoint sitesinde yayımlayabilirsiniz. SharePoint ziyaretçileri, neleri görebileceğini belirlemek için SharePoint izinlerini kullanarak veritabanı uygulamanızı Web tarayıcısında kullanabilirler. Bir şablonla başlayabilirsiniz, böylece hemen işbirliği yapmaya başlayabilirsiniz.

Access kullanıcı arabirimi de değiştirilmiştir. Access 2010 'da yeni Backstage görünümü sıkıştır ve Onar gibi tüm veritabanına veya Dosya menüsünden gelen komutlara erişim sağlar.

Bu makalede, Access 2010 tanıtılan özellikler açıklanmaktadır. Access 'e genel bir giriş gerekiyorsa, access 2010 ile çalışmaya başlamamakalesine bakın.

Bu makalede

Genel Bakış

Yeni Kullanıcı arabirimi

Daha güçlü nesne oluşturma araçları

Yeni veri türleri ve denetimleri

Geliştirilmiş veri sunusu

Gelişmiş güvenlik

Sorunları gidermek için daha iyi bir yol

Gelişmiş Yazım denetimi

Genel Bakış

Access Services 'ın yapılandırıldığı bir SharePoint sitesine erişiminiz varsa, Access 2010 kullanarak bir Web veritabanı oluşturabilirsiniz. SharePoint sitesinde hesapları olan kişiler veritabanınızı Web tarayıcısında kullanabilir, ancak Access 2010 kullanarak tasarım değişiklikleri yapabilirsiniz. Bazı masaüstü veritabanı özellikleri Web 'e çevrilmemesine rağmen, hesaplanan alanlar ve veri makroları gibi yeni özellikleri kullanarak aynı şeylerden fazlasını yapabilirsiniz.

Web üzerinde veritabanını paylaşma

  • Şablon kullanma    Beş şablon Access 2010: kişiler, varlıklar, projeler, etkinlikler ve yardımsever katkıları ile birlikte gelir. Ayrıca, yayımlamadan önce veya sonra da herhangi bir şablonu değiştirebilirsiniz.

  • Sıfırdan başlama    Boş yeni bir veritabanı oluşturduğunuzda, normal veritabanı ile Web veritabanı arasında seçim yapabilirsiniz. Bu seçim, gördüğünüz tasarım özelliklerini ve komutlarını etkiler, böylece uygulamanızın Web uyumlu olduğundan emin olmak kolaydır.

  • Varolan veritabanını Web veritabanına dönüştürme    Var olan bir uygulamayı Web 'de yayımlayabilirsiniz. Tüm masaüstü veritabanı özellikleri Web 'de desteklenmediğinden, uygulamanızın bazı özelliklerini ayarlamanız gerekebilir.

    Uyumluluk sorunlarını belirlemenize ve düzeltmenize yardımcı olması için yeni Web Uyumluluk Denetleyicisi 'Ni çalıştırabilirsiniz.

  • Intranet veya Internet    Kendi SharePoint sunucunuza yayımlayabilirsiniz veya barındırılan bir SharePoint çözümünü kullanabilirsiniz.

    Not: Web veritabanını kullanmak için bir kullanıcı hesabı gerekir. Anonim erişim desteklenmez.

Web veritabanları hakkında daha fazla bilgi için Web 'de paylaşmak üzere veritabanı oluşturmamakalesine bakın.

Yeni Makro Oluşturucusu

Access 2010, IntelliSense ve temiz, kolay bir arabirim sunan yeni bir Makro Oluşturucusu sunmaktadır.

Makro Oluşturucusu

1. listeden bir eylem seçin...

2.... veya eylem kataloğunda bir eyleme tıklayarak bunu makroya ekleyin.

3. bir makro üzerinde çalışırken Tasarım sekmesi görüntülenir.

Bir eylem eklediğinizde, Makro Oluşturucusu 'nda daha fazla seçenek görünür. Örneğin, bir "If" eylemi eklediğinizde:

If eyleminin bulunduğu makro

Yeni makro oluşturucunun nasıl çalıştığını görmek için aşağıdaki videoyu izleyin.

Tarayıcınız video desteklemiyor. Microsoft Silverlight, Adobe Flash Player veya Internet Explorer 9’u yükleyin.

Geleneksel makroların yanı sıra, Yeni Makro Oluşturucusu 'nu kullanarak yeni bir özellik oluşturun.

Veri makroları: verileri olaylara göre değiştirme

Veri makroları Web veritabanlarındaki toplamları desteklemenize yardımcı olur ve ayrıca herhangi bir Access 2010 veritabanında "Tetikleyiciler" uygulamak için bir yol sağlar.

Örneğin, tamamlanmalıdır tamamlanma alanı ve durum alanı olduğunu varsayalım. Durumu tamamlandıolarak ayarladığınızda, bir veri makrosunu 100 olarak ayarlamak için, durumu başlatılmadıolarak ayarladığınızda 0 ' ı kullanabilirsiniz.

Aşağıdaki videoda veri makrolarının eylemde görebilirsiniz.

Tarayıcınız video desteklemiyor. Microsoft Silverlight, Adobe Flash Player veya Internet Explorer 9’u yükleyin.

Gelişmiş Ifade Oluşturucusu

Ifade Oluşturucusu artık IntelliSense 'in özelliklerini, böylece siz yazarken seçeneklerinizi görebilirsiniz. Ayrıca, Ifade Oluşturucusu penceresinde seçili durumdaki ifade değeri için yardım görüntüler. Örneğin, Kırp işlevini seçerseniz, Ifade Oluşturucusu görüntülenir:

Trim (dize), baştaki ve sondaki boşluklar olmadan belirtilen dizenin bir kopyasını içeren dize türünde bir değişken döndürür.

Daha fazla bilgi için Ifade Oluşturucusu 'Nu kullanmamakalesine bakın.

Hesaplanan alanlar

Hesaplama sonuçlarının görüntülendiği bir alan oluşturabilirsiniz. Hesaplama, aynı tablonun başka alanlarına başvuru içermelidir. Hesaplamayı oluşturmak için Ifade Oluşturucusu 'nu kullanırsınız.

Yeni veritabanı şablonları

Access 2010, diğer veri türlerinin yanı sıra kişileri, görevleri, etkinlikleri, öğrencileri ve varlıkları izlemek için profesyonel bir veritabanı şablonları paketi içerir. Bilgileri tam olarak istediğiniz gibi izlemek için bunları hemen açabilir veya geliştirebilirsiniz ve geliştirebilirsiniz.

Backstage görünümünde kullanılabilir şablonlar

Her şablon, önceden tanımlanmış tablolar, formlar, raporlar, sorgular, makrolar ve ilişkiler içeren eksiksiz bir izleme uygulamasıdır. Şablonlar, hızlı bir şekilde, hızlı bir şekilde çalışmaya başlamak için, kutu içinde dışarıda olacak şekilde tasarlanmıştır. Şablon tasarımı gereksinimlerinizi karşılıyorsa, hazırsınız demektir. Aksi takdirde, belirli gereksinimlerinizi karşılayan veritabanı oluştururken bir baş başlangıç yapmak için bu şablonu kullanabilirsiniz.

Varlıklar Web Veritabanı

Access 2010 bulunan şablonlara ek olarak, Office.com bağlanabilir ve daha fazla şablon indirebilirsiniz.

Var olan bir veritabanına işlevsellik eklemek için uygulama bölümleri

Uygulama bölümü kullanarak varolan bir veritabanına kolayca işlevsellik ekleyebilirsiniz. Access 2010 'te, uygulama bölümü, bir veritabanının bir bölümünü oluşturan bir şablondur (örneğin, önceden biçimlendirilmiş bir tablo veya ilişkili bir form ve raporla bir tablo). Örneğin, veritabanınıza bir Görevler uygulaması bölümü ekleyin ve görevler tablosu, görevler formu ve görevler tablosunu veritabanınızda başka bir tabloyla ilişkilendirme seçeneğini kullanabilirsiniz.

Oluştur sekmesinde Uygulama Bölümleri

Daha fazla bilgi için, veritabanı tasarım öğelerini kaydetme ve yeniden kullanmamakalesine bakın.

Geliştirilmiş veri sayfası görünümü

Tablo oluşturabilir ve bu tabloyu, alanları kullanmadan kullanmaya başlayabilirsiniz — Oluştur sekmesindeki tablo 'ya tıklayın ve görüntülenen yeni veri sayfasına veri girmeye başlayabilirsiniz. Access 2010, her alan için en iyi veri türünü otomatik olarak belirler; Sütun eklemek Için tıkla , yeni bir alanın ekleneceği yeri gösterir ve yeni veya varolan bir alanın veri türünü veya görüntüleme biçimini değiştirmeniz gerekirse, Şeritteki komutları, alanlar sekmesinde kullanabilirsiniz. Ayrıca, Microsoft Excel tablolarından verileri yeni bir veri sayfasına da yapıştırabilirsiniz; Access 2010 tüm alanları oluşturur ve veri türlerini otomatik olarak tanır.

Veri Sayfası görünümünde Eklemek için Tıklatın

Alan Listesi bölmesi

Alan listesi bölmesi, diğer tablolardan alanlar eklemenize olanak tanır. Kayıt kaynağınızdaki tablodan, ilgili tablolardan veya veritabanındaki ilişkisiz tablolardan alanları sürükleyebilirsiniz. Tablolar arasındaki bir ilişkide gerekirse, otomatik olarak oluşturulur veya süreç aracılığıyla size sorulur.

Alan Listesi bölmesi

Düzen görünümü formların ve raporların tasarımını hızlandırmaya yardımcı olur

Form veya raporda verileri görüntülerken tasarım değişiklikleri yapmak için Düzen görünümünü kullanın.

Düzen görünümü bazı geliştirmeleri Özellikler ve Web için form veya rapor tasarlıyorsanız gereklidir.

Düzen görünümünde canlı verileri gösteren form

İşlerinizi halletmek için denetim düzenlerini kullanma

Düzenler, birim olarak taşıyabileceğiniz ve yeniden boyutlandırabileceğiniz denetim gruplarıdır. Access 2010, düzenler formlar ve raporlardaki denetimlerin daha esnek yerleştirmesini sağlayacak şekilde geliştirilmiştir. Hücreleri yatay veya dikey olarak bölebilir veya birleştirebilirsiniz, böylece alanları, sütunları veya satırları kolayca yeniden düzenleyebilirsiniz.

Web veritabanları tasarlarken Düzen görünümü kullanmalısınız, ancak tasarım görünümü hala masaüstü veritabanı tasarım çalışması için kullanılabilir.

Yeni Kullanıcı arabirimi

Yeni Kullanıcı arabirimi ( Access 2010 geliştirilmiş), karmaşık menülerde ve araç çubuklarında genellikle yer alan komutların ve özelliklerin bulunmasını kolaylaştırmak için tasarlanmıştır.

Şerit

Şerit, özellik ve işlevlere göre düzenlenmiş komut gruplarını içeren bir sekmeler topluluğudur. Şerit, Access 'in önceki sürümlerinde bulunan menü ve araç çubuklarının katmanlarını değiştirir. Aşağıdaki resimde, giriş sekmesinin seçili olduğu şerit gösterilmektedir.

Access 2010’daki şerit

Şeridin anahtar özellikleri şunları içerir:

  • Komut sekmeleri, ihtiyacınız olan komutları bulmanız için genellikle birlikte kullanılan komutları görüntüler.

  • Bağlamsal komut sekmeleri — sitenize bağlı olarak görünen bir komut sekmesi — Yani, üzerinde çalıştığınız nesne veya gerçekleştirdiğiniz görev. Bağlamsal komut sekmesi, yaptığınız şeylere en büyük olasılıkla uygulama komutlarını içerir.

  • Galeriler — bir stil veya seçeneğin önizlemesini görüntüleyen yeni denetimler; böylece, bir seçime kaydetmeden önce sonuçları görebilirsiniz.

Backstage görünümü

Access 2010 'da yeni Backstage görünümü sıkıştırma ve onarma gibi tüm veritabanına uyguladığınız ve yeni bir veritabanı açan komutları içerir. Komutlar, ekranın sol tarafındaki sekmelerde düzenlenir ve her sekmede ilgili komut veya bağlantı grubu bulunur. Örneğin, Yeni'yi tıklatırsanız, sıfırdan yeni bir veritabanı oluşturmanıza veya profesyonel olarak tasarlanmış veritabanı şablonları kitaplığından seçerek düğme kümesi görürsünüz.

Backstage görünümünde Yeni sekmesi

Backstage görünümünde bulduğunuz komutların çoğu, en son açtığınız ve (Internet 'e bağlıysanız) office.com makalelerine olan veritabanlarına ek olarak Access 'in önceki sürümlerindeki Dosya menüsünde bulunur.

Backstage görünümüne gitmek için Dosya sekmesini tıklatın.

Gezinti Bölmesi

Gezinti bölmesi, açık olan veritabanındaki tüm nesnelere kolay erişim sağlar.

Gezinti bölmesi Northwind 2007

Nesneleri nesne türüne, oluşturulma tarihine, Tarih değiştirme 'ye (nesne bağımlılıklarına göre) veya oluşturduğunuz özel gruplara göre düzenlemek için gezinti bölmesi 'ni kullanın. Form tasarımınızda çalışmak için daha fazla alana mı ihtiyacınız var? Gezinti Bölmesi 'ni kolay bir şekilde daraltabilir, ancak yine de kullanılabilir.

Sekmeli nesneler

Tablolar, sorgular, formlar, raporlar ve makrolar varsayılan olarak Access penceresinde sekmeli nesneler olarak görüntülenir.

Bu ayarı her veritabanı için değiştirebilir ve sekmeler yerine nesneler pencerelerini kullanabilirsiniz.

Nesne sekmelerini tıklatarak Access 2007'de sekmeli nesne çeşitli nesneler arasında kolayca geçiş yapabilirsiniz.

Yardım penceresi

Access 2010, Access Yardımı ve Access geliştiricisi başvuru içeriği aynı Yardım penceresinde sunulur. İki sistem farklı türde yardım içeriği içerir. Yardım Görüntüleyici, hangi içeriğin görüntüleneceğini seçmenizi sağlar. Aramanızın kapsamını yalnızca Access geliştiricisi başvuru içeriğiyle değiştirebilirsiniz; örneğin. Yardım penceresinde yaptığınız ayarlardan bağımsız olarak, tüm Access Yardımı ve Access geliştiricisi başvuru içeriği her zaman çevrimiçi olarak Office.com veya MSDN 'de kullanılabilir.

Daha güçlü nesne oluşturma araçları

Access 2010, veritabanı nesneleri oluşturmak için sezgisel bir ortam sağlar.

Oluştur sekmesi

Yeni formlar, raporlar, tablolar, sorgular ve diğer veritabanı nesnelerini hızlıca oluşturmak için Oluştur sekmesini kullanın. Gezinti Bölmesi 'nde bir tablo veya sorgu seçerseniz, form veya rapor komutunu kullanarak tek tıklamayla bu nesneye dayalı yeni bir form veya rapor oluşturabilirsiniz.

Access’te şeritteki Oluştur sekmesi

Bu tek tıklama süreci tarafından oluşturulan yeni formlar ve raporlar, bunları görsel açıdan çekici ve hemen kullanışlı hale getirmenize yardımcı olmak için güncelleştirilmiş bir tasarım kullanın. Otomatik olarak oluşturulan formlar ve raporlar, logo ve başlık içeren üst bilgilerle profesyonel görünümlü bir tasarım alır. Ayrıca, otomatik olarak oluşturulan rapor da, tarih ve saati, bilgilendirici altbilgi ve toplamları da içerir.

Rapor görünümü ve Düzen görünümü

Access 2010 'da geliştirilmiş bu görünümler, formlarla ve raporlarla etkileşimli olarak çalışmanıza olanak tanır. Rapor görünümünü kullanarak, raporunuzu baskı önizlemede yazdırmadan veya görüntülemenize gerek kalmadan doğru şekilde işleme başlayabilirsiniz. Belirli kayıtlara yoğunlaşmak için filtre özelliğini kullanın veya eşleşen metni aramak için bir bul işlemi kullanın. Metni panoya kopyalamak için Kopyala komutunu kullanabilir veya tarayıcınızdaki bağlantıyı izlemek için raporunuzda görüntülenen etkin köprüleri tıklatabilirsiniz.

Düzen görünümü, verilerinizi tararken tasarım değişiklikleri yapmanızı sağlar. Düzen görünümünü kullanarak, form veya rapordaki verileri görüntülerken birçok yaygın tasarım değişikliği yapabilirsiniz. Örneğin, alan adını yeni alan listesi bölmesinden sürükleyerek alan ekleyin veya özellik sayfasını kullanarak özellikleri değiştirin.

Düzen görünümü artık alanları, sütunları, satırları veya tüm düzenleri kolayca yeniden düzenleyebilmek için sayfa olarak ayarlayabileceğiniz geliştirilmiş tasarım düzenleri (Denetim grupları) sunar. Bir alanı kaldırabilir veya Düzen görünümünde kolayca biçimlendirme ekleyebilirsiniz. Düzen görünümünde rapor

Raporlarda kolay gruplandırma ve sıralama oluşturma

Access 'de, raporlarda verileri gruplandırmak ve sıralamak ve toplamları eklemek için yeni bir yol vardır. Arabirimin gezinmeyi ve anlaşılmasını kolaylaştırmak ve yeni düzen görünümüyle kullanıldığında, yaptığınız değişikliklerin etkisini anında görebilirsiniz.

Gruplandırma, Sıralama ve Toplam bölmesi

Raporda bölgeye göre toplam satışları görmek istediğinizi varsayalım. Düzen görünümünü ve grup , Sırala ve toplam bölmesini kullanarak grup düzeyi ekleyin ve toplam isteyin ve değişiklikleri canlı olarak görün. Toplam satırı rapor üst bilgileri veya altbilgilere kolay bir toplam, ortalama, say, maksimum veya en az eklemeyi sağlar. Basit toplamlar artık el ile hesaplanan alan oluşturmayı gerektirmez. Şimdi sadece işaret edin ve tıklayın.

Raporda toplam oluşturma

Şık formlar ve raporlar oluşturmanıza yardımcı olacak geliştirilmiş Denetim düzenleri

Formlar ve raporlar genellikle, müşteri adlarını içeren sütun veya müşterinin tüm alanlarını içeren bir satır gibi sekmeli bilgiler içerir. Bu denetimleri, etiket dahil, tek bir birim olarak kolayca yönetilebilir bir düzende gruplandırabilirsiniz.

Düzenle sekmesinin Denetim Düzeni grubundaki komutlar

Bölüm üstbilgisindeki veya altbilgisindeki etiket gibi farklı bölümlerdeki denetimleri seçebildiğinden, oldukça esnek bir değer vardır. Kolayca:

  • Düzeni taşıma veya yeniden boyutlandırma. Örneğin, sütunu sola veya sağa taşıma.

  • Düzen biçimlendirme. Örneğin, bir müşteri adı sütununu kalın olarak ayarlayın; böylece.

  • Düzene sütun (alan) ekleme.

  • Düzenden bir sütun (alan) silme.

  • Hücreleri birleştirme veya bölme

Düzen görünümünde sütun taşıma

Düzenler, tasarımlarınız ile kaydedilir, böylece kullanılabilir. Aşağıdaki videoda, raporlarda ve raporlarda mizanpajlar nasıl çalışır?

Tarayıcınız video desteklemiyor. Microsoft Silverlight, Adobe Flash Player veya Internet Explorer 9’u yükleyin.

Verileri hızlı bir şekilde taramak için bölünmüş formlar

Bölünmüş form kullanarak veri sayfası görünümünü ve form görünümünü birleştiren bir form oluşturun. Access 'in veri sayfasını üste, aşağıya, sola veya sağa koyar.

Bölünmüş form

Not: Bölünmüş formlar web veritabanlarında kullanılamaz.

Formlarda ve raporlarda eklenmiş makrolar

Kod yazmak zorunda kalmamak için eklenmiş makroları kullanın. Katıştırılmış makro bir özellikte depolanır ve nesnenin ait olduğu nesnenin bir bölümüdür. Katıştırılmış bir makronun tasarımını, makroyu kullanan diğer denetimler hakkında endişelenmenize gerek kalmadan değiştirebilirsiniz; her katıştırılmış makro bağımsız. Ekli makrolar güvenilir olduğu için güvenilir.

Çift Tıklatma olayına katıştırılmış makro atama

Yeni veri türleri ve denetimleri

Access 2010 'da yeni, hesaplanan alanlar hesaplamanın sonucunu depolamanıza olanak tanır.

  • Birden çok değerli alanlar

  • Ek veri türü

  • Geliştirilmiş Not alanları

  • Tarih/saat alanları için yerleşik Takvim denetimi

Hesaplanan alanlar

Aynı tablodaki diğer verilerden hesaplanan bir değeri görüntüleyen bir alan oluşturabilirsiniz. Hesaplama oluşturmak için Ifade Oluşturucusu 'nu kullanıyorsunuz, böylece ifade değerleri için yardım 'a IntelliSense 'den ve kolay erişimden yararlanabilirsiniz.

Hesaplanan verilerin kaynağı olarak diğer tablolardaki veriler kullanılamaz. Bazı ifadeler, hesaplanan alanlar tarafından desteklenmez.

Birden çok değerli alanlar

Birden çok değerli alan kayıt başına birden çok değer depolayabilir. Bir görevi Çalışanlarınızdan birine veya yüklenicilere atamanız gerektiğini, ancak birden fazla kişiye atamak istediğinizi varsayalım. Çoğu veritabanı yönetim sisteminde ve Office Access 2007 'dan önceki Access sürümlerinde, bunu doğru şekilde yapmak için çok-çok ilişkisi oluşturmanız gerekirdi.

Not: Access, birden çok değerli alan için gereken çok-çok ilişkisinin korunması için gizli bir tablo oluşturur.

Birden çok değerli alanlar özellikle, Windows SharePoint Services kullanılan çok değerli alan türlerinden birini içeren bir SharePoint listesiyle çalışırken uygundur. Access 2010 Bu veri türleriyle uyumludur.

Birden çok değerli alan

Dosyalar için ek alanları

Ek veri türü, veritabanınızda tüm belge ve ikili dosyaları, veritabanında gereksiz büyüme olmadan kolayca depolamanıza olanak tanır. Access mümkün olduğunca, alan kullanımını en aza indirgemek için ekleri otomatik olarak sıkıştırır. Bir kayda Word belgesi eklemek veya veritabanınızda bir dizi dijital resim kaydetmek mi istiyorsunuz? Eklerin kullanılması bu görevleri çok daha kolay hale getirir. Hatta tek bir kayda birden çok ek ekleyebilirsiniz.

Ekler iletişim kutusu

Not: Web veritabanlarında ek alanlarını kullanabilirsiniz, ancak her Web tablosunda en fazla bir ek alanı olabilir.

Not alanları artık zengin metin ve destek düzeltme geçmişini depolar

Zengin metin Not alanları kayıtlarınızda artık düz metin ile sınırlandırılmaz. Metni (kalın, italik, farklı yazı tiplerine ve renklere ek olarak kalın, italik vb.) ve veritabanınızdaki metni depolayabilirsiniz. Zengin biçimlendirilmiş metin, Windows SharePoint Services 'daki zengin metin veri türüyle uyumlu HTML tabanlı bir biçimde bir not alanında depolanır. Yeni TextFormat özelliğini RichText veya düzmetin olarak ayarlarsınız ve bilgi, metin kutusu denetimlerinde ve veri sayfası görünümünde doğru şekilde biçimlendirilir.

Not alanları, çok büyük miktarlarda verinin depolanması için kullanışlı alanlardır. Not alanına yapılan tüm değişikliklerin geçmişini tutmak için yalnızca Append özelliğini yapılandırabilirsiniz. Sonra, söz konusu değişikliklerin geçmişini görüntüleyebilirsiniz. Bu özellik ayrıca Windows SharePoint Services izleme özelliğini destekleyerek, SharePoint listesi içerik geçmişini görüntülemek için de Access 'i de kullanabilirsiniz.

Tarihleri çekme takvimi

Tarih/saat veri türünü kullanan alanlar ve denetimler yerleşik etkileşimli bir takvim için otomatik olarak destek kazanır. Takvim düğmesi tarihin sağında otomatik olarak görüntülenir. Gelecek Cuma günü için tarihi öğrenmek mi istiyorsunuz? Tarihi bulup seçmenizi sağlamak için düğmeye tıklayın ve takvim otomatik olarak görüntülenir. Bir alan veya denetimin takvimini özellik kullanarak kapatmayı tercih edebilirsiniz.

Geliştirilmiş veri sunusu

Yeni veri sunusu özellikleri, veritabanı nesnelerini daha çabuk oluşturmanıza ve verilerinizi daha kolay çözümlemenize yardımcı olur.

Gelişmiş sıralama ve filtreleme araçları

Eşleşen bir değeri hızlı bir şekilde bulmanız veya bir veri sütununu sıralamanızı varsayalım. Otomatik filtre özelliği, size gereken verilere hızla odaklanabilmek için halen güçlü filtreleme yeteneklerine sahiptir. Bir sütundaki benzersiz değerler arasından kolayca seçim yapabilirsiniz; bu, size gereken adı geri çekemediğinizde durumlar için yararlı olabilir ya da yalnızca en Eskiden Yeniye Sırala veya küçükten büyüğe Sırala gibi düz dillerde bağlam menüsü seçeneklerini kullanarak değerleri sıralayabilirsiniz.

Otomatik Filtre

En yaygın filtre seçenekleri menü komutlarında kolayca görünür durumdadır veya hızlı filtreler kullanarak, girdiğiniz verilere dayalı olarak bilgileri sınırlayabilirsiniz. Hızlı filtre seçenekleri, metin, tarih ve sayısal bilgiler için istediğiniz seçenekleri görmeniz için veri türüne göre otomatik olarak değişir.

Veri Filtreleri menüsü

Veri sayfalarında toplamları ve alternatif arka plan renkleri

Veri sayfası görünümü toplam, say, ortalama, maksimum, en küçük, standart sapma veya varyansı gösterebileceğiniz toplam satırı sunar. Toplam satırını ekledikten sonra, sütunun hücresindeki oka işaret ettikten sonra istediğiniz hesaplamayı seçersiniz.

Veri sayfasında Toplam satırı

Veri sayfaları, raporlar ve sürekli formlar, satırlar için, varsayılan arka plan renginden bağımsız olarak yapılandırabileceğiniz farklı bir arka plan rengini destekler. Diğer tüm satırları gölgelendirme kolaydır ve istediğiniz rengi seçebilirsiniz.

Farklı satır renginin kullanıldığı veri sayfası

Koşullu biçimlendirme

Access 2010 yeni koşullu biçimlendirme özellikleri ekler ve Excel 'de sağlanan biçimlendirme stillerinden bazılarını elde etmenize olanak sağlar. Örneğin, aşağıdaki çizimde gösterildiği gibi, bir dizi sayının daha okunaklı olmasını sağlayacak veri çubukları ekleyebilirsiniz:

Access raporunda koşullu biçimlendirme

Not: Web veritabanlarında koşullu biçimlendirme kullanılamaz.

Gelişmiş güvenlik

Gelişmiş güvenlik özellikleri ve Windows SharePoint Services ile güçlü tümleştirme sayesinde, bilgi izleme uygulamalarınızı daha önce kullanmaktan daha güvenli hale getirmenize olanak tanır. Uygulama verilerinizi Windows SharePoint Services listelerde saklayarak, düzeltme geçmişini denetleyebilir, silinmiş bilgileri kurtarabilir ve veri erişim izinlerini yapılandırabilirsiniz.

Office Access 2007, Access 2010 'te taşınan ve geliştirilmiş yeni bir güvenlik modeli getirmiştir. Birleşik güven kararları Microsoft Office Güven Merkezi ile tümleşiktir. Güvenilen konumlar, güvenli klasörlerdeki tüm veritabanlarına güvenmeyi kolaylaştırır. Daha güvenli, korumalı (başka bir deyişle, güvenli olmayan komutlar çalıştırılamaz) deneyimi sağlamak amacıyla, kodu veya makroları devre dışı bırakılmış bir Office Access 2007 uygulaması yükleyebilirsiniz. Güvenilir makrolar Sandbox modunda çalıştırılır.

InfoPath formlarını ve Outlook 'U kullanarak veri biriktirme

Veri toplama özelliği, Outlook ve isteğe bağlı olarak InfoPath kullanarak görüşünüzü topmanıza yardımcı olur. Otomatik olarak bir InfoPath formu veya HTML formu oluşturabilir ve bunu e-posta iletisinin gövdesine ekleyebilirsiniz. Formu Outlook kişilerinizden seçilen alıcılara veya Access veritabanınızdaki bir alanda depolanan alıcıların adlarına gönderebilirsiniz.

E-posta iletisi kullanarak veri toplama

Yeni bilgileri toplamayı veya mevcut bilgileri güncelleştirmeyi seçersiniz. Ardından Alıcılar formu tamamlar ve iade edin. Outlook, gelen formları algılar ve verileri otomatik olarak Access veritabanınıza kaydeder; gerekli değildir.

PDF ve XPS 'e dışarı aktarma

Access 2010, önce PDF veya XPS eklentisi olarak Yayımla 'yı ilk kez yüklemeniz koşuluyla, verileri PDF 'ye (taşınabilir belge biçimi) veya XPS (XML Kağıt Belirtimi) dosya biçimine aktarabilirsiniz. Form, rapor veya veri sayfasını. PDF veya. XPS dosyasına dışarı aktarmak, tüm biçimlendirme özelliklerini koruyan, ancak diğer kişilerin çıktınızı yazdırması veya gözden geçirmek için bilgisayarlarında erişim gerektirmelerini zorunlu kılmanıza olanak tanır.

  • Taşınabilir Dosya Biçimi    PDF, belge biçimlendirmesini koruyan ve dosya paylaşmaya yardımcı olan sabit düzene sahip bir elektronik dosya biçimidir. PDF biçimi, dosyanın çevrimiçi veya yazdırılmış olduğu durumlarda, tam olarak amaçladığınız biçimi korur ve dosyadaki veriler kolayca kopyalanabilir veya değiştirilemez. PDF biçimi ticari yazdırma yöntemleri kullanılarak üretilecek belgeler için de uygundur.

  • XML Kağıt Belirtimi    XPS, belge biçimlendirmesini koruyan ve dosya paylaşmaya yardımcı olan elektronik bir dosya biçimidir. XPS biçimi, dosya çevrimiçi veya yazdırılmış olduğunda, tam olarak istediğiniz biçimi korur ve dosyadaki veriler kolayca kopyalanabilir veya değiştirilemez.

Dış verilerle çalışma

Artık bir Web hizmetine dış veri kaynağı olarak bağlanabilirsiniz. Web Hizmeti Yöneticisi tarafından sağlanan bir Web hizmeti tanım dosyasına ihtiyacınız olacak. Tanım dosyasını yükledikten sonra, Web hizmeti verilerine bağlı tablo olarak bağlanabilirsiniz.

Yeni özellikler verileri içeri aktarmayı ve vermeyi kolaylaştırır. İçeri veya dışarı aktarma işlemini kaydedebilir ve sonra aynı görevi gerçekleştirmek istediğinizde kaydedilen işlemi yeniden kullanabilirsiniz. Elektronik tablo Al Sihirbazı, Access tarafından seçilen veri türünü geçersiz kılmanıza ve Office Excel 2007 en az dosya biçimi olan dosyaları içeri aktarabilir, dışarı aktarabilir ve bunlara bağlantı kurabilirsiniz.

Sorunları gidermek için daha iyi bir yol

Microsoft Office Tanılama, bilgisayarınızın neden kilitlendiğinizi keşfetmenize yardımcı olabilecek bir dizi tanılama sınamadır. Tanı sınamaları bazı sorunları doğrudan çözebilir ve diğer sorunları çözmenize yol açabilir. Microsoft Office Tanılama aşağıdaki Microsoft Office 2003 özelliklerini değiştirir: Algıla ve Onar ve Microsoft Office uygulama kurtarması.

Gelişmiş Yazım denetimi

Yazım denetleyicisinin bazı yeni özellikleri aşağıda verilmiştir.

  • Yazım denetleyicisi Office programlarında daha tutarlı bir şekilde davranır. Bu değişiklik örnekleri şunlardır:

    • Bazı yazım denetimi seçenekleri artık geneldir. Bir Office programında bu seçeneklerden birini değiştirirseniz, diğer tüm Office programları için bu seçenek de değiştirilmiştir.

    • Aynı özel sözlükleri paylaşmanın yanı sıra, tüm programlar aynı iletişim kutusunu kullanarak bunları yönetebilir. Daha fazla bilgi için, yazım denetimcisini kullanarak sözcük eklemebaşlıklı makaleye bakın.

  • Yazım denetleyicisi reform sonrası Fransızca sözlüğünü içerir. Microsoft Office 2003 'da bu, ayrı yüklenmiş bir eklentidir.

  • Dil için bir dışlama sözlüğü, dil için otomatik olarak oluşturulur. Yazım denetleyicisini kullanmaktan kaçınmak istediğiniz sözcükleri bayrakla işaretleyezorlamak için dışarıda bırakma sözlükleri kullanabilirsiniz. Dışlama sözlükleri, obsahne olan veya stil kılavuzunuz ile eşleşmeyen sözcükleri önleþtirmek için faydalıdır. Daha fazla bilgi için, bir sözcüğün tercih edilen yazımını belirtmek üzere dışlama sözlüklerini kullanmamakalesine bakın.

Not:  Bu sayfanın çevirisi otomasyon aracılığıyla yapılmıştır ve bu nedenle hatalı veya yanlış dil bilgisi kullanımları içerebilir. Amacımız, bu içeriğin sizin için faydalı olabilmesini sağlamaktır. Bu bilgileri yararlı bulup bulmadığınızı bizimle paylaşır mısınız? Kolayca başvurabilmek için İngilizce makaleye buradan ulaşabilirsiniz.

Office yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×