Makro kaydetme

Not: En güncel yardım içeriklerini, mümkün olduğunca hızlı biçimde kendi dilinizde size sunmak için çalışıyoruz. Bu sayfanın çevirisi otomasyon aracılığıyla yapılmıştır ve bu nedenle hatalı veya yanlış dil bilgisi kullanımları içerebilir. Amacımız, bu içeriğin sizin için faydalı olabilmesini sağlamaktır. Buradaki bilgilerin faydalı olup olmadığını bu sayfanın sonunda bize bildirebilir misiniz? Kolayca başvurabilmek için İngilizce makaleye buradan ulaşabilirsiniz.

Microsoft Office Project'te bir görevi sürekli gerçekleştiriyorsanız, görevi bir makroyla otomatikleştirebilirsiniz. Makro, bir modül içinde saklanan bir dizi komut ve işlevden oluşur ve görevi yerine getirmeniz gereken her an çalıştırılabilir.

  1. Görünüm sekmesinde, makrolar' ı tıklatın ve sonra da MakroKaydet'i tıklatın.

    (Project 2007'de, Araçlar menüsünde, makroseçeneği üzerine gidin ve sonra Yeni makroKaydet öğesini tıklatın.)

  2. Makro adı kutusunda, makro için bir ad yazın.

    Makro adının ilk karakteri bir harf olmalıdır. Diğer karakterler harf, rakam veya altçizgi karakteri olabilir. Makro adında boşluk kullanılamaz, fakat altçizgi karakteri sözcükleri ayırma görevini üstlenir.

  3. Makroyu bir kısayol tuşu basarak çalıştırabilmek için Kısayol tuşu kutusuna bir harf veya tuş bileşimi girin.

    CTRL+harf (küçük harf için) veya CTRL+ÜSTKRKT+harf (büyük harf için) tuş bileşimlerini kullanabilirsiniz. Bu kullanımda harf, klavye üzerindeki herhangi bir harf tuşudur, ancak rakam veya özel karakter tuşu değildir. Halihazırda Microsoft Office Project'te kullanımda olan bir tuş bileşimini kullanamazsınız.

  4. Makroyu kaydetme yeri listesinde, makroyu saklamak istediğiniz konumu tıklatın:

    • Project'i her kullanışınızda makroyu kullanılabilir hale getirmek için Genel Dosya seçeneğini tıklatın.

    • Makroyu yalnızca geçerli proje için kullanılabilir hale getirmek için Bu Proje seçeneğini tıklatın.

  5. Makroyla ilgili bir açıklama eklemek için, açıklamayı Açıklama kutusuna yazın.

  6. Makro kaydederken hücreleri seçerseniz, makro, sütunlara mutlak başvurular kaydettiği için ilk önce hangi sütun seçilirse seçilsin, her çalıştığında aynı sütunu (alanı) seçer. Makroyu çalıştırdığınızda, etkin hücrenin konumundan bağımsız olarak, makronun sütunları seçmesini isterseniz, Sütun başvuruları altında Göreli'yi tıklatın.

    Bunun aksine olarak, satırlara göreli başvurular kaydettiği için makroyu çalıştırdığınızda etkin hücrenin konumundan bağımsız olarak satırları seçer. İlk önce hangi hücre seçilirse seçilsin, makronun her zaman aynı satırı seçmesini isterseniz Satır başvuruları altında Mutlak (Kimlik) öğesini tıklatın.

    Not: Project, siz ayarları değiştirinceye veya Project'i kapatıncaya kadar makroları kaydederken bu ayarları kullanmaya devam eder.

  7. Tamam seçeneğini tıklatın ve kaydetmek istediğiniz eylemleri gerçekleştirin.

  8. Tüm, Görünüm sekmesinde, kaydetmek istediğiniz eylemleri tamamladığınızda, makrolar' ı tıklatın ve ardından Kaydı Durdur'utıklatın.

    (Project 2007'de, Araçlar menüsünde, makroseçeneği üzerine gidin ve sonra Kaydedicisi'ni durduruntıklatın.)

Güvenlik Notu: Makrolar virüs içerebildiğinden, çalıştırırken dikkatli olun. Aşağıdaki önlemleri alın: bilgisayarınızda güncel antivirüs yazılımını çalıştırın; makro güvenliği düzeyinizi yüksek olarak ayarlayın; Tüm yüklü eklentilere ve şablonlara güven onay kutusunu temizleyin; dijital imzalar kullanın; güvenilir yayımcıların listesini verin.

Office yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×