Mac için Office 'te makro oluşturma, çalışma, düzenleme veya silme

Not: En güncel yardım içeriklerini, mümkün olduğunca hızlı biçimde kendi dilinizde size sunmak için çalışıyoruz. Bu sayfanın çevirisi otomasyon aracılığıyla yapılmıştır ve bu nedenle hatalı veya yanlış dil bilgisi kullanımları içerebilir. Amacımız, bu içeriğin sizin için faydalı olabilmesini sağlamaktır. Buradaki bilgilerin faydalı olup olmadığını bu sayfanın sonunda bize bildirebilir misiniz? Kolayca başvurabilmek için İngilizce makaleye buradan ulaşabilirsiniz.

Sık yaptığınız görevlerle ilgili zaman kazanmak Için, bu görevlerin adımlarını makro olarak kaydedebilirsiniz. Ardından, bu kaydedilmiş görevlerden birini gerçekleştirmek istediğinizde, adımları sizin için gerçekleştirecek şekilde özelleştirebilirsiniz.

Word

Mac için Word 2016 'Te, klavye kısayoluna sahip bir makro oluşturabilir, makro çalıştırabilir ve artık ihtiyacınız olmayan bir makroyu silebilirsiniz.

  1. Görünüm > Makrolar > Makro Kaydet'i tıklatın.

    Bir makro oluşturmaya başlamak için Görünüm sekmesinde Makro’ya tıklayın ve ardından Makro Kaydet’e tıklayın.
  2. Makro için bir ad yazın veya Word ile sağlanan varsayılanı kabul edin.

    Makronuz için Makro adı alanına bir ad girin veya Word tarafından sağlanan genel adı kabul edin.
  3. Bu makroyu oluşturduğunuz tüm yeni belgelerde kullanmak Için, tüm belgelerin (normal) listede depola listesinde seçili olduğunu doğrulayın.

  4. Makroya bir tuş bileşimi atamak için klavye 'yi tıklatın.

    Wordklavyeyi Özelleştir iletişim kutusunu görüntüler.

  5. Yeni klavye kısayoluna basın kutusuna bir tuş bileşimi yazın.

    Bir tuş bileşimine basıldıktan sonra Word, varsa o tuş bileşimine atanmış komutu veya makroyu görüntüler.

    Bir tuş bileşimine bastığınızda, Word, varsa bu tuş bileşimine atanmış olan komutu veya eylemi görüntüler.

  6. Seçtiğiniz tuş kombinasyonu zaten atanmışsa, Yeni klavye kısayol kutusundan bunu silin ve sonra yeni bir tuş bileşimi seçin.

    Atanmamış bir anahtar birleşimi bulduktan sonraki adıma geçin.

    Word henüz bir komuta veya makroya atanmamış bir tuş bileşimine bastığınızda bunu tanımlar.
  7. Bu klavye kısayolunu tüm yeni belgelerde kullanmak Için, Değişiklikleri Kaydet listesinde normal. dotm(genel şablon) seçeneğinin belirlendiğinden emin olun.

    Bir makroyu, oluşturduğunuz yeni belgelerde kullanılabilir hale getirmek için Normal.dotm’yi seçin.
  8. Ata'yı tıklatın.

  9. Makroyu kaydetmeye hazır olduğunuzda Tamam'ı tıklatın.

  10. Görevdeki her adım için komutları tıklatın veya tuşlara basın.

    Word tıklamaları ve tuş vuruşlarını kaydeder, ancak fareyle seçtiğiniz metni kaydetmez. Makro kaydederken metin seçmek Için klavyeyi kullanın.

  11. Kaydetmeyi durdurmak için Görünüm > Makrolar > Kaydı Durdur'u tıklatın.

    Makro kaydını durdurmak için Makrolar menüsündeki Kaydı Durdur’a tıklayın.

Makro çalıştırmak Için, ona atanmış klavye kısayoluna basın veya makroyu makrolar listesinden çalıştırabilirsiniz.

  1. Görünüm > Makrolar > Makroları Görüntüle'yi tıklatın.

    Geçerli belgeyle ilişkili makroları görüntülemek ve düzenlemek için Makroları Görüntüle'ye tıklayın.
  2. Makro adıaltında, çalıştırmak istediğiniz makroyu seçin.

  3. Çalıştır'ı tıklatın.

    Makro adı altında bir makro seçtikten sonra, çalıştırmak için Çalıştır’a tıklayın.

  1. Görünüm > Makrolar > Makroları Görüntüle'yi tıklatın.

    Geçerli belgeyle ilişkili makroları görüntülemek ve düzenlemek için Makroları Görüntüle'ye tıklayın.
  2. Makro tarafından belirtilen konumun, silmek istediğiniz makronun konumunu içerdiğini doğrulayın.

    Görüntülemek istediğiniz makroların konumlarını Makro yeri listesinden seçin.

    Liste, geçerli pencerede açık olan belgeyi ve genel şablonu ve Word komutlarını içerir.

  3. Makro adıaltında, silmek istediğiniz makroyu seçin ve ardından listenin altındaki eksi işaretine tıklayın.

    Silmek istediğiniz makroyu seçin ve ardından listenin altındaki eksi işaretine tıklayın.
  4. Word makroyu silmek istediğinizi onaylamanızı istediğinde Evet'i tıklatın.

Excel

Mac için Excel 2016 ' te, klavye kısayoluna sahip bir makro oluşturabilir, makro çalıştırabilir ve artık ihtiyacınız olmayan bir makroyu silebilirsiniz.

Bir makro kaydettiğinizde, makro kaydedicisi makronuzun gerçekleştirmesini istediğiniz eylemleri tamamlamak için gereken tüm adımları kaydeder. Bu adımlar metin veya sayı girmeyi, şeritteki veya menülerdeki komutları tıklatmayı, biçimlendirmeyi, hücreleri, satırları veya sütunları seçmeyi ve elektronik tablonuzdaki hücreleri seçmek için farenizi sürüklemeyi kapsayabilir.

Not: Diğer gelişmiş özelliklerin yanı sıra makroları da kaydetme, oluşturma ve silme komutlarını da Şeritteki Geliştirici sekmesinde bulabilirsiniz. Geliştirici sekmesini kullanma hakkında daha fazla bilgi Için, Mac Için Excel 2016 'te makro oluşturmak veya silmek üzere Geliştirici sekmesini kullanmakonusuna bakın.

  1. Yeni> makro > makro seçin.

    Araçlar 'ı, ardından makro 'yu ve sonra Yeni Makro Kaydet

  2. Makro adı kutusuna makro için bir ad girin.

    Makro adı, konumu ve kısayol tuşunu girme

  3. Makro için bir klavye kısayolu oluşturmak Için, Option + cmd kutusuna bir harf yazın.

  4. Açılan listeden makro için bir konum seçin.

    Makroyu kaydetmek için

    Buna tıklayın

    Makro oluşturduğunuz belgede

    Bu Çalışma Kitabı

    Tüm açık belgelerde

    Yeni Çalışma Kitabı

    Excel'i her kullanışınızda kullanılabilmesi için

    Kişisel Makro Çalışma Kitabı

  5. Isteğe Makronuzun bir açıklama ekleyin.

  6. Kayıt yapmaya hazır olduğunuzda Tamam'ı tıklatın.

  7. Görevdeki her adım için komutları tıklatın veya tuşlara basın.

  8. Kaydı durdurmak Için, > makro > Kaydı Durdur'a tıklayın. (Bu adım makronuza kaydedilmeyecek.)

    Kaydı Durdur 'u seçin

Makro çalıştırmak Için, ona atanmış klavye kısayoluna basın veya makroyu makrolar iletişim kutusundan çalıştırabilirsiniz.

  1. Görünüm sekmesinde, Makro Görüntüle’ye tıklayın.

  2. Açılan menüde makrolar 'a tıklayın ve Bu çalışma kitabınıseçin.

  3. Listeden makronuzu seçip Çalıştır’a tıklayın.

    Mac için Excel Makrolar iletişim kutusu

  1. Araçlar > makro > makrolarınıseçin.

    Makro seçip makrolar 'ı seçin

  2. Silinecek makroyu seçin ve eksi işaretine basın.

    Makro adını seçin ve eksi işareti 'ni seçin

  3. Bir onay iletisi görüntülenir. Silme işlemini onaylamak için Evet'e tıklayın.

    Silmeyi Onayla

Ayrıca Geliştirici sekmesinden makro silebilirsiniz.

  1. Geliştirici sekmesinde, Makrolar’a tıklayın.

  2. Listede, silmek istediğiniz makroya tıklayın ve sonra sil düğmesine tıklayın.

    Silmek için bir makro seçin ve eksi işaretine tıklayın

Word

Yinelenen bir görevi otomatikleştirmek için, Word‘de hızlı şekilde bir makro oluşturabilirsiniz. Ayrıca kendi makro betiğinizi yazmak veya bir makronun tamamını veya bir bölümünü yeni bir makroya kopyalamak için Microsoft Visual Basic for Applications‘da Visual Basic Düzenleyicisi kullanabilirsiniz.

Makro kaydettiğinizde, makronuzun gerçekleştirmesini istediğiniz eylemleri tamamlamak için gereken adımların tümü kaydedilir. Bununla birlikte, kaydetmeyi durdurmak için sekmeye geri gitme, kaydedilen adımlara dahil edilmez.

  1. Geliştirici sekmesinde, Visual Basic altında, Kaydet’e tıklayın.

    Excel Geliştirici sekmesi, Visual Basic grubu

    Geliştirici sekmesi yoksa

    1. Şeridin sağ tarafında, Eylem açılan menüsü öğesine tıklayın ve sonra Şerit Tercihleri’ne tıklayın.

    2. Özelleştir altında, Geliştirici onay kutusunu seçin.

  2. Makro adı kutusuna makro için bir ad girin.

  3. Makronun saklanacağı yer açılır menüsünde, aşağıdakilerden birini yapın:

    Makroyu kaydetmek için

    Buna tıklayın

    Makroyu oluşturmakta olduğunuz belgede

    [belge adı] (belge)

    Tüm açık belgelerde

    Tüm belgeler (Normal)

  4. Tamam düğmesine tıklayın ve daha sonra, kaydetmek istediğiniz eylemleri gerçekleştirin.

  5. Geliştirici sekmesinde, Visual Basic altında, Durdur’a tıklayın.

Makro oluşturmak için yerleşik Visual Basic Düzenleyicisi'ni kullanabilirsiniz.

  1. Geliştirici sekmesinde, Visual Basic altında, Düzenle’ye tıklayın.

    Excel Geliştirici sekmesi, Visual Basic grubu

    Geliştirici sekmesi yoksa

    1. Şeridin sağ tarafında, Eylem açılan menüsü öğesine tıklayın ve sonra Şerit Tercihleri’ne tıklayın.

    2. Özelleştir altında, Geliştirici onay kutusunu seçin.

  2. Bir modülü yeniden başlatmanız gerekirse, Visual Basic Düzenleyicisi'ndeki Ekle menüsünde Modül'e tıklayın.

  3. Modülün kod penceresinde, kullanmak istediğiniz makro kodunu yazın veya yapıştırın.

  4. Bitirdiğinizde, Word menüsünde, Kapat ve Microsoft Word’e Dön’e tıklayın.

  1. Geliştirici sekmesinde, Visual Basic altında, Makrolar’a tıklayın.

    Excel Geliştirici sekmesi, Visual Basic grubu

    Geliştirici sekmesi yoksa

    1. Şeridin sağ tarafında, Eylem açılan menüsü öğesine tıklayın ve sonra Şerit Tercihleri’ne tıklayın.

    2. Özelleştir altında, Geliştirici onay kutusunu seçin.

  2. Listede, çalıştırmak istediğiniz makroya tıklayın ve sonra Çalıştır’a tıklayın.

Bir makroyu düzenlemek için, Visual Basic Düzenleyicisi kullanırsınız.

  1. Geliştirici sekmesinde, Visual Basic altında, Makrolar’a tıklayın.

    Excel Geliştirici sekmesi, Visual Basic grubu

    Geliştirici sekmesi yoksa

    1. Şeridin sağ tarafında, Eylem açılan menüsü öğesine tıklayın ve sonra Şerit Tercihleri’ne tıklayın.

    2. Özelleştir altında, Geliştirici onay kutusunu seçin.

  2. Listede, düzenlemek istediğiniz makroya tıklayın ve sonra Düzenle’ye tıklayın.

    Visual Basic Düzenleyicisi açılır.

  3. İstediğiniz değişiklikleri yapın.

  4. Bitirdiğinizde, Word menüsünde, Kapat ve Microsoft Word’e Dön’e tıklayın.

  1. Geliştirici sekmesinde, Visual Basic altında, Makrolar’a tıklayın.

    Excel Geliştirici sekmesi, Visual Basic grubu

    Geliştirici sekmesi yoksa

    1. Şeridin sağ tarafında, Eylem açılan menüsü öğesine tıklayın ve sonra Şerit Tercihleri’ne tıklayın.

    2. Özelleştir altında, Geliştirici onay kutusunu seçin.

  2. Listede, kopyalamak istediğiniz makroya tıklayın ve sonra Düzenle’ye tıklayın.

    Visual Basic Düzenleyicisi açılır.

  3. Visual Basic Düzenleyicisi'nin kod penceresinde, kopyalamak istediğiniz makro satırlarını seçin.

    İpucu: Tüm makroyu kopyalamak için seçime Sub ve End Sub satırlarını ekleyin.

  4. Düzen menüsünde Kopyala’ya tıklayın.

  5. Kod penceresinin Proje kutusunda, kodu yerleştirmek istediğiniz modüle tıklayın.

  6. Düzen menüsünde Yapıştır’a tıklayın.

  1. Geliştirici sekmesinde, Visual Basic altında, Makrolar’a tıklayın.

    Excel Geliştirici sekmesi, Visual Basic grubu

    Geliştirici sekmesi yoksa

    1. Şeridin sağ tarafında, Eylem açılan menüsü öğesine tıklayın ve sonra Şerit Tercihleri’ne tıklayın.

    2. Özelleştir altında, Geliştirici onay kutusunu seçin.

  2. Listede, silmek istediğiniz makroya tıklayın ve sonra Sil’e tıklayın.

PowerPoint

Yinelenen bir görevi otomatikleştirmek Için, PowerPoint 'te makro oluşturmak üzere Visual Basic for Applications kullanabilirsiniz.

Makro oluşturmak için yerleşik Visual Basic Düzenleyicisi'ni kullanabilirsiniz.

  1. Geliştirici sekmesinde, Visual Basic altında, Düzenle’ye tıklayın.

    PowerPoint Geliştirici sekmesi, Visual Basic grubu

    Geliştirici sekmesi yoksa

    1. Şeridin sağ tarafında, Eylem açılan menüsü öğesine tıklayın ve sonra Şerit Tercihleri’ne tıklayın.

    2. Özelleştir altında, Geliştirici onay kutusunu seçin.

  2. Bir modülü yeniden başlatmanız gerekirse, Visual Basic Düzenleyicisi'ndeki Ekle menüsünde Modül'e tıklayın.

  3. Modülün kod penceresinde, kullanmak istediğiniz makro kodunu yazın veya yapıştırın.

  4. Bitirdiğinizde, PowerPoint menüsünde, Kapat ve Microsoft PowerPoint’e Dön’e tıklayın.

  1. Geliştirici sekmesinde, Visual Basic altında, Makrolar’a tıklayın.

    PowerPoint Geliştirici sekmesi, Visual Basic grubu

    Geliştirici sekmesi yoksa

    1. Şeridin sağ tarafında, Eylem açılan menüsü öğesine tıklayın ve sonra Şerit Tercihleri’ne tıklayın.

    2. Özelleştir altında, Geliştirici onay kutusunu seçin.

  2. Listede, çalıştırmak istediğiniz makroya tıklayın ve sonra Çalıştır’a tıklayın.

Bir makroyu düzenlemek için, Visual Basic Düzenleyicisi kullanırsınız.

  1. Geliştirici sekmesinde, Visual Basic altında, Makrolar’a tıklayın.

    PowerPoint Geliştirici sekmesi, Visual Basic grubu

    Geliştirici sekmesi yoksa

    1. Şeridin sağ tarafında, Eylem açılan menüsü öğesine tıklayın ve sonra Şerit Tercihleri’ne tıklayın.

    2. Özelleştir altında, Geliştirici onay kutusunu seçin.

  2. Listede, düzenlemek istediğiniz makroya tıklayın ve sonra Düzenle’ye tıklayın.

    Visual Basic Düzenleyicisi açılır.

  3. İstediğiniz değişiklikleri yapın.

  4. Bitirdiğinizde, PowerPoint menüsünde, Kapat ve Microsoft PowerPoint’e Dön’e tıklayın.

  1. Geliştirici sekmesinde, Visual Basic altında, Makrolar’a tıklayın.

    PowerPoint Geliştirici sekmesi, Visual Basic grubu

    Geliştirici sekmesi yoksa

    1. Şeridin sağ tarafında, Eylem açılan menüsü öğesine tıklayın ve sonra Şerit Tercihleri’ne tıklayın.

    2. Özelleştir altında, Geliştirici onay kutusunu seçin.

  2. Listede, kopyalamak istediğiniz makroya tıklayın ve sonra Düzenle’ye tıklayın.

    Visual Basic Düzenleyicisi açılır.

  3. Visual Basic Düzenleyicisi'nin kod penceresinde, kopyalamak istediğiniz makro satırlarını seçin.

    İpucu: Tüm makroyu kopyalamak için seçime Sub ve End Sub satırlarını ekleyin.

  4. Düzen menüsünde Kopyala’ya tıklayın.

  5. Kod penceresinin Proje kutusunda, kodu yerleştirmek istediğiniz modüle tıklayın.

  6. Düzen menüsünde Yapıştır’a tıklayın.

  1. Geliştirici sekmesinde, Visual Basic altında, Makrolar’a tıklayın.

    PowerPoint Geliştirici sekmesi, Visual Basic grubu

    Geliştirici sekmesi yoksa

    1. Şeridin sağ tarafında, Eylem açılan menüsü öğesine tıklayın ve sonra Şerit Tercihleri’ne tıklayın.

    2. Özelleştir altında, Geliştirici onay kutusunu seçin.

  2. Listede, silmek istediğiniz makroya tıklayın ve sonra Sil’e tıklayın.

Excel

Yinelenen bir görevi otomatikleştirmek için, Excel‘de hızlı şekilde bir makro oluşturabilirsiniz. Ayrıca kendi makro betiğinizi yazmak veya bir makronun tamamını veya bir bölümünü yeni bir makroya kopyalamak için Microsoft Visual Basic for Applications‘da Visual Basic Düzenleyicisi kullanabilirsiniz.

Makronuzun gerçekleştirmesini istediğiniz eylemleri tamamlamak için gereken tüm adımlar kaydedilir. Bununla birlikte, kaydetmeyi durdurmak için sekmeye geri gitme, kaydedilen adımlara dahil edilmez.

  1. Geliştirici sekmesinde, Visual Basic altında, Kaydet’e tıklayın.

    Excel Geliştirici sekmesini, Visual Basic grubu

    Geliştirici sekmesi yoksa

    1. Şeridin sağ tarafında, Eylem açılan menüsü öğesine tıklayın ve sonra Şerit Tercihleri’ne tıklayın.

    2. Özelleştir altında, Geliştirici onay kutusunu seçin.

  2. Makro adı kutusuna makro için bir ad girin.

    İpucu: Makro için bir klavye kısayolu oluşturmak için, Option+Cmd+ kutusuna bir harf yazın.

  3. Makronun saklanacağı yer açılır menüsünde, aşağıdakilerden birini yapın:

    Makroyu kaydetmek için

    Buna tıklayın

    Makroyu oluşturmakta olduğunuz belgede

    Bu Çalışma Kitabı

    Tüm açık belgelerde

    Yeni Çalışma Kitabı

    Excel'i her kullanışınızda kullanılabilmesi için

    Kişisel Makro Çalışma Kitabı

    Kişisel makro çalışma kitabı Users/ kullanıcıadı/Library/Application Support Support/Microsoft/Office/Excel 'de bulunuyor.

  4. Tamam düğmesine tıklayın ve daha sonra, kaydetmek istediğiniz eylemleri gerçekleştirin.

  5. Geliştirici sekmesinde, Visual Basic altında, Kaydet’e tekrar tıklayın.

Makro oluşturmak için yerleşik Visual Basic Düzenleyicisi'ni kullanabilirsiniz.

  1. Geliştirici sekmesinde, Visual Basic altında, Düzenle’ye tıklayın.

    Excel Geliştirici sekmesini, Visual Basic grubu

    Geliştirici sekmesi yoksa

    1. Şeridin sağ tarafında, Eylem açılan menüsü öğesine tıklayın ve sonra Şerit Tercihleri’ne tıklayın.

    2. Özelleştir altında, Geliştirici onay kutusunu seçin.

  2. Bir modülü yeniden başlatmanız gerekirse, Visual Basic Düzenleyicisi'ndeki Ekle menüsünde Modül'e tıklayın.

  3. Modülün kod penceresinde, kullanmak istediğiniz makro kodunu yazın veya yapıştırın.

  4. Bitirdiğinizde, Excel menüsünde, Kapat ve Microsoft Excel’e Dön’e tıklayın.

  1. Geliştirici sekmesinde, Visual Basic altında, Makrolar’a tıklayın.

    Excel Geliştirici sekmesini, Visual Basic grubu

    Geliştirici sekmesi yoksa

    1. Şeridin sağ tarafında, Eylem açılan menüsü öğesine tıklayın ve sonra Şerit Tercihleri’ne tıklayın.

    2. Özelleştir altında, Geliştirici onay kutusunu seçin.

  2. Listede, çalıştırmak istediğiniz makroya tıklayın ve sonra Çalıştır’a tıklayın.

    İpucu: Klavye kısayolu kullanarak bir makroyu çalıştırmak için, OPTION + COMMAND +klavye kısayolunu oluştururken kullandığınız harf tuşuna basın.

Bir makroyu düzenlemek için, Visual Basic Düzenleyicisi kullanırsınız.

  1. Geliştirici sekmesinde, Visual Basic altında, Makrolar’a tıklayın.

    Excel Geliştirici sekmesini, Visual Basic grubu

    Geliştirici sekmesi yoksa

    1. Şeridin sağ tarafında, Eylem açılan menüsü öğesine tıklayın ve sonra Şerit Tercihleri’ne tıklayın.

    2. Özelleştir altında, Geliştirici onay kutusunu seçin.

  2. Listede, düzenlemek istediğiniz makroya tıklayın ve sonra Düzenle’ye tıklayın.

    Visual Basic Düzenleyicisi açılır.

  3. İstediğiniz değişiklikleri yapın.

  4. Bitirdiğinizde, Excel menüsünde, Kapat ve Microsoft Excel’e Dön’e tıklayın.

Bu yordamı tamamladıktan sonra, makroyu içeren çalışma kitabını her açtığınızda makro çalışır.

  1. Geliştirici sekmesinde, Visual Basic altında, Kaydet’e tıklayın.

    Excel Geliştirici sekmesini, Visual Basic grubu

    Geliştirici sekmesi yoksa

    1. Şeridin sağ tarafında, Eylem açılan menüsü öğesine tıklayın ve sonra Şerit Tercihleri’ne tıklayın.

    2. Özelleştir altında, Geliştirici onay kutusunu seçin.

  2. Makro adı kutusuna, Kendiliğinden_Aç yazın.

  3. Makronun saklanacağı yer açılır menüsünde, aşağıdakilerden birini yapın:

    Makroyu kaydetmek için

    Buna tıklayın

    Makroyu oluşturmakta olduğunuz belgede

    Bu Çalışma Kitabı

    Tüm açık belgelerde

    Yeni Çalışma Kitabı

    Excel'i her kullanışınızda kullanılabilmesi için

    Kişisel Makro Çalışma Kitabı

  4. Tamam düğmesine tıklayın ve daha sonra, kaydetmek istediğiniz eylemleri gerçekleştirin.

  5. Geliştirici sekmesinde, Visual Basic altında, Kaydet’e tekrar tıklayın.

  6. Dosya menüsünde, Farklı Kaydet'e tıklayın.

  7. Biçim açılır menüsünde, Excel Makro İçerebilen Çalışma Kitabı (.xlsm)’e tıklayın ve sonra Kaydet’e tıklayın.

  1. Geliştirici sekmesinde, Visual Basic altında, Makrolar’a tıklayın.

    Excel Geliştirici sekmesini, Visual Basic grubu

    Geliştirici sekmesi yoksa

    1. Şeridin sağ tarafında, Eylem açılan menüsü öğesine tıklayın ve sonra Şerit Tercihleri’ne tıklayın.

    2. Özelleştir altında, Geliştirici onay kutusunu seçin.

  2. Listede, kopyalamak istediğiniz makroya tıklayın ve sonra Düzenle’ye tıklayın.

    Visual Basic Düzenleyicisi açılır.

  3. Visual Basic Düzenleyicisi'nin kod penceresinde, kopyalamak istediğiniz makro satırlarını seçin.

    İpucu: Tüm makroyu kopyalamak için seçime Sub ve End Sub satırlarını ekleyin.

  4. Düzen menüsünde Kopyala’ya tıklayın.

  5. Kod penceresinin Proje kutusunda, kodu yerleştirmek istediğiniz modüle tıklayın.

  6. Düzen menüsünde Yapıştır’a tıklayın.

  1. Geliştirici sekmesinde, Visual Basic altında, Makrolar’a tıklayın.

    Excel Geliştirici sekmesini, Visual Basic grubu

    Geliştirici sekmesi yoksa

    1. Şeridin sağ tarafında, Eylem açılan menüsü öğesine tıklayın ve sonra Şerit Tercihleri’ne tıklayın.

    2. Özelleştir altında, Geliştirici onay kutusunu seçin.

  2. Listede, silmek istediğiniz makroya tıklayın ve sonra Sil’e tıklayın.

Office yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×