Formüller ve işlevler

EĞER işlevi

EĞER işlevi

Excel’in en popüler işlevlerinden biri olan EĞER işlevi, bir değer ile beklediğiniz değer arasında mantıksal karşılaştırmalar yapmanıza olanak tanır.

Dolayısıyla, EĞER deyiminin iki sonucu olabilir. İlk sonuç karşılaştırmanızın Doğru olması, ikinci sonuç da karşılaştırmanızın Yanlış olmasıdır.

Örneğin, =EĞER(C2=”Evet”,1,2) formülü EĞER(C2 = Evet ise 1 döndür, değilse 2 döndür) demektir.

Tarayıcınız video desteklemiyor. Microsoft Silverlight, Adobe Flash Player veya Internet Explorer 9’u yükleyin.

Bir koşul doğru olduğunda belirli bir değerin ve yanlış olduğunda başka bir değerin döndürülmesi için, mantıksal işlevlerden biri olan EĞER işlevini kullanın.

EĞER(mantıksal_sınama, eğer_doğruysa_değer, [eğer_yanlışsa_değer])

Örneğin:

  • =EĞER(A2>B2,"Bütçeyi Aşıyor","Tamam")

  • =EĞER(A2=B2,B4-A4,"")

Bağımsız değişken adı

Açıklama

mantıksal_sınama    (gerekli)

Sınamak istediğiniz koşul.

eğer_doğruysa_değer    (gerekli)

Mantıksal_sınama sonucu DOĞRU ise döndürülmesini istediğiniz değer.

eğer_yanlışsa_değer    (isteğe bağlı)

Mantıksal_sınama sonucu YANLIŞ ise döndürülmesini istediğiniz değer.

Basit EĞER örnekleri

D2 hücresindeki formül: =EĞER(C2="Evet",1,2)
  • =EĞER(C2=”Evet”,1,2)

Yukarıdaki örnekte, D2 hücresi şunu söylüyor: EĞER(C2 = Evet, o zaman 1 döndür, değilse 2 döndür)

D2 hücresindeki formül: =EĞER(C2=1,"EVET","HAYIR")
  • =EĞER(C2=1,”Evet”,”Hayır”)

Bu örnekte D2 hücresindeki formül şunu söylüyor: EĞER(C2 = 1 ise Evet döndür, değilse Hayır döndür)Sizin de gördüğünüz gibi EĞER işlevi hem metinleri hem de değerleri değerlendirmek için kullanılabilir. Ayrıca bu işlevi hataları değerlendirmek için de kullanabilirsiniz. Yapabilecekleriniz bir öğenin başka bir öğeyle eşit olup olmadığına bakmak ve tek bir sonuç döndürmekle sınırlı değildir; matematiksel işleçler kullanabilir ve ölçütlerinize bağlı olarak ek hesaplamalar gerçekleştirebilirsiniz. Bunun dışında, birkaç EĞER işlevini iç içe kullanarak birden çok karşılaştırma da yapabilirsiniz.

D2 hücresindeki formül: =EĞER(C2>B2,”Bütçeyi Aşıyor”,”Bütçe İçinde”)
  • =EĞER(C2>B2,”Bütçeyi Aşıyor”,”Bütçe İçinde”)

Yukarıdaki örnekte, D2 hücresindeki EĞER işlevi şunu söylüyor: EĞER(C2 B2'den Büyükse, o zaman “Bütçeyi Aşıyor” metnini döndür, değilse “Bütçe İçinde” metnini döndür)

E2 formülündeki hücre: =EĞER(C2>B2,C2-B2,"")
  • =EĞER(C2>B2,C2-B2,0)

Yukarıdaki çizimde, Metin sonucu yerine matematiksel bir hesaplama döndüreceğiz. Dolayısıyla E2'deki formül şunu söylüyor: EĞER(Gerçek Değeri Bütçelenen Değerinden Büyükse, o zaman Bütçelenen tutarı Gerçek tutardan çıkar, değilse hiçbir şey döndürme).

F7 hücresindeki formül: EĞER(E7=”Evet”,F5*0,0825,0)
  • =EĞER(E7=”Evet”,F5*0,0825,0)

Bu örnekte F7'deki formül şunu söylüyor: EĞER(E7 = “Evet”, o zaman F5 * %8,25'te Toplam Tutarı hesapla, değilse süresi geçmiş Satış Vergisi yoktur bu nedenle 0 döndür)

Not: Formüllerde metin kullanacaksanız, metni tırnak içine almalısınız (örneğin, “Metin”). Bu kural yalnızca DOĞRU ve YANLIŞ sözcükleri için geçerli değildir; Excel bu sözcükleri otomatik olarak anlar.

Sık karşılaşılan sorunlar

Sorun

Nerede sorun çıktı

Hücrede 0 (sıfır) var

Eğer_doğruysa_değer ve eğer_yanlışsa_değer bağımsız değişkenlerinden biri yoktur. Döndürülen doğru değeri görmek için, iki bağımsız değişkene de bağımsız değişken metni ekleyin veya bağımsız değişkene DOĞRU veya YANLIŞ ekleyin.

Hücrede #AD? var

Bu çoğunlukla formülde yazım hatası olduğu anlamına gelir.

Daha fazla yardım mı gerekiyor?

Sorularınızı Excel Teknoloji Topluluğu’ndaki uzmanlara sorabilir, Yanıt topluluğu’ndan destek alabilir ya da Excel için UserVoice platformuna yeni bir özellik veya iyileştirme önerisi sunabilirsiniz.

Ayrıca Bkz:

Excel’de hesaplama işleçleri ve öncelikleri

Formülde iç içe yerleştirilmiş işlevleri kullanma

Hücrenin boş olup olmadığını denetlemek için EĞER’i kullanma

Hücrenin boş olup olmadığını denetlemek için EĞER’i kullanma

Video: Gelişmiş EĞER işlevleri

ÇOKEĞER işlevi (Office 365, Excel 2016 ve sonrası)

Gelişmiş EĞER işlevleri: İç içe formüller ile çalışma ve hatalardan kaçınma

Eğitim Videoları: Gelişmiş EĞER işlevleri

EĞERSAY işlevi, değerleri tek bir ölçüte göre sayar

ÇOKEĞERSAY işlevi, değerleri birden fazla ölçüte göre sayar

ETOPLA işlevi, değerleri tek bir ölçüte göre toplar

ÇOKETOPLA işlevi, değerleri birden fazla ölçüte göre toplar

VE işlevi

YADA işlevi

DÜŞEYARA işlevi

Excel’deki formüllere genel bakış

Bozuk formülleri önleme

Formüllerde hataları algılama

Mantıksal İşlevler

Excel işlevleri (alfabetik)

Excel işlevleri (kategoriye göre)

Office yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×