EĞERHATA işlevi

Bir formüldeki hataları yakalamak ve işlemek için EĞERHATA işlevini kullanabilirsiniz. IFERROR, formül bir hata verirse belirttiğiniz bir değeri döndürür; Aksi takdirde, formülün sonucunu döndürür.

Söz Dizimi

EĞERHATA(değer, eğer_hataysa_değer)

EĞERHATA işlevinin söz diziminde aşağıdaki bağımsız değişkenler bulunur:

  • değer    Gerekli. Hatayı denetleyen bağımsız değişkendir.

  • value_if_error    Gerekli. Formül bir hata verirse döndürülecek değer. Aşağıdaki hata türleri değerlendirilir: #N/A, #VALUE!, #REF!, #DIV/0!, #NUM!, #NAME? veya #NULL!.

Notlar

  • Value veya value_if_error boş bir hücredir, ıFERROR bunu boş dize değeri ("") olarak değerlendirir.

  • Değer bir dizi formülüyse, ıFERROR değer alanında belirtilen aralıktaki her hücre için bir sonuç dizisi döndürür. Aşağıda ikinci örneğe bakın.

Örnekler

Aşağıdaki tabloda yer alan örnek verileri kopyalayın ve yeni bir Excel çalışma sayfasının A1 hücresine yapıştırın. Formüllerin sonuçları göstermesi için, bunları seçin, F2 tuşuna ve sonra da Enter tuşuna basın.

Kota

Satılan Birimler

210

35

55

0

parça

Formül

Açıklama

Sonuç

=EĞERHATA(A2/B2, "Hesaplama hatası")

İlk bağımsız değişkendeki formül hatasını denetler (210'u 35'e bölün), hata bulamaz ve sonra formülün sonucunu getirir

6

=EĞERHATA(A3/B3, "Hesaplama hatası")

İlk bağımsız değişkendeki formül hatasını denetler (55'i 0'a bölün), 0 hatası tarafından bir bölme bulur ve sonra eğer_hataysa_değer'i getirir

Hesaplama hatası

=EĞERHATA(A4/B4, "Hesaplama hatası")

İlk bağımsız değişkendeki formül hatasını denetler ("" değerini 23'e bölün), hata bulamaz ve sonra formülün sonucunu getirir.

0

Örnek 2

Kota

Satılan Birimler

Oran

210

35

6

55

0

Hesaplama hatası

parça

0

Formül

Açıklama

Sonuç

=C2

d>Dizinin ilk öğesindeki ilk bağımsız değişkendeki formül hatasını denetler (A2/B2 veya 210'u 35'e bölün), hata bulamaz ve sonra formülün sonucunu getirir

6

=C3

Dizinin ikini öğesindeki ilk bağımsız değişkendeki formül hatasını denetler (A3/B3 veya 55'i 0'a bölün), 0 hatası tarafından bir bölme bulur ve sonra eğer_hataysa_değer'i getirir

Hesaplama hatası

=C4

Dizinin üçüncü öğesindeki ilk bağımsız değerdeki formül hatasını denetler (A4/B4 veya "" değerini 23'e bölün), hata bulamaz ve sonra formülün sonucunu getirir

0

Not: Office 365' in güncel bir sürümünü kullanıyorsanız, formülü, formülü bir dinamik dizi formülü olarak onaylamak için ENTER tuşuna basın. Aksi takdirde, formülün önce çıkış aralığını seçerek eski bir dizi formülü olarak girilmesi gerekir, formülü çıktı aralığının sol üst hücresine girer ve ardından CTRL + SHIFT + ENTER tuşlarına basarak onaylayın. Excel, formülün başında ve sonunda süslü ayraçlar ekler. Dizi formülleri hakkında daha fazla bilgi için bkz. Dizi formülleriyle ilgili yönergeler ve örnekler.

Daha fazla yardım mı gerekiyor?

Sorularınızı Excel Teknoloji Topluluğu’ndaki uzmanlara sorabilir, Yanıt topluluğu’ndan destek alabilir ya da Excel için UserVoice platformuna yeni bir özellik veya iyileştirme önerisi sunabilirsiniz.

Not:  Bu sayfanın çevirisi otomasyon aracılığıyla yapılmıştır ve bu nedenle hatalı veya yanlış dil bilgisi kullanımları içerebilir. Amacımız, bu içeriğin sizin için faydalı olabilmesini sağlamaktır. Bu bilgileri yararlı bulup bulmadığınızı bizimle paylaşır mısınız? Kolayca başvurabilmek için İngilizce makaleye buradan ulaşabilirsiniz.

Office yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×