Formüller ve işlevler

EĞER işlevi

EĞER işlevi

Not: En güncel yardım içeriklerini, mümkün olduğunca hızlı biçimde kendi dilinizde size sunmak için çalışıyoruz. Bu sayfanın çevirisi otomasyon aracılığıyla yapılmıştır ve bu nedenle hatalı veya yanlış dil bilgisi kullanımları içerebilir. Amacımız, bu içeriğin sizin için faydalı olabilmesini sağlamaktır. Buradaki bilgilerin faydalı olup olmadığını bu sayfanın sonunda bize bildirebilir misiniz? Kolayca başvurabilmek için İngilizce makaleye buradan ulaşabilirsiniz.

Eğer işlevini Excel'in en popüler işlevlerinden biri olan ve bir değer arasındaki beklediğiniz mantıksal karşılaştırmalar yapma olanak tanır.

Dolayısıyla, EĞER deyiminin iki sonucu olabilir. İlk sonuç karşılaştırmanızın Doğru olması, ikinci sonuç da karşılaştırmanızın Yanlış olmasıdır.

Örneğin, =EĞER(C2=”Evet”,1,2) formülü şunu söylüyor: EĞER(C2 = Evet, o zaman 1 döndür, değilse 2 döndür).

Tarayıcınız video desteklemiyor. Microsoft Silverlight, Adobe Flash Player veya Internet Explorer 9’u yükleyin.

Bir koşul doğru olduğunda belirli bir değerin ve yanlış olduğunda başka bir değerin döndürülmesi için, mantıksal işlevlerden biri olan EĞER işlevini kullanın.

EĞER(mantıksal_sınama, eğer_doğruysa_değer, [eğer_yanlışsa_değer])

Örneğin:

  • =EĞER(A2>B2,"Bütçeyi Aşıyor","Tamam")

  • =EĞER(A2=B2,B4-A4,"")

Bağımsız değişken adı

Açıklama

mantıksal_sınama    (gerekli)

Sınamak istediğiniz koşul.

eğer_doğruysa_değer    (gerekli)

Mantıksal_sınama sonucu DOĞRU ise döndürülmesini istediğiniz değer.

eğer_yanlışsa_değer    (isteğe bağlı)

Mantıksal_sınama sonucu YANLIŞ ise döndürülmesini istediğiniz değer.

Basit EĞER örnekleri

D2 hücresindeki formül: =EĞER(C2="Evet",1,2)
  • =EĞER(C2=”Evet”,1,2)

Yukarıdaki örnekte, D2 hücresi şunu söylüyor: EĞER(C2 = Evet, o zaman 1 döndür, değilse 2 döndür)

D2 hücresindeki formül: =EĞER(C2=1,"EVET","HAYIR")
  • =EĞER(C2=1,”Evet”,”Hayır”)

Bu örnekte, D2 hücresine formülü Yazan: IF(C2 = 1, then return Yes, otherwise return No)hem metin hem de değerleri değerlendirmek için gördüğünüz gibi Eğer işlevi kullanılabilir. Bu, hataları değerlendirmekiçin de kullanılabilir. Bir şey diğerine eşit ise ve tek bir sonuç döndürerek, ayrıca matematik işleçleri kullanın ve bağlı olarak, ölçütlerinizi ek hesaplamalar denetimini yalnızca sınırlı değildir. Ayrıca birden fazla Eğer işlevleri birlikte birden çok karşılaştırmaları gerçekleştirmek için yerleştirebilirsiniz.

D2 hücresindeki formül: =EĞER(C2>B2,”Bütçeyi Aşıyor”,”Bütçe İçinde”)
  • =EĞER(C2>B2,”Bütçeyi Aşıyor”,”Bütçe İçinde”)

Yukarıdaki örnekte, D2 hücresindeki EĞER işlevi şunu söylüyor: EĞER(C2 B2'den Büyükse, o zaman “Bütçeyi Aşıyor” metnini döndür, değilse “Bütçe İçinde” metnini döndür)

E2 hücresindeki formül: =EĞER(C2>B2,C2-B2,"")
  • =EĞER(C2>B2,C2-B2,0)

Yukarıdaki çizimde, metin sonucu yerine matematiksel bir hesaplama döndüreceğiz. Dolayısıyla E2’deki formül şunu söylüyor: EĞER(Gerçek Değeri Bütçelenen Değerinden Büyükse, o zaman Bütçelenen tutarı Gerçek tutardan Çıkar, değilse hiçbir şey döndürme).

F7 hücresindeki formül: EĞER(E7=”Evet”,F5*0,0825,0)
  • =EĞER(E7=”Evet”,F5*0,0825,0)

Bu örnekte F7'deki formül şunu söylüyor: EĞER(E7 = “Evet”, o zaman F5 * %8,25'te Toplam Tutarı hesapla, değilse süresi geçmiş Satış Vergisi yoktur bu nedenle 0 döndür)

Not: Formüllerde metin kullanacaksanız, metni tırnak içine almalısınız (örneğin, “Metin”). Bu kural yalnızca DOĞRU ve YANLIŞ sözcükleri için geçerli değildir; Excel bu sözcükleri otomatik olarak anlar.

Sık karşılaşılan sorunlar

Sorun

Nerede sorun çıktı

Hücrede 0 (sıfır) var

Eğer_doğruysa_değer ve eğer_yanlışsa_değer bağımsız değişkenlerinden biri yoktur. Döndürülen doğru değeri görmek için, iki bağımsız değişkene de bağımsız değişken metni ekleyin veya bağımsız değişkene DOĞRU veya YANLIŞ ekleyin.

Hücrede #AD? var

Bu çoğunlukla formülde yazım hatası olduğu anlamına gelir.

Daha fazla yardım mı gerekiyor?

Sorularınızı Excel Teknoloji Topluluğu’ndaki uzmanlara sorabilir, Yanıt topluluğu’ndan destek alabilir ya da Excel için UserVoice platformuna yeni bir özellik veya iyileştirme önerisi sunabilirsiniz.

Ayrıca Bkz:

Hesaplama işleçleri ve Excel'de önceliği

Bir formülde iç içe geçen işlevler kullanma

Bir hücrenin boş olup olmadığını denetlemek için Eğer kullanma

Bir hücrenin boş olup olmadığını denetlemek için Eğer kullanma

Video: Gelişmiş Eğer işlevleri

(Office 365, Excel 2016 ve sonrası) IFS işlevi

Gelişmiş Eğer işlevleri - iç içe formüllerle çalışma ve sorunları önleme

Eğitim videoları: Gelişmiş Eğer işlevleri

EĞERSAY işlevi tek bir ölçüte dayalı olarak değerleri saymak

ÇOKEĞERSAY işlevi birden çok ölçüte dayalı olarak değerleri saymak

ETOPLA işlevi, tek bir ölçüte dayalı olarak değerleri toplama

ÇOKETOPLA işlevi birden çok ölçüte dayalı olarak değerleri toplama

Ve işlevi

OR işlevi

DÜŞEYARA işlevi

Excel'deki formüllere genel bakış

Bozuk formülleri önleme

Formüllerdeki hataları saptamak için kullanım hata denetimini

Mantıksal işlevler

Excel işlevleri (alfabetik)

Excel işlevleri (kategoriye göre)

Office yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×