Değerleri DÜŞEYARA, DİZİN veya EŞLEŞTİR ile arama

Not:  En güncel yardım içeriklerini, mümkün olduğunca hızlı biçimde kendi dilinizde size sunmak için çalışıyoruz. Bu sayfanın çevirisi otomasyon aracılığıyla yapılmıştır ve bu nedenle hatalı veya yanlış dil bilgisi kullanımları içerebilir. Amacımız, bu içeriğin sizin için faydalı olabilmesini sağlamaktır. Buradaki bilgilerin faydalı olup olmadığını bu sayfanın sonunda bize bildirebilir misiniz? Kolayca başvurabilmek için İngilizce makaleye buradan ulaşabilirsiniz .

Office konum sayı listesi vardır ve her Office'te çalışanlardan hangileri olduğunu bilmeniz gerekir olduğunu varsayalım. Elektronik Tablo çok büyük, olduğundan bu görev zor düşünebilirsiniz. Ara işlevi ile yapmak gerçekten basittir.

DÜŞEYARA ve YATAYARA işlevleri, indis ve KAÇINCI,birlikte Excel'de en kullanışlı işlevlerinden bazılarıdır.

Not: Arama Sihirbazı'nı özellik artık Excel'de kullanılabilir.

Burada, DÜŞEYARA İŞLEVİNİN kullanımını örneği verilmiştir.

=DÜŞEYARA(B2,C2:E7,3,DOĞRU)

Bu örnekte, B2 ilk bağımsızdeğişkendir — işlevinin çalışması için gereken veri öğesi. DÜŞEYARA için bu ilk bağımsız değişken, bulmak istediğiniz değerdir. Bu bağımsız değişkeni, bir hücre başvurusu veya "atakan" veya 21.000 gibi sabit bir değer olabilir. İkinci bağımsız değişken hücreleri, bulmak istediğiniz değeri aramanızın C2-:E7 aralığıdır. Üçüncü bağımsız değişken, arama değerini içeren hücre aralığını sütundur.

Dördüncü bağımsız değişkeni isteğe bağlıdır. TRUE veya FALSE girin. TRUE girin veya bağımsız değişkeni boş bırakırsanız işlev yaklaşık eşleşme ilk bağımsız değişkendeki belirttiğiniz değeri verir. YANLIŞ girerseniz, işlev değeri eşleştirir ilk bağımsız değişken sağlayın. Başka bir deyişle, Dördüncü bağımsız değişken boş bırakarak — veya doğru girerek —, daha fazla esneklik sağlar.

Bu örnekte, işlevinin nasıl çalıştığını gösterir. DÜŞEYARA (ilk bağımsız değişkeni) B2 hücresine bir değer girdiğinizde, C2:E7 aralıktaki hücreleri arar (2. bağımsız değişkeni) ve üçüncü sütunun sütun E aralıktaki en yakın yaklaşık eşleşmeyi döndürür (3'üncü bağımsız değişkeni).

DÜŞEYARA işlevinin tipik bir kullanımı

Dördüncü bağımsız değişken boş olduğundan işlev yaklaşık eşleşmeyi döndürür. Almadıysanız, değerlerden birine sütunlara C veya D hiç bir sonucu elde etmek için girmeniz gerekir.

DÜŞEYARA'yla rahat YATAYARA işlevinin kullanımı eşit oranda kolay olur. Aynı bağımsız değişkenleri girin, ancak satırlar yerine sütunlara arar.'

Bir de kendiniz deneyin

Kendi verilerinizle denemeden önce arama işlevleri ile denemeler isterseniz, burada bazı örnek veriler. DÜŞEYARA ve YATAYARA kullanarak gibi bazı Excel kullanıcılar; Başkalarının indis ve KAÇINCI İŞLEVLERİNİ birlikte kullanarak tercih eder. Her yöntemin deneyin ve en beğendiğiniz hangilerini bakın.

İşte DÜŞEYARA örneği

Aşağıdaki verileri boş bir elektronik tabloya kopyalayın..

İpucu:    Verileri Excel'e yapıştırmadan önce A-C sütunları sütun genişliğini 250 piksel olarak ayarlayın ve Metni Kaydır (Giriş sekmesi, Hizalama grubu) tıklatın.

Yoğunluk

Akışkanlık

Sıcaklık

0,457

3,55

500

0,525

3,25

400

0,606

2.93

300

0.675

2.75

250

0.746

2.57

200

0.835

2.38

150

0.946

2.17

100

1.09

1.95

50

1.29

1.71

0

Formül

Açıklama

Sonuç

=DÜŞEYARA(1,A2:C10,2)

Yaklaşık eşleşme kullanarak A sütununda 1 değerini arar, A sütununda 1'den küçük veya eşit en büyük değer olan 0,946'yı bulur ve B sütununun aynı satırındaki değeri döndürür.

2,17

=DÜŞEYARA(1,A2:C10,3,DOĞRU)

Yaklaşık eşleşme kullanarak A sütununda 1 değerini arar, A sütununda 1'den küçük veya eşit en büyük değer olan 0,946'yı bulur ve C sütununun aynı satırındaki değeri döndürür.

100

=DÜŞEYARA(0,7,A2:C10,3,YANLIŞ)

Tam eşleşme kullanarak A sütununda 0,7 değerini arar. A sütununda tam eşleşme bulunmadığından hata verir.

#YOK

=DÜŞEYARA(0.1,A2:C10,2,DOĞRU)

Yaklaşık eşleşme kullanarak A sütununda 0,1 değerini arar. 0,1 değeri A sütunundaki en küçük değerden küçük olduğundan hata verir.

#YOK

=DÜŞEYARA(2,A2:C10,2,DOĞRU)

Yaklaşık eşleşme kullanarak A sütununda 2 değerini arar, A sütununda 2'den küçük veya buna eşit en büyük değer olan 1,29'u bulur ve B sütununun aynı satırındaki değeri verir.

1,71

YATAYARA örneği

Bu tablodaki tüm hücreleri kopyalayın ve Excel'de boş bir çalışma sayfasında A1 hücresine yapıştırın.

İpucu:    Verileri Excel'e yapıştırmadan önce A-C sütunları sütun genişliğini 250 piksel olarak ayarlayın ve Metni Kaydır (Giriş sekmesi, Hizalama grubu) tıklatın.

Miller

Yataklar

Cıvatalar

4

4

9

5

7

10

6

8

11

Formül

Açıklama

Sonuç

=YATAYARA("Miller", A1:C4, 2, Doğru)

Sıra 1'deki "Milleri" arar ve sıra 2'den aynı sütundaki (A sütunu) değeri verir.

4

=YATAYARA("Yataklar", A1:C4, 3, YANLIŞ)

Sıra 1'deki "Yatakları" arar ve sıra 3'den aynı sütundaki (B sütunu) değeri verir.

7

=HLOOKUP("B", A1:C4, 3, TRUE)

Sıra 1'deki "B"yi arar ve sıra 3'den aynı sütundaki değeri verir. "B" ile tam uyan olmadığı için, satırdaki en büyük, fakat "B"den küçük olan değer kullanılır: A sütunundaki "Miller".

5

=YATAYARA("Cıvatalar", A1:C4, 4)

Sıra 1'deki "Cıvataları" arar ve sıra 4'ten aynı sütundaki (C sütunu) değeri verir.

11

=YATAYARA(3, {1,2,3;"a","b","c";"d","e","f"}, 2, DOĞRU)

Üç satırlı dizi sabitinde 3 sayısını arar ve aynı sütundaki (bu durumda üçüncü) sıra 2'de yer alan değeri verir. Dizi sabitinde üç değer satırı vardır ve her satır noktalı virgülle (;) ayrılmıştır. 3 ile aynı sütundaki satır 2'de "c" bulunduğundan, "c" sonucunu verir.

c

İNDİS ve KAÇINCI örnekleri

Son örnek birlikte erken fatura numarası ve onun karşılık gelen tarihi her beş Şehir dönmek için İNDİS ve KAÇINCI işlevlerini kullanır. Tarih olarak biçimlendirmek için bir sayı olarak tarih döndürdüğünden biz METNEÇEVİR işlevini kullanın. İNDİS işlevi, KAÇINCI işlevinin sonucu gerçekte kendi bağımsız değişkeni kullanır. İNDİS ve KAÇINCI işlevlerinin birleşimini iki kez her formülde – ilk olarak, fatura numarası dönmek için kullanılır ve ardından tarih vermek için.

Bu tablodaki tüm hücreleri kopyalayın ve Excel'de boş bir çalışma sayfasında A1 hücresine yapıştırın.

İpucu:    Verileri Excel'e yapıştırmadan önce sütunların A ile D genişliğini 250 piksel olarak ayarlayın ve Metni Kaydır (Giriş sekmesi, Hizalama grubu) tıklatın.

Fatura

Şehir

Fatura tarihi

Tarih ile şehre göre en erken fatura

3115

İzmir

07.04.2012

="İzmir = "&DİZİN($A$2:$C$33,EŞLEŞTİR("İzmir",$B$2:$B$33,0),1)& ", Fatura tarihi: " & METİN(DİZİN($A$2:$C$33,EŞLEŞTİR("İzmir",$B$2:$B$33,0),3),"g/a/yy")

3137

İzmir

09.04.2012

="Adana = "&DİZİN($A$2:$C$33,EŞLEŞTİR("Adana",$B$2:$B$33,0),1)& ", Fatura tarihi: " & METİN(DİZİN($A$2:$C$33,EŞLEŞTİR("Adana",$B$2:$B$33,0),3),"g/a/yy")

3154

İzmir

11.04.2012

="Ankara = "&DİZİN($A$2:$C$33,EŞLEŞTİR("Ankara",$B$2:$B$33,0),1)& ", Fatura tarihi: " & METİN(DİZİN($A$2:$C$33,EŞLEŞTİR("Ankara",$B$2:$B$33,0),3),"g/a/yy")

3191

İzmir

21.04.2012

="Şanlıurfa = "&DİZİN($A$2:$C$33,EŞLEŞTİR("Şanlıurfa",$B$2:$B$33,0),1)& ", Fatura tarihi: " & METİN(DİZİN($A$2:$C$33,EŞLEŞTİR("Şanlıurfa",$B$2:$B$33,0),3),"g/a/yy")

3293

İzmir

25.04.2012

="Bursa = "&DİZİN($A$2:$C$33,EŞLEŞTİR("Bursa",$B$2:$B$33,0),1)& ", Fatura tarihi: " & METİN(DİZİN($A$2:$C$33,EŞLEŞTİR("Bursa",$B$2:$B$33,0),3),"g/a/yy")

3331

İzmir

27.04.2012

3350

İzmir

28.04.2012

3390

İzmir

01.05.2012

3441

İzmir

02.05.2012

3517

İzmir

08.05.2012

3124

Adana

09.04.2012

3155

Adana

11.04.2012

3177

Adana

19.04.2012

3357

Adana

28.04.2012

3492

Adana

06.05.2012

3316

Ankara

25.04.2012

3346

Ankara

28.04.2012

3372

Ankara

01.05.2012

3414

Ankara

01.05.2012

3451

Ankara

02.05.2012

3467

Ankara

02.05.2012

3474

Ankara

04.05.2012

3490

Ankara

05.05.2012

3503

Ankara

08.05.2012

3151

Şanlıurfa

09.04.2012

3438

Şanlıurfa

02.05.2012

3471

Şanlıurfa

04.05.2012

3160

Bursa

18.04.2012

3328

Bursa

26.04.2012

3368

Bursa

29.04.2012

3420

Bursa

01.05.2012

3501

Bursa

06.05.2012

Arama işlevleri hakkında daha fazla bilgi edinin

Office yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×