DEĞİL işlevi

İki değerin birbirine eşit olmadığından emin olmak istiyorsanız mantıksal işlevlerden biri olan DEĞİL işlevini kullanın.

Örnek

Bağımsız değişkenleri ters çevirmek için kullanılan DEĞİL işlevi örnekleri.  ÖRN. =DEĞİL(1+1=2)

DEĞİL işlevi, bağımsız değişkeninin değerini tersine çevirir.

DEĞİL işlevinin yaygın kullanımlarından biri de, mantıksal sınama yapan diğer işlevlerin kullanışlılığını artırmaktır. Örneğin EĞER işlevi, bir mantıksal sınama gerçekleştirir ve sınama DOĞRU değerlendirdiğinde bir değeri, YANLIŞ değerlendirdiğinde de başka bir değeri döndürür. DEĞİL işlevini, EĞER işlevinin mantıksal_sınama bağımsız değişkeni olarak kullanarak, tek bir koşul yerine birden fazlasını sınayabilirsiniz.

Söz dizimi

DEĞİL(mantıksal)

DEĞİL işlevi söz diziminin bağımsız değişkenleri şunlardır:

  • Mantıksal    Gerekli. DOĞRU veya YANLIŞ olarak değerlendirilebilecek değerdir.

Açıklamalar

Mantıksal değer YANLIŞ ise DEĞİL, DOĞRU döndürür; mantıksal DOĞRU ise DEĞİL, YANLIŞ döndürür.

Örnekler

DEĞİL’in kendi başına ve EĞER, VE ve YADA ile kullanımına yönelik örnekleri aşağıda bulabilirsiniz.

DEĞİL, EĞER, VE ve YADA işlevlerinin örnekleri

Formül

Açıklama

=DEĞİL(A2>100)

A2, 100’den büyük DEĞİL

=EĞER(VE(DEĞİL(A2>1),DEĞİL(A2<100)),A2,"Değer aralık dışı")

50, 1’den büyüktür (DOĞRU) VE 50, 100’den küçüktür (DOĞRU). Bu nedenle DEĞİL işlevi, iki bağımsız değişkeni de YANLIŞ’a çevirir. VE, YANLIŞ olduğunda sonucu döndürebilmek için iki bağımsız değişkenin de DOĞRU olmasını gerektirir.

=EĞER(YADA(DEĞİL(A3<0),DEĞİL(A3>50)),A3,"Değer aralık dışı")

100, 0’dan küçük değildir (YANLIŞ) ve 100, 50’den büyüktür (DOĞRU). Bu nedenle DEĞİL işlevi, bağımsız değişkenleri DOĞRU/YANLIŞ’a çevirir. YADA, DOĞRU olduğunda sonucu döndürebilmek için, sadece bir bağımsız değişkenin DOĞRU olmasını gerektirir.

Satış Komisyonu hesaplama

DEĞİL’i EĞER ve VE ile kullanarak satış personelinin prime hak kazanıp kazanmadığını hesaplamaya yönelik örneğe bakalım

EĞER, VE ve DEĞİL işlevleriyle satış primi hesaplama örneği.  E14 hücresindeki formül: =EĞER(VE(DEĞİL(B14<$B$7),DEĞİL(C14<$B$5)),B14*$B$8,0)
  • =EĞER(VE(DEĞİL(B14<$B$7),DEĞİL(C14<$B$5)),B14*$B$8,0)- EĞER Toplam Satış, Satış Hedefi’nden az, DEĞİL ise VE Hesaplar, Hesap Hedefi’nden az DEĞİL ise Toplam Satış’ı Komisyon % ile çarp; değilse 0’a dönüştür

Daha fazla yardım mı gerekiyor?

Sorularınızı Excel Teknoloji Topluluğu’ndaki uzmanlara sorabilir, Yanıt topluluğu’ndan destek alabilir ya da Excel için UserVoice platformuna yeni bir özellik veya iyileştirme önerisi sunabilirsiniz.

İlgili Konular

Video: Gelişmiş EĞER işlevleri
Formülde iç içe geçen işlevler kullanmayı öğrenin
EĞER işlevi
VE işlevi
YADA işlevi
Excel formüllerine genel bakış
Bozuk formülleri önleme
Formüllerdeki hataları saptamak için hata denetimini kullanma
Windows için Excel 2016’da klavye kısayolları
Mac için Excel 2016’da klavye kısayolları
Mantıksal işlevler (başvuru)
Excel işlevleri (alfabetik sıraya göre)
Excel işlevleri (kategoriye göre)

Office yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×