Bir liste kutusu, aşağı açılan liste kutusu veya birleşik giriş kutusunu doldurmak için bir SQL Server veritabanından değerleri kullanın

Not:  En güncel yardım içeriklerini, mümkün olduğunca hızlı biçimde kendi dilinizde size sunmak için çalışıyoruz. Bu sayfanın çevirisi otomasyon aracılığıyla yapılmıştır ve bu nedenle hatalı veya yanlış dil bilgisi kullanımları içerebilir. Amacımız, bu içeriğin sizin için faydalı olabilmesini sağlamaktır. Buradaki bilgilerin faydalı olup olmadığını bu sayfanın sonunda bize bildirebilir misiniz? Kolayca başvurabilmek için İngilizce makaleye buradan ulaşabilirsiniz .

Bir liste kutusu, aşağı açılan liste kutusu veya birleşik giriş kutusu için Microsoft SQL Server veritabanı bir sorgu veri bağlantısı verilerle doldurabilirsiniz.

Bu makalede

Genel bakış

Başlamadan önce

Adım 1: sorgu veri bağlantısı ekleme

Adım 2: denetimi yapılandırma

Genel Bakış

Bir liste kutusu, aşağı açılan liste kutusu veya birleşik giriş kutusu kullanıcı form şablonunuzu temel alan bir form doldururken seçebileceği öğelerin görüntüler. Bu tür bir ikincil veri bağlantısını Microsoft SQL Server veritabanına veri göstermek için denetimler yapılandırabilirsiniz. Bir ikincil veri bağlantısını bu form şablonunu temel alan formları dolduran kullanıcıların verileri alma veya bir Web hizmeti gibi bir dış veri kaynağına veri göndermek ve böylece bir form şablonuna ekleme dış veri kaynağı için herhangi bir veri bağlantısıdır.

Yaptığınız gibi veri karşılık gelen bir ikincil veri bağlantısını form şablonunuzda, Microsoft Office InfoPath sorguları veri veri kaynağı bir ikincil veri alanlarını ve gruplarla oluşturur eklediğinizde veritabanında depolanır. Sorgu veri bağlantısını Web hizmetinden alınan verileri alır ve bu verileri form ikincil veri kaynağı depolar. Varsayılan olarak, kullanıcılar bir ağına bağlıyken ikincil veri kaynağındaki veriler kullanılabilir. Böylece formlarına ağa bağlı değilken verilere erişimleri sorgunun sonuçlarını kullanıcılarınızın bilgisayarlarda kaydetmek için ikincil veri bağlantısını yapılandırabilirsiniz.

Güvenlik Notu: Bir dış veri kaynağından önemli verileri almak için ikincil veri bağlantısı kullanıyorsanız, bilgisayarınızda kaybolabilir veya çalınması durumunda verileri yetkisiz kullanıma karşı korunmasına yardımcı olmak için bu özelliği devre dışı isteyebilirsiniz. Bu özellik devre dışı bırakırsanız, verileri yalnızca kullanıcı ağına bağlıysa kullanılabilir.

Veri yapısı ikincil veri kaynağındaki veriler veritabanında depolanır biçimini eşleşmelidir olduğundan, varolan alanları veya grupları ikincil veri kaynağında değişiklik yapamazsınız. Ayrıca bkz bölümünde veri bağlantıları ve veri kaynakları hakkında daha fazla bilgi için bağlantılar bulabilirsiniz.

Sayfanın Başı

Başlamadan önce

Bir denetimi form şablonunuzdaki doldurmak için bir SQL Server veritabanından değerleri kullanmadan önce veritabanı yöneticinize aşağıdaki bilgiler gerekir:

  • Bu form şablonunu kullanacağınız veritabanı sunucusuyla adı.

  • Bu form şablonunu kullanacağınız veritabanının adı.

  • Kimlik doğrulaması veritabanı tarafından gerekiyor. Veritabanı kullanıcıları veritabanına nasıl erişebilir belirlemek için Microsoft Windows kimlik doğrulamasını veya SQL Server kimlik doğrulaması kullanabilirsiniz.

  • Forma göndermek istediğiniz verileri içeren tablonun adı. Birincil tablo budur. Birden fazla tablo veritabanında kullanmayı planlıyorsanız, size gereken diğer adlarını, alt tablolar. İlişkiler birincil tablodaki alanlara sahip alt tablolardaki alanları adlarını de gerekir.

  • Olup kullanıcılarınızın bilgisayarlarda çevrimdışı kullanım için güvenli bir şekilde sorgu sonuçlarını depolayabilirsiniz.

Sayfanın Başı

Adım 1: sorgu veri bağlantısı ekleme

Form şablonunuzdaki kullanabileceğiniz varolan bir sorgu veri kaynağını yoksa, bu sorgular verileri form şablonunuz için ikincil veri bağlantısı eklemek için aşağıdaki adımları izleyin. Form şablonunuzu kullanabileceğiniz bir ikincil veri bağlantısı zaten varsa, bu bölümü atlayabilir ve gidin Adım 2: denetimi yapılandırma.

  1. Araçlar menüsünde, Veri bağlantıları' nı tıklatın.

  2. Veri bağlantıları iletişim kutusunda, Ekle'yitıklatın.

  3. Veri Bağlantı Sihirbazı ' nda Yeni bir bağlantı oluştur' u tıklatın, Veri Al'ıve sonra İleri' yi tıklatın.

  4. Sihirbazın sonraki sayfasında, veritabanı (Microsoft SQL Server veya yalnızca Microsoft Office Access)tıklatın ve sonra İleri' yi tıklatın.

  5. Sihirbazın sonraki sayfasında, Veritabanını seçin'itıklatın.

  6. Veri kaynağını seç iletişim kutusunda, Yeni kaynak' ı tıklatın.

  7. Bağlanmak istediğiniz veri kaynağını ne tür listesinde, sihirbazın sonraki sayfasında Microsoft SQL Server ' ı tıklatın ve sonra İleri' yi tıklatın.

  8. Sunucu adı kutusunda SQL Server veritabanı içeren sunucu adını yazın.

  9. Oturum açma kimlik bilgilerialtında aşağıdakilerden birini yapın:

    • Microsoft Windows ağ içinde kullanılan kimlik bilgileri dayalı erişim izni olan veritabanı belirler, Windows kimlik doğrulamasını kullan'ıtıklatın.

    • Belirtilen kullanıcı adı ve veritabanı yöneticisinden alma parola göre erişim izni olan veritabanı karar verirse, Aşağıdaki kullanıcı adını ve parolayı kullan' ı tıklatın ve sonra Kullanıcı adı ve kullanıcı adınızı ve parolanızı yazın Parola kutuları.

  10. İleri'yi tıklatın.

  11. İstediğiniz verileri içeren veritabanını seçin listesinde, kullanmak, belirli bir tablo Bağlan' ı tıklatın, birincil tablo adını tıklatın ve sonra İleri' yi tıklatın, istediğiniz veritabanının adını tıklatın.

  12. Dosya adı kutusunda, sihirbazın sonraki sayfasında veri bağlantısı bilgilerini saklayan dosya için bir ad yazın ve sonra bu ayarları kaydetmek için Son'u tıklatın.

    Sorgu Veri bağlantısında diğer tablolar kullanmayı planlıyorsanız, sihirbazın bu sayfadaki diğer tablolar ekleyebilirsiniz.

    Diğer tablolar ekleme

    1. Tablo Ekle'yitıklatın.

    2. Tablo veya Sorgu Ekle iletişim kutusunda, alt tablo adını tıklatın ve sonra İleri' yi tıklatın. İlişkileri her iki tablodaki alan adları eşleşen göre ayarlamak InfoPath çalışır. Önerilen ilişki kullanmak istemiyorsanız, ilişkiyi seçin ve İlişki Kaldır'ıtıklatın. İlişki eklemek için İlişki Ekle'ıtıklatın. İlişki Ekle iletişim kutusunda, ilgili her alana karşılık gelen sütun adını tıklatın ve sonra da Tamam' ı tıklatın.

    3. Son'a tıklayın.

    4. Ek alt tablolar eklemek için bu adımları yineleyin.

  13. İleri'yi tıklatın.

  14. Form şablonu ile sorgu sonuçlarını depolamak için form şablonunda verilerin bir kopyasını depolama onay kutusunu seçin. Bu onay kutusunu seçme sorgusu sonuçları form şablonunda depolar. Form şablonunda Becuase veriler depolanır. kendi bilgisayarlarına bir ağa bağlı değilken bile, verilerin kullanıcıların dolduracağı, formlarda kullanılabilir.

    Güvenlik Notu: Bu onay kutusunu seçme sorgusu sonuçları form şablonunda depolar. Form şablonunda verilerin depolandığı için kendi bilgisayarlarına bir ağa bağlı değilken bile, kullanıcıların dolduracağı, formlarda kullanılabilir. Bu veri bağlantısından hassas veri alıyorsanız, bilgisayarınızda kaybolabilir veya çalınması durumunda verileri korunmasına yardımcı olmak için bu özelliği devre dışı isteyebilirsiniz.

  15. İleri'yi tıklatın.

  16. Sihirbazın sonraki sayfasında, bu ikincil veri bağlantısı için açıklayıcı bir ad yazın. Formu form açıldığında verileri otomatik olarak almasını isterseniz, form açıldığında verileri otomatik olarak Al onay kutusunu seçin.

Sayfanın Başı

Adım 2: denetimi yapılandırma

  1. Form şablonu birden çok görünüm varsa, ikincil veri kaynağından verileri görüntülemek istediğiniz denetimle görünümüne gitmek için Görünüm menüsünde Görünüm adını tıklatın.

  2. Liste kutusu, aşağı açılan liste kutusu veya doldurmak istediğiniz birleşik giriş kutusu denetimi çift tıklatın.

  3. Veri sekmesine tıklayın.

  4. Liste kutusu girdileri'ninaltında değerleri dış veri kaynağından Ara' yı tıklatın.

  5. Veri kaynağı listesinde, kullanmak istediğiniz veri kaynağını tıklatın.

  6. Girdileri kutusunun yanındaki Düğme görüntüsü XPath Seç' i tıklatın.

  7. Alan veya Grup Seç iletişim kutusunda, hangi verilerin kullanıcıya gösterilir ve aşağıdakilerden birini yaparak dış veri kaynağına hangi verilerin gönderilecek belirtin.

    Kullanıcının göreceği verileri kullanıcı göndereceğiniz aynı verileri mı olduğunu belirtin

    • Bir alanı tıklatın ve sonra da Tamam' ı tıklatın.

    Kullanıcının göreceği verilerin kullanıcı göndereceğiniz verilerinden farklı olduğunu belirtin

    Not: Bu senaryoda, kullanıcının göreceği grubundaki alanların birinden veriler ve başka bir alanına aynı grubundaki kullanıcı göndereceğiniz veriler olduğu.

    1. Gruba tıklayın ve sonra da Tamam' ı tıklatın.

    2. Denetim Özellikleri iletişim kutusunda, değeri kutusunun yanındaki Düğme görüntüsü XPath Seç' i tıklatın.

    3. Alan veya Grup Seç iletişim kutusunda, kullanıcı dış veri kaynağına gönderme ve Tamam' ı tıklatın, istediğiniz verileri içeren bir alanı tıklatın.

    4. Denetim Özellikleri iletişim kutusunda, görünen ad kutusunun yanındaki Düğme görüntüsü XPath Seç' i tıklatın.

    5. Alan veya Grup Seç iletişim kutusunda, denetiminde görünür ve Tamam' ı veri içeren bir alanı tıklatın.

  8. Görünen ad kutusunda alanı benzer görünen adlarla değerleri varsa ve yalnızca benzersiz adlar görüntülemek istediğiniz, yalnızca benzersiz görüntü adlara sahip girdileri göster onay kutusunu seçin.

Sayfanın Başı

Office yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×