Bir liste kutusu, aşağı açılan liste kutusu veya birleşik giriş kutusunu doldurmak için Access veritabanından değerleri kullanın

Not:  En güncel yardım içeriklerini, mümkün olduğunca hızlı biçimde kendi dilinizde size sunmak için çalışıyoruz. Bu sayfanın çevirisi otomasyon aracılığıyla yapılmıştır ve bu nedenle hatalı veya yanlış dil bilgisi kullanımları içerebilir. Amacımız, bu içeriğin sizin için faydalı olabilmesini sağlamaktır. Buradaki bilgilerin faydalı olup olmadığını bu sayfanın sonunda bize bildirebilir misiniz? Kolayca başvurabilmek için İngilizce makaleye buradan ulaşabilirsiniz .

InfoPath formunda, bir liste kutusu, aşağı açılan liste kutusu veya birleşik giriş kutusu Microsoft Office Access 2007 (.accdb biçimine) veritabanına veya Access veritabanı (.mdb biçimi) önceki bir sürümde kaydedilmiş bir sorguyu veri bağlantısı verilerle doldurabilirsiniz.

Bu makalede

Genel bakış

Uyumluluk dikkat edilmesi gereken noktalar

Başlamadan önce

Adım 1: sorgu veri bağlantısı ekleme

Adım 2: denetimi yapılandırma

İsteğe bağlı: denetim öğeleri sınırlamak için Filtre ayarlama

Genel Bakış

Bir liste kutusu, aşağı açılan liste kutusu veya birleşik giriş kutusu bir InfoPath formu doldururken kullanıcılara seçebileceği öğelerin görüntüler. Bir form şablonu tasarladığınızda, bu tür bir ikincil veri bağlantısını Access veritabanına verileri görüntülemek için denetimler yapılandırabilirsiniz.

Bir ikincil veri bağlantısını herhangi bir form şablonuna ekleme bir dış veri kaynağına veri bağlantısıdır. Kullanıcılarınız form şablonunuzu temel alan bir form doldurma veya bir Web hizmeti gibi bir dış veri kaynağı form veri göndermek için gereken verileri almak için ikincil veri bağlantıları yapılandırabilirsiniz.

InfoPath form şablonunuzu bu sorguları verileri ikincil veri bağlantısı eklediğinizde, veri alanları ve veriler veritabanında depolanır biçimini karşılık grupları içeren bir ikincil veri kaynağı oluşturur. Sorgu veri bağlantısını Web hizmetinden alınan verileri getirir ve ardından formun ikincil veri kaynağı bu verileri depolar.

Sorgu sonuçlarını, kullanıcılarınızın bilgisayarlarda kaydedin, böylece bile kendi bilgisayarlarına bir ağa bağlı değilken bu kullanıcılar verilere erişimi için ikincil veri bağlantısını yapılandırabilirsiniz. Veri yapısı bağlı olarak, kullanıcılar bir ağına bağlıyken sorgu sonuçlarını görüntülemek isteyebilirsiniz.

Güvenlik Notu: Bir dış veri kaynağından önemli verileri almak için ikincil veri bağlantısı kullanıyorsanız, bilgisayarınızda kaybolabilir veya çalınması durumunda verileri yetkisiz kullanıma karşı korunmasına yardımcı olmak için bu özelliği devre dışı isteyebilirsiniz. Bu özellik devre dışı bırakırsanız, verileri yalnızca kullanıcı ağına bağlıysa kullanılabilir.

Liste kutusu denetimi öğelerin sayısını sınırlandırmak istiyorsanız, filtrekullanabilirsiniz. Her bir kullanıcı tarafından seçilen ölçütlere göre bir sorgu tarafından döndürülen veri alt kümesini görüntülemek gereksinim duyduğunuzda filtre kullanın. Ölçüt (örneğin, bir liste kutusu, birleşik giriş kutusu, aşağı açılan liste kutusu veya metin kutusu) veri kaynağındaki bir alana bağlı başka bir denetimi seçili olan öğenin emin olabilir.

Veri yapısı ikincil veri kaynağındaki veriler veritabanında depolanır biçimini eşleşmelidir olduğundan, varolan alanları veya grupları ikincil veri kaynağında değişiklik yapamazsınız. Ayrıca bkz bölümünde, bu makalenin veri bağlantıları ve veri kaynakları hakkında daha fazla bilgi için bağlantılar bulabilirsiniz.

Sayfanın Başı

Uyumluluk dikkat edilmesi gereken noktalar

Yalnızca bir tarayıcıyla uyumlu form şablonuolmayan bir form şablonu tasarlama varsa, Access veritabanına sorgu veri bağlantısı ekleyebilirsiniz.

Sayfanın Başı

Başlamadan önce

Bir denetimi form şablonunuzdaki doldurmak için Access veritabanından değerleri kullanmadan önce veritabanı yöneticinize aşağıdaki bilgiler gerekir:

  • Veritabanının konumunu ve adını.

    Not: Ağdaki diğer kullanıcıların bu form şablonunu temel alan formları oluşturur, veritabanınızı bu kullanıcılar için erişilebilir olduğundan emin olun.

  • Tablo veya sorguyu denetimler için değerleri sağlayan adıdır. Birincil tablo olarak sorgu veri bağlantısını yapılandırdığınızda, bu tablo veya sorgudan kullanacaksınız.

  • Herhangi bir tabloları veya sorguları içinden birincil tablo veya sorguyu veri gerektirebilir adlarını. Çoğu durumda, tablo ilişkileri zaten veritabanında kurulur. Birincil tablo veya sorgu ve başka bir tablo veya sorguyu arasındaki ilişkileri el ile oluşturmak gereksinim duyarsanız, hem tabloları veya sorguları ilişkili alan adlarını gerekir.

Sayfanın Başı

Adım 1: sorgu veri bağlantısı ekleme

Form şablonunuzda kullanabileceğiniz varolan bir sorgu veri kaynağını yoksa, form şablonunuzu bu sorguları verileri ikincil veri bağlantısı eklemek için aşağıdaki yordamı kullanın. Form şablonunuzu kullanabileceğiniz bir ikincil veri bağlantısı zaten varsa, bu bölümü atlayabilir ve gidin Adım 2: denetimi yapılandırma.

  1. Araçlar menüsünde, Veri bağlantıları' nı tıklatın.

  2. Veri bağlantıları iletişim kutusunda, Ekle'yitıklatın.

  3. Veri Bağlantı Sihirbazı ' nda Yeni bir bağlantı oluştur' u tıklatın, Veri Al'ıve sonra İleri' yi tıklatın.

  4. Sihirbazın sonraki sayfasında, veritabanı (Microsoft SQL Server veya yalnızca Microsoft Office Access)tıklatın ve sonra İleri' yi tıklatın.

  5. Sihirbazın sonraki sayfasında, Veritabanını seçin'itıklatın.

  6. Veri kaynağını seç iletişim kutusunda, veritabanınızı konumunu bulun.

    Not: Veritabanınızı bir ağ konumu depolanıyorsa, Evrensel Adlandırma Kuralı (UNC) bulunduğu konumun yolunu için göz atın. Eşlenmiş bir ağ sürücüsüne aracılığıyla ağ konumuna göz atın değil. (Yani bir harf y: veya Z: gibi bir ağ sürücüsüne atama olan) bir eşlenmiş bir ağ sürücüsüne kullanırsanız, bu belirli eşlenen ağ sürücüsündeki veritabanı kullanıcılar oluşturduğunuz bu form şablonunu temel alan formlar arar. Kullanıcı bir ağ sürücüsüne tam olarak aynı şekilde eşlenen yoksa, form veritabanı bulmaz.

  7. Veritabanınızı adını tıklatın ve sonra da ' ı tıklatın.

  8. Tablo Seç iletişim kutusunda, birincil tablo veya kullanmak istediğiniz sorguyu tıklatın ve sonra da Tamam' ı tıklatın.

  9. Sihirbazın sonraki sayfasında Tablo Sütunları Göster onay kutusunu seçin.

    Varsayılan olarak, tablo veya sorgudaki tüm alanları form şablonunun ana veri kaynağına eklenir.

  10. Ana veri kaynağında dahil etmek istemediğiniz alanların onay kutularını temizleyin.

  11. Herhangi bir ek tablo veya sorgu veri bağlantısında dahil etmek istediğiniz sorguları ekleyin.

    Nasıl mı?

    1. Tablo Ekle'yitıklatın.

    2. Tablo veya Sorgu Ekle iletişim kutusunda, alt tablo adını tıklatın ve sonra İleri' yi tıklatın. İlişkileri her iki tablodaki alan adları eşleşen göre ayarlamak InfoPath çalışır. Önerilen ilişki kullanmak istemiyorsanız, ilişkiyi seçin ve İlişki Kaldır'ıtıklatın. İlişki eklemek için İlişki Ekle'ıtıklatın. İlişki Ekle iletişim kutusunda, ilgili her alana karşılık gelen sütun adını tıklatın ve sonra da Tamam' ı tıklatın.

    3. Son'a tıklayın.

    4. Ek alt tablolar eklemek için bu adımları yineleyin.

  12. İleri'yi tıklatın.

  13. Formu ağa bağlı değilken sorgu veri bağlantısı sonuçlarını kullanılabilmesi için form şablonunda verilerin bir kopyasını depola onay kutusunu seçin.

    Güvenlik Notu: Form bu veri bağlantısını kullandığında bu onay kutusunu seçerek verileri kullanıcının bilgisayarında depolar. Bu veri bağlantısından form önemli verileri alıyorsa, bilgisayarınızda kaybolabilir veya çalınması durumunda verileri korunmasına yardımcı olmak için bu özelliği devre dışı isteyebilirsiniz veya yetkisiz bir kullanıcı tarafından aksi erişilir.

  14. İleri'yi tıklatın.

  15. Sihirbazın sonraki sayfasında, bu ikincil veri bağlantısı için açıklayıcı bir ad yazın ve sonra da Özet bölümündeki bilgilerin doğru olduğunu doğrulayın.

  16. Form açıldığında verileri otomatik olarak almayı yapılandırmak için form açıldığında verileri otomatik olarak Al onay kutusunu seçin.

Sayfanın Başı

Adım 2: denetimi yapılandırma

  1. Form şablonu birden çok görünüm varsa, ikincil veri kaynağından verileri görüntülemek istediğiniz denetimle görünümüne gitmek için Görünüm menüsünde Görünüm adını tıklatın.

  2. Liste kutusu, aşağı açılan liste kutusu veya birleşik giriş kutusu denetimi form şablonunuzdaki yapılandırmak istediğiniz çift tıklatın.

  3. Veri sekmesine tıklayın.

  4. Liste kutusu girdileri'ninaltında değerleri dış veri kaynağından Ara' yı tıklatın.

  5. Veri kaynağı listesinde, kullanmak istediğiniz veri kaynağını tıklatın.

  6. XPath Seç Düğme görüntüsü , girdileri kutusunun yanındaki'ı tıklatın.

  7. Alan veya Grup Seç iletişim kutusunda, alan veya alanları kullanıcıya gösterilen verileri ve dış veri kaynağına aşağıdakilerden birini yaparak gönderilecek verileri içeren grubu belirtin.

    Kullanıcının göreceği verileri kullanıcı göndereceğiniz aynı verileri mı olduğunu belirtin

    • Bir alanı tıklatın ve sonra da Tamam' ı tıklatın.

    Kullanıcının göreceği verileri kullanıcı göndereceğiniz verilerinden farklıdır belirtme

    Not: Bu senaryoda, kullanıcının göreceği veriler grubunda alanlardan birini gelir ve kullanıcı göndereceğiniz verileri aynı grubundaki başka bir alanda bulunan.

    1. Gruba tıklayın ve sonra da Tamam' ı tıklatın.

    2. Denetim Özellikleri iletişim kutusunda, XPath Seç Düğme görüntüsü , değer kutusunun yanındaki'ı tıklatın.

    3. Alan veya Grup Seç iletişim kutusunda, kullanıcı dış veri kaynağına gönderme ve Tamam' ı tıklatın, istediğiniz verileri içeren bir alanı tıklatın.

    4. Denetim Özellikleri iletişim kutusunda, XPath Seç Düğme görüntüsü , görünen ad kutusunun yanındaki'ı tıklatın.

    5. Alan veya Grup Seç iletişim kutusunda, denetiminde görünür ve Tamam' ı veri içeren bir alanı tıklatın.

  8. Görünen ad kutusunda alanı benzer görünen adlarla değerleri varsa ve yalnızca benzersiz adlar görüntülemek istediğiniz, yalnızca benzersiz görüntü adlara sahip girdileri göster onay kutusunu seçin.

Sayfanın Başı

Sayfanın Başı

İsteğe bağlı: denetim öğeleri sınırlamak için Filtre ayarlama

  1. Liste kutusu, aşağı açılan liste kutusu veya birleşik giriş kutusu denetimi form şablonunuzdaki yapılandırmak istediğiniz çift tıklatın.

  2. Veri sekmesine tıklayın.

  3. Girdileri kutusunun yanındaki Düğme görüntüsü XPath Seç' i tıklatın.

  4. Alan veya Grup Seç iletişim kutusunda, alan veya denetim için değerleri sağlayan alanları içeren grubu tıklatın ve sonra Verilere filtretıklatın.

  5. Verilere filtre iletişim kutusunda, Ekle'yitıklatın.

    Not: Bir koşul eklemek için varolan bir filtreyi istiyorsanız, uygulamak istediğiniz filtreyi tıklatın ve sonra Değiştir' i tıklatın.

  6. İlk kutuya Filtre Koşullarını Belirle iletişim kutusunda, veri, filtre uygulamak istediğiniz alanın adını tıklatın.

  7. İkinci kutuya, kullanmak istediğiniz filtre türüne tıklayın.

  8. Üçüncü kutusunda, filtre uygulamak istediğiniz koşul türünü tıklatın ve ardından koşulu yazın.

  9. Filtre için birden fazla koşul yapılandırmak için ve' ı tıklatın ve sonra aşağıdakilerden birini yapın:

    • Varolan bir koşulun ve yeni koşul, filtre uygulamak için vetıklatın ve sonra yeni koşul ekleyin.

    • Varolan bir koşulun veya yeni koşul, filtre uygulamak için veya' yı tıklatın ve sonra ek koşul ekleyin.

  10. İletişim kutularını kapatmak için Tamam ' ı tıklatın.

  11. Yaptığınız değişiklikleri test etmek için, Standart araç çubuğunda Önizleme’ye tıklayın veya CTRL+SHIFT+B tuşlarına basın.

    Form şablonuna yeni bir pencerede açılır.

  12. Önizleme penceresinde, çeşitli değerleri filtre düzgün çalıştığını sınamak için filtre denetimini seçin.

    Filtreyi düzgün çalışmıyor

    Filtre içeren denetimi değerleri doğru değilse, çok fazla değer ya da yeterli değerler olduğundan ya da aşağıdakileri deneyin:

    • Birden fazla koşul, filtrede kullanıyorsanız, bu tek bir koşul doğru değerleri döndürülür denetlemek üzere biri hariç tüm koşul kaldırın. İlk koşul doğru değerleri döndürürse, başka bir koşul eklemek ve test edin.

    • Filtreler bir büyük ve küçük harf karakterler arasında ayrım olun. Büyük veya küçük harf karakterle başlayan verileri görüntülemek istiyorsanız, bir büyük harfi koşul filtre oluşturma, veyaFiltre koşul belirtmek iletişim kutusundan seçin ve sonra küçük harf koşul oluşturabilirsiniz.

    • Filtrelenen değerlerin tam olarak karşı hangi sizin düşünmüyorsanız, örneğin tek bir sağlayıcı ürünlerinden yerine tedarikçileri görüntü ürünlerinden, koşulu filtre türünü değiştirin. Örneğin, filtre türü eşittir , koşulu kullanıyorsa ve çok fazla ürünleri elde edeceğinizi, filtre türü eşit değildirkullanmayı deneyin.

Sayfanın Başı

Office yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×