Bir değerin hangi sıklıkta yinelendiğini sayma

Çalışma sayfası işlevlerinin bir kısmı, bir hücre aralığındaki belirli bir metnin veya sayı değerinin kaç kez ortaya çıktığını hesaplamanıza yardım edebilir. Örneğin, tek bir değerin ne sıklıkta ortaya çıktığını hesaplamak için, aşağıdaki örnekte gösterildiği gibi, EĞERSAY işlevi’ni kullanabilirsiniz.

Örnek

Satış Elemanı

Fatura

Biber

15.000

Biber

9.000

Göktepe

8.000

Göktepe

20.000

Biber

5.000

Koçak

22.500

Formül

Açıklama

Sonuç

=EĞERSAY(A2:A7,"Biber")

Biber'in girişlerinin sayısı (3)

3

=EĞERSAY(A2:A7,A4)

Göktepe'nin girişlerinin sayısı (2)

2

=EĞERSAY(B2:B17,"< 20000")

Değeri 20.000'in altında olan fatura değerlerinin sayısı (4)

4

=EĞERSAY(B2:B7,">="&B5)

Değeri 20.000'e eşit veya bundan büyük olan fatura değerlerinin sayısı (2)

2

Birden çok ölçüte dayalı olarak değerleri saymak için ÇOKEĞERSAY işlevini kullanma

Excel 127'de kullanılmaya başlanan ÇOKEĞERSAY işlevi, EĞERSAY işlevine benzemekle birlikte bu işlevden önemli bir farkı vardır: ÇOKEĞERSAY işlevi, birden fazla aralıkta bulunan hücrelere ölçüt uygulamanıza izin verir ve tüm ölçütlerin kaç kez karşılandığını sayar. ÇOKEĞERSAY işleviyle en çok 127 aralık/ölçüt çifti kullanabilirsiniz. İşlevin söz dizimi şuna benzer:

ÇOKEĞERSAY(ölçüt_aralığı1; ölçüt1; [ölçüt_aralığı2; ölçüt2];…)

Örnek

Çalışan Kimliği

Bölge Numarası

Bölüm

20552

2

Satış

21268

2

Finans

23949

1

Yönetim

24522

4

Yönetim

28010

3

BT

29546

4

Satış

31634

3

BT

32131

1

BT

35106

4

Finans

40499

1

İK

42051

1

Satış

43068

2

İK

45382

2

Finans

47971

1

BT

Formül

Açıklama

Sonuç

=ÇOKEĞERSAY(B2:B15,"2",C2:C15,"Finans")

Bölge 2’de ve Finans bölümünde yer alan çalışan sayısı

2

İlk ölçüt aralığı tüm bölge numaralarını, ikinci ölçüt aralığı ise tüm bölüm adlarını içerir. İlk ölçüt aralığına uygulanan ölçüt "2,", ikinci ölçüt aralığına uygulanan ölçüt ise "Finans" ölçütüdür. ÇOKEĞERSAY iki kriterin birden sağlanıp sağlanmadığını denetler.

Office yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×