Bir arama işlevinde tablo_dizisi bağımsız değişkenini kullanma

Not:  En güncel yardım içeriklerini, mümkün olduğunca hızlı biçimde kendi dilinizde size sunmak için çalışıyoruz. Bu sayfanın çevirisi otomasyon aracılığıyla yapılmıştır ve bu nedenle hatalı veya yanlış dil bilgisi kullanımları içerebilir. Amacımız, bu içeriğin sizin için faydalı olabilmesini sağlamaktır. Buradaki bilgilerin faydalı olup olmadığını bu sayfanın sonunda bize bildirebilir misiniz? Kolayca başvurabilmek için İngilizce makaleye buradan ulaşabilirsiniz .

DÜŞEYARA veya YATAYARA işlevlerini kullanan bir formül oluşturduğunuzda, D2:F39 gibi hücre aralığı olan bir tablo_dizisi bağımsız değişkeni girin. İşlev aralığın bulmaya çalıştığınız veriler için arama yapar.

Tablo_dizisi bağımsız değişkeni, bir DÜŞEYARA veya YATAYARA işlevinde her zaman ikinci bağımsız değişkendir (birincisi, bulmak istediğiniz değerdir). tablo_dizisi bağımsız değişkeni olmadan bu işlevler çalışmaz.

İlk bağımsız değişkeniniz “41” veya “demirci” gibi belli bir değer ya da F2 gibi bir hücre başvurusu olabilir Birinci bağımsız değişken şöyle görünür:

=DÜŞEYARA(F2,...

Tablo_dizisi bağımsız değişkeni her zaman düşeyara değerini şu şekilde takip eder:

=DÜŞEYARA(F2,B4:D39, ...

Tablo_dizisi bağımsız değişkeninde listelenen hücre aralığı göreli veya mutlak hücre başvuruları kullanabilir. Formülünüzü başka hücrelere kopyalayacaksınız şu şekilde mutlak hücre başvuruları kullanmanız gerekir ($ işaretlerine dikkat edin):

=DÜŞEYARA(F2,$B$2:BD$39, ...

tablo_dizisi bağımsız değişkenindeki hücreler çalışma kitabınızın başka bir çalışma sayfasındaysa bağımsız değişkene sayfa adını yazıp sonuna ünlem işareti ekleyin. Söz dizimi şu şekilde görünür:

=DÜŞEYARA(F2,Sheet2!$C$14:E$42, ...

Bulmak istediğiniz değerleri içinde aradığınız sütun gireceğiniz üçüncü bağımsız değişkendir. Buna arama sütunu denir. Görmek istediğiniz değerler D sütunundaysa (tablo_dizisinde üçüncü sütun) son bağımsız değişken 3’tür.

=DÜŞEYARA(F2,B4:D39,3)

İsteğe bağlı olsa da dördüncü bir bağımsız değişken, Yanlış veya Doğru, kullanmanız önerilir. Tam eşleşme arıyorsanız Yanlış değişkenini kullanın.

=DÜŞEYARA(F2,B4:D39,3,False)

Doğru değişkenini kullanır veya dördüncü bağımsız değişkeni boş bırakırsanız, işlev ilk bağımsız değişkeninizdeki değerle yaklaşık bir eşleşme verir. Yani ilk bağımsız değişkeniniz "demirci" ise ve Doğru değişkenini kullanırsanız, DÜŞEYARA "Demirci", "Demirciler" vb. sonuçlar verir. Ancak Yanlış değişkenini kullanırsanız işlev, tam eşleşme olan "Demirci" sonucunu verir ve çoğu zaman da istenen budur.

Doğru değişkeninin daha kafa karıştırıcı bir kullanımına baktığımızda, arama sütununuz (üçüncü bağımsız değişkende belirttiğiniz sütun) artan düzende (A - Z veya en küçük sayıdan en büyüye doğru) sıralanmamışsa yanlış sonuç alabilirsiniz.

DÜŞEYARA ve YATAYARA işlevleri hakkında daha fazla bilgi için Arama ve başvuru işlevleri (başvuru)bakın.

Office yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×