BİRLEŞTİR işlevindeki #DEĞER! hatasını düzeltme

Önemli: Excel 2016, Excel Mobile ve Web için Excel, art arda CONCAT işlevi değiştirilmiştir. Geriye dönük uyumluluk için BİRLEŞTİR hala kullanılabilse de, çok daha güçlü bir işlev olan ARALIKBİRLEŞTİR işlevini kullanmayı dikkate almalısınız.

#VALUE karşılaştığınız en yaygın senaryolarından biridir! BIrLEŞTIr ile ilgili hata, #VALUE! gibi bir hata içeren hücre başvurusunu içeren bir dize oluşturmaya çalıştığınızda.

Aşağıdaki örnekte, D2, E2 ve F2'yi birleştirmek istiyoruz ve E2'de #DEĞER! hatası var.

BİRLEŞTİR işlevinde #DEĞER! hatası

E2'deki hata, işlevin #DEĞER! hatası görüntülenmesine neden olur. Başarılı bir şekilde çalışması için, bu hatayı hata dışında bir değerle değiştirmeniz gerekir. Hücre başvurusunda hata olup olmadığını denetleyen ve hata varsa, hatanın yerine 0 değerinin gösterildiği bir metin dizesi görüntüleyen bir formül oluşturabilirseniz (veya 0 yerine kendi metninizi koyabilirsiniz, ancak bu durumda metninizi tırnak içine almanız gerekir: "Metniniz").

Şöyle bir formül çalışır:

=EĞER(EHATALIYSA(E2),BİRLEŞTİR(D2," ",0," ",F2))

#DEĞER! hatası içeren bir dizeyi birleştirirken geçici bir çözüm olarak EĞER ve EHATALIYSA işlevleri kullanılır

Bu nasıl çalışır? EĞER işlevi EĞERHATA işlevini kullanarak E2'de hata olup olmadığını denetler; hata varsa, BİRLEŞTİR işlevi D2, E2 ve F2 değerlerini birleştirir (işlev hatayı 0 ile değiştirir) ve sonuçta elde edilen metin dizesini görüntüler. Formülde değerleri ayırmaya yardımcı olmak için boşlukların (“ “) kullanıldığına da dikkat edin.

Excel 2003 ve daha eski sürümlerde #DEĞER! hatası olan BİRLEŞTİR işlevini düzeltme

Office Excel 2003 veya daha eski sürümlerde #DEĞER! Office Excel 2003 veya önceki sürümlerde hata, Excel Geçiş formülü değerlendirme (TFE) seçeneğinin işaretini kaldırmanız gerekir. #VALUE! hücreleri birleştirirken hatayı birleştirirken hata oluştu konusunda altı çizilen adımları izleyin.

İşlevlerle ilgili bir sorunuz mu var?

Excel topluluk forumuna soru gönderin

Excel’i geliştirmemize yardımcı olun

Excel'in sonraki sürümünü nasıl geliştirebileceğimiz konusunda önerileriniz var mı? Varsa, lütfen Excel User Voice forumundaki başlıkları gözden geçirin.

Ayrıca bkz.

#DEĞER! hatasını düzeltme

BİRLEŞTİR işlevi

ARALIKBİRLEŞTİR işlevi

Excel’deki formüllere genel bakış

Bozuk formülleri önleme

Formüllerde hataları algılama

Tüm Excel işlevleri (alfabetik)

Tüm Excel işlevleri (kategoriye göre)

Not:  Bu sayfanın çevirisi otomasyon aracılığıyla yapılmıştır ve bu nedenle hatalı veya yanlış dil bilgisi kullanımları içerebilir. Amacımız, bu içeriğin sizin için faydalı olabilmesini sağlamaktır. Bu bilgileri yararlı bulup bulmadığınızı bizimle paylaşır mısınız? Kolayca başvurabilmek için İngilizce makaleye buradan ulaşabilirsiniz.

Office yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×