Alt raporları oluşturma ve kullanma

İlişkisel verilerle çalışırken (ilgili veriler ayrı tablolarda depolandığında), çoğu durumda aynı raporun birden çok tablo veya sorgusundaki bilgileri görüntülemeniz gerekir. Örneğin, müşteri verilerini görmek istersiniz ama aynı anda müşterilerin siparişleri hakkındaki bilgileri de görmek istersiniz. Access'te alt raporlar bunu yapmak için yararlı bir araçtır çünkü raporda sipariş bilgilerini müşteri bilgileriyle birlikte mantıklı ve okunabilir bir şekilde görüntülemenize olanak tanır. Access alt raporları hızla oluşturmanıza yardımcı olacak birçok yol sağlar.

Ne yapmak istiyorsunuz?

Alt raporları anlama

Alt rapor oluşturma

Alt raporda tasarım değişiklikleri yapma

Alt raporları anlama

Alt rapor, başka bir raporun içine eklenen rapordur. Raporları birleştirdiğinizde, raporlardan birinin diğerini içeren ana rapor işlevi görmesi gerekir. Ana rapor ilişkili veya ilişkisiz olur. İlişkili rapor verileri görüntüleyebilen ve Kayıt Kaynağı özelliğinde belirtilen bir tablosu, sorgusu veya SQL deyimi olan bir rapordur. İlişkisiz rapor bir tablo, sorgu veya SQL deyimine dayanmayan bir rapordur (başka bir deyişle, raporun Kayıt Kaynağı özelliği boştur).

İlgili olmayan iki alt rapor içeren ilişkisiz bir ana rapor örneği    

İlişkisiz ana rapor kendi verilerini görüntüleyemez ama yine de birleştirmek istediğiniz ilgili olmayan alt raporlar için ana rapor işlevi görebilir.

İlgili olmayan verilerin görüntülendiği iki alt raporla ana raporun bağlantısını kesme

1. İlişkisiz ana rapor iki alt rapor içeriyor.

2. Bir alt rapor çalışana göre satışları özetliyor.

3. Diğer alt rapor kategoriye göre satışları özetliyor.

Aynı kayıt kaynağına bağlı olan bir ana rapor ve alt rapor örneği    

Ana raporu kullanarak ayrıntı kayıtlarını, örneğin bir yılın tüm satışlarını ve ardından alt raporu kullanarak özet bilgileri, örneğin her çeyreğin toplam satılarını gösterebilirsiniz.

Aynı kayıt kaynağına bağlı ana rapor ve alt rapor

1. Alt rapor yılın satışlarını çeyrek döneme göre özetliyor.

2. Ana rapor gündelik satışları listeliyor.

İlgili kayıt kaynaklarıyla ilişkili olan bir ana rapor ve alt rapor örneği    

Ana rapor bir veya birden çok alt raporda ortak olan veriler içerebilir. Bu durumda, alt rapor ana rapordaki verilerle ilgili olan veriler içerir.

İlgili verileri görüntüleyen iki alt raporla birlikte ana rapor

1. Ana rapor her fuarın adını ve şehrini listeliyor.

2. Alt rapor her fuara katılacak olan temsilcileri listeler.

Rapordaki alt formlar

Ana rapor alt raporlara ek olarak alt formlar da içerebilir ve ana raporda istediğiniz sayıda alt form ve alt rapor bulunabilir. Buna ek olarak, ana rapor en çok yedi düzeyde alt form ve alt rapor içerebilir. Örneğin raporun bir alt raporu, o alt raporun bir alt formu veya alt raporu olabilir ve bu şekilde yedi düzey derinliğe kadar gidebilir.

Rapora bir alt form ekler ve ardından raporu Rapor görünümünde açarsanız, alt formu kullanarak kayıtları filtreleyebilir ve kayıtlarda gezinebilirsiniz. Forma ve formdaki denetimlere eklenen Visual Basic for Applications (VBA) kodu ve ekli makrolar yine çalışır, ama bu bağlamda bazı olaylar devre dışı bırakılır. Rapordaki bir alt formu kullanarak kayıtları ekleyemez, düzenleyemez veya silemezsiniz.

Raporu bir alt forma veya alt rapora bağlama

Ana rapordaki verilerle ilgili bilgiler içeren bir alt form veya alt rapor eklediğinizde, alt rapor denetiminin ana rapora bağlanması gerekir. Bu bağ, alt form veya alt raporda görüntülenen kayıtların doğru bir şekilde ana raporda yazdırılan kayıtlara karşılık gelmesini sağlar.

Sihirbaz kullanarak veya Gezinti Bölmesi'nde bir nesneyi rapora sürükleyerek alt form veya alt rapor oluşturduğunuzda, aşağıdaki koşullardan herhangi biri karşılandığında Access alt formu veya alt raporu otomatik olarak ana rapora bağlar.

  • Seçtiğiniz tablolar için ilişkiler tanımlarsınız veya seçtiğiniz sorguların temeli olan tablolar için ilişkiler tanımlarsınız.

  • Ana rapor birincil anahtar içeren bir tabloyu temel alır ve alt form veya alt rapor birincil anahtarla aynı ada sahip bir alan içeren ve veri türü aynı veya uyumlu olan bir tabloyu temel alır. Örneğin, ana raporun temel aldığı tablonun birincil anahtarı OtomatikSayı alanıysa ve AlanBoyutu özelliği Uzun Tamsayı olarak ayarlandıysa, alt form veya alt raporun temel aldığı tabloda buna karşılık gelen alan bir Sayı alanı olmalı ve bu alanın AlanBoyutu özelliği Uzun Tamsayı olarak ayarlanmalıdır. Alt form veya alt raporun kayıt kaynağı olarak bir veya birden çok sorgu seçtiyseniz, sorgunun veya sorguların temel tabloları da aynı koşullara uymalıdır.

Sayfanın Başı

Alt rapor oluşturma

Alt rapor ana rapora bağlanacaksa, aşağıdaki yordamı kullanmadan önce teme kayıt kaynaklarının ilgili olduğundan emin olmalısınız.

Alt Rapor Sihirbazı'nı kullanarak alt rapor oluşturma

Bu yordamda, zaten alt raporu eklemek istediğiniz bir raporunuzun olduğu varsayılır. Rapor oluşturma hakkında daha fazla bilgi için, Basit rapor oluşturma veya Gruplandırılmış veya özet rapor oluşturma makalesine bakın.

  1. Gezinti Bölmesi'nde, alt raporu eklemek istediğiniz rapora sağ tıklayın ve ardından Tasarım Görünümü'ne tıklayın.

  2. Tasarım sekmesinin Denetimler grubunda Denetimler Galerisi'ni açmak için sağ alt köşedeki aşağı oka tıklayın:

    şerit resmi

  3. Görüntülenen menüde Denetim Sihirbazları Kullan'ın seçili olmasına dikkat edin.

  4. Denetimler Galerisi'ni yeniden açın ve Alt Form/Alt Rapor'a tıklayın.

  5. Raporda, alt formu yerleştirmek istediğiniz yere tıklayın.

  6. Güvenlik bildirimi iletişim kutusu görüntülenirse, 'a tıklayarak sihirbazı başlatın.

  7. Alt Rapor Sihirbazı'nın ilk sayfasında, yeni bir alt form veya alt rapor oluşturup bunu bir tablo veya sorguya dayandırmak istiyorsanız, Varolan Tabloları ve Sorguları kullan'a tıklayın. Alt rapor olarak kullanmak istediğiniz bir rapor veya form varsa Varolan bir raporu veya formu kullan'a tıklayın, listede raporu veya formu seçin ve ardından İleri'ye tıklayın.

    Alt Rapor Sihirbazı’nda verilerin kaynağını seçme

    Not:  Veritabanında başka rapor veya form yoksa liste boş olur ve Varolan bir raporu veya formu kullan seçeneği kullanılabilir durumda olmaz.

  8. Sihirbazın önceki sayfasında Varolan bir raporu veya formu kullan'ı seçtiyseniz, bu adımı atlayın ve doğrudan 9. adıma gidin. Aksi takdirde, Tablolar/Sorgular listesinden alt rapora eklenmesini istediğiniz alanları içeren tabloyu veya sorguyu seçin ve ardından Kullanılabilir Alanlar listesinde istediğiniz alanlara çift tıklayarak bunları alt rapora ekleyin.

    Alt Rapor Sihirbazı'nda alanları seçme

    Alt raporu ana rapora bağlamayı planlıyorsanız, bağı oluşturmak için kullanılacak alanı veya alanları (bunların görüntülenmesini istemiyor bile olsanız) eklediğinizden emin olun. Normalde, bağlama alanı bir kimlik alanıdır. Yukarıdaki resimde, Siparişler tablosu alt raporun kayıt kaynağıdır ve Müşteriler tablosu da ana raporun kayıt kaynağıdır. Siparişler tablosu Müşteri Kimliği alanı sayesinde Müşteriler tablosuyla ilişkili olduğundan, bu alan Seçili Alanlar listesine eklenir.

    Not: Alt raporunuza birden çok tablo veya sorgudan alanlar ekleyebilirsiniz. Bir tablodan alanları eklemeyi bitirdiğinizde, Tablolar/Sorgular listesinden bir sonraki tabloyu veya sorguyu seçin ve istediğiniz alanları ekleyin.

    Devam etmek için İleri'ye tıklayın.

  9. Sihirbazın bu sayfasında, alt raporu ana rapora nasıl bağlayacağınıza karar verirsiniz. Access alt raporu ana rapora bağlamak için uygun gibi görünen alanlar bulursa, sihirbaz olası bağlama önerilerinin listesini görüntüler.

    Alt Rapor Sihirbazı’nda Access bağlanacak alanlar için öneride bulunur

    Sizin durumunuza en uygun görünen bağlama önerisini seçebilir veya alt raporun ana rapora bağlanmasını istemiyorsanız Hiçbiri seçeneğini belirtebilirsiniz. Alt raporu ana rapora bağlamak istiyorsanız ama önerilerden hiçbiri uygun görünmüyorsa, Kendim tanımlayacağım seçeneğine tıklayın.

    Not: Sihirbaz bağlama için uygun alanları bulamazsa, bağlama önerileri listesi sağlamaz ve Kendim tanımlayacağım seçeneği otomatik olarak seçilir.

    Alt Rapor Sihirbazı'nda kendi bağlantılarınızı tanımlama

    Kendim tanımlayacağım seçeneği belirtildiğinde, sihirbazı iki grup liste görüntüler.

    • Form/rapor alanları'nın altında, ana raporu alt forma veya alt rapora bağlamak için kullanmak istediğiniz alanı veya alanları ana rapordan seçin. En çok üç alan seçebilirsiniz ve seçtiğiniz her alanın alt form veya alt raporun veri kaynağındaki bir ilgili alanla eşleşmesi gerekir.

    • Alt form/alt rapor alanları'nın altında, seçtiğiniz ana rapor alanlarına bağlanan ilgili alanı veya alanları alt form veya alt rapordan seçin.

    • Alt form veya alt raporu ana rapora bağlamadan bırakmak için, tüm listelerin boş olduğundan emin olun.

      Devam etmek için İleri'ye tıklayın.

  10. Sihirbazın son sayfasında, alt form veya alt rapor için bir ad yazın veya varsayılan adı kabul etmek için doğrudan Son'a tıklayın.

    Alt Rapor Sihirbazı'nda ad girme

Access raporunuza bir alt rapor denetimi ekler ve aşağıda gösterildiği gibi denetimi bağlar (başka bir deyişle, denetimin Kaynak Nesne özelliğini ayarlar):

  • Sihirbazın ilk sayfasında Varolan bir raporu veya formu kullan'ı seçtiyseniz, Access alt rapor denetimini belirttiğiniz rapora veya forma bağlar.

  • Sihirbazın ilk sayfasında Varolan Tabloları ve Sorguları kullan'ı seçtiyseniz, Access Gezinti Bölmesi'nde yeni bir rapor nesnesi oluşturur ve sonra alt rapor denetimini ona bağlar. Yeni rapor nesnesinin adı, sihirbazın son sayfasında yazdığınız adla aynıdır.

Bir rapora tablo, sorgu, form veya raporu alt rapor olarak ekleme

Rapora alt rapor eklemenin hızlı bir yolu, ana raporu Düzen görünümünde veya Tasarım görünümünde açmak ve ardından Gezinti Bölmesi'nden bir nesneyi bu ana rapora sürüklemektir. Alt raporun ana rapora bağlanmasını istiyorsanız, temel kayıt kaynaklarının ilgili olduğundan ve kayıt kaynaklarının alt form veya alt raporu ana rapora bağlamak için kullanılacak alanları içerdiğinden emin olun.

  1. Gezinti Bölmesi'nde ana rapor olarak kullanmak istediğiniz rapora sağ tıklayın ve sonra kısayol menüsünde Düzen Görünümü'ne veya Tasarım Görünümü'ne tıklayın.

  2. Gezinti Bölmesi'nden bir tabloyu, sorguyu, formu veya başka bir raporu, ana raporda alt raporun gösterilmesini istediğiniz bölüme sürükleyin.

Access aşağıdakilerden birini yapar:

  • Access iki nesnenin nasıl bağlanacağını saptayabilirse, rapora bir alt rapor denetimi ekler. Form veya rapor eklerseniz, Access alt rapor denetimini bu nesneye bağlar. Tablo veya sorgu eklerseniz, Access önce bir rapor nesnesi oluşturur ve ardından alt rapor denetimini bu yeni nesneye bağlar.

  • Access iki nesnenin nasıl bağlanacağını saptayamazsa, Alt Rapor Sihirbazı görüntülenir. Devam etmek için, Alt Rapor Sihirbazı'nı kullanarak alt rapor oluşturma bölümündeki yordamı 9. adımdan başlayarak izleyin.

    Sihirbazı tamamladıktan sonra, Access alt raporu rapora ekler.

Alt form veya alt raporun ana rapora doğru bağlanıp bağlanmadığını bir kez daha denetlemek için aşağıdaki yordamı kullanın.

  1. Alt rapor denetimini tıklayarak seçin.

  2. Özellik sayfası görünmüyorsa, görüntülenmesi için F4 tuşuna basın.

  3. Özellik sayfasının Veri sekmesinde, Üst Alanları Bağla ve Alt Alanları Bağla özelliklerini inceleyin.

    • Bağlı olmayan bir alt form veya alt rapor için, bu özelliklerin her ikisi de boş olmalıdır.

    • Bağlı bir alt form veya alt rapor için, Üst Alanları Bağla ve Alt Alanları Bağla özelliklerinin iki nesneyi ilişkilendiren alan veya alanları görüntülediğinden emin olun. Örneğin, ana rapor Çalışanlar tablosundaki bilgileri görüntülüyorsa ve alt form veya alt rapor Siparişler tablosundaki verileri görüntülüyorsa, Üst Alanları Bağla özelliği Çalışanlar tablosundaki Kimlik alanını ve Alt Alanları Bağla özelliği de Siparişler tablosundaki Çalışan Kimliği alanını görüntülemelidir.

Alt form veya alt raporda düzgün çalışması için bu özelliklerin düzenlenmesi gerektiğini keşfedebilirsiniz. Aşağıdaki yordamı kullanın.

  1. Özellik sayfasının Veri sekmesinde Üst Alanları Bağla özellik kutusuna tıklayın ve sonra da Oluştur düğmesine düğme resmi tıklayın.

    Alt Form Rapor Bağlayıcısı iletişim kutusu görüntülenir.

    Alt Form Rapor Bağlayıcısı iletişim kutusu

  2. Üst Alanlar ve Alt Alanlar listelerinde raporu bağlamak istediğiniz alanları seçin. Hangi alanları kullanacağınızdan emin değilseniz, Access'in bağlama alanlarını saptamayı denemesini sağlamak için Öner'e tıklayın. İşiniz bittiğinde Tamam'a tıklayın.

    Raporu bağlamak için kullanmak istediğiniz alanı görmezseniz, ana raporun ya da alt form veya alt raporun kayıt kaynağını bağlama alanını içerecek şekilde düzenlemeniz gerekir. Örneğin, rapor bir sorguyu temel alıyorsa, bağlama alanının sorgu sonuçlarında yer aldığından emin olmalısınız.

  3. Ana raporu kaydedin ve Rapor görünümüne geçerek raporun beklediğiniz gibi çalıştığını doğrulayın.

Bir rapora tablo veya sorguyu veri sayfası olarak ekleme

Veri sayfası, verilerin elektronik tabloya benzeyen basit bir görsel gösterimidir. Veri sayfasındaki her sütun, kaynak tablo veya sorgudaki bir alanı ve her satır da bir kaydı temsil eder. Raporda bir veri sayfası görüntülemek için Alt Form/Alt Rapor denetimini kullanabilirsiniz. Verilerin küçük bir görüntüsünü kullanmak istediğiniz ama bir form veya rapor nesnesinin biçimlendirme özelliklerine gerek duymadığınız durumlarda bu iyi bir tekniktir. Rapora veri sayfası eklemek için:

  1. Gezinti Bölmesi'nde ana rapor olarak kullanmak istediğiniz rapora sağ tıklayın ve sonra kısayol menüsünde Düzen Görünümü'ne tıklayın.

  2. Tasarım sekmesinin Denetimler grubunda Denetimler Galerisi'ni açmak için sağ alt köşedeki aşağı oka tıklayın:

    şerit resmi

  3. Görüntülenen menüde Denetim Sihirbazları Kullan'ın seçili olmamasına dikkat edin.

  4. Denetimler Galerisi'ni yeniden açın ve Alt Form/Alt Rapor'a tıklayın.

  5. Raporda, alt formu yerleştirmek istediğiniz yere tıklayın.

  6. Alt Rapor Sihirbazı başlatılırsa İptal'e tıklayarak sihirbazı kapatın.

  7. Özellik sayfası görünmüyorsa, görüntülenmesi için F4 tuşuna basın.

  8. Raporda, yeni alt rapor denetimini tıklayarak seçin.

  9. Özellik sayfasının Veri sekmesinde, Kaynak Nesne özellik kutusundaki oka tıklayın ve ardından alt rapor denetiminde görüntülenmesini istediğiniz tablo veya sorguya tıklayın. Örneğin, Siparişler tablosunu görüntülemek için Tablo.Siparişler'e tıklayın.

    Access, veritabanında tanımlanmış olan ilişkiler temelinde veri sayfasını ana rapora bağlamayı dener.

  10. Özellik sayfasının Veri sekmesinde, Üst Alanları Bağla ve Alt Alanları Bağla özelliklerini inceleyin.

    • Bağlı olmayan bir veri sayfası için, bu özelliklerden her ikisinin de boş olduğundan emin olun.

    • Bağlı bir veri sayfası için, Üst Alanları Bağla ve Alt Alanları Bağla özelliklerinin ana raporu veri sayfasıyla ilişkilendiren alan veya alanları görüntülediğinden emin olun. Örneğin, ana rapor Çalışanlar tablosundaki bilgileri görüntülüyorsa ve veri sayfası Siparişler tablosundaki verileri görüntülüyorsa, Üst Alanları Bağla özelliği Çalışanlar tablosundaki Kimlik alanını ve Alt Alanları Bağla özelliği de Siparişler tablosundaki Çalışan Kimliği alanını görüntülemelidir.

Bazı durumlarda, bağlama alanı özelliklerini kendiniz ayarlamanız gerekebilir. Aşağıdaki yordamı izleyerek bunu yapabilirsiniz.

  1. Özellik sayfasının Veri sekmesinde Üst Alanları Bağla özellik kutusuna tıklayın ve sonra da Oluştur düğmesine düğme resmi tıklayın.

  2. Güvenlik bildirimi iletişim kutusu görüntülenirse, 'a tıklayın.

    Alt Form Rapor Bağlayıcısı iletişim kutusu görüntülenir.

    Alt Form Rapor Bağlayıcısı iletişim kutusu

  3. Üst Alanlar ve Alt Alanlar listelerinde ana raporu veri sayfasına bağlamak için kullanmak istediğiniz alanları seçin. Hangi alanları kullanacağınızdan emin değilseniz, Access'in bağlama alanlarını saptamayı denemesini sağlamak için Öner'e tıklayın. İşiniz bittiğinde Tamam'a tıklayın.

    Bağlamak için kullanmak istediğiniz bir alan görmezseniz, ana raporun veya veri sayfasının kayıt kaynağını bağlama alanını içerecek şekilde düzenlemeniz gerekir. Örneğin, veri sayfası bir sorguyu temel alıyorsa, bağlama alanının sorgu sonuçlarında yer aldığından emin olmalısınız.

  4. Ana raporu kaydedin ve Rapor görünümüne geçerek raporun beklediğiniz gibi çalıştığını doğrulayın.

Sayfanın Başı

Alt raporda tasarım değişiklikleri yapma

Rapora bir alt rapor ekledikten sonra, alt raporda tasarım değişiklikleri yapmak veya ana raporda alt rapor verilerine başvurmak isteyebilirsiniz. Aşağıdaki bölümlerde bu görevlerin nasıl yerine getirileceğine ilişkin ipuçları sağlanır.

Tasarım görünümündeyken alt formu veya alt raporu yeni pencerede açma

Tasarım görünümünde üzerinde çalıştığınız ana raporun bir alt formunda veya alt raporunda tasarım değişiklikleri yapmak için, alt formu veya alt raporu kendi penceresinde açabilirsiniz.

  1. Alt formu veya alt raporu tıklayarak seçin.

  2. Tasarım sekmesinin Araçlar grubunda Yeni Pencerede Alt Rapor’a tıklayın.

Not: Alt form/alt rapor denetimi bir tablo veya sorguya bağlıysa bu komut kullanılamaz.

Alt rapordan bir toplamı ana raporda görüntüleme

Sevkiyat Ücreti Toplamı adlı bir metin kutusu içeren Siparişler alt raporu adlı bir alt rapor kullandığınızı ve bu metin kutusunun Sevkiyat Ücreti sütununun toplamını hesapladığını varsayalım. Alt rapordaki toplamı ana raporda görüntülemek için, ana rapora bir metin kutusu eklemeli ve sonra alt rapordaki Sevkiyat Ücreti Toplamı metin kutusuna başvuran bir ifade kullanmalısınız. Aşağıdaki yordamı izleyerek bunu yapabilirsiniz.

  1. Gezinti Bölmesi'nde ana rapora sağ tıklayın ve ardından kısayol menüsünde Tasarım Görünümü'ne tıklayın.

  2. Tasarım sekmesinin Denetimler grubunda Metin Kutusu'na tıklayın.

  3. Ana raporda, yeni metin kutusunu yerleştirmek istediğiniz yere tıklayın.

  4. Özellik sayfası görünmüyorsa, görüntülenmesi için F4 tuşuna basın.

  5. Özellik sayfasının Veri sekmesindeki Denetim Kaynağı özellik kutusuna aşağıdaki ifadeyi yazın.

    =IIf(IsError([Siparişler alt raporu].[Report]![Sevkiyat Ücreti Toplamı]),0,[Siparişler alt toplamı].[Report]![Sevkiyat Ücreti Toplamı])

    Notlar: 

    • Bu örnekte, daha basit bir ifade (=[Siparişler alt raporu].[Report]![Sevkiyat Ücreti Toplamı]) kullanabilirsiniz ama alt rapor hiçbir veri içermiyorsa ana rapordaki denetim #Hata görüntüler. İlk ifadede gösterildiği gibi IIf işlevi içinde IsError işlevinin kullanılması, alt raporun hiçbir veri döndürmemesi durumunda ana rapordaki metin kutusunda sıfır (0) gösterilmesini güvence altına alır.

    • İfade Oluşturucusu'nu kullanarak Denetim Kaynağı özellik kutusunda Oluştur düğmesine düğme resmi tıklayıp ifadeyi oluşturabilirsiniz.

  6. Özellik sayfasının Biçim sekmesinde, Biçim özelliğini uygun bir değere (bu örnekte, Para Birimi) ayarlayın.

  7. Raporu kaydedin ve ardından Rapor görünümüne geçerek hesaplamanın beklediğiniz gibi çalıştığını doğrulayın.

Sayfanın Başı

Office yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×