Yinelenen veritabanımı Access 2007 biçiminde kaydedemiyorum

Önemli : Bu makale makine çevisidir. Bkz. yasal uyarı. Bu makalenin İngilizce sürümüne buradan ulaşabilirsiniz.

Belirtiler

Access'in önceki sürümlerinde oluşturulan veritabanlarına Microsoft Office Access 2007içinde çoğaltılan (. MDB biçimi) yeni kaydedilemez. ACCDB dosya biçimi. Seçeneği soluk (kullanılamaz) Veritabanı olarak Kaydet komutu kullanmaya çalıştığınız sırada ( düğme resmi Microsoft Office düğmesi' ı tıklatın ve sonra Kaydetyanındaki oku tıklatın).

Neden

.ACCDB dosya biçimi yinelemeyi desteklemez.

Çözüm

Yinelenen veritabanını .MDB dosya biçiminde kullanın

Yinelenen veritabanınızı .MDB dosya biçiminde kullanmaya devam edebilirsiniz. Yineleme işlevi .MDB dosya biçimi için halen desteklenmektedir.

Veritabanını Office Access 2007 dosya biçiminde el ile yeniden oluşturun

Yeni dosya biçiminin sağladığı yararların, yinelemeden elde edeceğiniz yararlara göre daha fazla olduğuna karar verirseniz, Office Access 2007 biçiminde yeni bir veritabanı oluşturabilir ve yinelenen veritabanını el ile yeniden oluşturabilirsiniz.

Not : Bu yöntem tüm yinelenen veritabanlarında işe yarar, ancak kopyalar kümesinde bulunan diğer tüm yinelemelerle eşitlenmiş olan tam bir kopyayla çalışmadığınız sürece, henüz kopyanızda bulunmayan veriler ve projeler yeni veritabanında yer almayacaktır.

Veritabanınızı yeniden oluşturmaya başlamadan önce, yinelemede yer alan tüm gizli nesnelerin ve sistem nesnelerinin görünür durumda olduğunda emin olmanız gerekir. Yeniden oluşturduğunuz zaman yinelemede bulunan yinelemeye özgü alanlara erişebilmeniz için bu gereklidir.

  1. Dönüştürmek istediğiniz yinelemeyi açın. Gizli alanları ve sistem alanlarını görüntülemek için, yinelemeyi, oluşturulduğu Access sürümünü kullanarak açmanız gerekir .

  2. Araçlar menüsünde, Seçenekler'i tıklatın. Seçenekler iletişim kutusu açılır.

  3. Görünüm sekmesinde, Göster bölümünde, Gizli nesneler ve Sistem nesneleri'ni seçin. Yeni ayarları uygulayarak Seçenekler iletişim kutusunu kapatmak için Tamam'ı tıklatın.

Veritabanını el ile yeniden oluşturma

  1. Boş bir veritabanı oluşturun ve açın.

    Not : Access Tablo1 adında yeni, boş bir tablo oluşturur. Bu tabloyu silmeniz gerekir; herhangi bir değişiklik yapmadan hemen kapatarak bunu yapabilirsiniz. Nesne sekmesini sağ tıklatıp kısayol menüsünden Kapat'ı tıklatın.

  2. Dış Veri sekmesinin Al grubunda Access'i tıklatın.

    Dış Veri Al - Access Veritabanı iletişim kutusu görünür.

  3. Yinelenen veritabanını bulmak için Gözat düğmesini tıklatın.

  4. Yeni veritabanında yeniden oluşturmak istediğiniz nesneleri içeren yinelenen veritabanını tıklatın ve sonra düğmesini tıklatın.

  5. Dış Veri Al - Access Veritabanı iletişim kutusunda, Tabloları, sorguları, formları, raporları, makroları ve modülleri geçerli veritabanına al'ı tıklatın ve sonra Tamam düğmesini tıklatın.

  6. Yeni veritabanına almak istediğiniz veritabanı nesnelerini tıklatın. Tüm nesneleri almak isterseniz, her sekmede Tümünü Seç öğesini tıklatın.

    Önemli    Bu noktada hiçbir tabloyu seçmeyin. Tabloları ileriki bir adımda yeniden oluşturacaksınız.

  7. Nesneleri seçmeniz bittiğinde, almak için Tamam düğmesini tıklatın.

    Sihirbazın son sayfasında, alma adımlarını ileride kullanmak üzere kaydetme seçeneğiniz vardır. Bunu yapmak için, Alma adımlarını kaydet onay kutusunu seçin, ilgili bilgileri girin ve Al'ı Kaydet'i tıklatın.

  8. Yinelenen veritabanını Office Access 2007 uygulamasında açın. Yinelenen veritabanındaki her tablo için, eski tablodaki tüm verileri alan ve yeni veritabanında aynı verilerle tablo oluşturan bir Tablo Oluştur sorgusu oluşturun.

    Not : S_GUID birincil anahtar (ve diğer tablolardaki yabancı anahtarlar ona başvuran varsa), yeni tabloda s_GUID alanı içermelidir. Birincil anahtar olarak s_GUID alanı kullanılmazsa, yeni tabloda korumak için bir neden yoktur. Yeni tabloyu s_Lineage ve s_Generation alanları kopyalamak yoktur.

    Varsayılan olarak, s_GUID, s_Lineage ve s_Generation alanları gizlidir. Bu alanları görüntülemek için, aşağıdaki yordamı kullanın:

    1. Yinelenen veritabanında, tüm tabloların kapalı olduğundan emin olun.

    2. Gezinti Bölmesi'nin üst tarafını sağ tıklatın ve Gezinti Seçenekleri'ni tıklatın. Gezinti Seçenekleri iletişim kutusu açılır.

    3. Görüntü Seçenekleri bölümünde, Sistem Nesnelerini Göster'i seçin ve Tamam'ı tıklatın.

      Nasıl Yapılır?

      1. Yeni tabloya koymak istediğiniz kayıtları içeren tabloları seçerek bir sorgu oluşturun.

        Nasıl Yapılır?

        1. Oluştur sekmesinde, Diğer grubunda, Sorgu Tasarımı'nı tıklatın.

        2. Tablo Göster iletişim kutusunda, çalışmak istediğiniz verilerin bulunduğu tabloların listelendiği sekmeyi tıklatın.

        3. Sorguya eklemek istediğiniz her nesnenin adını çift tıklatın ve sonra Kapat seçeneğini tıklatın.

        4. tasarım kılavuzuAlansatırına alan ekleyin.

        5. Sorgunun sonuçlarını görüntülemek için, Görünüm menüsünü tıklatın ve Veri Sayfası Görünümü seçeneğini tıklatın.

      2. Sorgu Tasarım görünümü, Tasarım sekmesinde, Sorgu Türü grubunda, Tablo Yap öğesini tıklatın. Tablo Yap iletişim kutusu görüntülenir.

      3. Tablo Adı kutusundan oluşturmak veya yerleştirmek istediğiniz tablonun adını girin.

      4. Başka Veritabanı'nı tıklatın ve  sonra yeni tabloyu koymak istediğiniz veritabanının yolunu yazın  ya da veritabanının yerini göstermek üzere Gözat'ı tıklatın.

      5. Tamam düğmesini tıklatın.

      6. Tasarım sekmesinin Sonuçlar grubunda Çalıştır' ı tıklatın. Bu yeni tabloyu yapar.

        Not : Oluşturduğunuz yeni tablo, alan özelliklerini veya birincil anahtar ayarını özgün tablodan devralmaz.

  9. Yeni veritabanındaki her tablo için, kopyanın tablosunda kullanılanla aynı dizin ve birincil anahtarı oluşturun.

    Nasıl Yapılır?

    1. Tasarım görünümünde bir tabloyu açın.

    2. Pencerenin üst kısmında, kendisi için dizin oluşturmak istediğiniz alanı tıklatın.

    3. Pencerenin alt kısmında, Sıralı özellik kutusunu tıklatın ve sonra Evet (Yineleme Var) veya Evet (Yineleme Yok) öğesini tıklatın.

    4. Birincil anahtarı içeren alan veya alanları seçin.

    5. Tasarım sekmesinde, Araçlar grubunda, Birincil Anahtar öğesini tıklatın.

  10. Yeni veritabanında her tablo için yineleme tablosunda varolan ilişkiler oluşturun.

    Nasıl Yapılır?

    Tablolar arasında ilişki oluşturduğunuzda, ilişkili alanları aynı ada sahip gerekmez. Bununla birlikte, otomatik sayı alanı birincil anahtar alanı olmadığı sürece ilişkili alanları veri türü aynı olmalıdır. Eşleşen alanlar hem de AlanBoyutu özelliği aynı ise, sayı alanı içeren bir otomatik sayı alanı eşleştirebilirsiniz. Örneğin, her iki alanın AlanBoyutu özelliği Uzun tamsayıdeğilse otomatik sayı alanı ve bir sayı alanı eşleştirebilirsiniz. Her iki eşleşen alanları çift sayı alanları olduğunda, bunlar aynı AlanBoyutu özelliği ayarına sahip olmanız gerekir.

    Bir bir-çok tanımlayın veya bir-bir ilişkisi

    1. Açtığınız tüm tabloları kapatın. Açık tablolar arasında ilişki oluşturamaz veya değiştiremezsiniz.

    2. Veritabanı Araçlarısekmesinde, Göster/Gizle grubunda, İlişkiler'i tıklatın.

    3. Veritabanınızda henüz bir ilişki tanımladıysanız, Tablo Göster iletişim kutusu otomatik olarak görüntülenir.

      İlişkilendirmek istediğiniz tablolar eklemeniz gerekiyorsa ve Tabloyu Göster iletişim kutusu görüntülenmezse, çağırın: Tasarım sekmesinde, Göster/Gizle grubunda, Tabloyu Göster düğmesini tıklatın.

    4. İlişkilendirmek istediğiniz tabloların adlarını çift tıklatın, sonra da Tablo Göster iletişim kutusunu kapatın. Bir tablo ile kendisi arasında ilişki oluşturmak için bu tabloyu iki kere ekleyin.

    5. Bağlamak istediğiniz alanları bir tablodan başka bir tablodaki ilgili alana sürükleyin.

      Birden çok alanı sürüklemek için CTRL tuşuna basılı tutarak istediğiniz alanları tıklatın ve sürükleyin.

      Çoğu durumlarda, birincil anahtar alanını (koyu metinde görüntülenen) bir tablodan başka bir tablodaki yabancı anahtar olarak adlandırılan benzer alana (genellikle aynı adı taşır) sürüklersiniz.

    6. İlişkileri Düzenle iletişim kutusu görüntülenir. Doğru olduklarından emin olmak için iki sütunda görüntülenen alan adlarını onaylayın. Gerekirse bunları değiştirebilirsiniz.

      Gerekiyorsa ilişki seçeneklerini ayarlayın.

    7. İlişki oluşturmak için Oluştur düğmesini tıklatın.

    8. İlişkilendirmek istediğiniz her tablo çifti için 4 ile 7 arasındaki adımları tekrarlayın.

      İlişkiler penceresi kapatırsanız, Microsoft Access yerleşimi kaydetmek isteyip istemediğinizi sorar. Oluşturduğunuz ilişkiler, yerleşimi kaydedip kaydetmediğiniz dikkate alınmaksızın veritabanına kaydedilir.

    Çok-çok ilişkisi tanımlama

    1. çok-çok ilişkisi içinde bulunacak iki tabloyu oluşturun.

    2. Kesişme tablosu olarak kullanılacak üçüncü bir tablo oluşturun ve kesişme tablosuna diğer iki tablonun birincil anahtar alanları ile aynı tanıma sahip yeni alanlar ekleyin. Kesişme tablosunda, birincil anahtar alanları yabancı anahtar işlevi görür. Diğer tablolara yapabildiğiniz gibi kesişme tablosuna da başka alanlar ekleyebilirsiniz.

    3. Kesişme tablosunda, diğer iki tablodan birincil anahtar alanları eklemek için birincil anahtarı ayarlayın. Örneğin, bir Sipariş Ayrıntıları kesişme tablosunda, birincil anahtar, SiparişKodu ve ÜrünKodu alanlarından oluşturabilir.

      Nasıl Yapılır?

      1. Tabloyu Tasarım görünümünde açın.

      2. Birincil anahtar olarak tanımlamak istediğiniz alan veya alanları seçin.

        Tek bir alanı seçmek için istenen alanla ilgili satır seçici tıklatın.

        Birden fazla alanı seçmek için, CTRL tuşunu basılı tutun ve her alanla ilgili satır seçiciyi tıklatın.

      3. Tasarım sekmesinde, Araçlar grubunda, Birincil Anahtar öğesini tıklatın.

        Not : Birden çok alan birincil anahtarında alanların sırasının tablodaki alanların sırasından farklı olmasını isterseniz, Göster/Gizle grubunda Dizinler düğmesini tıklatarak Dizinler penceresi görüntüleyin ve Birincil Anahtar adlı dizin için alan adlarını yeniden sıralayın.

    4. Her iki birincil tablo ve kavşak tablosu arasında bir bir-çok ilişkisi tanımlayın.

  11. Yeni veritabanınızı kaydedin.

Not : Makine Çevirisi Yasal Uyarısı: Bu makale, insan müdahalesi olmadan bir bilgisayar sistemi tarafından çevrilmiştir. Microsoft bu makine çevirilerini İngilizce bilmeyen kullanıcıların Microsoft ürünleri, hizmetleri ve teknolojileriyle ilgili içeriklerden yararlanmasına yardımcı olmak için sunar. Bu makale makine çevirisi olduğundan sözcük, cümle dizilimi ve gramer hataları içerebilir.

Yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×