Yinelemeler arasında benzersiz değerleri hesaplama

Önemli : Bu makale makine çevisidir. Bkz. yasal uyarı. Bu makalenin İngilizce sürümüne buradan ulaşabilirsiniz.

Kaç benzersiz metin veya sayı değerinin bir aralıktaki vardır bulmak istediğiniz varsayalım. Örneğin, bir sütunu varsa Bradley, Derya, Derya, Deryametin değerleri, iki benzersiz değerler vardır — Bradley ve Derya. Aralık sayılar 5, 6, 7, 6varsa, benzersiz 5, 6 ve 7 değerlerdir.

Yalnızca benzersiz değerlerin sayısını belirlemek için aşağıdaki örnek çalışma sayfasında gösterildiği gibi, buradaki işlevlerin bileşimini kullanın:

  • DOĞRU olan her koşula 1 değerini atamak için EĞER işlevini kullanın.

  • Benzersiz tüm değerleri toplamak için TOPLA işlevini kullanın.

  • Benzersiz değerlerin sayısını belirlemek için SIKLIK işlevini kullanın. Bu işlev metni ve sıfır değerlerini yok sayar. Belirli bir değerin ilk geçtiği yerde, bu değerin yinelenme sayısına eşit bir sayı verir. Aynı değerin ilkinden sonraki her yinelenmesinde, bu işlev 0 değerini verir.

  • Bir aralıktaki metin değerinin konumunu vermesi için KAÇINCI işlevini kullanın. SIKLIK işlevi, karşılık gelen metin değerlerini değerlendirmek için sonuç değeri kullanır.

  • Boş hücreleri bulmak için UZUNLUK işlevini kullanın. Boş hücrelerin uzunluğu (karakter sayısı) 0’dır.

Örnek

İşlevlerin kullanıldığı bu formül örnekleriyle çalışmak için, tabloyu Excel'deki boş bir çalışma sayfasında A1 hücresine kopyalayın.

Veri

Veri

986

Beyhan

Derya

563

67

789

235

Beyhan

Derya

689

789

Derya

143

56

237

67

235

Formül

Açıklama (Sonuç)

=TOPLA(EĞER(SIKLIK(A2:A10,A2:A10)>0,1))

A2:A10 hücrelerindeki benzersiz sayı değerlerinin sayısını hesaplar, ancak boş hücreleri veya metin değerlerini saymaz (4)

=TOPLA(EĞER(SIKLIK(KAÇINCI(B2:B10,B2:B10,0),KAÇINCI(B2:B10,B2:B10,0))>0,1))

B2:B10 hücrelerindeki benzersiz metin ve sayı değerlerinin sayısını hesaplar (boş hücreler içermemelidir) (7)

=TOPLA(EĞER(SIKLIK(EĞER(UZUNLUK(A2:A10)>0,KAÇINCI(A2:A10,A2:A10,0),""), EĞER(UZUNLUK(A2:A10)>0,KAÇINCI(A2:A10,A2:A10,0),""))>0,1))

A2:A10 hücrelerindeki benzersiz metin ve sayı değerlerinin sayısını hesaplar, ancak boş hücreleri veya metin değerlerini saymaz (6)

Notlar : 

  • Bu örnekte formüller dizi formülleri olarak girilmelidir. Formül içeren her hücreyi seçin, F2 tuşuna basın ve sonra Ctrl + Shift + Enter tuşlarına basın.

  • Bir işlevin adım adım değerlendirilmesini görmek için, formülün bulunduğu hücreyi seçin ve Formüller sekmesindeki Formül Denetimi grubunda Formülü Değerlendir öğesini tıklatın.

Not : Makine Çevirisi Yasal Uyarısı: Bu makale, insan müdahalesi olmadan bir bilgisayar sistemi tarafından çevrilmiştir. Microsoft bu makine çevirilerini İngilizce bilmeyen kullanıcıların Microsoft ürünleri, hizmetleri ve teknolojileriyle ilgili içeriklerden yararlanmasına yardımcı olmak için sunar. Bu makale makine çevirisi olduğundan sözcük, cümle dizilimi ve gramer hataları içerebilir.

Yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×