Yinelemeler arasında benzersiz değerleri hesaplama

Not:  En güncel yardım içeriklerini, mümkün olduğunca hızlı biçimde kendi dilinizde size sunmak için çalışıyoruz. Bu sayfanın çevirisi otomasyon aracılığıyla yapılmıştır ve bu nedenle hatalı veya yanlış dil bilgisi kullanımları içerebilir. Amacımız, bu içeriğin sizin için faydalı olabilmesini sağlamaktır. Buradaki bilgilerin faydalı olup olmadığını bu sayfanın sonunda bize bildirebilir misiniz? Kolayca başvurabilmek için İngilizce makaleye buradan ulaşabilirsiniz .

Kaç benzersiz metin veya sayı değerinin bir aralıktaki vardır bulmak istediğiniz varsayalım. Örneğin, bir sütunu varsa Beyhan, Derya, Derya, Deryametin değerleri, iki benzersiz değerler vardır — Beyhan ve Derya. Aralık sayılar 5, 6, 7, 6varsa, benzersiz 5, 6 ve 7 değerlerdir.

Yalnızca benzersiz değerlerin sayısını belirlemek için aşağıdaki örnek çalışma sayfasında gösterildiği gibi, buradaki işlevlerin bileşimini kullanın:

  • DOĞRU olan her koşula 1 değeri atamak için Eğer işlevini kullanın.

  • Benzersiz tüm değerleri toplamak için TOPLA işlevini kullanın.

  • Sıklık işlevi benzersiz değerleri saymak için kullanın. Bu işlev, metin ve sıfır değerlerinin yoksayar. Belirli bir değeri ilk geçtiği için bunu bir sayı eşit, bu değerin yinelenme sayısını döndürür. Her tekrarını aynı değeri ilk sonra bu işlev 0 değerini döndürür.

  • Bir aralıktaki bir metin değerini konumunu dönmek için KAÇINCI işlevini kullanın. Sıklık işlevinin ilgili metin değerleri değerlendirmek için sonuç değerini kullanır.

  • Boş hücreleri bulmak için uzunluk işlevini kullanın. Boş hücreler 0 (karakter sayısını) uzunluğuna var.

Örnek

İşlevlerin kullanıldığı bu formül örnekleriyle çalışmak için, tabloyu Excel'deki boş bir çalışma sayfasında A1 hücresine kopyalayın.

Veri

Veri

986

Beyhan

Derya

563

67

789

235

Beyhan

Derya

689

789

Derya

143

56

237

67

235

Formül

Açıklama (Sonuç)

=TOPLA(EĞER(SIKLIK(A2:A10,A2:A10)>0,1))

A2:A10 hücrelerindeki benzersiz sayı değerlerinin sayısını hesaplar, ancak boş hücreleri veya metin değerlerini saymaz (4)

=TOPLA(EĞER(SIKLIK(KAÇINCI(B2:B10,B2:B10,0),KAÇINCI(B2:B10,B2:B10,0))>0,1))

B2:B10 hücrelerindeki benzersiz metin ve sayı değerlerinin sayısını hesaplar (boş hücreler içermemelidir) (7)

=TOPLA(EĞER(SIKLIK(EĞER(UZUNLUK(A2:A10)>0,KAÇINCI(A2:A10,A2:A10,0),""), EĞER(UZUNLUK(A2:A10)>0,KAÇINCI(A2:A10,A2:A10,0),""))>0,1))

A2:A10 hücrelerindeki benzersiz metin ve sayı değerlerinin sayısını hesaplar, ancak boş hücreleri veya metin değerlerini saymaz (6)

Notlar: 

  • Bu örnekte formüller dizi formülleri olarak girilmelidir. Formül içeren her hücreyi seçin, F2 tuşuna basın ve sonra Ctrl + Shift + Enter tuşlarına basın.

  • Bir işlevin adım adım değerlendirilmesini görmek için, formülün bulunduğu hücreyi seçin ve Formüller sekmesindeki Formül Denetimi grubunda Formülü Değerlendir öğesini tıklatın.

Office yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×